Subject: [alto] Fwd: Process of IETF'93 interop

From: Shu Dong <[email-masked]>
Date: Fri, 17 Jul 2015 20:19:21 +0800

---------- Forwarded message ----------
From: Jensen Zhang <[email-masked]>
Date: Fri, Jul 17, 2015 at 7:39 PM
Subject: Process of IETF'93 interop
To: IETF ALTO <[email-masked]>, "Y. Richard Yang" <[email-masked]>
Cc: Wendy Roome <[email-masked]>, "Gurbani, Vijay K (Vijay)" <
[email-masked]>, Young Lee <[email-masked]>, Greg
Bernstein <[email-masked]>, Jan Seedorf <[email-masked]>,
Xiao Lin <[email-masked]>, Haoran <[email-masked]>, Shu Dong <
[email-masked]>, "G. Robert Cheng (Huawei)" <[email-masked]>

Dear all,

Following is the process of IETF'93 interop day. If you have any problems,
please contact with our volunteers.

Volunteers:
"Jensen" <[email-masked]>
"Xiao Lin" <[email-masked]>
"Haoran" <[email-masked]>
"Shu Dong" <[email-masked]>
"G. Robert Chen" <[email-masked]>
Outline:

Below is a brief guide of ALTO test process. You will find following
information in the guide:

   1. How to login to the start platform and what should be prepared by
   local and remote participants before the Interop day?
   2. The details of the test on interop-day.

 ------------------------------
Preparation: Before Interop-day

   1. The interop volunteers have registered a IRC channel (
   #alto-interop@freenode
   <http://webchat.freenode.net/?channels=alto-interop>). Please make sure
   you have an IRC client and be able to connect to the IRC channel before the
   interop-day.
   2. Each server participant should deploy its ALTO server with a public
   IP.
   3. Please download the test template from here:
   https://docs.google.com/document/d/1irUuS40aydX5hxQIexz1PTIcnYOJRBj_OYB2lXa3vd8/edit?usp=sharing
   .

Steps: On Interop-day Step 1. Start

   1. Please login to the IRC channel (#alto-interop@freenode
   <http://webchat.freenode.net/?channels=alto-interop>), and each
   participant please announce yourself.
   2. Hearing all announcements, test chair will allocate a test ID (server
   A, .. client B) for every participant.
   3. Each server participant posts to the IRC its entry IRD.
   4. The test chair will continue to announce the matching of clients and
   servers.

Step 2. Test

   1. Upon the announcement of a client-server matching, a google doc for
   the matching is created and announced on the IRC.
   2. The corresponding client participant will start to run its client to
   test the corresponding server.
   3. Test results will be recorded in the google doc. For a template of
   the good doc, please see
   https://docs.google.com/document/d/1irUuS40aydX5hxQIexz1PTIcnYOJRBj_OYB2lXa3vd8/edit?usp=sharing
   .
   4. After finishing testing, please post to the IRC to let the test chair
   know.

Step 3. Summary of Results

   1. After all the tests finished, client participants should send test
   reports to the volunteers. Volunteers will summarize the results.
   2. The WG chair may report the summary results in the WG meeting next
   day.

--
Jensen, Xiao, Haoran, Shu, Robert

---

From: "Y. Richard Yang" <[email-masked]>
Date: Fri, 17 Jul 2015 23:02:15 +0800

Dear all,

Jensen, Robert, Shu and a few other volunteers have proposed the interop
process below. It is by no means to be rigid, but a possibility. Any
suggestions from ALTO participants on changes are greatly appreciated!

A key item is the Google spreadsheet, which listed a set of interop cases.
Robert has an open source client which can do the tests. I believe Wendy
has a more complete client.

In the long term, a possibility is to host such related items (e.g., some
open source test clients, servers, Lyle's schema) on a web site. One
candidate we are thinking is www.openalto.org. It will be wonderful to have
as many ALTO participants engaged.

Cheers,
Richard

On Friday, July 17, 2015, Jensen Zhang <[email-masked]
<javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:

>    <https://urldefense.proofpoint.com/v2/url?u=http-3A__webchat.freenode.net_-3Fchannels-3Dalto-2Dinterop&d=AwMFaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=1YTsFrolaLIuHrz2blrhYb8v-7iNSbnITyJIP12hyAg&s=em1KuyX2j-UAGmaAwfpei-py7bf_GC1A0fOSMvTPRKg&e=>).
>    Please make sure you have an IRC client and be able to connect to the IRC
>    channel before the interop-day.
>    <https://urldefense.proofpoint.com/v2/url?u=https-3A__docs.google.com_document_d_1irUuS40aydX5hxQIexz1PTIcnYOJRBj-5FOYB2lXa3vd8_edit-3Fusp-3Dsharing&d=AwMFaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=1YTsFrolaLIuHrz2blrhYb8v-7iNSbnITyJIP12hyAg&s=RK8rP07AGKw4USexmfEHUtm-MRFUPOhyolewhyLUqsU&e=>
>    .
>
>    <https://urldefense.proofpoint.com/v2/url?u=http-3A__webchat.freenode.net_-3Fchannels-3Dalto-2Dinterop&d=AwMFaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=1YTsFrolaLIuHrz2blrhYb8v-7iNSbnITyJIP12hyAg&s=em1KuyX2j-UAGmaAwfpei-py7bf_GC1A0fOSMvTPRKg&e=>),
>    and each participant please announce yourself.
>    2. Hearing all announcements, test chair will allocate a test ID
>    (server A, .. client B) for every participant.
>    4. The test chair will continue to announce the matching of clients
>    and servers.
>
> Step 2. Test
>
>    2. The corresponding client participant will start to run its client
>    to test the corresponding server.
>    <https://urldefense.proofpoint.com/v2/url?u=https-3A__docs.google.com_document_d_1irUuS40aydX5hxQIexz1PTIcnYOJRBj-5FOYB2lXa3vd8_edit-3Fusp-3Dsharing&d=AwMFaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=1YTsFrolaLIuHrz2blrhYb8v-7iNSbnITyJIP12hyAg&s=RK8rP07AGKw4USexmfEHUtm-MRFUPOhyolewhyLUqsU&e=>
>    .
>    4. After finishing testing, please post to the IRC to let the test
>    chair know.
>

-- 
Richard

-- 
Richard

---

From: ChenGuohai <[email-masked]>
Date: Fri, 17 Jul 2015 15:15:23 +0000

Hi all,
chenguohai67@outlook is another  email address.
Guohai(Robert) Chen
Date: Fri, 17 Jul 2015 23:02:15 +0800
From: [email-masked]
To: [email-masked]
Subject: Re: [alto] Process of IETF'93 interop

Dear all,
Jensen, Robert, Shu and a few other volunteers have proposed the interop process below. It is by no means to be rigid, but a possibility. Any suggestions from ALTO participants on changes are greatly appreciated!

A key item is the Google spreadsheet, which listed a set of interop cases. Robert has an open source client which can do the tests. I believe Wendy has a more complete client.

In the long term, a possibility is to host such related items (e.g., some open source test clients, servers, Lyle's schema) on a web site. One candidate we are thinking is www.openalto.org. It will be wonderful to have as many ALTO participants engaged.
Cheers,Richard 

On Friday, July 17, 2015, Jensen Zhang <[email-masked]> wrote:
Dear all,

Following is the process of IETF'93 interop day. If you have any problems, please contact with our volunteers.

Volunteers:
"Jensen" <[email-masked]>
"Xiao
 Lin" <[email-masked]>
"Haoran" 
<[email-masked]>
"Shu Dong" <[email-masked]>
"G. 
Robert Chen" <[email-masked]>
Outline:

Below is a brief guide of ALTO test process. You will find following information in the guide:

How to login to the start platform and what should be prepared by local and remote participants before the Interop day?The details of the test on interop-day.

The interop volunteers have registered a IRC channel (#alto-interop@freenode). Please make sure you have an IRC client and be able to connect to the IRC channel before the interop-day.Each server participant should deploy its ALTO server with a public IP.Please download the test template from here: https://docs.google.com/document/d/1irUuS40aydX5hxQIexz1PTIcnYOJRBj_OYB2lXa3vd8/edit?usp=sharing.

Steps: On Interop-day

Step 1. Start

Please login to the IRC channel (#alto-interop@freenode), and each participant please announce yourself.Hearing all announcements, test chair will allocate a test ID (server A, .. client B) for every participant.Each server participant posts to the IRC its entry IRD.The test chair will continue to announce the matching of clients and servers.

Step 2. Test

Upon the announcement of a client-server matching, a google doc for the matching is created and announced on the IRC.The corresponding client participant will start to run its client to test the corresponding server.Test results will be recorded in the google doc. For a template of the good doc, please see https://docs.google.com/document/d/1irUuS40aydX5hxQIexz1PTIcnYOJRBj_OYB2lXa3vd8/edit?usp=sharing.After finishing testing, please post to the IRC to let the test chair know.

After all the tests finished, client participants should send test reports to the volunteers.
Volunteers will summarize the results.The WG chair may report the summary results in the WG meeting next day.

-- 
Richard

-- 
Richard

_______________________________________________
alto mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/alto