Subject: Re: [alto] ALTO interop planning

From: Shu Dong <[email-masked]>
Date: Sun, 19 Jul 2015 16:52:17 +0800

Hi everyone,

For your information, I just updated the text template for ALTO Interop
according to @Hans and @Wendy's suggestion (Thanks @Wendy and @Hans!).
Since the "priv:ietf-type" property is always optional, the
requirement of "priv:ietf-type"
property has been removed from Service Test No.42 while a new EPS test
(Service Test No. 43) with key word "MAY" is created to test this property.
The test descriptions for the two EPS tests and test number for related
other tests are also updated. Please update your test template or download
the latest version here
<https://docs.google.com/document/d/1irUuS40aydX5hxQIexz1PTIcnYOJRBj_OYB2lXa3vd8/edit>
if
necessary.

Thanks!

From,
Shu

On Sun, Jul 19, 2015 at 3:04 PM, Y. Richard Yang <[email-masked]> wrote:

> Hans,
>
> This looks reasonable to me, but I defer to Wendy, Shu, Jensen,
> and Robert.
>
> Wendy, Shu, Jensen, Robert: what do you think?
>
> Thanks!
> Richard
>
> On Sunday, July 19, 2015, Hans Seidel <[email-masked]> wrote:
>
>>  Hi Richard,
>>
>> I took a look at the google spreadsheet for the interop and I would
>> suggest to split Service Test No. 42 ( EPS) into two tests since the
>> priv:ietf-type property is optional.
>>
>> Cheers,
>> Hans
>>
>> On 17.07.2015 18:37, Y. Richard Yang wrote:
>>
>> Hi Hans,
>>
>>  I hope that you have seen more details on the interop. If you want any
>> changes, it will be great. It will be wonderful if you can co-lead the
>> interop--I have not received my visa yet, and hence may have to participate
>> only remotely.
>>
>>  Cheers,
>> Richard
>>
>> On Mon, Jul 13, 2015 at 2:58 PM, Hans Seidel <[email-masked]> wrote:
>>
>>>  Richard,
>>>
>>> I have an ALTO server which is capable of running the tests. I do not
>>> have a full client but a small tool that produces all sorts of ALTO
>>> requests and print the corresponding responses on screen.
>>>
>>> Hans
>>>
>>>
>>> On 12.07.2015 11:15, Y. Richard Yang wrote:
>>>
>>> Dear Hans,
>>>
>>>  This is a private email.
>>>
>>>  We are starting to get into the organization of the interop. To make
>>> sure we have a productive event, I am first checking key participants.  So
>>> far we have two ALTO servers and two ALTO clients. Will you be able to have
>>> a server on the interop time running the interop tests specified by Wendy (
>>>  https://datatracker.ietf.org/wg/alto/documents/
>>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_wg_alto_documents_&d=AwMDaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=gQnQyzW1u7b1mj3KIgcpBvHHZ0Yqa0yPAXzNmyib3hM&s=EHX7y5bjbnlhm6xuNg93d9Ta31dcIyIG-eR9R9NlzL8&e=>
>>> )
>>>
>>>  We feel that if we have >=4 servers/clients, it can be more
>>> interesting. If we have less, I am open with either defer to next ietf or
>>> still proceed.
>>>
>>>  If we proceed, it will be great to work together.
>>>
>>>  Thanks!
>>>
>>>  Richard
>>>
>>> On Monday, June 29, 2015, Jan Seedorf <[email-masked]> wrote:
>>>
>>>>  Dear all,
>>>>
>>>>
>>>>
>>>> as discussed on this list and requested by several of you, we have
>>>> arranged a room for an ALTO interop at IETF-93 as follows:
>>>>
>>>>
>>>>
>>>> ** MONDAY, July 20th, 20:00-23:00 **
>>>>
>>>>
>>>>
>>>> There has already been some good discussion on this list regarding the
>>>> interop, plus a draft from Wendy. Please continue this discussion, so that
>>>> we can make the best use of the time in Prague.
>>>>
>>>>
>>>>
>>>> -          Jan
>>>>
>>>>
>>>>
>>>> ============================================================
>>>>
>>>> Prof. Dr. Jan Seedorf
>>>>
>>>> Senior Researcher
>>>>
>>>> NEC Europe Ltd., NEC Laboratories Europe, Network Division
>>>> Kurfuerstenanlage 36, D-69115 Heidelberg Tel.     +49 (0)6221 4342-221
>>>>
>>>> Fax:     +49 (0)6221 4342-155
>>>>
>>>> e-mail:  [email-masked]
>>>>
>>>> ============================================================
>>>>
>>>> NEC Europe Ltd, Registered Office: Athene, Odyssey Business Park, West
>>>> End  Road, London, HA4 6QE, GB, Registered in England 2832014
>>>>
>>>>
>>>>
>>>> _______________________________________________
>>>> alto mailing list
>>>> [email-masked]
>>>>
>>>> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_alto&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=ohQ8rQ80_VczPm1nmj_8EEwGGdryuJuOv9d-B-LAMDo&s=he4jo-xrW7A_q6yTg3Miw889pk-yL2aofxJgfbfDg0w&e=
>>>>
>>>>
>>>
>>> --
>>> Richard
>>>
>>>
>>>
>>
>>
>>  --
>>  --
>>  =====================================
>> | Y. Richard Yang <[email-masked]>   |
>> | Professor of Computer Science       |
>> | http://www.cs.yale.edu/~yry/        |
>>  =====================================
>>
>>
>>
>
> --
> Richard
>

---

From: Piotr Wydrych <[email-masked]>
Date: Mon, 20 Jul 2015 19:15:02 +0200

Hello Shu,

W dniu 2015-07-19 o 10:52, Shu Dong pisze:
> Please update your test template or download the latest version here
> <https://docs.google.com/document/d/1irUuS40aydX5hxQIexz1PTIcnYOJRBj_OYB2lXa3vd8/edit> if
> necessary.

Did you consider changing document sharing settings. Currently every 
person with a link can edit. This is risky - somebody can accidentally 
start to fill the template instead of making a copy before. People do 
strange things when in hurry :-)

Best,
Piotr 'GhosT' Wydrych
-- 
Piotr 'GhosT' Wydrych .. xmpp:wydrych//agh.edu.pl .. http://wydrych.net/

A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?