Subject: Re: [alto] On-line interop-93 test client

From: "Y. Richard Yang" <[email-masked]>
Date: Tue, 1 Sep 2015 13:35:24 -0400

Wendy,

We use your server, but I believe that it is OK to switch, as long as you
send a note to the mailing list first.

Cheers,
Richard

On Fri, Aug 28, 2015 at 9:33 AM, Wendy Roome <[email-masked]>
wrote:

> Hans,
>
> Thanks, I will look that over. I certainly agree that the original network
> & cost maps were not realistic, and I would be happy to switch to
> something else.
>
> While I do, here is a question for the rest of you. Who is using my public
> ALTO server and test client? Assuming we do switch to different maps,
> instead of maintaining two versions, I would prefer to do a flag-day
> cutover. Would anyone have a problem with that?  Assuming suitable
> warning, of course.
>
>         - Wendy Roome
>
> On 08/28/2015, 05:15, "Hans Seidel" <[email-masked]> wrote:
>
> >At the interop in Prague, Ingmar and I mentioned that cost values of the
> >cost map in the current interop draft are not very realistic and we
> >faced some problems feeding them into our server since we use real
> >network data.
> >I modified the current interop draft in such way that the cost map
> >values are more realistic. To be as non-invasive as possible I left the
> >network maps unmodified. Additionally, I added example network figures
> >to the draft that
> >can be used (and are used by us) to generate the default and alternate
> >maps.
> >
> >We also updated our ALTO server accordingly:
> >
> https://urldefense.proofpoint.com/v2/url?u=http-3A__alto.benocs.berlin-3A8000_directory&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=ZlC4kfqvOTgC_UyCQQ2EYJvjJVz5BZBfztHrESbzC5Q&s=aOatA95GDKcMXhDa_HOmb05JIlEqSfFWHnkIRB-YAzg&e=
> >
> >Find attached the modified version of the interop draft.
> >Please have a look and send me some feedback.
> >
> >Cheers
> >Hans
> >
>
>
> _______________________________________________
> alto mailing list
> [email-masked]
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_alto&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=ZlC4kfqvOTgC_UyCQQ2EYJvjJVz5BZBfztHrESbzC5Q&s=xjPEr75grjToe34xRH2ilUR50tZoPLuSGVrEvt750ms&e=
>

-- 
-- 
 =====================================
| Y. Richard Yang <[email-masked]>   |
| Professor of Computer Science       |
| http://www.cs.yale.edu/~yry/        |
 =====================================

---

From: ChenGuohai <[email-masked]>
Date: Thu, 17 Sep 2015 10:11:30 +0000

Hi Wendy and Hans,

I found an error about section 4.4.2 in interop document. Appendix A.2. defines the 'routingcost' from *private* to *private*.
Did I misunderstand this. I made a record about this and we may update in next submitting if my understandig is right.

@Wendy your server does return a cost (ipv4:10.0.1.0 -- > ipv4:10.0.1.1 ).
http://alto.benocs.berlin:8000/directory does not return any cost.

4.4.2.  ECS Test 2

   This test determines the costs between endpoints in the "default"
   PID:

      Query:
        sources:
              ipv4:10.0.1.0 ("private")
              ipv6:::2      ("default")
        destinations:
              ipv4:10.0.1.1 ("private")
              ipv6:::1:2    ("default")

                           Figure 15: ECS Test 2

   Since no costs are defined between those PIDs the server MUST return
   an ECS response containing no costs.

Date: Fri, 4 Sep 2015 15:04:51 -0400
Subject: Re: [alto] On-line interop-93 test client
From: [email-masked]
To: [email-masked]
CC: [email-masked]; [email-masked]

Hans,
I have revised the interop document. See attached.
NOTE: Please check the link costs in Figures 5 & 10. I did *not* update them from the version you gave me last week. In particular I am sure that Figure 5 is out-of-date, since that uses your original link costs.
I dropped the ECS tests for omitted source & destination. Those were always flakey, because the client address is unpredictable. Let me know if you think those are worth putting back in.
	- Wendy Roome
From:  Hans Seidel <[email-masked]>
Date:  Thu, September 3, 2015 at 09:41
To:  Wendy Roome <[email-masked]>
Cc:  "[email-masked]" <[email-masked]>, ChenGuohai <[email-masked]>
Subject:  Re: [alto] On-line interop-93 test client

  
    Wendy

      Server is updated and running. Please check if the results are now
      as expected.

      Thanks

      Hans

      On 02.09.2015 19:43, Wendy Roome wrote:

      Hans,

      Okay. Let me know when you have revised your server.

      	-
        Wendy

      
        From:  Hans Seidel <[email-masked]>

          Date:  Wed, September
          2, 2015 at 12:08

          To:  Wendy Roome <[email-masked]>

          Cc:  "[email-masked]"
          <[email-masked]>,
          ChenGuohai <[email-masked]>

          Subject:  Re: [alto]
          On-line interop-93 test client

        Wendy,
        
        Thank you. No I got it.
        
        Yes. At the moment we rank the costs
          for each source separately. This also concerns endpoint cost
          service which I have to fix accordingly as well.
        
        Hans

---

From: Chenguohai <[email-masked]>
Date: Thu, 17 Sep 2015 11:33:30 +0000

Hi Wendy and Hans,

I found an error about section 4.4.2 in ALTO interop document [http://tools.ietf.org/html/draft-roome-alto-interop-ietf93-01]. Section 4.4.2 indicates there is no costs in response but appendix A.2. defines a 'routingcost' cost  from *private* to *private*.

Did I misunderstand this. I made a record about this and we may update in next submitting if my understanding is right.

-------------------------------------------------
4.4.2.  ECS Test 2

      Query:
        sources:

                           Figure 15: ECS Test 2

   Since no costs are defined between those PIDs the server MUST return
   an ECS response containing no costs.
------------------------------------------------
A.2<http://tools.ietf.org/html/draft-roome-alto-interop-ietf93-01#appendix-A.2>.  Default "routingcost" Cost Map

   "cost-map": {
      "default": {
         "mine": 60.0,  "mine1": 63.0,  "mine2": 64.0,  "mine1a": 65.0,
         "mine3": 65.0 },
      "linklocal": {
         "linklocal": 0.0 },
      "loopback": {
         "loopback": 0.0 },
      "mine": {
         "mine": 0.0,  "mine1": 3.0,  "mine2": 4.0,  "mine1a": 5.0,
         "mine3": 5.0,  "peer1": 20.0,  "peer2": 25.0,  "tran1": 35.0,
         "tran2": 45.0,  "default": 60.0 },
      "mine1": {
         "mine": 3.0,  "mine1": 0.0,  "mine2": 6.5,  "mine1a": 2.0,
         "mine3": 8.0,  "peer1": 23.0,  "peer2": 28.0,  "tran1": 38.0,
         "tran2": 48.0,  "default": 63.0 },
      "mine1a": {
         "mine": 5.0,  "mine1": 2.0,  "mine2": 4.5,  "mine1a": 0.0,
         "mine3": 10.0,  "peer1": 25.0,  "peer2": 30.0,  "tran1": 40.0,
         "tran2": 50.0,  "default": 65.0 },
      "mine2": {
         "mine": 4.0,  "mine1": 7.0,  "mine2": 0.0,  "mine1a": 9.0,
         "mine3": 9.0,  "peer1": 24.0,  "peer2": 29.0,  "tran1": 39.0,
         "tran2": 49.0,  "default": 64.0 },
      "mine3": {
         "mine": 5.0,  "mine1": 8.0,  "mine2": 9.0,  "mine1a": 10.0,
         "mine3": 0.0,  "peer1": 25.0,  "peer2": 30.0,  "tran1": 40.0,
         "tran2": 50.0,  "default": 65.0 },
      "peer1": {
         "mine": 20.0,  "mine1": 23.0,  "mine2": 24.0,  "mine1a": 25.0,
         "mine3": 25.0,  "peer1": 0.0
         },
      "peer2": {
         "mine": 25.0,  "mine1": 28.0,  "mine2": 29.0,  "mine1a": 30.0,
         "mine3": 30.0,  "peer2": 0.0 },
   "private": {
        "private": 0.0 },

BR
G.Robert Chen
From: alto [mailto:[email-masked]] On Behalf Of ChenGuohai
Sent: Thursday, September 17, 2015 6:12 PM
To: Roome Wendy; Seidel Hans
Cc: [email-masked]
Subject: Re: [alto] On-line interop-93 test client

________________________________
Date: Fri, 4 Sep 2015 15:04:51 -0400
Subject: Re: [alto] On-line interop-93 test client
From: [email-masked]<mailto:[email-masked]>
To: [email-masked]<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Hans,

        - Wendy Roome

From: Hans Seidel <[email-masked]<mailto:[email-masked]>>
Date: Thu, September 3, 2015 at 09:41
To: Wendy Roome <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, ChenGuohai <[email-masked]<mailto:[email-masked]>>
Subject: Re: [alto] On-line interop-93 test client

Wendy

Server is updated and running. Please check if the results are now as expected.

Thanks
Hans

        - Wendy

From: Hans Seidel <[email-masked]<mailto:[email-masked]>>
Date: Wed, September 2, 2015 at 12:08
To: Wendy Roome <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, ChenGuohai <[email-masked]<mailto:[email-masked]>>
Subject: Re: [alto] On-line interop-93 test client

Wendy,

Thank you. No I got it.

Yes. At the moment we rank the costs for each source separately. This also concerns endpoint cost service which I have to fix accordingly as well.

Hans

---

From: Hans Seidel <[email-masked]>
Date: Thu, 17 Sep 2015 16:56:50 +0200

Hi Robert,

If I remember correctly we agreed to set the costs for "private" <-> 
"private" to 0.  The definitions in section 2.1 and 2.2 as well as the 
appendices A.2 and A.5 say so too.

So Wendy's server response seems correct to me. I also checked the 
BENOCS server which returned the correct cost value to me.

ECS Test 2 is indeed not correct.

Thanks
Hans

On 17.09.2015 13:33, Chenguohai wrote:
>
> Hi Wendy and Hans,
>
> I found an error about section 4.4.2 in ALTO interop document 
> [http://tools.ietf.org/html/draft-roome-alto-interop-ietf93-01]. 
> Section 4.4.2 indicates there is no costs in response but appendix 
> A.2. defines a 'routingcost' cost from *private* to *private*.
>
>
> Did I misunderstand this. I made a record about this and we may update 
> in next submitting if my understanding is right.
>
> *A.2*<http://tools.ietf.org/html/draft-roome-alto-interop-ietf93-01#appendix-A.2>*.Default 
> "routingcost" Cost Map*
>
> "cost-map": {
>
> "default": {
>
> "mine": 60.0,"mine1": 63.0,"mine2": 64.0,"mine1a": 65.0,
>
> "mine3": 65.0 },
>
> "linklocal": {
>
> "linklocal": 0.0 },
>
> "loopback": {
>
> "loopback": 0.0 },
>
> "mine": {
>
> "mine": 0.0,"mine1": 3.0,"mine2": 4.0,"mine1a": 5.0,
>
> "mine3": 5.0,"peer1": 20.0,"peer2": 25.0,"tran1": 35.0,
>
> "tran2": 45.0,"default": 60.0 },
>
> "mine1": {
>
> "mine": 3.0,"mine1": 0.0,"mine2": 6.5,"mine1a": 2.0,
>
> "mine3": 8.0,"peer1": 23.0,"peer2": 28.0,"tran1": 38.0,
>
> "tran2": 48.0,"default": 63.0 },
>
> "mine1a": {
>
> "mine": 5.0,"mine1": 2.0,"mine2": 4.5,"mine1a": 0.0,
>
> "mine3": 10.0,"peer1": 25.0,"peer2": 30.0,"tran1": 40.0,
>
> "tran2": 50.0,"default": 65.0 },
>
> "mine2": {
>
> "mine": 4.0,"mine1": 7.0,"mine2": 0.0,"mine1a": 9.0,
>
> "mine3": 9.0,"peer1": 24.0,"peer2": 29.0,"tran1": 39.0,
>
> "tran2": 49.0,"default": 64.0 },
>
> "mine3": {
>
> "mine": 5.0,"mine1": 8.0,"mine2": 9.0,"mine1a": 10.0,
>
> "mine3": 0.0,"peer1": 25.0,"peer2": 30.0,"tran1": 40.0,
>
> "tran2": 50.0,"default": 65.0 },
>
> "peer1": {
>
> "mine": 20.0,"mine1": 23.0,"mine2": 24.0,"mine1a": 25.0,
>
> "mine3": 25.0,"peer1": 0.0
>
> },
>
> "peer2": {
>
> "mine": 25.0,"mine1": 28.0,"mine2": 29.0,"mine1a": 30.0,
>
> "mine3": 30.0,"peer2": 0.0 },
>
> "private": {
>
> "private": 0.0 },
>
> BR
>
> G.RobertChen
>
> *From:*alto [mailto:[email-masked]] *On Behalf Of *ChenGuohai
> *Sent:* Thursday, September 17, 2015 6:12 PM
> *To:* Roome Wendy; Seidel Hans
> *Cc:* [email-masked]
> *Subject:* Re: [alto] On-line interop-93 test client
>
> ------------------------------------------------------------------------
>
> CC: [email-masked]<mailto:[email-masked]>; 
> [email-masked]<mailto:[email-masked]>
>
> Hans,
>
> NOTE: Please check the link costs in Figures 5 & 10. I did *not* 
> update them from the version you gave me last week. In particular I am 
> sure that Figure 5 is out-of-date, since that uses your original link 
> costs.
>
> I dropped the ECS tests for omitted source & destination. Those were 
> always flakey, because the client address is unpredictable. Let me 
> know if you think those are worth putting back in.
>
> - Wendy Roome
>
> *From: *Hans Seidel <<mailto:[email-masked]>[email-masked]>
> *Date: *Thu, September 3, 2015 at 09:41
> *To: *Wendy Roome 
> <<mailto:[email-masked]>[email-masked]>
> *Cc: *"<mailto:[email-masked]>[email-masked]" 
> <<mailto:[email-masked]>[email-masked]>, ChenGuohai 
> <<mailto:[email-masked]>[email-masked]>
> *Subject: *Re: [alto] On-line interop-93 test client
>
> Wendy
>
>     *From: *Hans Seidel <<mailto:[email-masked]>[email-masked]>
>     *Date: *Wed, September 2, 2015 at 12:08
>     *To: *Wendy Roome
>     <<mailto:[email-masked]>[email-masked]>
>     *Cc: *"<mailto:[email-masked]>[email-masked]"
>     <<mailto:[email-masked]>[email-masked]>, ChenGuohai
>     <[email-masked]<mailto:[email-masked]>>
>     *Subject: *Re: [alto] On-line interop-93 test client
>
>     Wendy,
>
>     Thank you. No I got it.
>
>     Yes. At the moment we rank the costs for each source separately.
>     This also concerns endpoint cost service which I have to fix
>     accordingly as well.
>
>     Hans
>

---

From: Wendy Roome <[email-masked]>
Date: Thu, 17 Sep 2015 11:36:01 -0400

Thanks for spotting that. Yes, Section 4.4.2 is incorrect; it should say the
expected costs are

   Costs:                     routingcost  hopcount
     ipv4:10.0.1.0 =>
           ipv4:10.0.1.1             0.0         0

We will fix it in -02.

- Wendy Roome

From:  ChenGuohai <[email-masked]>
Date:  Thu, September 17, 2015 at 06:11
To:  Wendy Roome <[email-masked]>, Seidel Hans
<[email-masked]>
Cc:  "[email-masked]" <[email-masked]>
Subject:  RE: [alto] On-line interop-93 test client

Hi Wendy and Hans,

I found an error about section 4.4.2 in interop document. Appendix A.2.
defines the 'routingcost' from *private* to *private*.
Did I misunderstand this. I made a record about this and we may update in
next submitting if my understandig is right.

4.4.2.  ECS Test 2

      Query:
        sources:

                           Figure 15: ECS Test 2

---

From: ChenGuohai <[email-masked]>
Date: Fri, 18 Sep 2015 03:56:06 +0000

Hi  Wendy,

 I have tested my client with your server in according to interop document(v01).

BR
G.Robert Chen

---

From: ChenGuohai <[email-masked]>
Date: Fri, 18 Sep 2015 03:57:14 +0000

And no problems found。
From: [email-masked]
To: [email-masked]
CC: [email-masked]
Subject: I have used my client  to do interop test with your server
Date: Fri, 18 Sep 2015 03:56:06 +0000

Hi  Wendy,

BR
G.Robert Chen

---

From: Wendy Roome <[email-masked]>
Date: Fri, 18 Sep 2015 07:07:06 -0400

That's wonderful!  And thanks for the clarification.

     - Wendy Roome

> On Sep 17, 2015, at 23:57, ChenGuohai <[email-masked]> wrote:
> 
> 
> And no problems found。
> https://www.ietf.org/mailman/listinfo/alto