Subject: [alto] I-D Action: draft-ietf-alto-multi-cost-01.txt

From: [email-masked]
Date: Mon, 19 Oct 2015 15:27:10 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Application-Layer Traffic Optimization Working Group of the IETF.

        Title           : Multi-Cost ALTO
        Authors         : Sabine Randriamasy
                          Wendy Roome
                          Nico Schwan
	Filename        : draft-ietf-alto-multi-cost-01.txt
	Pages           : 23
	Date            : 2015-10-19

Abstract:
   The ALTO (Application Layer-Traffic Optimization) Protocol
   ([RFC7285]) defines several services that return various metrics
   describing the costs between network endpoints.  For example, when
   downloading a file that is mirrored on several sites, a user
   application may use these ALTO cost metrics to determine the most
   efficient mirror site.

   An ALTO Server may offer a variety of cost metrics, based on latency,
   bandwidth, hop count, jitter, or whatever else the ALTO Server deems
   useful.  When selecting a mirror site, a client may consider more
   than one metric, perhaps trading bandwidth for latency.  While the
   base ALTO Protocol allows a client to use more than one cost metric,
   to do so, the client must request each metric separately.  This
   document defines a new service that allows a client to retrieve
   several cost metrics with one request, which is considerably more
   efficient.  In addition, this document extends the ALTO constraint
   tests to allow a user to specify an arbitrary logical combination of
   tests on several cost metrics.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-alto-multi-cost/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-alto-multi-cost-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-alto-multi-cost-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Y. Richard Yang" <[email-masked]>
Date: Mon, 19 Oct 2015 19:21:11 -0400

Sabine, Wendy, Nico,

Just want to let you know that I just wrote a first version draft of
supporting general cost types, and multi-cost is an example motivating the
design:
https://datatracker.ietf.org/doc/draft-yang-alto-general-cost-type/

I see other "struct" types to be defined, to replace the generic JSONValue
in both ECS and cost maps.

The basic idea is to go beyond 'numerical' and 'ordinal' in 'cost-mode'.
Instead, we introduce schema languages, and the 'cost-mode' indicates the
schema language and 'cost-metric' indicate the type defined using the
schema language. It will be great to discuss how the "general" design might
have on your multi-cost design. The example I gave uses YANG as the schema
specification language, but unfortunately it does not produce as compact,
flexible a representation as your spec.

Richard

On Mon, Oct 19, 2015 at 6:27 PM, <[email-masked]> wrote:

> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dalto-2Dmulti-2Dcost_&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=Xd_HLgaqYezBYFKuvPwEy-l1yTedlgKtJkOH4V34Yuc&s=ll9Yp5oMnBYK4CbUwySW4fnVY71Vwby7CAe9OUUGB_U&e=
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dalto-2Dmulti-2Dcost-2D01&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=Xd_HLgaqYezBYFKuvPwEy-l1yTedlgKtJkOH4V34Yuc&s=TxiqIdnCP_WDu4XTslMrXpyEK-HRPv5WIYZo8OiBYO0&e=
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dietf-2Dalto-2Dmulti-2Dcost-2D01&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=Xd_HLgaqYezBYFKuvPwEy-l1yTedlgKtJkOH4V34Yuc&s=r-ambg6GI5PWGIZJyGfKe2xhkgO7Ph-Eb_Jm5XP43PY&e=
>
>
> https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_internet-2Ddrafts_&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=Xd_HLgaqYezBYFKuvPwEy-l1yTedlgKtJkOH4V34Yuc&s=Ufa7jowVSi9gYQn2VUSQqHxvNfbqTtUfsstPV8_SaBY&e=
>
> _______________________________________________
> alto mailing list
> [email-masked]
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_alto&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=Xd_HLgaqYezBYFKuvPwEy-l1yTedlgKtJkOH4V34Yuc&s=9BdPcPlcfWEL2-8O5l5NDaKW7fX1cIQx0SJGAjB0uA4&e=

---

From: "RANDRIAMASY, SABINE (SABINE)" <[email-masked]>
Date: Tue, 20 Oct 2015 17:27:48 +0000

Hi Richard,

Thank you for the pointer. Indeed there are lots of cases motivating the extension of ALTO cost value expressions.
And as you pointed, the challenge is then to keep the extension compact and flexible.
I will take a closer look to your draft.

Thanks
Sabine

De : alto [mailto:[email-masked]] De la part de Y. Richard Yang
Envoyé : mardi 20 octobre 2015 01:21
À : Drafts IETF
Cc : IETF ALTO; [email-masked]
Objet : Re: [alto] I-D Action: draft-ietf-alto-multi-cost-01.txt

Sabine, Wendy, Nico,

Just want to let you know that I just wrote a first version draft of supporting general cost types, and multi-cost is an example motivating the design:
https://datatracker.ietf.org/doc/draft-yang-alto-general-cost-type/

I see other "struct" types to be defined, to replace the generic JSONValue in both ECS and cost maps.

The basic idea is to go beyond 'numerical' and 'ordinal' in 'cost-mode'. Instead, we introduce schema languages, and the 'cost-mode' indicates the schema language and 'cost-metric' indicate the type defined using the schema language. It will be great to discuss how the "general" design might have on your multi-cost design. The example I gave uses YANG as the schema specification language, but unfortunately it does not produce as compact, flexible a representation as your spec.

Richard

On Mon, Oct 19, 2015 at 6:27 PM, <[email-masked]<mailto:[email-masked]>> wrote:

        Title           : Multi-Cost ALTO

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

_______________________________________________
alto mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_alto&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=Xd_HLgaqYezBYFKuvPwEy-l1yTedlgKtJkOH4V34Yuc&s=9BdPcPlcfWEL2-8O5l5NDaKW7fX1cIQx0SJGAjB0uA4&e=

---

From: "Y. Richard Yang" <[email-masked]>
Date: Thu, 22 Oct 2015 15:11:37 -0400

Sabine,

Thanks.
On Tue, Oct 20, 2015 at 1:27 PM, RANDRIAMASY, SABINE (SABINE) <
[email-masked]> wrote:

> Hi Richard,
>
>
>
> Thank you for the pointer. Indeed there are lots of cases motivating the
> extension of ALTO cost value expressions.
>

Yes. The key issue, in my view, is that if we can develop a general
mechanism to accommodate a relative larger set of extensions, without per
use-case extension. At the same time, a key challenge is that we do not
make a "giant" extension (e.g., introducing a new language) that may lead
to a huge effort and delay in making progress.

Richard

> *De :* alto [mailto:[email-masked]] *De la part de* Y. Richard Yang
> *Envoyé :* mardi 20 octobre 2015 01:21
> *À :* Drafts IETF
> *Cc :* IETF ALTO; [email-masked]
> *Objet :* Re: [alto] I-D Action: draft-ietf-alto-multi-cost-01.txt
>
>
>
> Sabine, Wendy, Nico,
>
>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dyang-2Dalto-2Dgeneral-2Dcost-2Dtype_&d=AwMGaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=oRgzkCHIhI4oVd0zEt7WDqLghXITM8BMCHXzuvtnAqE&s=0guowbIPkYpHeqp7453GimMlxgJhDSHA80nQYSMXVBA&e=>
>
>
>
> until the htmlized version and diff are available at tools.ietf.org
> <https://urldefense.proofpoint.com/v2/url?u=http-3A__tools.ietf.org&d=AwMGaQ&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=oRgzkCHIhI4oVd0zEt7WDqLghXITM8BMCHXzuvtnAqE&s=MbzylRQ_OAzSdFF-2te--6eEwxV8qCXSz9CnPpb_EZI&e=>
> .
>