Subject: [alto] ALTO deployment considerations and map calculation draft

From: "Vijay K. Gurbani" <[email-masked]>
Date: Wed, 28 Oct 2015 10:42:14 -0500

Michael, Hans: Pursuant to our virtual meeting yesterday, I have been
thinking whether Hans' draft [1] has any input that can go into
Michael's deployment draft [2]?

Can I kindly request the authors to inform the working group if there
is any beneficial overlap from [1] that we may take into [2]?  I
realize that [2] has been through WGLC so I am not expecting
large-scale changes in it.  But if there is any deployment-related
experience from [1] that can be put into [2], we should do our due
diligence and make sure that we reflect that experience.

Thanks!

[1] http://datatracker.ietf.org/doc/draft-seidel-alto-map-calculation/
[2] http://datatracker.ietf.org/doc/draft-ietf-alto-deployments/

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web: http://ect.bell-labs.com/who/vkg/  | Calendar: http://goo.gl/x3Ogq

---

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Wed, 28 Oct 2015 15:55:00 +0000

Well, draft-ietf-alto-deployments is not *my* draft - I just volunteered a long time ago to help the WG completing it.

I could see value in including draft-seidel-alto-map-calculation, even if we are post WGLC. Personally, I'd also be open to add another author/editor.

But I am interested in completing draft-ietf-alto-deployments soon, i.e., not further delaying it by several IETF meetings.

Michael

> -----Original Message-----
> From: Vijay K. Gurbani [mailto:[email-masked]]
> Sent: Wednesday, October 28, 2015 4:42 PM
> To: Scharf, Michael (Michael); Hans Seidel
> Cc: IETF ALTO
> Subject: ALTO deployment considerations and map calculation draft
>

---

From: "Y. Richard Yang" <[email-masked]>
Date: Wed, 28 Oct 2015 13:13:16 -0400

Vijay, Michael,

On Wed, Oct 28, 2015 at 11:55 AM, Scharf, Michael (Michael) <
[email-masked]> wrote:

> Well, draft-ietf-alto-deployments is not *my* draft - I just volunteered a
> long time ago to help the WG completing it.
>
> I could see value in including draft-seidel-alto-map-calculation, even if
> we are post WGLC. Personally, I'd also be open to add another author/editor.
>
> I liked draft-seidel-alto-map-calculation, and support that we report the
results in an RFC.

> But I am interested in completing draft-ietf-alto-deployments soon, i.e.,
> not further delaying it by several IETF meetings.
>

I share the same interest: completing the deployment doc soon. One
procedural question. If we add content from
draft-seidel-alto-map-calculation to the deployment doc, do we need to go
through a WGLC again?

Richard

> > [1]
> https://urldefense.proofpoint.com/v2/url?u=http-3A__datatracker.ietf.org_doc_draft-2Dseidel-2Dalto-2Dmap-2Dcalculation_&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=QvVJUkVLNsiDKevD6EXWJbBa36od3GmkD8x5WwbFGeU&s=ogDB4bGxutijuhVJDM13ygucSj_-7ZaSBnUUSNOTuRc&e=
> > [2]
> https://urldefense.proofpoint.com/v2/url?u=http-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dalto-2Ddeployments_&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=QvVJUkVLNsiDKevD6EXWJbBa36od3GmkD8x5WwbFGeU&s=c52wZRonSYcres77EBSpAxjFoFfgtBPyl4QiE_GAykk&e=
> >
> > - vijay
> > --
> > Web:
> https://urldefense.proofpoint.com/v2/url?u=http-3A__ect.bell-2Dlabs.com_who_vkg_&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=QvVJUkVLNsiDKevD6EXWJbBa36od3GmkD8x5WwbFGeU&s=UtLmwbRQFni1BKwt7zRu__ySlRu5zu5h8lYj-Voz9-0&e=
>  | Calendar:
> https://urldefense.proofpoint.com/v2/url?u=http-3A__goo.gl_x3Ogq&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=QvVJUkVLNsiDKevD6EXWJbBa36od3GmkD8x5WwbFGeU&s=aGc_uWMJanaOoxYY9kEwEB7s2vXo7O_xPsWIr_FJk-8&e=
> _______________________________________________
> alto mailing list
> [email-masked]
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_alto&d=AwICAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=4G36iiEVb2m_v-0RnP2gx9KZJjYQgfvrOCE3789JGIA&m=QvVJUkVLNsiDKevD6EXWJbBa36od3GmkD8x5WwbFGeU&s=BsbxqGGNZY9i4qFnlvi-dLmrNkvPy2kZQUFMcWukmv8&e=
>

-- 
-- 
 =====================================
| Y. Richard Yang <[email-masked]>   |
| Professor of Computer Science       |
| http://www.cs.yale.edu/~yry/        |
 =====================================

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Wed, 28 Oct 2015 13:04:00 -0500

Michael Scharf wrote:
> Well, draft-ietf-alto-deployments is not *my* draft - I just
> volunteered a long time ago to help the WG completing it.
>
> I could see value in including draft-seidel-alto-map-calculation,
> even if we are post WGLC. Personally, I'd also be open to add another
> author/editor.
> But I am interested in completing draft-ietf-alto-deployments soon,
> i.e., not further delaying it by several IETF meetings.

Michael: Agree.  Not delaying the draft is not in the interest of the
WG, so no worries.  Regarding a new editor, that is entirely up to you.
As I said, you have done most of the heavy lifting, so unless you
absolutely need a new editor, my preference would be that you finish
the work.

However, I want to make sure that we do our due diligence with respect
to the new information in draft-siedel-...-calculation.  I will
respond more on the process part in Richard's email.

Thanks,

- vijay

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Wed, 28 Oct 2015 13:11:07 -0500

> Vijay, Michael,
[...]
> I liked draft-seidel-alto-map-calculation, and support that we report
> the results in an RFC.

Richard, whether and in which track draft-siedel-...-calculation moves
ahead will get hashed out on the list, I am sure.  Probably sooner
rather than later.

> draft-seidel-alto-map-calculation to the deployment doc, do we need
> to go through a WGLC again?

If we end up taking some text from draft-siedel-...-calculation, then
yes, we'd socialize the change with the WG.  However, it does not have
to be a WGLC again, just a revision that presents the newly added text
to the WG.

In the past, I have authored drafts and been part of WGs where new text
is added after the WGLC.  The change gets socialized, and if the feeling
in the WG is that the change is substantial, then a second WGLC may get
issued.  However, I don't think that will be the case here.  I suspect
we can identify if there is any information we can carry into
draft-...-deployment-considerations, and if so we can revise the draft
to socialize the change and move it ahead.

The bigger issue is finding the time for the authors (or list members)
to scan draf-siedel-...-calculation and see if there is any text that
is worth including in draft-...-deployment-considerations.  The sooner
this happens, the better.

Hans, Michael: If you could devote a bit of time to determining this,
it'll be great.

Thanks,

- vijay

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Wed, 28 Oct 2015 13:12:22 -0500

On 10/28/2015 01:04 PM, Vijay K. Gurbani wrote:
> Michael: Agree.  Not delaying the draft is not in the interest of the  [...]

I am sorry, I meant "Delaying the draft is not in the interest ..."

Sigh.

- vijay