Subject: [alto] AD review of draft-ietf-alto-xdom-disc

From: "Mirja Kuehlewind (IETF)" <[email-masked]>
Date: Tue, 30 Oct 2018 18:33:25 +0100

Hi authors, hi shepherd,

thanks for the well-written document and write-up! I've reviewed the draft and would be ready to start IETF last call any time. However, I will not be able to join the next telechat on Nov 21 and therefore this doc has to wait for final approval for Dec 6 anyway. That means we have plenty of time to start IETF last call and I would prefer to start it after the meeting week! Let me know if there are any concerns about this time line!

While I think the document is ready, I of course still have a couple comments after my review. See below for my comments which are mostly editorial. Feel free to address them or not and update the doc before or after IETF last call accordingly. Just let me know what your plans are!

Thanks!
Mirja

———————————————
Review Comments:

1) There are a few abbreviations that are not spelled out at first occurrence (but later instead). Can you double-check this…? 
(You can also check with the RFC Editor Abbreviations List: 
https://www.rfc-editor.org/materials/abbrev.expansion.txt )

2) This part seems to be twice in the doc

sec 2: "For the remainder of the document, we use the notation:
   IRD_URIS_X = XDOMDISC(X,"ALTO:https“)“

sec 3: "For the remainder of the document, we use the following notation for
   calling the ALTO Cross-Domain Server Discovery Procedure:

      IRD_URIS_X = XDOMDISC(X,"ALTO:https“)“

I guess you can just remove it in sec 2.

3) sec 3: "These error
   conditions have to be reported to the caller in an appropriate way.“
Would you be able to say more here?

4) sec 3.4: "If no IRD URI could be
   found after looking up all domain names from the 3rd and 4th column,
   the procedure terminates unsuccessfully, without producing a result.“
What does this mean for the caller? Or should an empty result rather be returned?

5) section 4: in 4.3 and 4.4 the step to call the ALTO Cross-Domain Server Discovery Procedure and then query the IRD(s) are listed as explicit step while in section 4.1. and 4.2 the same (?) steps are described in text. The way this is represented is a bit confusing. Also given these two first steps are always the same, is it really necessary to describe them separately in each subsection? To be honest, the way it is currently presented I’m a bit confused where the differences are…

6) Appendix A and B: Thanks for moving this part in the appendix. It is absolutely appropriate to have any such information in the appendix. However, please reconsider before final publication if all of this information actually has an achievable value or if some maybe can be removed before final publication. Also for appendix A please consider renaming it.

7) In appendix maybe replace "sk@labpc12“ with something more neutral e.g. „user1“…

---

From: Jan Seedorf <[email-masked]>
Date: Tue, 30 Oct 2018 19:11:42 +0100

Martin, Sebastian,

I suggest you get to the editorial comments from Mirja sometime soon, so 
we that a new version is published by the time this goes into the IESG 
call in December.

  - Jan