Subject: [alto] Alvaro Retana's Discuss on draft-ietf-alto-cost-calendar-09: (with DISCUSS)

From: Alvaro Retana <[email-masked]>
Date: Wed, 05 Dec 2018 13:53:45 -0800

Alvaro Retana has entered the following ballot position for
draft-ietf-alto-cost-calendar-09: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-alto-cost-calendar/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

This is a process DISCUSS.

This document replaces draft-randriamasy-alto-cost-calendar, but this
information is not reflected in the datatracker.  The individual draft has an
IPR declaration attached to it [1], but the failure to link the two documents
has resulted in the IPR indication not carrying over.   The direct effect is
that the IETF Last Call [2] explicitly says that "No IPR declarations have been
submitted directly on this I-D."

The Shepherd writeup says that "The entire author team has confirmed
conformance with BCP 78/79 with the shephered." -- but that doesn't indicate
whether IPR is present or not, just conformance.  In looking through the
mailing list archive, I couldn't find mention of the IPR at adoption [3] [4] or
at WGLC [5].

The declaration was made early in the process [6], and there was no discussion
in the WG about it.  I can see how it would be easy to overlook.

Nonetheless, it is necessary for the WG (and the IETF as a whole) to explicitly
consider the declaration before proceeding with the publication of this
document.

[1] https://datatracker.ietf.org/ipr/2392/
[2] https://mailarchive.ietf.org/arch/msg/alto/LI01TfoTCnJRDImEUXA-9x8KsZ4
[3] https://mailarchive.ietf.org/arch/msg/alto/xFErWArHhpF-0ZVR_1BAhgzRj3k
[4] https://mailarchive.ietf.org/arch/msg/alto/-D7cj6qoD-Q3ye3rpuj8li2xWms
[5] https://mailarchive.ietf.org/arch/msg/alto/67W_XuMfu7JMXQEEZFLkulw_xBI
[6]
https://mailarchive.ietf.org/arch/msg/ipr-announce/lnZ65z15_Dn3bylJp7h9rGHxZFk

---

From: "Mirja Kuehlewind (IETF)" <[email-masked]>
Date: Thu, 6 Dec 2018 14:53:32 +0100

Hi Alvaro,

thanks for detecting this. I wasn’t aware of this!

I will check with authors and chairs, however it could also be the cause that the IPR was not applicable to the wg doc anymore, as there have been quite some changes to the -01 version of the draft (when the IPR was filed) and the adopted version.

If that is not the case, we will re-issue wg and IETF last call and bring it back.

Mirja

> Am 05.12.2018 um 22:53 schrieb Alvaro Retana <[email-masked]>:
> 
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto

---

From: Alvaro Retana <[email-masked]>
Date: Thu, 6 Dec 2018 07:13:58 -0800

Perfect!

Thanks!

Alvaro.

On December 6, 2018 at 8:53:38 AM, Mirja Kuehlewind (IETF) (
[email-masked]) wrote:

I will check with authors and chairs, however it could also be the cause
that the IPR was not applicable to the wg doc anymore, as there have been
quite some changes to the -01 version of the draft (when the IPR was filed)
and the adopted version.

If that is not the case, we will re-issue wg and IETF last call and bring
it back.

---

From: "Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Thu, 6 Dec 2018 18:31:34 +0000

Hello,

I confirm that the IPR attached to draft-randriamasy-alto-cost-calendar still applies to draft-ietf-alto-cost-calendar.
I also attach the IPR declaration that I sent on June 7th
Please let me know what I can do to help resolving this issue.

Sabine

From: Alvaro Retana <[email-masked]>
Sent: Thursday, December 06, 2018 4:14 PM
To: Mirja Kuehlewind (IETF) <[email-masked]>
Cc: [email-masked]; [email-masked]; The IESG <[email-masked]>; [email-masked]; Gurbani, Vijay (Nokia - US/Naperville) <[email-masked]>
Subject: Re: [alto] Alvaro Retana's Discuss on draft-ietf-alto-cost-calendar-09: (with DISCUSS)

Perfect!

Thanks!

Alvaro.

On December 6, 2018 at 8:53:38 AM, Mirja Kuehlewind (IETF) ([email-masked]<mailto:[email-masked]>) wrote:
I will check with authors and chairs, however it could also be the cause that the IPR was not applicable to the wg doc anymore, as there have been quite some changes to the -01 version of the draft (when the IPR was filed) and the adopted version.

Subject: RE: IPR decleration for draft-ietf-alto-cost-calendar
From: "Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
To: "Gurbani, Vijay (Nokia - US/Naperville)" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: Jan Seedorf <[email-masked]>
Date: Thu, 7 Jun 2018 17:32:18 +0000

Hello,

I hereby state that all IPR on this draft that I know of have been disclosed as per IETF BCP 78 [1] and IETF BCP 79 [2].

Thanks,
Sabine

-----Original Message-----
From: Vijay K. Gurbani [mailto:[email-masked]]
Sent: Monday, June 04, 2018 7:45 PM
To: [email-masked]
Cc: Jan Seedorf <[email-masked]>
Subject: IPR decleration for draft-ietf-alto-cost-calendar

Dear Authors: In preparation for moving the draft-ietf-alto-cost-calendar ahead I will need an email from each one of you that states that all IPR on this draft that you know of have been disclosed as per IETF BCP 78 [1] and IETF BCP 79 [2].

To move this work expeditiously ahead, please send me all declarations by Thursday of this week.

[1] https://tools.ietf.org/html/bcp78
[2] https://tools.ietf.org/html/bcp79

Thanks,

- vijay
--
Vijay K. Gurbani / [email-masked] Network Data Science, Nokia Networks
Calendar: http://goo.gl/x3Ogq

---

From: "Mirja Kuehlewind (IETF)" <[email-masked]>
Date: Thu, 6 Dec 2018 19:53:06 +0100

Hi Sabine,

thanks for confirming this. I have set the „replaces“ field in the datatracker now correctly and the IPR shows up respectively.

Vijay, can you update the shepherd write up and re-run the wg last call with a note to the working group that this IPR exists?

Sabine, maybe you can also address the other comments from the IESG in a new revision before we re-start WG last call, especially the use of examples IP addresses as flagged by Suresh and Adam, and use of https as flagged by Alissa and Adam. I think Ben’s discuss needs further discussion before we can update. Please reply to his email as well as soon as possible!

Thanks!

Mirja

> Am 06.12.2018 um 19:31 schrieb Randriamasy, Sabine (Nokia - FR/Paris-Saclay) <[email-masked]>:
> 
> Hello,
>  
> On December 6, 2018 at 8:53:38 AM, Mirja Kuehlewind (IETF) ([email-masked]) wrote:
> 
> <Mail-Anhang.eml>

---

From: Jan Seedorf <[email-masked]>
Date: Thu, 6 Dec 2018 23:22:57 +0100

> Vijay, can you update the shepherd write up and re-run the wg last call with a note to the working group that this IPR exists?
As co-chair I agree: we need to inform the WG and re-do a WG last call, 
giving people the chance to comment if they think necessary
> Sabine, maybe you can also address the other comments from the IESG in a new revision before we re-start WG last call, especially the use of examples IP addresses as flagged by Suresh and Adam, and…
That is a good idea; Sabine, what do you think?

  - Jan

---

From: "Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Fri, 7 Dec 2018 10:51:30 +0000

Hi Mirja,

Thanks a lot for the datatracker update. I will address the IESG comments with the co-authors asap before submitting a new version for the WG last call. 

Sabine
PS: I added Vijay's new e-mail address 

-----Original Message-----
From: Mirja Kuehlewind (IETF) <[email-masked]> 
Sent: Thursday, December 06, 2018 7:53 PM
To: Randriamasy, Sabine (Nokia - FR/Paris-Saclay) <[email-masked]>
Cc: Alvaro Retana <[email-masked]>; [email-masked]; [email-masked]; The IESG <[email-masked]>; [email-masked]; Gurbani, Vijay (Nokia - US/Naperville) <[email-masked]>
Subject: Re: [alto] Alvaro Retana's Discuss on draft-ietf-alto-cost-calendar-09: (with DISCUSS)

Hi Sabine,

Thanks!

Mirja

> I also attach the IPR declaration that I sent on June 7th Please let 
> me know what I can do to help resolving this issue.
>  
> Sabine
>  
>  
>  
> Cc: [email-masked]; [email-masked]; The 
> IESG <[email-masked]>; [email-masked]; Gurbani, Vijay (Nokia - 
> US/Naperville) <[email-masked]>
> Subject: Re: [alto] Alvaro Retana's Discuss on 
> draft-ietf-alto-cost-calendar-09: (with DISCUSS)
>  
> Perfect!
>  
> Thanks!
>  
> Alvaro.
>