Subject: [alto] Status of cost-calendar

From: Vijay Gurbani <[email-masked]>
Date: Tue, 5 Feb 2019 12:30:54 -0600

Sabine, Based on my posting on the mailing list [1], it does not appear
that ALTO or any of its extensions are intimately tied to UTF-{16,32}.

As such, please reference the new JSON RFC 8259 in the Introduction to the
cost-calendar draft and please move it ahead as soon as possible after
incorporating other comments from IESG review.

I have forgotten whether we have to redo the WG and IETF last calls.  Can
you please provide the status of the draft with respect to IETF last call
and whether we need to do a WGLC again.

[1] https://mailarchive.ietf.org/arch/msg/alto/EGuPfDqoYBv7H8grPXE0qtjQsGc

Thank you.

---

From: "Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Wed, 6 Feb 2019 11:10:27 +0000

Hi Vijay,

Thanks for the clarification. I will then just cite RFC 8259 in the intro and 3.1. Maybe the “operational considerations” section can include a paragraph saying that implementations using UTF-{16,32} need to be cognizant of both the 8259 evolution that mandates UTF-8, essentially for interoperability reasons. Therefore it is recommended for them to switch to UTF-8 encoding.

Thanks,
Sabine

From: Vijay Gurbani <[email-masked]>
Sent: Tuesday, February 05, 2019 7:31 PM
To: [email-masked]; Randriamasy, Sabine (Nokia - FR/Paris-Saclay) <[email-masked]>
Cc: [email-masked]
Subject: Status of cost-calendar

Sabine, Based on my posting on the mailing list [1], it does not appear that ALTO or any of its extensions are intimately tied to UTF-{16,32}.

As such, please reference the new JSON RFC 8259 in the Introduction to the cost-calendar draft and please move it ahead as soon as possible after incorporating other comments from IESG review.

I have forgotten whether we have to redo the WG and IETF last calls.  Can you please provide the status of the draft with respect to IETF last call and whether we need to do a WGLC again.

Thank you.

---

From: "Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Wed, 6 Feb 2019 11:18:34 +0000

And yes, we need to redo the WG and IETF last calls, see (1). The draft has been substantially updated, and once the text related to RFC8259 will be integrated, the only thing pending will be parsing the JSON examples and updating the ipv6 addresses.

(1) https://mailarchive.ietf.org/arch/browse/alto/?qdr=y

From: Randriamasy, Sabine (Nokia - FR/Paris-Saclay) <[email-masked]>
Sent: Wednesday, February 06, 2019 12:10 PM
To: Vijay Gurbani <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: RE: Status of cost-calendar

Hi Vijay,

Thanks,
Sabine

From: Vijay Gurbani <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, February 05, 2019 7:31 PM
To: [email-masked]<mailto:[email-masked]>; Randriamasy, Sabine (Nokia - FR/Paris-Saclay) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Status of cost-calendar

Thank you.