Subject: [alto] I-D Action: draft-ietf-alto-cost-calendar-10.txt

From: [email-masked]
Date: Thu, 07 Feb 2019 09:19:39 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Application-Layer Traffic Optimization WG of the IETF.

        Title           : ALTO Cost Calendar
        Authors         : Sabine Randriamasy
                          Richard Yang
                          Qin Wu
                          Lingli Deng
                          Nico Schwan
	Filename        : draft-ietf-alto-cost-calendar-10.txt
	Pages           : 30
	Date            : 2019-02-07

Abstract:
   This document is an extension to the base Application-Layer Traffic
   Optimization (ALTO) protocol.  It extends the ALTO cost information
   service such that applications decide not only 'where' to connect,
   but also 'when'.  This is useful for applications that need to
   perform bulk data transfer and would like to schedule these transfers
   during an off-peak hour, for example.  This extension introduces ALTO
   Cost Calendars, with which an ALTO Server exposes ALTO cost values in
   JSON arrays where each value corresponds to a given time interval.
   The time intervals as well as other Calendar attributes are specified
   in the Information Resources Directory and ALTO Server responses.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-alto-cost-calendar/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-alto-cost-calendar-10
https://datatracker.ietf.org/doc/html/draft-ietf-alto-cost-calendar-10

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-alto-cost-calendar-10

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Thu, 7 Feb 2019 17:32:32 +0000

Hello,

The updates address all the IESG DISCUSS and COMMENTS and are quite substantial. 
https://tools.ietf.org/rfcdiff?url2=draft-ietf-alto-cost-calendar-10.txt. In a nutshell:

- Among others, the design has been changed, many clarification text was added, section 4.1.2 has been reorganized, ipv6 formats, units and references have been updated and JSON errors have been hopefully corrected, some typo harmonization was started.   

Two pending COMMENTS have been addressed:
- format of "time-interval-size": the value is now a JSONNUmber defined in seconds,
- ALTO Calendars of long duration and changes in the actual values: it is now RECOMMENDED that Calendar-aware Clients and Servers also support the ALTO incremental updates service. 

I will send an e-mail to Ben Campbell detailing how his comments were addressed. 

Your feedback on how this new version addresses the IESG feedback will be more than welcome. 

To start with, it will be great if the WG can check the JSON examples, and look at:
- JSON errors 
- check the "content-length" 

Thanks,
Sabine

-----Original Message-----
From: alto <[email-masked]> On Behalf Of [email-masked]
Sent: Thursday, February 07, 2019 6:20 PM
To: [email-masked]
Cc: [email-masked]
Subject: [alto] I-D Action: draft-ietf-alto-cost-calendar-10.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
alto mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/alto