Subject: [alto] ALTO meeting info for Oct. 02, 2019

From: Danny Alex Lachos Perez <[email-masked]>
Date: Tue, 1 Oct 2019 13:04:59 -0300

Dear all,

Just a friendly reminder that we will have our weekly meeting this
Wednesday (*Oct-02*) at *9:30 am US ET*.

Current Agenda*:

   - Quick updates on existing WG documents
   - Discussion about integration design between ALTO and Globus/HTCondor
      -  Go over how to extend Globus for some simple but important use
      cases using ALTO
   - Planning for ALTO workshop (IETF106)

*If people have other agenda items, please feel free to post.

Bridge: https://yale.zoom.us/j/8423318713

Best regards,

Danny Lachos

---

From: "Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Tue, 1 Oct 2019 17:56:47 +0000

Hello,

Would it be possible to start with the side-meeting at IETF 106 ? We need to contact potential participants early enough for them to plan their participation and agree on a schedule. So we need to prepare some invitation text to introduce the context and purpose of the meeting. Below is some draft text based on our discussion last Friday, to be updated and amended upon your feedback and suggestions tomorrow.

Cheers,
Sabine

The IETF ALTO WG is planning a 2-3hours meeting with 20-30 participants at the IETF 106. The focus is to prepare the evolution of ALTO and explore both topics of application-aware networking (AAN) and network-aware applications (NAA).

To this end, we would like to invite a group of speakers willing to share their experience and insights about cooperative interactions between networks and applications. In particular: given today’s network usage trends, where do we identify problems that would be solved  with the help of such a cooperation?

AAN or NAA: what is it? What problems did we address? What did we try? What worked? What did not? What is missing ?  What are the changes in networks, applications, in research, technology that we need to take into account?

The goal of this meeting is to gather input helping to better identify how ALTO evolutions can complement with other IETF protocols or research activities. We therefore seek for insights of participants involved in network operations, application or cooperation thereof. A fruitful meeting would both collect experience and expectations in this field.

To start with (text to be shortened + completed): ALTO  is addressing the need for network-aware applications. It helps addressing issues such as unnecessary network costs or performance loss due: to network topology agnostic selection of application endpoints such as peers or CDN surrogates,  bad timing of connection, poor information on e2e network paths (no insight, outdated, too voluminous). What misses is are extensions to support applications covering multiple network domains and technologies, multiple paths, etc… The changes that we need to consider are the prevalence of wireless and cellular networks, 5G multi-technology e2e,

From: [email-masked] <[email-masked]> On Behalf Of Danny Alex Lachos Perez
Sent: Tuesday, October 01, 2019 6:05 PM
To: IETF ALTO <[email-masked]>; [email-masked]
Subject: ALTO meeting info for Oct. 02, 2019

Dear all,

Just a friendly reminder that we will have our weekly meeting this Wednesday (Oct-02) at 9:30 am US ET.

Current Agenda*:

  *   Quick updates on existing WG documents
  *   Discussion about integration design between ALTO and Globus/HTCondor

     *    Go over how to extend Globus for some simple but important use cases using ALTO

  *   Planning for ALTO workshop (IETF106)
*If people have other agenda items, please feel free to post.

Best regards,

Danny Lachos
--
You received this message because you are subscribed to the Google Groups "alto-weekly-meeting" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email-masked]<mailto:[email-masked]>.
To view this discussion on the web visit https://groups.google.com/d/msgid/alto-weekly-meeting/CAEDarXJG%3DXW%3DBjppyR5qdvGBp7vdkZrT4QvcT0J%2BTUr9zj-Dhg%40mail.gmail.com<https://groups.google.com/d/msgid/alto-weekly-meeting/CAEDarXJG%3DXW%3DBjppyR5qdvGBp7vdkZrT4QvcT0J%2BTUr9zj-Dhg%40mail.gmail.com?utm_medium=email&utm_source=footer>.

---

From: Danny Alex Lachos Perez <[email-masked]>
Date: Tue, 1 Oct 2019 17:32:14 -0300

Hi Sabine,

Thank you so much for your draft text.

See a couple of comments inline:

Below is some draft text based on our discussion last Friday, to be updated
> and amended upon your feedback and suggestions tomorrow.

   - We could create a Google Doc to make editing easier

What misses is are extensions to support applications covering multiple
> network domains and technologies, multiple paths, etc… The changes that we
> need to consider are the prevalence of wireless and cellular networks, 5G
> multi-technology e2e,

   - Maybe, we could add a reference to our ANRW19 paper: "Supporting
   Multi-domain use cases with ALTO" [0] (or the slides [1]). This could be a
   way of letting people know about the current interest of the research
   community and operator community in this type of multi-domain scenarios.
   - Slide 8 in [1] includes other examples about ALTO extensions (current
   drafts and potential topics to be considered): e.g., new settings NFV, SFC,
   Edge Cloud.

Best regards,

Danny Lachos
[0] https://dl.acm.org/citation.cfm?id=3341126
[1] https://irtf.org/anrw/2019/slides-anrw19-final28.pdf

On Tue, Oct 1, 2019 at 2:56 PM Randriamasy, Sabine (Nokia -
FR/Paris-Saclay) <[email-masked]> wrote:

> Hello,
>
>
>
> Would it be possible to start with the side-meeting at IETF 106 ? We need
> to contact potential participants early enough for them to plan their
> participation and agree on a schedule. So we need to prepare some
> invitation text to introduce the context and purpose of the meeting. Below
> is some draft text based on our discussion last Friday, to be updated and
> amended upon your feedback and suggestions tomorrow.
>
>
>
> Cheers,
>
> Sabine
>
>
>
>
>
> The IETF ALTO WG is planning a 2-3hours meeting with 20-30 participants at
> the IETF 106. The focus is to prepare the evolution of ALTO and explore
> both topics of application-aware networking (AAN) and network-aware
> applications (NAA).
>
>
>
> To this end, we would like to invite a group of speakers willing to share
> their experience and insights about cooperative interactions between
> networks and applications. In particular: given today’s network usage
> trends, where do we identify problems that would be solved  with the help
> of such a cooperation?
>
>
>
> AAN or NAA: what is it? What problems did we address? What did we try?
> What worked? What did not? What is missing ?  What are the changes in
> networks, applications, in research, technology that we need to take into
> account?
>
>
>
> The goal of this meeting is to gather input helping to better identify how
> ALTO evolutions can complement with other IETF protocols or research
> activities. We therefore seek for insights of participants involved in
> network operations, application or cooperation thereof. A fruitful
> meeting would both collect experience and expectations in this field.
>
>
>
> To start with (text to be shortened + completed): ALTO  is addressing the
> need for network-aware applications. It helps addressing issues such as
> unnecessary network costs or performance loss due: to network topology
> agnostic selection of application endpoints such as peers or CDN
> surrogates,  bad timing of connection, poor information on e2e network
> paths (no insight, outdated, too voluminous). What misses is are
> extensions to support applications covering multiple network domains and
> technologies, multiple paths, etc… The changes that we need to consider are
> the prevalence of wireless and cellular networks, 5G multi-technology e2e,
>
>
>
>
>
> *From:* [email-masked] <
> [email-masked]> *On Behalf Of *Danny Alex Lachos
> Perez
> *Sent:* Tuesday, October 01, 2019 6:05 PM
> *To:* IETF ALTO <[email-masked]>; [email-masked]
> *Subject:* ALTO meeting info for Oct. 02, 2019
>
>
>
> Dear all,
>
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [email-masked].
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/alto-weekly-meeting/CAEDarXJG%3DXW%3DBjppyR5qdvGBp7vdkZrT4QvcT0J%2BTUr9zj-Dhg%40mail.gmail.com
> <https://groups.google.com/d/msgid/alto-weekly-meeting/CAEDarXJG%3DXW%3DBjppyR5qdvGBp7vdkZrT4QvcT0J%2BTUr9zj-Dhg%40mail.gmail.com?utm_medium=email&utm_source=footer>
> .
>

---

From: Börje Ohlman <[email-masked]>
Date: Wed, 2 Oct 2019 07:21:56 +0000

I might join up to 30 min late (due to other conflicting meeting), but I will definitely join.

                Börje

From: <[email-masked]> on behalf of "Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Tuesday, 1 October 2019 at 19:56
To: Danny Alex Lachos Perez <[email-masked]>, IETF ALTO <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: ALTO meeting info for Oct. 02, 2019

Hello,

Cheers,
Sabine

Dear all,

Current Agenda*:
·         Quick updates on existing WG documents
·         Discussion about integration design between ALTO and Globus/HTCondor
o     Go over how to extend Globus for some simple but important use cases using ALTO
·         Planning for ALTO workshop (IETF106)
*If people have other agenda items, please feel free to post.

Best regards,

Danny Lachos
--
You received this message because you are subscribed to the Google Groups "alto-weekly-meeting" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email-masked]<mailto:[email-masked]>.
To view this discussion on the web visit https://groups.google.com/d/msgid/alto-weekly-meeting/CAEDarXJG%3DXW%3DBjppyR5qdvGBp7vdkZrT4QvcT0J%2BTUr9zj-Dhg%40mail.gmail.com<https://protect2.fireeye.com/url?k=97cffe92-cb45dc78-97cfbe09-0cc47ad93e32-3b5d63579af047f5&q=1&u=https%3A%2F%2Fgroups.google.com%2Fd%2Fmsgid%2Falto-weekly-meeting%2FCAEDarXJG%253DXW%253DBjppyR5qdvGBp7vdkZrT4QvcT0J%252BTUr9zj-Dhg%2540mail.gmail.com%3Futm_medium%3Demail%26utm_source%3Dfooter>.
--
You received this message because you are subscribed to the Google Groups "alto-weekly-meeting" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email-masked]<mailto:[email-masked]>.
To view this discussion on the web visit https://groups.google.com/d/msgid/alto-weekly-meeting/PR1PR07MB5100FE304ED24F5A80276C01959D0%40PR1PR07MB5100.eurprd07.prod.outlook.com<https://protect2.fireeye.com/url?k=1f710251-43fb20bb-1f7142ca-0cc47ad93e32-2b2f037057ef28a9&q=1&u=https%3A%2F%2Fgroups.google.com%2Fd%2Fmsgid%2Falto-weekly-meeting%2FPR1PR07MB5100FE304ED24F5A80276C01959D0%2540PR1PR07MB5100.eurprd07.prod.outlook.com%3Futm_medium%3Demail%26utm_source%3Dfooter>.

---

From: "Y. Richard Yang" <[email-masked]>
Date: Wed, 2 Oct 2019 08:34:21 -0400

Sabine,

Good idea to start with the side meeting/workshop. Please see this Google
doc for the list of questions and the invited/potential participants that I
am aware of:
https://docs.google.com/document/d/1GWDj8E34lyIKeasNrDgH584VEI7uV4FAy65LOV5j-10/edit?usp=sharing

Below

On Tue, Oct 1, 2019 at 1:56 PM Randriamasy, Sabine (Nokia -
FR/Paris-Saclay) <[email-masked]> wrote:

> https://groups.google.com/d/msgid/alto-weekly-meeting/PR1PR07MB5100FE304ED24F5A80276C01959D0%40PR1PR07MB5100.eurprd07.prod.outlook.com
> <https://groups.google.com/d/msgid/alto-weekly-meeting/PR1PR07MB5100FE304ED24F5A80276C01959D0%40PR1PR07MB5100.eurprd07.prod.outlook.com?utm_medium=email&utm_source=footer>
> .
>

-- 
-- 
 =====================================
| Y. Richard Yang <[email-masked]>   |
| Professor of Computer Science       |
| http://www.cs.yale.edu/~yry/        |
 =====================================

---

From: "Y. Richard Yang" <[email-masked]>
Date: Wed, 2 Oct 2019 08:38:31 -0400

I am on a train to the airport and hence might need to be on the mute mode
most of the time.

Talk to you soon,
Richard

On Wed, Oct 2, 2019 at 3:22 AM 'Börje Ohlman' via alto-weekly-meeting <
[email-masked]> wrote:

> *From: *<[email-masked]> on behalf of "Randriamasy,
> Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
> *Date: *Tuesday, 1 October 2019 at 19:56
> *To: *Danny Alex Lachos Perez <[email-masked]>, IETF ALTO <
> [email-masked]>, "[email-masked]" <
> [email-masked]>
> *Subject: *RE: ALTO meeting info for Oct. 02, 2019
>
>
>
> Hello,
>
>
>
> <https://protect2.fireeye.com/url?k=97cffe92-cb45dc78-97cfbe09-0cc47ad93e32-3b5d63579af047f5&q=1&u=https%3A%2F%2Fgroups.google.com%2Fd%2Fmsgid%2Falto-weekly-meeting%2FCAEDarXJG%253DXW%253DBjppyR5qdvGBp7vdkZrT4QvcT0J%252BTUr9zj-Dhg%2540mail.gmail.com%3Futm_medium%3Demail%26utm_source%3Dfooter>
> .
>
> --
> <https://protect2.fireeye.com/url?k=1f710251-43fb20bb-1f7142ca-0cc47ad93e32-2b2f037057ef28a9&q=1&u=https%3A%2F%2Fgroups.google.com%2Fd%2Fmsgid%2Falto-weekly-meeting%2FPR1PR07MB5100FE304ED24F5A80276C01959D0%2540PR1PR07MB5100.eurprd07.prod.outlook.com%3Futm_medium%3Demail%26utm_source%3Dfooter>
> .
>
> --
> https://groups.google.com/d/msgid/alto-weekly-meeting/A14F57A6-C3AD-48B3-8DC2-BE6400B08ADA%40ericsson.com
> <https://groups.google.com/d/msgid/alto-weekly-meeting/A14F57A6-C3AD-48B3-8DC2-BE6400B08ADA%40ericsson.com?utm_medium=email&utm_source=footer>
> .
>

---

From: "Y. Richard Yang" <[email-masked]>
Date: Wed, 2 Oct 2019 08:42:40 -0400

Danny,

On Tue, Oct 1, 2019 at 4:32 PM Danny Alex Lachos Perez <[email-masked]>
wrote:

> Below is some draft text based on our discussion last Friday, to be
>> updated and amended upon your feedback and suggestions tomorrow.
>
>
Good idea. I created one :-)

>    - Slide 8 in [1] includes other examples about ALTO extensions
>    (current drafts and potential topics to be considered): e.g., new settings
>    NFV, SFC, Edge Cloud.
>
>
It looks that we have someone has volunteered to be a speaker :-)

Richard

>    -
>> To this end, we would like to invite a group of speakers willing to
>> share their experience and insights about cooperative interactions between
>> networks, applications, in research, technology that we need to take
>> into account?
>>
>>
>>
>> The goal of this meeting is to gather input helping to better identify
>> how ALTO evolutions can complement with other IETF protocols or research
>> To start with (text to be shortened + completed): ALTO  is addressing
>> the need for network-aware applications. It helps addressing issues such as
> https://groups.google.com/d/msgid/alto-weekly-meeting/CAEDarX%2B9F9XpFHPjOhjSDH8tdOcpiKAf6xtMhJmV_kMRsN21yw%40mail.gmail.com
> <https://groups.google.com/d/msgid/alto-weekly-meeting/CAEDarX%2B9F9XpFHPjOhjSDH8tdOcpiKAf6xtMhJmV_kMRsN21yw%40mail.gmail.com?utm_medium=email&utm_source=footer>
> .
>
-- 
Richard