Subject: [alto] Unified properties terminology clarification

From: Qin Wu <[email-masked]>
Date: Thu, 19 Nov 2020 12:32:49 +0000

Hi, Sabine:
Follow up our discussion in today's ALTO session, one issue I raised is about the terminology we used in the unified properties draft. I feel the term "unified properties" lacks clarity and causes a little bit confusion to people who are familiar with this draft, that is on is unified property break existing protocol or component such as
Endpoint property, I am wondering if we can change the term into property Map, so the title will be changed into "ALTO extension: Property Map" , which is also align with the title of Path vector draft, Does this make sense?
As you mentioned, this was discussed in the past, can you remind me the history discussion why the current name is picked. Thanks in advance, hope we can resolve this as soon as possible.

-Qin

---

From: Qin Wu <[email-masked]>
Date: Fri, 20 Nov 2020 10:12:49 +0000

Thanks Wendy for clear clarification and thanks Sabine for proposed change, the proposed change adds more clarity, looks good to me, thanks!

-Qin
发件人: Randriamasy, Sabine (Nokia - FR/Paris-Saclay) [mailto:[email-masked]]
发送时间: 2020年11月20日 3:03
收件人: Wendy Roome <[email-masked]>; Qin Wu <[email-masked]>; [email-masked]
主题: RE: [alto] Unified properties terminology clarification

Hi Wendy and Qin,

Along your lines, my take is that this document extends the protocol in two major directions:
- from endpoints restricted to IP addresses to entities covering a wider and extensible set of objects,
- from properties on specific endpoints to entire entity property maps.
The document introduces additional features allowing entities and property values to be specific to a given information resource. This is made possible by a generic and flexible design of entity and property types.

So we may entitle the document w.r.t. the two major evolutions.
Do you think that the title  “ALTO extension: entity property maps” is suitable?
@ Richard and Kai: what is your opinion?

Thanks,
Sabine

From: alto <[email-masked]<mailto:[email-masked]>> On Behalf Of Wendy Roome
Sent: Thursday, November 19, 2020 5:19 PM
To: Qin Wu <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [alto] Unified properties terminology clarification

Hi, Qin!

I'm Wendy Roome, and I wrote the original version of this draft. I stopped being active in this group after I retired in 2017, but I can describe the motivation for the title.

Back then, we had "costs" between pairs of "entities," and we were expanding the concept of "entities" to include more than just PIDs & IP addresses. We also had GET requests to return entire maps, and POST requests to return a filtered subset.

We also had a property service, but it was very restricted: it only applied to endpoints, it could not be extended, and it only allowed POST requests for specific endpoints rather than GET requests for an entire set. Furthermore, when I implemented the protocol, I suspected that many "properties" would really be associated with CIDRs or PIDs, rather than individual endpoints, and the endpoints would inherit those properties.

My goals were to make "properties" as extensible as costs, to provide the same choice of GET-mode for complete maps and POST requests for subsets, and to define an inheritance mechanism. That is, I wanted to "unify" properties and costs. Hence the original title. If that name no longer fits, by all means change it!

                - Wendy Roome

From: alto <[email-masked]<mailto:[email-masked]>> on behalf of Qin Wu <[email-masked]<mailto:[email-masked]>>
Date: Thu, November 19, 2020 at 07:33
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [alto] Unified properties terminology clarification

Hi, Sabine:
Follow up our discussion in today’s ALTO session, one issue I raised is about the terminology we used in the unified properties draft. I feel the term “unified properties” lacks clarity and causes a little bit confusion to people who are familiar with this draft, that is on is unified property break existing protocol or component such as
Endpoint property, I am wondering if we can change the term into property Map, so the title will be changed into “ALTO extension: Property Map” , which is also align with the title of Path vector draft, Does this make sense?
As you mentioned, this was discussed in the past, can you remind me the history discussion why the current name is picked. Thanks in advance, hope we can resolve this as soon as possible.

-Qin
_______________________________________________ alto mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/alto