Subject: Re: [alto] ALTO recharter: proposed item - General ALTO protocol extensions

From: Qin Wu <[email-masked]>
Date: Tue, 17 Nov 2020 03:33:15 +0000

Hi, Sabine:
Thanks for the update on the proposed item.
See my comments inline.
发件人: alto [mailto:[email-masked]] 代表 Randriamasy, Sabine (Nokia - FR/Paris-Saclay)
发送时间: 2020年11月17日 1:16
收件人: Randriamasy, Sabine (Nokia - FR/Paris-Saclay) <[email-masked]>; IETF ALTO <[email-masked]>
主题: Re: [alto] ALTO recharter: proposed item - General ALTO protocol extensions

Dear all,

The paragraph below is proposed to define the WG item on “general protocol extensions”.
As the purpose of this work item is also to support other WG items that may need these extensions, your feedback again is more than welcome.
Thanks,
Sabine

General protocol extensions to convey a richer set of cost attributes allowing to determine not only "where" and "when" to connect but also under which conditions. Such additional information will be related both to entities (e.g. conveying time-averaged (cache storage capacities and)  server load in data center supported applications) and to ALTO path costs (e.g. ALTO path cost value depending on conditions such as real-time network indications or SLA or policy or access-type or indicator type).

The working group will specify such extension in coordination with both other ALTO working group items and IETF working groups that have a focus on the related use cases.  The scope of extensions is not limited to those identified by the WIs and WGs, but is limited by the criteria set out below.
--------------------------------------------

From: alto <[email-masked]<mailto:[email-masked]>> On Behalf Of Randriamasy, Sabine (Nokia - FR/Paris-Saclay)
Sent: Tuesday, November 10, 2020 7:24 PM
To: IETF ALTO <[email-masked]<mailto:[email-masked]>>
Subject: [alto] ALTO recharter: proposed item - General ALTO protocol extensions

Dear all,

Please find below a WG item proposal for “general ALTO protocol extensions”, on which your feedback and suggestions will be more than welcome.
Thanks,
Sabine

---------- Context: the current ALTO charter
o Extends the path cost values in several directions:
              - single to array of several cost metrics => allows apps to decide upon several metrics and make decision compromise
              - single cost value to array if time dependent cost values => allow apps to determine when to connect
o Extends endpoints to entities on which properties are defined
[Qin]:Good, I believe you talk about Path vector, ALTO cost calendar, and unified properties which provide a good basis for any new work.
---------- Basic Issues
+++  Issue 1: Some path cost values may depend on "contextual parameters" such as access type, SLA, policy or other indicators provided by network. In particular:
              - There may be different possible paths between source and destination, where some paths may or may not meet Application QoE or policy constraints. The Applications would like to see which path is most suitable.
              - Contextual parameters may be available at frequencies that are different from ALTO information frequency. For example, Cost on PID-Cell1 may differ, depending on some real-time network parameter value.
[Qin]: I see this contextual parameter as path constraints,  besides access type, SLA, policy, I think end to end latency, packet loss can also see as path constraints, which can help select a connection path to meet network performance requirements.
Also I think the specific intermediate network elements, transit administrative domain traversed by the flow identified by source destination pair can also be seen as contextual parameter, e.g.,  we have two end to end paths, we can have contextual parameter like:
route the path through transit domain A, route the path not through transit domain B.

or  if (service_destination matches 10.132.12.0/24)
       Use path: 10.125.13.1 => 10.125.15.1 => 10.132.12.1.

+++ Issue 2: Some entities may have properties whose values change over time. For instance, ANEs may have time-varying properties on cloud or networking resources
[Qin]: ANE having time varying properties on cloud or networking resource, can ANE be set as destination end point, I think we should distinguish whether properties are owned by destination endpoint or intermediate network element?
For the former case, we may use for service edge selection in the edge computing case, the properties could be the load, capability. For intermediate network elements, one example property is timestamp or queue length, let me know what is your example properties?
---------- Potential solution(s)
+++  To address issue 1 and related : extend cost attributes towards conditional values and parameters allowing a better interpretation of the received values
- Extension from single cost value to array of values dependent on context parameters:
allowing applications to make context-dependent decisions,
allowing also to combine information generated with different time dynamics, (freshness)
See examples on https://datatracker.ietf.org/doc/slides-98-alto-alto-cost-context/

+++  To address issue 2:
- ALTO Property Calendars to extend a single property value to an array of time-dependent property values

---------- Remaining issues to be addressed
- How to define cost value attributes?
[Qin]: Please provide a use case for this, can cost value attribute be defined as contextual parameter as well?
- How to achieve a light and flexible design?
- How to moderate additional Server workload and ALTO traffic increase?
[Qin]: I am thinking when one server is overloaded, it may ask the client to redirect the request to other ALTO server. Is there any new mechanism needed here?
---------- Who will work on it, rough planning
+++  Extensions may go in standalone documents and/or extend existing ones, eg ALTO performance metrics
+++ Contributors: Sabine and any other interested people
+++ Plans for IETF 110:
              -  Reactivation and update of related existing ALTO drafts
              -  First draft for ALTO Property Calendars

---

From: "Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Thu, 19 Nov 2020 01:20:06 +0000

Hi Qin,

Thanks a lot for your feedback,
The text and slide deck presenting the proposed re-charter item hopefully address your comments.
Please see inline.
Best regards,
Sabine

From: Qin Wu <[email-masked]>
Sent: Tuesday, November 17, 2020 4:33 AM
To: Randriamasy, Sabine (Nokia - FR/Paris-Saclay) <[email-masked]>; IETF ALTO <[email-masked]>
Subject: RE: ALTO recharter: proposed item - General ALTO protocol extensions

Hi, Sabine:
Thanks for the update on the proposed item.
See my comments inline.
发件人: alto [mailto:[email-masked]] 代表 Randriamasy, Sabine (Nokia - FR/Paris-Saclay)
发送时间: 2020年11月17日 1:16
收件人: Randriamasy, Sabine (Nokia - FR/Paris-Saclay) <[email-masked]<mailto:[email-masked]>>; IETF ALTO <[email-masked]<mailto:[email-masked]>>
主题: Re: [alto] ALTO recharter: proposed item - General ALTO protocol extensions

Dear all,

Dear all,

[ [SR] ] indeed
[ [SR] ] I think constraints on end to end performance metrics such as latency and packet loss may be better supported with filtering constraints on queries for path costs. “Contextual parameters” are rather used to “detail” cost values wrt the value of a contextual parameter. The expression “Contextual parameters” may be indeed ambiguous and is now named “cost attributes” in the proposed paragraph, to better distinguish with constraints on metrics.
[ [SR] ] this corresponds to the case where several possible paths are possible. A context parameter Ptd representing transit domains may indeed be used to prevent using a path with prohibitive costs. For instance, Cost(Spid,Dpid) = moderate for Ptd = A and very high for Ptd = B.
Such a case should be considered in the design considerations.

[ [SR] ] ANEs were initially defined as intermediate abstracted steps between source and destination. However endpoints are now also entities and nothing prevents them from having properties that are applicable for node-like ANEs. For instance: an ANE can be also a DC or a Server, just like an endpoint.
[ [SR] ] An example provided in the slides is the set of Server properties such as CPU, RAM, Storage but a Calendar may be defined for other properties for which it makes sense

+++  To address issue 2:

[ [SR] ] As said above the paragraph text was updated to avoid confusion. The expression “cost attribute” is now used instead of “contextual parameter”
[ [SR] ] Indeed a request can be redirected. The slides now mention “scalability” meaning that there is a need to moderate the volume of conveyed ALTO information which is an issue as illustrated by a recent publication by Ingmar on ALTO deployments.