Subject: [alto] Any implementations of unified-props, alto-cdni, path-vector

From: Vijay Gurbani <[email-masked]>
Date: Wed, 11 Nov 2020 10:56:35 -0600

All: I am the shepherd for the three drafts identified in the subject.

As I prepare the shepherd writeup, I will like to document if there are any
implementations of these three drafts that the WG members are aware of.
These implementations can be private (a few individuals working on the
drafts), or be more formal with a GitHub repository and a larger community.

If any WG member is aware of implementations, please let me know.  Please
drop me an email (or  post on the list) with the details as you know them.
I would like to kindly ask you to do this as soon as possible ---
preferably by the end of this week --- to allow me to prepare the shepherd
writeup.

Thank you.

- vijay

---

From: "Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Thu, 12 Nov 2020 17:43:32 +0000

Hi Vijay,

To my knowledge,

- there is no implementation of Unified Properties that reflects the latest design updates, defined in 2019 and 2020,
- I am not aware of any implementation of Path Vector.

Best regards,
Sabine

From: alto <[email-masked]> On Behalf Of Vijay Gurbani
Sent: Wednesday, November 11, 2020 5:57 PM
To: IETF ALTO <[email-masked]>
Subject: [alto] Any implementations of unified-props, alto-cdni, path-vector

As I prepare the shepherd writeup, I will like to document if there are any implementations of these three drafts that the WG members are aware of.  These implementations can be private (a few individuals working on the drafts), or be more formal with a GitHub repository and a larger community.

If any WG member is aware of implementations, please let me know.  Please drop me an email (or  post on the list) with the details as you know them.  I would like to kindly ask you to do this as soon as possible --- preferably by the end of this week --- to allow me to prepare the shepherd writeup.

Thank you.

- vijay

---

From: "Y. Richard Yang" <[email-masked]>
Date: Thu, 12 Nov 2020 12:58:19 -0500

Hi Vijay,

- I believe that there was an implementation of unified properties by Wendy
Roome. But it is for an earlier version, not the latest one which we just
posted.

- I understand that there was an implementation of path vector used in
super computing demonstration; but it was for an earlier version of path
vector without the integration of unified properties.

Richard

On Thu, Nov 12, 2020 at 12:43 PM Randriamasy, Sabine (Nokia -
FR/Paris-Saclay) <[email-masked]> wrote:

> Hi Vijay,
>
>
>
> To my knowledge,
>
>
>
> - there is no implementation of Unified Properties that reflects the
> latest design updates, defined in 2019 and 2020,
>
> *From:* alto <[email-masked]> *On Behalf Of *Vijay Gurbani
> *Sent:* Wednesday, November 11, 2020 5:57 PM
> *To:* IETF ALTO <[email-masked]>
> *Subject:* [alto] Any implementations of unified-props, alto-cdni,
> path-vector
>
>
>
> As I prepare the shepherd writeup, I will like to document if there are
> any implementations of these three drafts that the WG members are aware
> of.  These implementations can be private (a few individuals working on the
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto
>
-- 
Richard

---

From: Wendy Roome <[email-masked]>
Date: Thu, 12 Nov 2020 16:30:41 -0500

Vijay,

My server did support PID properties and allowed endpoints to inherit them, and had a “get-all-props” extension.

But it didn’t implement the current version.

Wendy

From: alto <[email-masked]> on behalf of "Y. Richard Yang" <[email-masked]>
Date: Thu, November 12, 2020 at 12:58
To: "Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <[email-masked]>
Cc: IETF ALTO <[email-masked]>
Subject: Re: [alto] Any implementations of unified-props, alto-cdni, path-vector

Hi Vijay,

- I believe that there was an implementation of unified properties by Wendy Roome. But it is for an earlier version, not the latest one which we just posted.

- I understand that there was an implementation of path vector used in super computing demonstration; but it was for an earlier version of path vector without the integration of unified properties.

Richard

On Thu, Nov 12, 2020 at 12:43 PM Randriamasy, Sabine (Nokia - FR/Paris-Saclay) <[email-masked]> wrote:

Hi Vijay,

To my knowledge, 

Best regards,

Sabine 

Thank you.

- vijay

-- 

Richard

_______________________________________________ alto mailing list [email-masked] https://www.ietf.org/mailman/listinfo/alto

---

From: Jensen Zhang <[email-masked]>
Date: Fri, 13 Nov 2020 11:18:09 +0800

Hi Vijay,

Sorry for my late reply.

I want to mention that Kai and I are implementing the latest version of
these three documents. The implementation will be open-source on GitHub
[1]. But it is still in progress. We may have a release by the next IETF.

As Richard mentioned, we have an implementation for a very early version of
the path vector document [2]. It is only for OpenFlow-based networks. And
we didn't integrate unified properties.

I remember Danny also has an implementation of the unified properties
document.

[1] https://github.com/openalto/sextant
[2] https://github.com/openalto/mercator-setup

Best,
Jensen

On Fri, Nov 13, 2020 at 5:30 AM Wendy Roome <[email-masked]> wrote:

> Vijay,
>
>
>
> My server did support PID properties and allowed endpoints to inherit
> them, and had a “get-all-props” extension.
>
>
>
>    - Wendy
> *From: *alto <[email-masked]> on behalf of "Y. Richard Yang" <
> [email-masked]>
> *Date: *Thu, November 12, 2020 at 12:58
> *To: *"Randriamasy, Sabine (Nokia - FR/Paris-Saclay)" <
> [email-masked]>
> *Cc: *IETF ALTO <[email-masked]>
> *Subject: *Re: [alto] Any implementations of unified-props, alto-cdni,
> path-vector
>
>
>
> Hi Vijay,
>
>
>
> - I believe that there was an implementation of unified properties by
> Wendy Roome. But it is for an earlier version, not the latest one which we
> just posted.
>
>
>
> _______________________________________________ alto mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/alto

---

From: Vijay Gurbani <[email-masked]>
Date: Fri, 13 Nov 2020 13:55:50 -0600

Dear Jensen: Thank you, this is excellent information.  You don't have to
hurry up your release schedule due to my query.  I just want to document
the implementations that are in the path of progress, or have been
implemented (even on older releases of the I-Ds).

Also, thanks to Richard, Sabine, Wendy for getting back to me on
implementations as well.

I think I have all I need for the shepherd writeups.

Cheers,

- vijay

On Thu, Nov 12, 2020 at 9:18 PM Jensen Zhang <[email-masked]>
wrote:

> As Richard mentioned, we have an implementation for a very early version
> of the path vector document [2]. It is only for OpenFlow-based networks.
> And we didn't integrate unified properties.
>