Subject: Re: [alto] WG Review: ALTO Charter Update

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 1 May 2021 12:37:36 +0100

Hi Qin, Chairs,

Thanks for this.

> Dear Martin and working group,
>
> Thank you for the useful rechartering discussions on the mailing list and
at IETF-110.
>
> I have listened to the people who say that further protocol work needs to
be based on
> strong deployment needs, and I also hear very many different use cases
proposed. I 
> think we need more discussion and understanding to work out which use
cases are
> high priority and which are more research-based.

Agree. While research-based use of ALTO is important and encouraging, I
think we need to focus on the primary use cases for IETF work. That is, we
need to understand the steps that are needed to move ALTO into the next
stage of implementations and deployments. As you hint, that is probably
going to take some careful discussion and probably some time.

> This makes me think that we need a small short-term recharter to allow us
to work on
> immediate issues (protocol maintenance, operational support) while we
discuss and
> investigate the best uses cases for further work.

That sounds like a very reasonable compromise: it allows the WG to fix small
issues with the protocol, and (IMHO) operational support is fundamental and
in need of attention; but it also doesn't make commitments to any specific
additional protocol work before the discussions have completed.

I only have one comment on the proposed charter text...

> o Future use cases. The working group will provide a forum to discuss
>    possible future use cases. The objective of this discussion will be to
>    determine a small set of use cases that have strong support and a
>    realistic chance of implementation and deployment. The working
>    group will not develop protocol extensions for these use cases until
>    it has been re-chartered specifically for that purpose.

I'm glad this is explicitly in the charter and it supports your initial
point about needing to discuss this point further. I think it is reasonable
to say that the WG will not work on protocol extensions until a further
re-charter.

But, this bullet item should say something about what the output of this
charter item is. I think it is: "The working group will report back to the
Area Director on the results of these discussions which may be documented in
an email or in an Internet-Draft."

In turn, that would lead to another milestone:

* Report back to the Area Director to identify any use cases that have
strong support and a realistic chance of implementation and deployment.

Best,
Adrian

---

From: Qin Wu <[email-masked]>
Date: Wed, 5 May 2021 10:05:00 +0000

Thanks Adrian for valuable review and input, see my reply inline below.
-----邮件原件-----
发件人: Adrian Farrel [mailto:[email-masked]] 
发送时间: 2021年5月1日 19:38
收件人: [email-masked]
抄送: [email-masked]; 'Martin Duke' <[email-masked]>; 'Zaheduzzaman Sarker' <[email-masked]>
主题: Re: WG Review: ALTO Charter Update

Hi Qin, Chairs,

Thanks for this.

at IETF-110.
be based on
proposed. I 
cases are
> high priority and which are more research-based.

Agree. While research-based use of ALTO is important and encouraging, I think we need to focus on the primary use cases for IETF work. That is, we need to understand the steps that are needed to move ALTO into the next stage of implementations and deployments. As you hint, that is probably going to take some careful discussion and probably some time.

[Qin]:Exactly, we have discussed this in the ALTO design team meeting. We have agreed to use WG wiki page to keep track of implementations and deployments update. 

to work on
discuss and
> investigate the best uses cases for further work.

That sounds like a very reasonable compromise: it allows the WG to fix small issues with the protocol, and (IMHO) operational support is fundamental and in need of attention; but it also doesn't make commitments to any specific additional protocol work before the discussions have completed.

>    it has been re-chartered specifically for that purpose.

I'm glad this is explicitly in the charter and it supports your initial point about needing to discuss this point further. I think it is reasonable to say that the WG will not work on protocol extensions until a further re-charter.

But, this bullet item should say something about what the output of this charter item is. I think it is: "The working group will report back to the Area Director on the results of these discussions which may be documented in an email or in an Internet-Draft."

* Report back to the Area Director to identify any use cases that have strong support and a realistic chance of implementation and deployment.

[Qin]: Good comment, this issue has been brought up by many ALTO design team members as well, one of proposal from ALTO team member is to accommodate this in the first deliverable, but the first deliverable only focuses on existing implementation deployment,
I think it make sense to add one more new milestones and also it encourages WG members to document new use cases and idea in the I-Ds.
Best,
Adrian

---

From: Qin Wu <[email-masked]>
Date: Wed, 5 May 2021 10:09:25 +0000

Hi, Kai:
Thanks for your comments and input to this charter proposal, please see my rely inline below.

发件人: [email-masked] [mailto:[email-masked]]
发送时间: 2021年5月4日 20:50
收件人: Qin Wu <[email-masked]>
抄送: IETF ALTO <[email-masked]>; [email-masked]; Zaheduzzaman Sarker <[email-masked]>
主题: Re: [alto] WG Review: ALTO Charter Update

Hi Qin and all,

Thanks for sharing the proposal. I just have one comment on the milestones and deliverables:

The last bullet mentioned that "The objective of this discussion will be to determine a small set of use cases that have strong support and a realistic chance of implementation and deployment.". However, the output of this bullet does not seem to be included in the milestones and deliverables.

[Qin]:Good Catch, Adrian also raised the similar issue.
I suggest we change the first sentence of the 1st milestone to

Conduct a survey of working group participants and the wider community to discover ALTO implementation, deployment experience, and future use cases that have strong support and realistic chance of implementation and deployment.

[Qin]: As I replied to Adrian, I think it will be more clear to separate existing implementation experience documentation and new use case and solution documentation.
I think we can add one more milestone to address your comment.

By the way, the end of the 2nd milestone should be "configuration and management of ALTO servers", right?

[Qin]: Good, your propose change looks good to me.

Best,
Kai

2021-04-24 00:05:46"Qin Wu" <[email-masked]><mailto:>wrote:

Thank you for the useful rechartering discussions on the mailing list and at IETF-110.

I have listened to the people who say that further protocol work needs to be based on strong deployment needs, and I also hear very many different use cases proposed. I think we need more discussion and understanding to work out which use cases are high priority and which are more research-based.

This makes me think that we need a small short-term recharter to allow us to work on immediate issues (protocol maintenance, operational support) while we discuss and investigate the best uses cases for further work.

So I propose this as our new charter with input from our AD.

=========================================================================================

Application-Layer Traffic Optimization Working Group Charter Update

The ALTO working group was established in 2008 to devise a request/response protocol to allow a host to benefit from a server that is more cognizant of the network infrastructure than the host is.

The working group has developed an HTTP-based protocol and recent work has reported proof-of-concepts of ALTO based solutions supporting applications such as content distribution networks (CDN).

To support current and future deployments of ALTO, the working group is now chartered for the following activities:

o Provide a place to collect implementation deployment and experience. It is hoped that implementer and deployers of ALTO will report their experiences on the mailing list, and the working group will track implementation and deployment reports on a wiki or in an Internet-Draft.

o Perform protocol maintenance for the existing published protocol. It is anticipated that questions and issues will arise concerning the existing protocol specifications: The working group will develop and publish updates as necessary to resolve any interoperability, performance, operational, or security, or privacy problems that arise. The working group will also help resolve any errata reports that are raised. This work item might be addressed by discussions and reviews, or might require additional RFCs.

o Develop operational support tools for the ALTO protocol. Based on experience from deployments, the advice in RFC 7971<http://tools.ietf.org/html/rfc7971>, and considering the latest opinions and techniques from the Operations and Management Area, the working group will develop tools to configure, operate, and manage the ALTO protocol and networks that use ALTO. This may include YANG models and OAM mechanisms. The working group may also update RFC 7971<http://tools.ietf.org/html/rfc7971> in the light of new experience and protocol features that were added to ALTO after that RFC was published.

o Support for modern transport protocols. When work on ALTO began, the protocol was supported using HTTP version 1. Since then, the IETF has developed HTTP/2 and HTTP/3. The working group will develop any necessary protocol extensions and guidance to support the use of ALTO over HTTP/2 and HTTP/3.

o Future use cases. The working group will provide a forum to discuss possible future use cases. The objective of this discussion will be to determine a small set of use cases that have strong support and a realistic chance of implementation and deployment. The working group will not develop protocol extensions for these use cases until it has been re-chartered specifically for that purpose.

At the conclusion of the OAM and HTTP2/3 deliverables, plus completion of any adopted drafts emerging from the other work items, the working group will close or recharter.

Milestones and Deliverables:

  *   Conduct a survey of working group participants and the wider community to discover ALTO implementation and deployment experience. Record the results in a publicly visible wiki.
  *   Develop and standardize at least one OAM mechanisms to support ALTO including a YANG model for configuration and management of YANG servers.
  *   Perform an analysis of ALTO over HTTP/2 and HTTP/3 and publish a support document. Develop any necessary protocol modifications.
====================================================================================
Please comment here on this draft charter proposal.

-Qin (on behalf of chairs)