Subject: Re: [alto] WG Review: ALTO Charter Update

From: [email-masked]
Date: Tue, 4 May 2021 20:49:34 +0800 (GMT+08:00)

Hi Qin and all,

Thanks for sharing the proposal. I just have one comment on the milestones and deliverables:

The last bullet mentioned that "The objective of this discussion will be to determine a small set of use cases that have strong support and a realistic chance of implementation and deployment.". However, the output of this bullet does not seem to be included in the milestones and deliverables. I suggest we change the first sentence of the 1st milestone to

Conduct a survey of working group participants and the wider community to discover ALTO implementation, deployment experience, and future use cases that have strong support and realistic chance of implementation and deployment. 

By the way, the end of the 2nd milestone should be "configuration and management of ALTO servers", right?

Best,
Kai

2021-04-24 00:05:46"Qin Wu" <[email-masked]>wrote:

Dear Martin and working group,

Thank you for the useful rechartering discussions on the mailing list and at IETF-110.

I have listened to the people who say that further protocol work needs to be based on strong deployment needs, and I also hear very many different use cases proposed. I think we need more discussion and understanding to work out which use cases are high priority and which are more research-based.

This makes me think that we need a small short-term recharter to allow us to work on immediate issues (protocol maintenance, operational support) while we discuss and investigate the best uses cases for further work.

So I propose this as our new charter with input from our AD.

=========================================================================================

Application-Layer Traffic Optimization Working Group Charter Update

The ALTO working group was established in 2008 to devise a request/response protocol to allow a host to benefit from a server that is more cognizant of the network infrastructure than the host is.

The working group has developed an HTTP-based protocol and recent work has reported proof-of-concepts of ALTO based solutions supporting applications such as content distribution networks (CDN).

To support current and future deployments of ALTO, the working group is now chartered for the following activities:

o Provide a place to collect implementation deployment and experience. It is hoped that implementer and deployers of ALTO will report their experiences on the mailing list, and the working group will track implementation and deployment reports on a wiki or in an Internet-Draft.

o Perform protocol maintenance for the existing published protocol. It is anticipated that questions and issues will arise concerning the existing protocol specifications: The working group will develop and publish updates as necessary to resolve any interoperability, performance, operational, or security, or privacy problems that arise. The working group will also help resolve any errata reports that are raised. This work item might be addressed by discussions and reviews, or might require additional RFCs.

o Develop operational support tools for the ALTO protocol. Based on experience from deployments, the advice in RFC 7971, and considering the latest opinions and techniques from the Operations and Management Area, the working group will develop tools to configure, operate, and manage the ALTO protocol and networks that use ALTO. This may include YANG models and OAM mechanisms. The working group may also update RFC 7971 in the light of new experience and protocol features that were added to ALTO after that RFC was published.

o Support for modern transport protocols. When work on ALTO began, the protocol was supported using HTTP version 1. Since then, the IETF has developed HTTP/2 and HTTP/3. The working group will develop any necessary protocol extensions and guidance to support the use of ALTO over HTTP/2 and HTTP/3.

o Future use cases. The working group will provide a forum to discuss possible future use cases. The objective of this discussion will be to determine a small set of use cases that have strong support and a realistic chance of implementation and deployment. The working group will not develop protocol extensions for these use cases until it has been re-chartered specifically for that purpose.

At the conclusion of the OAM and HTTP2/3 deliverables, plus completion of any adopted drafts emerging from the other work items, the working group will close or recharter.

Milestones and Deliverables:

Conduct a survey of working group participants and the wider community to discover ALTO implementation and deployment experience. Record the results in a publicly visible wiki.
Develop and standardize at least one OAM mechanisms to support ALTO including a YANG model for configuration and management of YANG servers.
Perform an analysis of ALTO over HTTP/2 and HTTP/3 and publish a support document. Develop any necessary protocol modifications.

====================================================================================

Please comment here on this draft charter proposal.

-Qin (on behalf of chairs)

---

From: chunshxiong(熊春山) <[email-masked]>
Date: Tue, 11 May 2021 08:39:48 +0000

Hello WuQian and working group,

I provide our views on this recharter.

Firstly, we think ALTO is an IETF WG to standardize the interaction between application and network, initially for P2P application and now it is a good chance to continue optimization to support these new interactive services like Cloud Gaming, XR/AR, V2X application etc.

Secondly, we have been working together with colleagues from network operator, network vendor and academy et. al. for quite long to perform ALTO-oriented research and also real network testing which have already show very clear benefits and we contribute MoWIE to this WG （https://datatracker.ietf.org/doc/draft-huang-alto-mowie-for-network-aware-app/).  We think the listed items, i.e. the generic protocol extension for policy attributer, proposed as the high priority for recharter proposal in IETF#110 ALTO shows rough consensus to some extent. If ALTO WG doesn't continue these topics explicitly, it is very regretful and we really feel disappointed about this.

Thirdly, there have been more and more interests in these interactive services from many SDOs including 3GPP and IEEE etc. In year 2020, IEEE has setup up a new working group related to cloud gaming. In 3GPP since 2019 we have led Rel-17 5G_AIS (Advanced Interactive Services) and also we are driving another new Rel-18 study item in 3GPP to further enhance interaction between application and network for these interactive services from network perspective. If IETF can have corresponding standard activities (as 3GPP and IEEE are working on network and lower layers), that would be great for standards synergy and Internet ecosystem. Otherwise, it is really a pity that we missed a very important technical direction in Internet.

Therefore, we sincerely hope ALTO can re-consider such way forward.

BRs,
Chunshan Xiong

From: alto <[email-masked]> On Behalf Of Qin Wu
Sent: Saturday, April 24, 2021 12:06 AM
To: IETF ALTO <[email-masked]>
Cc: [email-masked]; Zaheduzzaman Sarker <[email-masked]>
Subject: [alto] WG Review: ALTO Charter Update(Internet mail)

o Develop operational support tools for the ALTO protocol. Based on experience from deployments, the advice in RFC 7971<http://tools.ietf.org/html/rfc7971>, and considering the latest opinions and techniques from the Operations and Management Area, the working group will develop tools to configure, operate, and manage the ALTO protocol and networks that use ALTO. This may include YANG models and OAM mechanisms. The working group may also update RFC 7971<http://tools.ietf.org/html/rfc7971> in the light of new experience and protocol features that were added to ALTO after that RFC was published.

  *   Conduct a survey of working group participants and the wider community to discover ALTO implementation and deployment experience. Record the results in a publicly visible wiki.
  *   Develop and standardize at least one OAM mechanisms to support ALTO including a YANG model for configuration and management of YANG servers.
  *   Perform an analysis of ALTO over HTTP/2 and HTTP/3 and publish a support document. Develop any necessary protocol modifications.
====================================================================================
Please comment here on this draft charter proposal.