Subject: Re: [alto] A new draft draft-liu-alto-can-usecase-00 for discussion and comments

From: Peng Liu<[email-masked]>
Date: 22 Jul 2021 18:16:45 +0800

Hi Luis,

Thanks for the question and comments, please see inline.

Regards,

Peng

Peng Liu | 刘鹏

China Mobile | 移动研究院

mobile phone：13810146105

email:  [email-masked]

发件人: LUIS MIGUEL CONTRERAS MURILLO

时间: 2021/07/21(星期三)23:36

收件人: Peng Liu;alto;

主题: RE: [alto] A new draft draft-liu-alto-can-usecase-00 for discussion and comments 

Hi Peng, 

Thanks for sharing. Looking at the figure of the CAN framework I can see depicted multiple components interacting with the ALTO server: Service Orchestration,  Computing OAM, Routing Management and Resource Management. This brings to my mind a number of questions: 

-          Do you foresee an individual interaction per component with the ALTO Server? If so, what would be the specific interaction per component and to what  extend such interaction would imply some extension?

[][   [PL] I think Alto has the potential to do some management work. Each component interacts with specific information, and may also make corresponding expansion. But I don't mean that every component has to interact with Alto(Maybe it's a misunderstanding of the graph). An alternative way is to have a unified agent to interact with Alto. On the one hand, it needs to consider the specific implementation of functions, on the other hand, it depend on whether alto could or want. 

-          Would not be more practical to consider a single ALTO Client as part of the Computing and Network Management Layer aggregating all the requests towards  the ALTO Server? This also could decouple the solution from a specific CAN architecture

[]   [PL] It is a good way, thank you! Maintaining a certain degree of decoupling is also conducive to the realization, which we will consider in detail later. 

-          In the scheduling section, you mention the possibility of retrieving real time information. How far the information could be “real-time”? I mean, in  the way ALTO works (i.e., collecting information from protocols such BGP with certain timers) the notion of “real-time” could be relative. Would the aging of that information sufficient to ensure the “real-time” needs? Would it be needed any other mechanisms  to shorten the period of information refreshment? 

[PL] I agree with that the notion of “real-time” could be relative. The real-time performance may affect the result of scheduling. If it is good, the scheduling can be more accurate and better meet the application requirements; If the real-time performance is not good, the network or node state may change when the flows arrive, resulting in the demand can not be met. BGP is an option but may not be satisfied for the application with very high delay requirements, so we are also studying how to improve the performance of BGP or announce the corresponding information through other ways. 

Best regards 

Luis 

De: alto <[email-masked]> En nombre de Peng Liu
 Enviado el: miércoles, 21 de julio de 2021 5:39
 Para: alto <[email-masked]>
 Asunto: [alto] A new draft draft-liu-alto-can-usecase-00 for discussion and comments   

 Hi All, 

 A new draft draft-liu-alto-can-usecase-00 has been submitted（https://www.ietf.org/archive/id/draft-liu-alto-can-usecase-00.txt） 

 Since some work of computing related service deployment and routing have been proposed in IETF and ITU, this draft describes a new network scenario and architecture considering computing-related  properties, and assumes that Alto could be used to help realize the deployment of services, and to assist in the selection of service nodes. 

 Any comments are welcome. 

 Regards, 

 peng  

 

Peng Liu | 刘鹏  

China Mobile | 移动研究院  

mobile phone：13810146105  

email:  [email-masked]    
  
 Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la  lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.
 
 The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination,  distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.
 
 Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a  leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Qin Wu <[email-masked]>
Date: Fri, 23 Jul 2021 13:35:13 +0000

Hi Peng,

-          Do you foresee an individual interaction per component with the ALTO Server? If so, what would be the specific interaction per component and to what extend such interaction would imply some extension?
[Qin Wu] Good question, let me ask authors in a different angle

1.       Can we have one single protocol to collect both network information and compute information

2.       or we still use different protocol to collect network information and compute information but, we could use one single protocol e.g., ALTO protocol to expose both network information and compute information to the application?

The problem, how we can make sure the network information and compute information are synchronized if these information change over time?

Best regards

Luis

De: alto <[email-masked]<mailto:[email-masked]>> En nombre de Peng Liu
Enviado el: miércoles, 21 de julio de 2021 5:39
Para: alto <[email-masked]<mailto:[email-masked]>>
Asunto: [alto] A new draft draft-liu-alto-can-usecase-00 for discussion and comments

Hi All,

Regards,
peng

Peng Liu | 刘鹏
China Mobile | 移动研究院
mobile phone：13810146105
email:  [email-masked]<mailto:[email-masked]>

________________________________

---

From: Peng Liu<[email-masked]>
Date: 25 Jul 2021 11:46:24 +0800

Hi Qin,

Thanks. These issues really deserve further consideration. Please see inline.

Regards,

Peng

Peng Liu | 刘鹏

China Mobile | 移动研究院

mobile phone：13810146105

发件人: Qin Wu

时间: 2021/07/23(星期五)21:31

收件人: LUIS MIGUEL CONTRERAS MURILLO;Peng Liu;alto;

Hi Peng, 

[PL] Yes, extending BGP may be an option, or the network probe packet carrys computing information. Both require the service node to expose the corresponding information to the gateway. 

[PL] If the network and computing information are colleted to Alto through different protocols, it is difficult to maintain absolute synchronization unless time stamps and other information are added, but this may require time synchronization of all the network nodes and the service nodes, which will cause some additional expenses. The accuracy of synchronization will affect the quality of service, and the demands of applications should also be considered. 

Best regards 

Luis 

 

 Hi All, 

 Regards, 

 peng  

 

 Peng Liu | 刘鹏  

 China Mobile | 移动研究院  

 mobile phone：13810146105