Subject: [alto] PANRG questions

From: Martin Duke <[email-masked]>
Date: Wed, 17 Nov 2021 16:30:18 -0800

Hello ALTO,

Please have a look at this paper in the PANRG about open research questions
in path aware networking.

https://datatracker.ietf.org/doc/draft-irtf-panrg-questions/

In some ways this document is orthogonal to ALTO, but in others (notably
2.1 and 2.2) ALTO has at least attempted to provide a complete answer.

As I've said before, a lot of proposals for future extensions to ALTO could
usefully get vetted in PANRG while we complete the items in our current
charter.

Thanks,
Martin

---

From: Qin Wu <[email-masked]>
Date: Fri, 19 Nov 2021 02:57:22 +0000

Thanks Martin for bringing up this work for attention, I think the current status of this work has passed through IRSG review and is now ready for IESG conflict review,
To all WG members, this is our last chance to revisit this draft and look for alignment with what we have already done.

For some relevant discussion, please take a look at this thread:
https://mailarchive.ietf.org/arch/msg/panrg/vHxu_j9exs1_K9dSUsMpBOgC3HE/

-Qin (on behalf of chairs)
BTW: we briefly discussed the collaboration with PANRG on Tuesday ALTO weekly meeting.
Actually we have engaged with PANRG WG members in IETF 112 to discuss how to align draft-irtf-panrg-path-properties with ALTO path vector and Unified property drafts
and will provide another round review on this draft in couple of weeks and cross post to both ALTO and PANRG list.

发件人: alto [mailto:[email-masked]] 代表 Martin Duke
发送时间: 2021年11月18日 8:30
收件人: IETF ALTO <[email-masked]>
主题: [alto] PANRG questions

Hello ALTO,

Please have a look at this paper in the PANRG about open research questions in path aware networking.

In some ways this document is orthogonal to ALTO, but in others (notably 2.1 and 2.2) ALTO has at least attempted to provide a complete answer.

As I've said before, a lot of proposals for future extensions to ALTO could usefully get vetted in PANRG while we complete the items in our current charter.

Thanks,
Martin

---

From: Qin Wu <[email-masked]>
Date: Fri, 26 Nov 2021 03:23:37 +0000

Hi, Martin and All:
I believe PANRG questions paper focuses on cross layer cross domain path aware networking research and set guideline or requirements for future protocol in the future internet architecture. A few thoughts on PANRG questions:
1. This draft said "PCEP technologies or SD-WAN technologies are limited to a single administrative domain", I think there are many technologies which can be extended to multi-domain cases such as SFC technology, etc. PCEP technologies can be used in large, multi-domain networks, but this requires special computational components and cooperation between the elements in different domains, See RFC4655 for more details. Many computational components have been well developed in PCE WGs.
The ONUG Open SD-WAN Exchange (OSE) works on an open framework which allows for one vendor SD-WAN domain to communicate with another vendor SD-WAN domain. Therefore I am not sure "limited to a single administrative domain" is accurate.

2. I think the endpoints can be categorized into application endpoint, and network endpoint, network endpoint can be tunnel endpoint, or overlay endpoint.
Application endpoint works at transport layer or application layer while network endpoint works at network layer.
If the trend is from path-oblivious networking to path aware networking, should all network endpoints with path awareness or path oblivious are replaced with application endpoints with path awareness? Only communication between application endpoint are allowed? How it is different from peer to peer protocol (https://datatracker.ietf.org/wg/ppsp/about/)?

3. When we add more path control to application endpoint? What about two application endpoints compete for the same path control? What about one application endpoint takes all best path?
What about one application endpoint is an attacker? How does this change the current internet architecture?

4. When application endpoint has path control, does it mean more states need to be maintained at the host side, i.e., stateful?  Or it still needs to communicate with another party for all the path information, i.e., stateless?

5. Do panrg questions set requirements or guidelines for existing work in IETF or future technologies for next generation of internet architecture?
I can see draft-arkko-iab-path-signals-collaboration laid foundation for many privacy related work coming out recently in IETF such as oblivious HTTP.

6. When we say "Competing control inputs from path-aware endpoints and the routing control plane", I thought path aware endpoints can select the best peer in the destination while routing control plane
can help you in the network side select different network path with better SLA or select less congested path, I see this complimentary, One can be seen as hosted based solution, i.e., path aware endpoint while the other is network based solution, i.e., rely on routing control plane to select the path. They are complimentary. Similar example is Mobile IPv6 and Proxy Mobile IPv6, one is host based solution ,the other is network based solution,  Not necessarily one replacing another.
If the application endpoint works at transport layer or application layer, e.g., multiple TCP path selection, while the network endpoint have path control at the network layer
in the underlay network, e. g, multiple TE path selection. no competing, in my think. Even the network endpoint is the overlay endpoint, I feel path control or selection on the overlay will not have impact on the underlay network.

7. When we talk about "Need to resolve conflicts of intent between the network's operator and the path selection at an endpoint", if it is in the same layer, my impression is one is network policy while
the other is local policy at the endpoint or tunnel endpoint or overlay endpoint? When there are policy conflicts, one could override another.
8. Who will be the consumer of path aware networking in the future? personal consumer device in a home network who has 5G connection, Wifi connection, broadband fixed line connection to different ISPs?

-Qin (Speak as individual)
发件人: alto [mailto:[email-masked]] 代表 Martin Duke
发送时间: 2021年11月18日 8:30
收件人: IETF ALTO <[email-masked]>
主题: [alto] PANRG questions

Hello ALTO,

Thanks,
Martin