Subject: [alto] Francesca Palombini's Discuss on draft-ietf-alto-performance-metrics-20: (with DISCUSS)

From: Francesca Palombini via Datatracker <[email-masked]>
Date: Wed, 01 Dec 2021 13:57:09 -0800

Francesca Palombini has entered the following ballot position for
draft-ietf-alto-performance-metrics-20: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/blog/handling-iesg-ballot-positions/
for more information about how to handle DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-alto-performance-metrics/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

Thank you for the work on this document.

Many thanks to Christian Amsüss for his review:
https://mailarchive.ietf.org/arch/msg/art/owYhcoFnl1vEipZ2D62cWiiE-LA/ , and
thanks to the authors for addressing it.

I am holding a DISCUSS to make sure the examples are fixed before publication.
Additionally, I agree with Christian that the line "Content-Length: TBA" in all
the examples is not really helpful to the reader, and I suggest to either
remove it or replace TBA with the actual content length for each example.

Francesca

1. -----

{
       "meta": {
                  "cost type": {
                "cost-mode": "numerical",
                "cost-metric":"hopcount"}
          }
       },
      "endpoint-cost-map": {
              "ipv4:192.0.2.2": {
              "ipv4:192.0.2.89"   : 5,
              "ipv4:198.51.100.34": 3
             }
       }
    }

FP: JSON doesn't validate. There is one "}" too many after "hopcount".

2. -----

   {
     "meta": {
        "cost type": {
           "cost-mode": "numerical",
           "cost-metric":"tput"
       }
     }
     "endpoint-cost-map": {
       "ipv4:192.0.2.2": {
         "ipv4:192.0.2.89"   : 256000,
         "ipv4:198.51.100.34": 128000
     }
   }

FP: JSON doesn't validate. I believe there is 2 errors: after the second "}"
after "tput" there is a missing "," , and it is also missing a final "}" at the
end.

3. -----

{
     "meta": {
       "cost-type" {
         "cost-mode": "numerical",
         "cost-metric": "bw-residual"
       }
     },
     "endpoint-cost-map" {
       "ipv4:192.0.2.2" {
         "ipv4:192.0.2.89" :    0,
         "ipv4:198.51.100.34": 2000
       }
     }
   }

FP: JSON doesn't validate - there is a bunch of missing ":" all over.

4. -----

{
       "cost-type" { "cost-mode":   "numerical",
                     "cost-metric": "bw-maxres"},
       "endpoints":  {
         "srcs": [ "ipv4 : 192.0.2.2" ],
         "dsts": [
           "ipv4:192.0.2.89",
           "ipv4:198.51.100.34"
         ]
       }
     }

FP: JSON doesn't validate: missing ":" after "cost-type"

5. -----

{
     "meta": {
       "cost-type": {
         "cost-mode":   "numerical",
         "cost-metric": "bw-maxres"
       }
     },
     "endpoint-cost-map": {
       "ipv4:192.0.2.2" {
         "ipv4:192.0.2.89" :    0,
         "ipv4:198.51.100.34": 2000
       }
     }
   }

FP: JSON doesn't validate: missing ":" after "ipv4:192.0.2.2"

---

From: "Y. Richard Yang" <[email-masked]>
Date: Wed, 1 Dec 2021 20:14:53 -0500

Hi Francesca,

Thank you so much for the review! Please see inline.

> https://datatracker.ietf.org/doc/draft-ietf-alto-performance-metrics/

Additionally, I agree with Christian that the line "Content-Length: TBA" in
> all
Thank you for the reminder. We will double-check that the examples are
fixed. In our
updated version---to be uploaded soon, will use the actual content length,
to be
conforming to HTTP.

> FP: JSON doesn't validate. There is one "}" too many after "hopcount".

Thank you for catching it. It is fixed in the running version.

> Yep. You are right and they are fixed.

> FP: JSON doesn't validate - there is a bunch of missing ":" all over.
Fixed.

> Got it and fixed.

> Fixed.

Thank you so much!
Richard

>
>
>
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto