Subject: [ANCP] ANCP use for smart adaptive modems?

From: Lloyd Wood <[email-masked]>
Date: Mon, 18 Jun 2007 19:56:18 +0100

We have been looking at the problem of routers talking to smart adaptive wireless modems - modems that can vary their output from say 16kbps to 512kbps, or 1-6Mbps, depending on channel conditions. These modems often have ethernet ports, because ethernet is cheap, and they're connected to a router the next hop along. (There are hundreds of custom modems, so they're not built into the router directly.) But you need to rate-limit and set QoS on the router's Ethernet interface to match the modem output - and when the modem rate varies, your static QoS config is rendered useless. You can't usefully let 100Mbps go over Ethernet to the modem.

So, we would need a way for the modem to signal that its output/input wireless speeds have changed, so that the router dynamically updates its QoS/rate-limiting configuration to match.

So, could ANCP communication over Ethernet between modem and router be one way to solve this? is there any wider interest in using ANCP in this way, generalising from the managed DSL space?

thanks,

L.

<http://www.ee.surrey.ac.uk/Personal/L.Wood/><[email-masked]> 

_______________________________________________
ANCP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ancp

---

From: "Wojciech Dec \(wdec\)" <[email-masked]>
Date: Wed, 20 Jun 2007 16:57:33 +0200

Hi Lloyd,

Your application would seem to fit in nicely with the modem train rate
reporting functionality already defined in ANCP. Would be interesting to
know whether the smart adaptive wireless modem application would require
additional info to what's define in the protocol spec so far. While the
WG has been focusing on DSL service providers as the primary adopters of
ANCP, it would seem reasonable for the WG to look into a generic
extensibility scheme for the protocol. 

Regards,
Woj.

> -----Original Message-----
> From: Lloyd Wood [mailto:[email-masked]] 
> Sent: 18 June 2007 20:56
> To: [email-masked]
> Cc: Daniel Floreani (danielf)
> Subject: [ANCP] ANCP use for smart adaptive modems?
> 
> We have been looking at the problem of routers talking to 
> smart adaptive wireless modems - modems that can vary their 
> output from say 16kbps to 512kbps, or 1-6Mbps, depending on 
> channel conditions. These modems often have ethernet ports, 
> because ethernet is cheap, and they're connected to a router 
> the next hop along. (There are hundreds of custom modems, so 
> they're not built into the router directly.) But you need to 
> rate-limit and set QoS on the router's Ethernet interface to 
> match the modem output - and when the modem rate varies, your 
> static QoS config is rendered useless. You can't usefully let 
> 100Mbps go over Ethernet to the modem.
> 
> So, we would need a way for the modem to signal that its 
> output/input wireless speeds have changed, so that the router 
> dynamically updates its QoS/rate-limiting configuration to match.
> 
> So, could ANCP communication over Ethernet between modem and 
> router be one way to solve this? is there any wider interest 
> in using ANCP in this way, generalising from the managed DSL space?
> 
> thanks,
> 
> L.
>

---

From: Lloyd Wood <[email-masked]>
Date: Sat, 30 Jun 2007 11:16:26 +0100

We've now written this satellite/wireless scenario up as a draft:
http://www.ietf.org/internet-drafts/draft-floreani-ancp-wireless-00.txt

(Thanks to Derek for details of the history of ANCP.)

L.