Subject: [ANCP] Proposal for clarification in the ancp-protocol draft

From: "Freudenberger, Markus" <[email-masked]>
Date: Fri, 12 Oct 2007 10:45:34 +0200

Hello All,

I suggest to add the following into section 5.4.4 "OAM Extensions" to clarify/refine the meaning of some return codes.

****************** Original text in draft-ietf-ancp-protocol-01 - begin ******************

           0x500 : Specified access line does not exist. 

           0x501 : Loopback test timed out. 

           0x502 : Reserved 

           0x503 : DSL line status showtime. 

           0x504 : DSL line status idle. 

           0x505 : DSL line status silent. 

           0x506 : DSL line status training. 

           0x507 : DSL line integrity error. 

           0x508 : DSLAM resource not available. 

           0x509 : Invalid test parameter.

****************** Original text in draft-ietf-ancp-protocol-01 - end ******************

****************** Changed text in draft-ietf-ancp-protocol-01 - begin ******************

           0x500 : Specified access line does not exist. 

           0x501 : Loopback test timed out. 

           0x502 : Reserved 

           0x503 : DSL line status showtime	(Line is synchronised, L0 state). 

           0x504 : DSL line status idle		(Line not synchronised, port administrative "down", L3 state). 

           0x505 : DSL line status silent		(Line not synchronised, port administrative "up", no CPE connected, L3 state). 

           0x506 : DSL line status training	(Line is synchronizing, G.994.1, handshake procedure active). 

           0x507 : DSL line integrity error. 

           0x508 : DSLAM resource not available. 

           0x509 : Invalid test parameter.

****************** Changed text in draft-ietf-ancp-protocol-01 - end ******************

Any Comments?

Regards
Markus Freudenberger 

T-Systems Enterprise Services GmbH
Systems Integration
Telco Project & Design
Line of Business Networks & Processes
Technology Consultant
Deutsche-Telekom-Allee 7, D-64295 Darmstadt
+49 6151 937-3679 (Phone) 
+49 6151 937-19875 (Fax) 
+49 521 5224 5816 (PC-Fax) 
E-Mail: mailto:[email-masked] 
Internet: http://t-systems.com

T-Systems Enterprise Services GmbH
Aufsichtsrat: René Obermann (Vorsitzender)
Executive Committee: Helmut Binder, Albert Henn, Olaf Heyden*, Katrin Horstmann, Ulrich Kemp,
Wilfried Peters*, Dr. Herbert Schaaff*, Zvezdana Seeger*
Handelsregister: Amtsgericht Frankfurt am Main HRB 55933
Sitz der Gesellschaft: Frankfurt am Main
WEEE-Reg.-Nr. DE87523644
*Geschäftsführer gem. § 35 GmbHG

Notice: This transmittal and/or attachments may be privileged or confidential. If you are not the intended recipient, you are hereby notified that you have received this transmittal in error; any review, dissemination, or copying is strictly prohibited. If you received this transmittal in error, please notify us immediately by reply and immediately delete this message and all its attachments. Thank you.
T-Systems - Business flexibility

_______________________________________________
ANCP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ancp

---

From: "Sanjay Wadhwa" <[email-masked]>
Date: Sun, 28 Oct 2007 20:30:56 -0400

Hi Markus
  We can either add explicit clarification as you suggest or add references to G.994.1, G.993.2 (Annexe D) and G.Lite for more on DSL line states (which result in these status codes) in section 5.44.  I am fine with either approach, but would like to hear what others have to say.

Regards
-Sanjay

ps. Slight mods (indicated inline) to your sugggested text.

>-----Original Message-----
>From: Freudenberger, Markus [  <mailto:[email-masked]> mailto:[email-masked]]
>Sent: Friday, October 12, 2007 4:46 AM
>To: [email-masked]
>Cc: Langhammer, Michael; Haag,T; Busser, M
>Subject: [ANCP] Proposal for clarification in the ancp-protocol draft
>
>
>Hello All,
>
>I suggest to add the following into section 5.4.4 "OAM
>Extensions" to clarify/refine the meaning of some return codes.
>
>****************** Original text in
>draft-ietf-ancp-protocol-01 - begin ******************
>
>****************** Original text in
>draft-ietf-ancp-protocol-01 - end ******************
>
>
>           0x503 : DSL line status showtime    : Line is synchronised, Power state L0 ( full ON).
>
>           0x504 : DSL line status idle                : Line not synchronised, port administrative "down", Power state L3 (no transmit signal)
>
>           0x505 : DSL line status silent              : Line not synchronised, port administrative "up", no CPE connected, Power state L3 (no transmit signal).
>
>E-Mail:  <mailto:[email-masked]> mailto:[email-masked]
>Internet:  <http://t-systems.com> http://t-systems.com
>
>Notice: This transmittal and/or attachments may be privileged
>or confidential. If you are not the intended recipient, you
>are hereby notified that you have received this transmittal in
>error; any review, dissemination, or copying is strictly
>prohibited. If you received this transmittal in error, please
>notify us immediately by reply and immediately delete this
>message and all its attachments. Thank you.
>  <https://www1.ietf.org/mailman/listinfo/ancp> https://www1.ietf.org/mailman/listinfo/ancp
>