Subject: [ANCP] ANCP MIB

From: Stefaan DE CNODDER <[email-masked]>
Date: Thu, 14 Feb 2008 09:49:05 +0100

Hi,

In revising the ANCP MIB for access nodes, there will be mainly minor 
updates but maybe two update deserves somewhat more attention:

1) The textual conventions defining the TCs GsmpSubVersion and 
AncpSessionCapabilities (previously named AncpAnSessionCapabilities), 
will be taken out the ANCP MIB module for access nodes, and will be put 
in a separate MIB module (also defined in the same document).

2) The ANCP MIB modules (we have 2 now) will not be put directly under 
mib-2, but under ancpMIB.  ANCP will have its own node ancpMIB and all 
ANCP MIB mdoules can be put under mib-2.

These changes will be done (except if someone has another opinion) to 
make the ANCP MIBs more general, to better support other ANCP related 
MIB modules in the future.

Thanks,
Stefaan

_______________________________________________
ANCP mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ancp

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 14 Feb 2008 09:58:15 +0100

Hi Stefaan,

For the two ANCP MIB modules, do you plan to request the allocation one
root OID under mib-2 or two? RFC 4181 believes two (and more down the
road if needed) is better. 

Dan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Stefaan DE CNODDER
> Sent: Thursday, February 14, 2008 10:49 AM
> To: [email-masked]
> Subject: [ANCP] ANCP MIB
> 
> 
> Hi,
> 
> In revising the ANCP MIB for access nodes, there will be 
> mainly minor updates but maybe two update deserves somewhat 
> more attention:
> 
> 1) The textual conventions defining the TCs GsmpSubVersion 
> and AncpSessionCapabilities (previously named 
> AncpAnSessionCapabilities), will be taken out the ANCP MIB 
> module for access nodes, and will be put in a separate MIB 
> module (also defined in the same document).
> 
> 2) The ANCP MIB modules (we have 2 now) will not be put 
> directly under mib-2, but under ancpMIB.  ANCP will have its 
> own node ancpMIB and all ANCP MIB mdoules can be put under mib-2.
> 
> These changes will be done (except if someone has another 
> opinion) to make the ANCP MIBs more general, to better 
> support other ANCP related MIB modules in the future.
> 
> Thanks,
> Stefaan
>

---

From: Stefaan DE CNODDER <[email-masked]>
Date: Thu, 14 Feb 2008 10:21:14 +0100

Hi Dan,

Actually, the intend was to have only 1 OID under mib-2 to have 
something like:

ancpMIB ::= { mib-2 xxx }
ancpTcMIB ::= { ancpMIB 1 }
ancpAnMIB ::= { ancpMIB 2 }

and a new future ANCP MIB module would use { ancpMIB 3 }.

But indeed, when looking to RFC 4181, it looks that this way of working 
is not recommended.  Should it then be as follows?

ancpTcMIB ::= { mib-2 xxx }
ancpAnMIB ::= { mib-2 yyy }

and a new future ANCP MIB module will be { mib-2 zzz }.

If the intend of RFC 4181 is the latter (so no ancpMIB), then we will 
use that.

Thanks,
Stefaan

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 14 Feb 2008 10:31:38 +0100

I would actually not recommend this, because this will make the ANCP WG
the eternal registry authority responsible for OID allocation, instead
of leaving this task to IANA, which has a well defined process with an
exact timing about when the OID needs to be allocated. There are a few
other good reasons for this which I can explain if you wish. I suggest
that you change this now, otherwise you will get almost surely comments
in MIB Doctor reviews. See the example in RFC4181 of the power Ethernet
MIB, which although is a MIB is not under an Ethernet tree administered
by the WG, but directly under mib-2. 

Regards,

Dan

> From: Stefaan DE CNODDER 
> [mailto:[email-masked]] 
> Sent: Thursday, February 14, 2008 11:21 AM
> To: Romascanu, Dan (Dan)
> Cc: [email-masked]
> Subject: Re: [ANCP] ANCP MIB
> 
> 
> Hi Dan,
> 
> Actually, the intend was to have only 1 OID under mib-2 to 
> have something like:
> 
> But indeed, when looking to RFC 4181, it looks that this way 
> of working is not recommended.  Should it then be as follows?
> 
> If the intend of RFC 4181 is the latter (so no ancpMIB), then 
> we will use that.
> 
> Thanks,
> Stefaan
> 
> 
> 
> > For the two ANCP MIB modules, do you plan to request the allocation 
> > one root OID under mib-2 or two? RFC 4181 believes two (and 
> more down 
> > the road if needed) is better.
> > 
> > Dan
> > 
> > 
> >  
> >  
> > 
> > 
> >>From: [email-masked] [mailto:[email-masked]] 
> On Behalf 
> >>Of Stefaan DE CNODDER
> mainly minor 
> >>will be taken out the ANCP MIB module for access nodes, and will be 
> >>put in a separate MIB module (also defined in the same document).
> >>
> directly under 
> This email was protected during delivery to Avaya with TLS encryption
> 
>