Subject: [ANCP] Question regarding Capability negotiation

From: Sidd Aanand <[email-masked]>
Date: Thu, 7 May 2009 15:18:51 -0400

Hi All,
 
Section 5.3 of the current ANCP draft talks about Capability
negotiation. It says that if a receiver can't support a capability in
the received message, it will send an updated adjacency message with
that capability turned off. This process will eventually result in both
ends resolving the commonly supported capabilities. My question is, when
the receiver sends the adjacency message with the updated capabilities,
should it send the code as SYN or SYNACK?
 
Thanks,
Sidd

---

From: "Aniruddha A (anira)" <[email-masked]>
Date: Fri, 8 May 2009 09:45:16 +0530

Hi Sidd,
 
The new capability set it sent as SYN message.
The procedure is: 
   On receiving a SYN, 
      if receiver finds that the sender supports more capabilities, 
		receiver waits for a new SYN
      if sender does not support all capabilities of the receiver, 
		receiver turns-off un-supported capabilities and sends a
new SYN.
 
--
Regards,
Aniruddha. A

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Sidd Aanand
Sent: Friday, May 08, 2009 12:49 AM
To: [email-masked]
Subject: [ANCP] Question regarding Capability negotiation

Hi All,

Thanks,
Sidd