Subject: [ANCP] Changes in Multicast extension codepoints

From: Francois Le Faucheur <[email-masked]>
Date: Tue, 2 Mar 2010 18:42:06 +0100

Hi Tom,

Some of these codepoints have already been implemented. When moving from hexa allocation to decimal allocation, would it be possible to retain the existing values (and just express them in decimal) - unless of course this happens to conflict with another value already allocated?
For example:
For Multicast Replication Control, could we go from existing " 0x90" to "144" (instead of "100").

This will result in holes in the allocated numbers, but that shoudl not be much of an issue, and these holes can be reused in the future,
And on the positive side it would avoid code-impacting changes.

Or am I missing some issue here that would prevent that?

Thanks

Francois

Begin forwarded message:

> From: Tom Taylor <[email-masked]>
> Date: 11 February 2010 15:57:55 CET
> To: "Wojciech Dec (wdec)" <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [ANCP] Multicast extension codepoints
> 
> Here's a tabulation of everything we have now and what I propose.
> 
> Message Types
> -------------
> 
> Message                             Current         Proposed
> 
> Multicast Replication Control         0x90            100
> Multicast Admission Control           0x92            101
> Bandwidth Reallocation Request        0x94            102
> Bandwidth Transfer                    0x95            103
> Delegated Bandwidth Query             0x96            104
> Multicast Flow Query                  0x97            105
> 
> Command Directives
> ------------------
> 
> Directive                           Current (no change proposed)
> 
> Add                                              0x01
> Delete                                           0x02
> Delete all                                       0x03
> Admission Control Reject                         0x04
> Conditional Access Reject                        0x05
> Admission Control and Conditional Access Reject  0x06
> 
> Failure Codes
> -------------
> 
> Error Condition                     Current         Proposed
> 
> Command error                         0x100           100
> Bad flow address                      0x101           101
> Multicast flow does not exist         0x102           102
> Invalid preferred bandwidth amount    0x103           103
> Inconsistent views of delegated       0x104           104
> bandwidth amount
> Bandwidth request conflict            0x105           105
> 
> TLVs
> ----
> I'm assuming we continue with hexadecimal for this one.
> 
> TLV                                 Current         Proposed
> 
> Multicast-Service-Profile              0x13          0x20
> Multicast-Service-Profile-Name         0x01          delete
> (sub-TLV)
> List-Action (sub-TLV)                  0x02          0x21
> Command-Number                        (none)         0x22
> Bandwidth-Allocation                   0x15          0x23
> White-List-CAC                        (none)         0x24
> MRepCtl-CAC                           (none)         0x25
> Bandwidth-Request                      0x16          0x26
> Multicast-Service-Profile-Name (TLV)   0x18          0x27
> Request-Source-IP (sub-TLV)            0x92          0x28
> Request-Source-MAC (sub-TLV)           0x93          0x29
> Multicast-Flow                         0x19          0x2A
> 
> Capabilities
> ------------
> 
> Capability                          Current (no change proposed)
> 
> NAS-initiated replication              0x05
> Conditional access with                0x06
> white and black lists
> Conditional access with grey lists     0x07
> Bandwidth delegation                   0x08
> 
> 
> Wojciech Dec (wdec) wrote:
>> Hi Tom,
>> Do you mean the message type code-points?
>> Regards,
>> Woj.
>>> -----Original Message-----
>>> From: [email-masked] [mailto:[email-masked]] On Behalf Of Tom Taylor
>>> Sent: 10 February 2010 22:28
>>> To: [email-masked]
>>> Subject: [ANCP] Multicast extension codepoints
>>> 
>>> Can I tidy up the various codepoint assignments in the multicast extensions document, or have people started to implement it already?
>>> 
>>> One issue I've noticed is that the GSMPv3 registries we are updating use decimal codepoint assignments, while we've used hexadecimal in both the base protocol document and the multicast extensions document. We'll have to try to sort that out.
>>> 
>>> Tom Taylor
>>> co-editor
>>> _______________________________________________
>>> ANCP mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/ancp
>>> 
> _______________________________________________
> ANCP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ancp

Francois Le Faucheur
Distinguished Engineer
Corporate Development
[email-masked]
Phone: +33 49 723 2619
Mobile: +33 6 19 98 50 90

Cisco Systems France
Greenside
400 Ave de Roumanille
06410 Sophia Antipolis
France
Cisco.com

 Think before you print.

This email may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply email and delete all copies of this message.

Cisco Systems France, Société à responsabiité limitée, Rue Camille Desmoulins – Imm Atlantis Zac Forum Seine Ilot 7 92130 Issy les Moulineaux, Au capital de 91.470 €, 349 166 561 RCS Nanterre, Directeur de la publication: Jean-Luc Michel Givone.

For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: Tom Taylor <[email-masked]>
Date: Tue, 02 Mar 2010 12:52:31 -0500

I have no problem with this. I'll update the draft accordingly. How about the 
other codepoint spaces mentioned below?

Francois Le Faucheur wrote:
> Hi Tom,
> 
> Some of these codepoints have already been implemented. When moving from hexa 
> allocation to decimal allocation, would it be possible to retain the existing 
> values (and just express them in decimal) - unless of course this happens to 
> conflict with another value already allocated?
> For example:
> This will result in holes in the allocated numbers, but that shoudl not be much 
> of an issue, and these holes can be reused in the future,
>> *From: *Tom Taylor <[email-masked] <mailto:[email-masked]>>
>> *Date: *11 February 2010 15:57:55 CET
>> *To: *"Wojciech Dec (wdec)" <[email-masked] <mailto:[email-masked]>>
>> *Cc: [email-masked] <mailto:[email-masked]>
>> *Subject: **Re: [ANCP] Multicast extension codepoints*
>>
>>>> From: [email-masked] <mailto:[email-masked]> 
>>>> [mailto:[email-masked]] On Behalf Of Tom Taylor
>>>> To: [email-masked] <mailto:[email-masked]>
>>>> Can I tidy up the various codepoint assignments in the multicast extensions 
>>>> document, or have people started to implement it already?
>>>>
>>>> One issue I've noticed is that the GSMPv3 registries we are updating use 
>>>> decimal codepoint assignments, while we've used hexadecimal in both the base 
>>>> protocol document and the multicast extensions document. We'll have to try 
>>>> to sort that out.
>>>>
>>>> Tom Taylor
>>>> co-editor
>>>> [email-masked] <mailto:[email-masked]>
>> [email-masked] <mailto:[email-masked]>
> *
> Francois Le Faucheur*
> *Distinguished Engineer*
> *Corporate Development*
> [email-masked] <mailto:[email-masked]>
> Phone: *+33 49 723 2619*
> Mobile: *+33 6 19 98 50 90*
> 
> 
> 	
> 
> *Cisco Systems France*
> Greenside
> 400 Ave de Roumanille
> 06410 Sophia Antipolis
> France
> Cisco.com <http://www.cisco.com>
> 
> 	 
> 
>  Think before you print.
> 
> This email may contain confidential and privileged material for the sole use of 
> the intended recipient. Any review, use, distribution or disclosure by others is 
> strictly prohibited. If you are not the intended recipient (or authorized to 
> receive for the recipient), please contact the sender by reply email and delete 
> all copies of this message.
> 
> Cisco Systems France, Société à responsabiité limitée, Rue Camille Desmoulins – 
> Imm Atlantis Zac Forum Seine Ilot 7 92130 Issy les Moulineaux, Au capital de 
> 91.470 €, 349 166 561 RCS Nanterre, Directeur de la publication: Jean-Luc Michel 
> Givone.
>