Subject: [ANCP] IETF78 ANCP WG meeting

From: Wojciech Dec <[email-masked]>
Date: Wed, 23 Jun 2010 18:17:56 +0200

Hi All,

We welcome requests for agenda slots at our next ANCP WG meeting in
Maastricht. Please respond with any requests.

Thanks,
Matthew & Woj

---

From: Tom Taylor <[email-masked]>
Date: Wed, 23 Jun 2010 12:33:57 -0400

I don't see any multicast issues this time around. I'd better complete my 
update, but the document is basically ready for WGLC once that's done, I think.

I'm part-way through finishing up my review of the base protocol document. So 
far no real technical issues, just a lot of editorial comments.

Wojciech Dec wrote:
> _______________________________________________
> ANCP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ancp
> 
>

---

From: Francois Le Faucheur <[email-masked]>
Date: Wed, 23 Jun 2010 18:47:29 +0200

On 23 Jun 2010, at 18:33, Tom Taylor wrote:

> I don't see any multicast issues this time around. I'd better complete my update, but the document is basically ready for WGLC once that's done, I think.

I thought we agreed to take on a bit of extra work to address the "Admitted Bandwidth Reporting" use case:
see http://www.ietf.org/mail-archive/web/ancp/current/msg01101.html

Or did you see that as part of "your update" ?

Thanks

Francois

> 
> I'm part-way through finishing up my review of the base protocol document. So far no real technical issues, just a lot of editorial comments.
> 
> Wojciech Dec wrote:
>> Hi All,

Francois Le Faucheur
Distinguished Engineer
Corporate Development
[email-masked]
Phone: +33 49 723 2619
Mobile: +33 6 19 98 50 90

Cisco Systems France
Greenside
400 Ave de Roumanille
06410 Sophia Antipolis
France
Cisco.com

 Think before you print.

This email may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply email and delete all copies of this message.

Cisco Systems France, Société à responsabiité limitée, Rue Camille Desmoulins – Imm Atlantis Zac Forum Seine Ilot 7 92130 Issy les Moulineaux, Au capital de 91.470 €, 349 166 561 RCS Nanterre, Directeur de la publication: Jean-Luc Michel Givone.

For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: Tom Taylor <[email-masked]>
Date: Wed, 23 Jun 2010 13:51:37 -0400

Yes, that is part of the update.

> Or did you see that as part of "your update" ?
...

---

From: "Poscic, Kristian (Kristian)" <[email-masked]>
Date: Wed, 23 Jun 2010 13:27:49 -0500

Hi there - 
A quick question. In ANCP protocol draft there are some Target TLVs defined but are mostly used for DSLAMs. 
How can I use a Target tlv for example for GPONs?

Let say that I need to submit a certain request from the NAS to the OLT, and that I need to address:
- uplink from the OLT towards the NAS
- or a particular PON port (slot 1/ port 1)
- or maybe even a particular subscriber on the OLT (slot 1, port 1, GEM 1)

Do we have provisions for this in any of the ANCP drafts?
Thanks,
Kris

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Wojciech Dec
Sent: Wednesday, June 23, 2010 9:18 AM
To: [email-masked]
Subject: [ANCP] IETF78 ANCP WG meeting

Hi All,

Thanks,
Matthew & Woj

---

From: Tom Taylor <[email-masked]>
Date: Wed, 23 Jun 2010 15:01:31 -0400

That's going to take an extension, presumably in the PON-related draft(s).

---

From: Wojciech Dec <[email-masked]>
Date: Thu, 24 Jun 2010 10:20:01 +0200

Hi Kristian,

That is something waiting to be defined, and we welcome your
proposals/drafts. We have accepted a WG draft to look at GPON extensions,
but this one is still in early phases:
http://tools.ietf.org/html/draft-bitar-wadhwa-ancp-pon-03

Regards,
Woj.

---

From: Hongyu Li <[email-masked]>
Date: Fri, 25 Jun 2010 09:39:05 +0800

Hi all,
 
IMHO, this draft
<http://tools.ietf.org/html/draft-bitar-wadhwa-ancp-pon-03>
http://tools.ietf.org/html/draft-bitar-wadhwa-ancp-pon-03 covers PON
framework, but multicast AC takes half weight of the full contents, which
could be applied to both DSL and PON. Therefore, I would suggest split this
draft into two, one for PON and one for multicast AC.
 
cheers,
Hongyu

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Wojciech Dec
Sent: Thursday, June 24, 2010 4:20 PM
To: Poscic, Kristian (Kristian); [email-masked]
Subject: Re: [ANCP] IETF78 ANCP WG meeting

Hi Kristian,

Regards,
Woj.

Hi there -
A quick question. In ANCP protocol draft there are some Target TLVs defined
but are mostly used for DSLAMs.
How can I use a Target tlv for example for GPONs?

Let say that I need to submit a certain request from the NAS to the OLT, and
that I need to address:
- uplink from the OLT towards the NAS
- or a particular PON port (slot 1/ port 1)
- or maybe even a particular subscriber on the OLT (slot 1, port 1, GEM 1)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Wojciech Dec
Sent: Wednesday, June 23, 2010 9:18 AM
To: [email-masked]
Subject: [ANCP] IETF78 ANCP WG meeting

Hi All,

Thanks,
Matthew & Woj

---

From: <[email-masked]>
Date: Fri, 25 Jun 2010 10:30:24 +0200

Hi all,
 
>From my understanding ancp-framework, ancp-protocol + multicast
extension address four use cases.
 
Looking to GPON we currently have only one draft which addresses
multicast mainly. In section 2 "Introduction" is stated:
 
..."The focus in this document will be on the ANCP requirements needed
for coordinated admission control of unicast and multicast video in FTTP
PON environments
between the AN complex and the NAS, specifically focusing on bandwidth
dedicated for multicast and shared bandwidth between multicast and
unicast."...
 
Considering the structure of that draft it implies that all use cases
are adressed. But I think it's not described in details that it can be
used for protocol development. Also document structure and introduction
have some differences.
 
I think it would be useful  to update current PON draft by using similar
structure as used in protocol draft and elaborate TLVs which are PON
specific (e.g. for FTTH deployment) and adopt TLVs already covered (e.g.
to be used in FTTC/B deployment).
 
Regards
 
Thomas

________________________________

Von: [email-masked] [mailto:[email-masked]] Im Auftrag von
Hongyu Li
Gesendet: Freitag, 25. Juni 2010 03:39
An: 'Wojciech Dec'; 'Poscic, Kristian (Kristian)'; [email-masked]
Betreff: Re: [ANCP] IETF78 ANCP WG meeting

Hi all,
 
IMHO, this draft
http://tools.ietf.org/html/draft-bitar-wadhwa-ancp-pon-03
<http://tools.ietf.org/html/draft-bitar-wadhwa-ancp-pon-03>  covers PON
framework, but multicast AC takes half weight of the full contents,
which could be applied to both DSL and PON. Therefore, I would suggest
split this draft into two, one for PON and one for multicast AC.
 
cheers,
Hongyu

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Wojciech Dec
	Sent: Thursday, June 24, 2010 4:20 PM
	To: Poscic, Kristian (Kristian); [email-masked]
	Subject: Re: [ANCP] IETF78 ANCP WG meeting

	Hi Kristian,
	
	That is something waiting to be defined, and we welcome your
proposals/drafts. We have accepted a WG draft to look at GPON
extensions, but this one is still in early phases:
	http://tools.ietf.org/html/draft-bitar-wadhwa-ancp-pon-03
	
	Regards,
	Woj.

		Hi there -
		A quick question. In ANCP protocol draft there are some
Target TLVs defined but are mostly used for DSLAMs.
		How can I use a Target tlv for example for GPONs?

		Let say that I need to submit a certain request from the
NAS to the OLT, and that I need to address:
		- uplink from the OLT towards the NAS
		- or a particular PON port (slot 1/ port 1)
		- or maybe even a particular subscriber on the OLT (slot
1, port 1, GEM 1)

		Do we have provisions for this in any of the ANCP
drafts?
		Thanks,
		Kris

		-----Original Message-----
		From: [email-masked]
[mailto:[email-masked]] On Behalf Of Wojciech Dec
		Sent: Wednesday, June 23, 2010 9:18 AM
		To: [email-masked]
		Subject: [ANCP] IETF78 ANCP WG meeting
		
		Hi All,

		We welcome requests for agenda slots at our next ANCP WG
meeting in
		Maastricht. Please respond with any requests.
		
		Thanks,
		Matthew & Woj

---

From: <[email-masked]>
Date: Fri, 25 Jun 2010 10:40:43 +0200

Hi all,

Based on expiriences running ANCP in carrier grade environment DT would like to present a problem statement in order to change the default value of T1 timer in document " draft-ietf-ancp-mib-an-03".

Regards
Thomas

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Wojciech Dec
Gesendet: Mittwoch, 23. Juni 2010 18:18
An: [email-masked]
Betreff: [ANCP] IETF78 ANCP WG meeting

Hi All,

Thanks,
Matthew & Woj

---

From: Sanjay Wadhwa <[email-masked]>
Date: Fri, 25 Jun 2010 06:11:43 -0700 (PDT)

Hi Kris
  The protocol draft will require extensions to define PON specific target TLVs. In defining these elements,  we can try to remain consistent with formats defined in BBF TR-156 for ACI and underlying port identification elements (also usable for uplink and PON ports). Please also see inline [SW].

Thanks
-Sanjay

________________________________
From: "Poscic, Kristian (Kristian)" <[email-masked]>
To: Wojciech Dec <[email-masked]>; "[email-masked]" <[email-masked]>
Sent: Wed, June 23, 2010 2:27:49 PM
Subject: Re: [ANCP] IETF78 ANCP WG meeting

Hi there - 

[SW] I am hoping NAS doesn't need to know about GEM IDs. The addressing should be generic to the extent possible with OLT deriving GEM IDs (from slot/port, VLAN tags...).

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Wojciech Dec
Sent: Wednesday, June 23, 2010 9:18 AM
To: [email-masked]
Subject: [ANCP] IETF78 ANCP WG meeting

Hi All,

Thanks,
Matthew & Woj

---

From: "Poscic, Kristian (Kristian)" <[email-masked]>
Date: Fri, 25 Jun 2010 09:04:46 -0500

Thanks Sanjay.
You mean the ANCP protocol draft or the GPON one? Some people think that this needs to go to the GPON draft.
I personally think that it should be part of ANCP protocol draft where the Target TLV is defined. But I'm fine either way.
Kris

From: Sanjay Wadhwa [mailto:[email-masked]]
Sent: Friday, June 25, 2010 6:12 AM
To: Poscic, Kristian (Kristian); Wojciech Dec; [email-masked]
Subject: Re: [ANCP] IETF78 ANCP WG meeting

Hi Kris

Thanks
-Sanjay

Hi there -

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Wojciech Dec
Sent: Wednesday, June 23, 2010 9:18 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [ANCP] IETF78 ANCP WG meeting

Hi All,

Thanks,
Matthew & Woj

_______________________________________________
ANCP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ancp
_______________________________________________
ANCP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ancp

---

From: Tom Taylor <[email-masked]>
Date: Fri, 25 Jun 2010 10:16:26 -0400

I object on principle to a series of application-specific extensions to the base 
protocol document. If that is necessary, the base was badly designed. Extensions 
should go into their own documents.

Poscic, Kristian (Kristian) wrote:
> ------------------------------------------------------------------------
>