Subject: [Anima-signaling] Question about GRASP discovery responses

From: Brian E Carpenter <[email-masked]>
Date: Mon, 7 Dec 2015 08:45:00 +1300

Hi Bing,

I have a question about GRASP discovery responses. According to the design,
the response message contains the Session ID and the discovered locator,
but not a confirmation of the objective. So that means that when receiving
the response, the receiver has to look up the Session ID in order to know
which objective the locator points too.

I think it would be a lot simpler if the response message also contained
the name of the discovery objective. It seems to me that it would simplify
the job of the receiver. What do you think?

Regards
   Brian

---

From: "Liubing (Leo)" <[email-masked]>
Date: Mon, 7 Dec 2015 02:28:24 +0000

Hi Brian,

> -----Original Message-----
> From: Brian E Carpenter [mailto:[email-masked]]
> Sent: Monday, December 07, 2015 3:45 AM
> To: Liubing (Leo)
> Cc: Anima signaling DT
> Subject: Question about GRASP discovery responses
> 
> Hi Bing,
> 
> I think it would be a lot simpler if the response message also contained the
> name of the discovery objective. It seems to me that it would simplify the
> job of the receiver. What do you think?

I think it might depends on how the GRASP be implemented: if it is per session per thread, then Session ID should be easier for the receiver; if per objective per thread, then Discovery Objective is easier.

In Section 3.7.3 (Response Message), it says "It MAY include a copy of the discovery objective
   from the Discovery message."
So, do we consider to change the "MAY" to "SHOULD", or even "MUST"? So that however you implement the GRASP, there is always proper info for the receiver.

Best regards,
Bing

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 8 Dec 2015 07:59:09 +1300

> I think it might depends on how the GRASP be implemented: if it is per session per thread, then Session ID should be easier for the receiver; if per objective per thread, then Discovery Objective i…

Yes, the natural implementation is to listen for the discovery response in the
same thread that sent the discovery message, so checking the session ID is
natural. In fact I think that is the only choice, because the response will come
on the ephemeral port used to send the discovery multicast.

> So, do we consider to change the "MAY" to "SHOULD", or even "MUST"? So that however you implement the GRASP, there is always proper info for the receiver.

No, I now think the original design is correct!

Thanks
   Brian