Subject: [Anima-signaling] Example messages for the GRASP draft

From: Brian E Carpenter <[email-masked]>
Date: Tue, 18 Oct 2016 16:46:56 +1300

Hi,

Here is a first look at what some GRASP example messages might look like.
In the attached, for each message, there are 3 lines:

1. the relevant CDDL definition.
2. the example message in Python format - essentially the same as CBOR
diagnostic format, except for some syntactic sugar. In the document,
I would convert fully to the CBOR notation.
3. a hexadecimal dump of the CBOR message.

The examples were generated by a tweaked version of my test suite with
its disgnostics switched on. (It was talking to itself, so all the IP addresses
are the same for now.)

Is this the sort of thing we want?

   Brian

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 18 Oct 2016 06:02:58 +0200

Do we need that many examples?

cbor.me (or the cbor-diag tool) converts

84011a00fdef78502406e001380c000128ccdc4c970367818463455831020200

to

[1, 16641912, h'2406e001380c000128ccdc4c97036781', ["EX1", 2, 2, 0]]

and then back to

84                                     # array(4)
   01                                  # unsigned(1)
   1a 00fdef78                         # unsigned(16641912)
   50                                  # bytes(16)
      2406e001380c000128ccdc4c97036781 # "$\x06\xE0\x018\f\x00\x01(\xCC\xDCL\x97\x03g\x81"
   84                                  # array(4)
      63                               # text(3)
         455831                        # "EX1"
      02                               # unsigned(2)
      02                               # unsigned(2)
      00                               # unsigned(0)

I think the “pretty-printed” bytes are quite useful for understanding what’s going on.

Grüße, Carsten

On 18 October 2016 at 05:47:09, Brian E Carpenter ([email-masked]) wrote:

Hi,  

Brian  

_______________________________________________  
Anima-signaling mailing list  
[email-masked]  
https://www.ietf.org/mailman/listinfo/anima-signaling