Subject: [Anima] Open Issues, take 2

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Wed, 17 Sep 2014 17:08:01 +0000

Today Laurent and I (same time zone, luxury!) discussed for almost 2 hours on how to make progress with the charter. 

Laurent had already started a list of open issues, and we continued to work on that list, below is the output. I wanted to go through all the recent emails to see whether we missed something, but haven't had the time yet. So the below text is likely incomplete.

I propose the following: 

- in the below text, we separated the issues in "critical - must be fixed now", "can be resolved in WG", and "can resolve now". 
- Let's make sure all issues are on this list. So if you raised an issue and it's not reflected here, please send a mail. 
   Please refrain from a complete charter re-write at this point, but be specific what should be changed where and how  :-) 
- When we have all the issues on the list:
  + let's resolve the last category right now; those are the easy ones. Should be editorial work. 
  + let's IGNORE the middle category for now, let's fix those once we have a WG (or once we cleared the "critical" list)
  + and let's focus the discussion NOW on the critical ones. 

So, for the call tomorrow, shall we focus on the first category and try to bring them to closure? 

Thoughts? 
Michael 

----

Open Issues

Critical Issues / Potential Show-Stoppers
=========================================

- perception that only 2 use cases are allowed. 
  response: The 2 mentioned will be working group drafts; other documents
  are ENCOURAGED, but as individual submissions. 
  ALL use case owners, including individual submissions are encouraged to validate
  the proposed autonomic functionalities and report potential issues. 
  Note: Add to charter?: Other use cases / solutions can be brought in with a 
        Charter change after the first phase is completed. 
  Note: not clear in charter right now that the first 2 use cases will be WG drafts.
        not clear that they may never progress.... 

- Why did those 2 use cases get selected? (Laurent) and
- Specific draft solutions taken as direction (Rene)  
  pre-selected on some criteria, ex: Both have running code. 

- the term "solution" (Dimitri) 
  (Dimitri, is there a simple way to fix this without re-doing the entire charter?)

Other Issues / Can resolve in WG later
======================================

- Naming the explicit drafts or not (cf thread initiated by Benoit).

Not critical because charter is clear that other documents are acceptable. 

- Not enough supporters on the list (Rene)
  (Not sure what we can do about this now)

Can resolve now
===============
- change: (Laurent)
   Definition of a discovery and negotiation protocol for autonomic functions
  to: 
   Definition of a discovery functionality for autonomic functions
   Definition of a negotiation functionality for autonomic functions

  - clarify in mile stones (new text refers to location of draft, in brackets) 

Nov 2014 - WG formation and adoption of initial drafts (see "specific goals")
           - Mar IETF 92nd - 
Apr 2015 - adoption of solution draft(s) (see "use cases")
Jun 2015 - WGLC for discovery and negotiation protocol
           - Jul IETF 93rd - 
Aug 2015 - submit discovery and negotiation protocol to IESG (standards track)
Aug 2015 - adoption of overview draft
Oct 2015 - WGLC for trust bootstrap draft
Oct 2015 - WGLC for solution draft(s) 
           - Nov IETF 94th - 
Dec 2015 - submit trust bootstrap draft to IESG (standards track)
Dec 2015 - submit solution draft(s) to IESG (standards track)
Jan 2016 - WGLC for autonomic control plane draft
Jan 2016 - WGLC for overview draft
           - Mar IETF 95th - 
Apr 2016 - submit autonomic control plane draft to IESG (standards track)

- delete section "Potential-future-works-not-for-initial-stage"
  (I think we already agreed on that)

- Division in camps (Rene)
  (we're trying to fix this...)

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 18 Sep 2014 08:44:01 +1200

On 18/09/2014 05:08, Michael Behringer (mbehring) wrote:

<snip>

> Critical Issues / Potential Show-Stoppers

Of course. That should be part of the process of reviewing the work
in progress.

>         Charter change after the first phase is completed. 

Actually, just as additional milestones - that is easier than
a formal charter change.

>   Note: not clear in charter right now that the first 2 use cases will be WG drafts.

Isn't it? I thought the milestones were clear enough.

>         not clear that they may never progress.... 

Don't get that point??

> - Why did those 2 use cases get selected? (Laurent) and

Because of pre-existing work, and because they are relatively
simple and fundamental.

>   pre-selected on some criteria, ex: Both have running code. 

Exactly.

>   (Dimitri, is there a simple way to fix this without re-doing the entire charter?)

I thought it was a fairly neutral choice of word. If it isn't perceived
as neutral, we could try "specification" in most places, but I don't
really see what it changes.

> Other Issues / Can resolve in WG later

Really? I mean I don't mind, because anything not in the charter
is not in scope, but I don't see the harm in it.
>   (we're trying to fix this...)

    Brian

---

From: Martin Vigoureux <[email-masked]>
Date: Wed, 17 Sep 2014 23:32:57 +0200

Hello,

>>    pre-selected on some criteria, ex: Both have running code.

This is not the first time I read this on this list and would appreciate 
some enlightenments.

I see two possible use of running code
1/ for experimentation, to develop practical (as opposed to theoretical) 
understanding of the behaviours
2/ for selling it

In the former case I would expect the associated Internet-Draft to be 
progressed as Informational, sharing, for the benefit of the community, 
the knowledge which was developed through experimentation.
In the latter case, I fail to understand the type of community feedback 
which is expected on a productised code.

Thank you

-m

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 18 Sep 2014 11:20:57 +1200

Martin,

> understanding of the behaviours

I'm not along those axes at all. Well, maybe a bit along #1 because
the point is: if somebody has implemented something, even as a prototype,
it passes the first tests: plausibility & proof of concept.

There is of course a lot more to be discussed after that.

> the knowledge which was developed through experimentation.

If the draft proceeds to RFC, sure. But many drafts just get used as
input to discussion that later results in consensus drafts.

> which is expected on a productised code.

Actually there are also quite a few RFCs that document proprietary solutions,
and those end up as Independent Stream RFCs these days. From what I've seen,
they mainly get feedback on clarity and grammar.

    Brian

---

From: Sheng Jiang <[email-masked]>
Date: Thu, 18 Sep 2014 03:32:20 +0000

Hi, Michael and all,

Thanks Michael and Laurent for this open issues list. I am working on next version, charter-ietf-anima-00-07. Several issues has been solved as we made progress through emails. Please see the attached charter-ietf-anima-00-07a. It shorts this list and make it easier for our meeting later today. Summary the solved issues and the shorter list of open issues:

  >- perception that only 2 use cases are allowed. 
  Response: 2 is specifically advised by ADs to demonstrate the use of common
  components while do NOT lose focus. The 2 mentioned are milestones for the
  initial stage; other documents are ENCOURAGED as individual submissions, and 
  may be added in later stage. 
  ALL use case owners, including individual submissions are encouraged to validate
  the proposed autonomic functionalities and report potential issues.

  >- Add new use cases to charter?
  <New text in the draft charter> "Additional work items may only be added
  with approval from the responsible Area Director or by re-chartering."

  >- Naming the explicit drafts or not (cf thread initiated by Benoit).
  <Closed> because charter is clear that other documents are acceptable. 
  And we did reach agreement to remove the draft names in early version. 
  But our AD has been very clear and insist to have them back. Following
  AD's advices would be the best choice.

  >- Separate discovery and negotiation functionality in mail goal section
  <Done in the new version>
  
  >- clarify in mile stones (new text refers to location of draft, in brackets)
  <Done in the new version>

  >- delete section "Potential-future-works-not-for-initial-stage"
  <Done in the new version>

Shorten list of open issues:

Can resolve now
===============

Thanks everybody for involvement and contributions. Let's work together to reach consensus for sending requests.

Best regards,

Sheng

>-----Original Message-----
>From: Anima [mailto:[email-masked]] On Behalf Of Michael
>Behringer (mbehring)
>Sent: Thursday, September 18, 2014 1:08 AM
>To: [email-masked]
>Subject: [Anima] Open Issues, take 2
>
>Laurent had already started a list of open issues, and we continued to work
>on that list, below is the output. I wanted to go through all the recent emails
>to see whether we missed something, but haven't had the time yet. So the
>below text is likely incomplete.
>
>I propose the following:
>
>- in the below text, we separated the issues in "critical - must be fixed now",
>"can be resolved in WG", and "can resolve now".
>   Please refrain from a complete charter re-write at this point, but be
>specific what should be changed where and how  :-)
>  + let's IGNORE the middle category for now, let's fix those once we have a
>WG (or once we cleared the "critical" list)
>_______________________________________________
>Anima mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/anima

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 18 Sep 2014 15:41:55 +1200

Sheng,

Thanks for that. Since I will not be on the call (2 a.m. for me),
I'll give my opinion: this version is OK for me and I think it's
time to submit it to the AD as the version we propose for IETF and
IESG review. I think we have really done the best we can to balance
the various opinions. (As a manager of mine once said, the job is
to achieve the best possible distribution of unhappiness. I will
accept the aspects of this charter that make me unhappy.)

Regards
   Brian

On 18/09/2014 15:32, Sheng Jiang wrote:
>> ------------------------------------------------------------------------
>>

---

From: Sheng Jiang <[email-masked]>
Date: Thu, 18 Sep 2014 04:56:04 +0000

Hi, all,

Please find the attached charter-ietf-anima-00-07b, which could be the base for our teleconf today.

Best regards,

Sheng

>From: Anima [mailto:[email-masked]] On Behalf Of Sheng Jiang
>Sent: Thursday, September 18, 2014 11:32 AM
>To: Michael Behringer (mbehring); [email-masked]
>Subject: Re: [Anima] Open Issues, take 2
>
>Hi, Michael and all,
>
>Thanks Michael and Laurent for this open issues list. I am working on next
>version, charter-ietf-anima-00-07. Several issues has been solved as we made
>progress through emails. Please see the attached charter-ietf-anima-00-07a.
>It shorts this list and make it easier for our meeting later today. Summary the
>solved issues and the shorter list of open issues:
>
>Solved:
>
>>Today Laurent and I (same time zone, luxury!) discussed for almost 2 hours
>on
>>how to make progress with the charter.
>>
>>- Let's make sure all issues are on this list. So if you raised an issue and it's
>not
>>reflected here, please send a mail.
>>So, for the call tomorrow, shall we focus on the first category and try to
>bring
>>them to closure?
>>
>>Thoughts?
>>Michael
>>
>>----
>>
>>Open Issues
>>

---

From: "Liubing (Leo)" <[email-masked]>
Date: Thu, 18 Sep 2014 09:34:45 +0000

Hi all,

I support moving forward the work to the next stage based on this version charter.
We've had multiple rounds for discussion and revising. It might not be necessary to stop and circle the discussion for more, let's just move on. 
I think most of our concerns have been reflected in this version. It may not satisfy everyone in every aspect, but I believe it is a decent start for a WG.

Best regards,
Bing

> Sent: Thursday, September 18, 2014 12:56 PM
> To: [email-masked]
> Subject: [Anima] charter-ietf-anima-00-07b//RE: Open Issues, take 2
> 
> Hi, all,
> 
> >Thanks Michael and Laurent for this open issues list. I am working on
> >next version, charter-ietf-anima-00-07. Several issues has been solved
> >as we made progress through emails. Please see the attached
> charter-ietf-anima-00-07a.
> >It shorts this list and make it easier for our meeting later today.
> >Summary the solved issues and the shorter list of open issues:
> >
> >Solved:
> >
> >  <New text in the draft charter> "Additional work items may only be
> > added  with approval from the responsible Area Director or by
> re-chartering."
> >
> >  But our AD has been very clear and insist to have them back.
> > Following  AD's advices would be the best choice.
> >
> >  >- Separate discovery and negotiation functionality in mail goal
> > section  <Done in the new version>
> >
> >  >- clarify in mile stones (new text refers to location of draft, in
> > brackets)  <Done in the new version>
> >
> >  (Dimitri, is there a simple way to fix this without re-doing the
> >entire
> >charter?)
> >
> >
> >>Laurent had already started a list of open issues, and we continued to
> >>work on that list, below is the output. I wanted to go through all the
> >>recent emails to see whether we missed something, but haven't had the
> >>time yet. So the below text is likely incomplete.
> >>
> >>I propose the following:
> >>
> >>- in the below text, we separated the issues in "critical - must be
> >>fixed now", "can be resolved in WG", and "can resolve now".
> >>   Please refrain from a complete charter re-write at this point, but
> >>be specific what should be changed where and how  :-)
> >>  + let's IGNORE the middle category for now, let's fix those once we
> >>have a WG (or once we cleared the "critical" list)
> >>  Note: Add to charter?: Other use cases / solutions can be brought in
> >>with
> >a
> >>  (Dimitri, is there a simple way to fix this without re-doing the
> >>entire
> >>charter?)
> >>
> >>
> >>Apr 2015 - adoption of solution draft(s) (see "use cases") Jun 2015 -
> >>WGLC for discovery and negotiation protocol
> >>           - Jul IETF 93rd -
> >>Aug 2015 - submit discovery and negotiation protocol to IESG
> >>(standards
> >>track)
> >>Oct 2015 - WGLC for trust bootstrap draft Oct 2015 - WGLC for solution
> >>draft(s)
> >>           - Nov IETF 94th -
> >>Dec 2015 - submit trust bootstrap draft to IESG (standards track) Dec
> >>2015 - submit solution draft(s) to IESG (standards track) Jan 2016 -
> >>WGLC for autonomic control plane draft Jan 2016 - WGLC for overview
> >>draft
> >>           - Mar IETF 95th -

---

From: Benoit Claise <[email-masked]>
Date: Wed, 24 Sep 2014 20:25:26 +0200

Dear all,

The charter attached below has been posted.

Regards, Benoit