Subject: [Anima] Agenda for Webex meeting #6

From: Sheng Jiang <[email-masked]>
Date: Wed, 17 Sep 2014 03:47:15 +0000

Dear all,

Please find attached a proposal for our Webex meeting #6 (in both ppt and pdf). In short, we will go through:

- Comments on the charter-ietf-anima-00-06 (<18/09/2014)
- Submit WG/BOF meeting request for IETF91 (action)

Please be constructive for suggestions/comments. We are supposed to reach consensus for sending requests. Otherwise, we may leave a hole for IETF91, particularly there may not be NMRG meeting for IETF91.

In case of problems, please contact the meeting organizers (Michael, Brian, Laurent and myself).

Best regards,

Sheng

---

From: Laurent Ciavaglia <[email-masked]>
Date: Wed, 17 Sep 2014 10:54:37 +0200

Hi Sheng, all,

Thanks for the agenda.

Following your advice, and in order to help the discussions during the 
time-limited call, could we all list and share the issues we think shall 
be resolved in order to have a stable and good charter for submission?

Starting the list:
-naming the drafts or not (cf thread initiated by Benoit).
-disambiguation and relationships on terms: use case, functionality, 
protocols...
-use cases or functionality "selection" i.e. do we agree on a 
process/set to start the WG.
-agree on the list of deliverables and rough schedule/order (underlying 
methodology/approach issue to be solved)
-group consensus / support for the two currently application use cases 
listed in charter 00-06.

I suggest paragraph(s) in 00-06 should be removed or reformulated, e.g. 
[Potential-future-works-not-for-initial-stage] ; I think the paragraph 
"autonomic service agents will demonstrate the usage of the above 
mentioned autonomic infrastructure components with __at least__ two use 
cases" should be removed, and the decision on application areas left to 
the group when we will reach that stage ; the paragraph "The initial set 
of work items is limited to the above list" is for me a showstopper 
because it is too narrow and prescriptive. IETF is contribution and 
consensus driven, so if there are (more) contributions and the WG 
supports them and want to deliver them, why should the charter forbid it?
Realistically, the use cases currently envisaged in charter 00-06 will 
be contributed so what is the risk/fear? to have more? I would be more 
than happy with this situation.
And if more contribution/use cases are not proposed to the WG, then we 
end in the same situation...

HTH, best regards, Laurent.

On 17/09/2014 05:47, Sheng Jiang wrote:
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima

-- 

Bien cordialement, Best regards,

*Laurent Ciavaglia*

Advanced Internet Research

Bell Labs | Alcatel Lucent

phone: +33 160 402 636

email: [email-masked] 
<mailto:[email-masked]>

linkedin: laurentciavaglia <http://fr.linkedin.com/in/laurentciavaglia/>

address: Route de Villejust | 91620 Nozay | France

---

From: Sheng Jiang <[email-masked]>
Date: Wed, 17 Sep 2014 10:17:36 +0000

Hi, Laurent,

Thanks for your constructive suggestions. I think we are on the way of reaching consensus. :)

>-naming the drafts or not (cf thread initiated by Benoit).

We did reach agreement to remove the draft names in version 09. But our AD has been very clear and insist to have them back. So, I don't think we should repeatly argue on this. Following AD's advices would be the best choice.

>paragraph(s) in 00-06 should be removed or reformulated, e.g. [Potential-future-works-not-for-initial-stage]

I think it was clear from the very beginning: [Potential-future-works-not-for-initial-stage] is a temporary paragraph that will be removed from the final charter. It was there to make us focus during the stage of writing draft charter.

>the paragraph "The initial set of work items is limited to the above list" is for me a showstopper because it is too narrow and prescriptive.

I think you mis-understood the meaning of this sentence. It only means we would not include other items as milestones for now (or maybe first couple IETF meetings). In any case, we could not include work items that have never been proposed as documents. Otherwise, the WG might have the risk that nobody works on these milestones.

We are *always* open and welcoming more contributions/user cases/proposals. That's why we have another sentense at the later of the same paragraph: "Additional documents concerning other autonomic infrastructure components, policy intent, use cases or autonomic service agents are strongly encouraged." Maybe we could improve the last sentense to be "Additional work items may only be added with approval from the responsible Area Director or by re-chartering."

Best regards,

Sheng

________________________________
From: Laurent Ciavaglia [[email-masked]]
Sent: 17 September 2014 16:54
To: Sheng Jiang; anima
Subject: Re: [Anima] Agenda for Webex meeting #6

Hi Sheng, all,

Thanks for the agenda.

Following your advice, and in order to help the discussions during the time-limited call, could we all list and share the issues we think shall be resolved in order to have a stable and good charter for submission?

Starting the list:
-naming the drafts or not (cf thread initiated by Benoit).
-disambiguation and relationships on terms: use case, functionality, protocols...
-use cases or functionality "selection" i.e. do we agree on a process/set to start the WG.
-agree on the list of deliverables and rough schedule/order (underlying methodology/approach issue to be solved)
-group consensus / support for the two currently application use cases listed in charter 00-06.

I suggest paragraph(s) in 00-06 should be removed or reformulated, e.g. [Potential-future-works-not-for-initial-stage] ; I think the paragraph "autonomic service agents will demonstrate the usage of the above mentioned autonomic infrastructure components with _at least_ two use cases" should be removed, and the decision on application areas left to the group when we will reach that stage ; the paragraph "The initial set of work items is limited to the above list" is for me a showstopper because it is too narrow and prescriptive. IETF is contribution and consensus driven, so if there are (more) contributions and the WG supports them and want to deliver them, why should the charter forbid it?
Realistically, the use cases currently envisaged in charter 00-06 will be contributed so what is the risk/fear? to have more? I would be more than happy with this situation.
And if more contribution/use cases are not proposed to the WG, then we end in the same situation...

Dear all,

Best regards,

Sheng

_______________________________________________
Anima mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/anima

Laurent Ciavaglia

phone: +33 160 402 636
email: [email-masked]<mailto:[email-masked]>
linkedin: laurentciavaglia<http://fr.linkedin.com/in/laurentciavaglia/>
address: Route de Villejust | 91620 Nozay | France

---

From: Laurent Ciavaglia <[email-masked]>
Date: Wed, 17 Sep 2014 15:50:57 +0200

Sheng,

Thanks for your clarifications. if the changes are implemented as you 
said, I am fine.
FYI, we ahd a good and long ;) call with Michael to discuss in detail 
the issues I listed and most of them are provisionally "solved", at 
least on my side. Other persons interested in the WG will of course 
express their views.
However, we did not manage to get around one or two issues because going 
one direction to solve the issue open the door to other risks... so we 
will have to decide tomorrow/on the list what is the decision on those 
issues.

I think Michael (if time allows) will send some synthesis before the 
call tomorrow.

Thanks, best regards, Laurent.

On 17/09/2014 12:17, Sheng Jiang wrote:
> We did reach agreement to remove the draft names in version 09. But 
> our AD has been very clear and insist to have them back. So, I don't 
> think we should repeatly argue on this. Following AD's advices would 
> be the best choice.
>
> >paragraph(s) in 00-06 should be removed or reformulated, e.g. 
> [Potential-future-works-not-for-initial-stage]
>
> I think it was clear from the very beginning: 
> [Potential-future-works-not-for-initial-stage] is a temporary 
> paragraph that will be removed from the final charter. It was there to 
> make us focus during the stage of writing draft charter.
>
> >the paragraph "The initial set of work items is limited to the above 
> list" is for me a showstopper because it is too narrow and prescriptive.
>
> I think you mis-understood the meaning of this sentence. It only means 
> we would not include other items as milestones for now (or maybe first 
> couple IETF meetings). In any case, we could not include work items 
> that have never been proposed as documents. Otherwise, the WG might 
> have the risk that nobody works on these milestones.
>
> We are *always* open and welcoming more contributions/user 
> cases/proposals. That's why we have another sentense at the later of 
> the same paragraph: "Additional documents concerning other autonomic 
> infrastructure components, policy intent, use cases or autonomic 
> service agents are strongly encouraged." Maybe we could improve the 
> last sentense to be "Additional work items may only be added with 
> approval from the responsible Area Director or by re-chartering."
>
> Best regards,
>
>
> Sheng
>
> ------------------------------------------------------------------------
> *From:* Laurent Ciavaglia [[email-masked]]
> *Sent:* 17 September 2014 16:54
> *To:* Sheng Jiang; anima
> *Subject:* Re: [Anima] Agenda for Webex meeting #6
>
> Hi Sheng, all,
>
> Thanks for the agenda.
>
> time-limited call, could we all list and share the issues we think 
> shall be resolved in order to have a stable and good charter for 
> submission?
>
> Starting the list:
> -agree on the list of deliverables and rough schedule/order 
> (underlying methodology/approach issue to be solved)
> I suggest paragraph(s) in 00-06 should be removed or reformulated, 
> e.g. [Potential-future-works-not-for-initial-stage] ; I think the 
> paragraph "autonomic service agents will demonstrate the usage of the 
> above mentioned autonomic infrastructure components with __at least__ 
> two use cases" should be removed, and the decision on application 
> areas left to the group when we will reach that stage ; the paragraph 
> "The initial set of work items is limited to the above list" is for me 
> a showstopper because it is too narrow and prescriptive. IETF is 
> contribution and consensus driven, so if there are (more) 
> contributions and the WG supports them and want to deliver them, why 
> should the charter forbid it?

-- 

*Laurent Ciavaglia*

phone: +33 160 402 636