Subject: [Anima] Call for agenda ANIMA @ IETF92

From: Sheng Jiang <[email-masked]>
Date: Mon, 2 Feb 2015 06:32:35 +0000

Hi, all,

After my pre-call-for-agenda "ANIMA @ IETF92" two weeks ago, we have received several applications for autonomic network topics besides the WG milestones. So, we have consulted our responsible AD and requested two sessions (a 2-hour session for WG milestones, another 1.5-hour session for non WG milestone topics) for our ANIMA Working Group meeting at IETF92.

The conflict list is as follows:
   First Priority:	homenet netconf dhc v6ops
   Second Priority:	opsarea 6man softwire nmrg
   Third Priority:	cfrg saag 6tisch

We have also requested a Meetecho support in the room in case anyone is remote / need to present remotely.

Please send us ([email-masked]) requests for time slot and include:

   Name of time slot:
   Name of draft(s) (preferred but not necessary):
   Time requested:
   Presenter name(s):
   Brief description of what issues need discussing and what you hope to accomplish by presenting:

Also, presenters and draft authors please invoke active discussions in the ANIMA list. We have very limited time for each topic in the face-to-face meeting. Mail list is a very good place to attract audiences' attention and get them to actually know your topic, also details, before the meeting. So, we could have the best use of our meeting time. We could not make significant progress with only the face-to-face meeting. Mail list is the official work place in the IETF.

Again, as a emphasis, the ANIMA WG is open for topics/drafts that are relevant to autonomic networking. Beside the current milestones, other autonomic infrastructure components, policy intents, use cases or autonomic 
service agents are strongly encouraged, as individual submissions. They could be discussed as potential recharter contents in the future.

Best regards,

Sheng and Toerless

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 03 Feb 2015 16:49:40 +1300

Name of time slot: GDNP
  Name of draft(s): draft-carpenter-anima-gdn-protocol
  Time requested: 20 min + discussion
  Presenter name(s): Brian Carpenter
  Brief description of what issues need discussing and what you hope to accomplish by presenting:
   Open issues listed in the draft (prioritised to fit the time). We want to
   resolve as many as possible, and understand the WG opinion of the general
   direction described in the draft.

     Brian + Bing

---

From: Laurent Ciavaglia <[email-masked]>
Date: Fri, 6 Feb 2015 12:05:43 +0100

Dear ANIMA chairs, all,

I am kindly asking for two slots.
_slot 1:_
    Name of time slot: predictive risk awareness for proactive management.
    Name of draft(s) (preferred but not necessary): TBA.
    Time requested: 10min. + Q&A
    Presenter name(s): Laurent Ciavaglia
    Brief description of what issues need discussing and what you hope 
to accomplish by presenting: requirements and applicability to ANIMA 
functionality/protocol suite.
_slot 2__:_
    Name of time slot: coordinating multiple (conflicting) autonomic 
functions.
    Name of draft(s) (preferred but not necessary): TBA.
    Time requested: 10min. + Q&A
    Presenter name(s): Laurent Ciavaglia
    Brief description of what issues need discussing and what you hope 
to accomplish by presenting: highlight coordination as a key issue in 
autonomic networking, requirements and applicability to ANIMA 
functionality/protocol suite.

Best regards, Laurent.

---

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Wed, 11 Feb 2015 19:08:41 +0000

Sheng, 

We should present the following drafts: 

Name of time slot: Bootstrapping a trust infrastructure
Name of draft(s) (preferred but not necessary): draft-pritikin-anima-bootstrapping-keyinfra
Time requested: 20 min plus discussion
Presenter name(s): Max Pritikin (tbd)
Brief description of what issues need discussing and what you hope to accomplish by presenting: This draft should describe a generic way to bootstrap a trust infrastructure, and it should be applicable to other working groups. 

Name of time slot: Separated Autonomic Control Plane
Name of draft(s) (preferred but not necessary): draft-behringer-anima-autonomic-control-plane
Time requested: 20 min plus discussion
Presenter name(s): Michael Behringer (tbd)
Brief description of what issues need discussing and what you hope to accomplish by presenting: This is a new concept, which needs peer validation and feedback. 

Name of time slot: ANIMA reference model
Name of draft(s) (preferred but not necessary): draft-behringer-anima-reference-model
Time requested: 20 min plus discussion
Presenter name(s): Michael Behringer (tbd)
Brief description of what issues need discussing and what you hope to accomplish by presenting: A new version of the draft will be posted soon; the reference model should accurately describe the overall architectural approach for ANIMA, and needs discussion. 

Thanks,
Michael

> -----Original Message-----
> From: Anima [mailto:[email-masked]] On Behalf Of Sheng Jiang
> Sent: 02 February 2015 07:33
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Anima] Call for agenda ANIMA @ IETF92
> 
> Hi, all,
> 
> After my pre-call-for-agenda "ANIMA @ IETF92" two weeks ago, we have
> received several applications for autonomic network topics besides the WG
> milestones. So, we have consulted our responsible AD and requested two
> sessions (a 2-hour session for WG milestones, another 1.5-hour session for
> non WG milestone topics) for our ANIMA Working Group meeting at IETF92.
> 
> Also, presenters and draft authors please invoke active discussions in the
> ANIMA list. We have very limited time for each topic in the face-to-face
> meeting. Mail list is a very good place to attract audiences' attention and get
> them to actually know your topic, also details, before the meeting. So, we
> could have the best use of our meeting time. We could not make significant
> progress with only the face-to-face meeting. Mail list is the official work
> place in the IETF.
> 
> Again, as a emphasis, the ANIMA WG is open for topics/drafts that are
> relevant to autonomic networking. Beside the current milestones, other
> autonomic infrastructure components, policy intents, use cases or
> autonomic service agents are strongly encouraged, as individual
> submissions. They could be discussed as potential recharter contents in the
> future.
> 
> Best regards,
> 
> Sheng and Toerless
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima

---

From: Markus Stenberg <[email-masked]>
Date: Mon, 16 Feb 2015 10:42:01 +0200

Name of time slot: DNCP
Name of draft(s) (preferred but not necessary): draft-ietf-homenet-dncp-01 (-01 will show up pre-Dallas)
Time requested: 10 min
Presenter name(s): Markus Stenberg (TBD)

As there was some call for ‘more generic’ state synchronization protocol in Hawaii, we obliged by splitting HNCP to DNCP and HNCP. This is relatively ’tightly coupled’ synchronization protocol, as it essentially ensures state perceived by all participants matches (about the data they care about, and as a side effect, about the connectivity graph of participating nodes). This is more of an awareness presentation than anything else.

Name of time slot: DNCP + X != GDNP
Name of draft(s) (preferred but not necessary): TBD (I hope to submit one pre-Dallas)
Time requested: 20min
Presenter name(s): Markus Stenberg

While the name of the time slot is bit of a joke, I am planning to write up my thoughts on how both loose and tightly coupled synchronization among anima nodes should work. It will be a DNCP profile, with few more exchanges defined for pure discovery and negotiation. Also, a “large scale” scalability model is introduced to describe how this could work with “many” nodes. 

(And to be precise, I am not planning to replace GDNP with this draft, but just to illustrate that with fewer pages of text + DNCP you can actually have a complete solution from my point of view, with some running code already forming base of it.)

Cheers,

-Markus

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 17 Feb 2015 08:16:23 +1300

Hi Markus,

> (And to be precise, I am not planning to replace GDNP with this draft, but just to illustrate that with fewer pages of text + DNCP you can actually have a complete solution from my point of view, w…

GDNP is not sacred, so we can have an open-minded discussion on that.
Unfortunately we probably won't have the GDNP prototype code updated to
the latest spec before Dallas, though.

As for the number of pages of text, I think that mainly depends where
you choose to write down the details, including background information,
requirements, theory of operation and alternatives. We chose to put all
of it into one document for GDNP.

   Brian

---

From: Markus Stenberg <[email-masked]>
Date: Tue, 17 Feb 2015 08:30:56 +0200

> of it into one document for GDNP.

Yes, GDNP spec is heavy on theory/requirements (and comparisons to some degree). 

However, given the document, it is completely unclear to me how it would work in practise (and given the latitude allowed to the individual objectives, perhaps intentionally so). The TODO list is a (partial) indicator of that. I do not mind the theory/requirements parts (they are skippable if not interested in them after all), but the lack of concrete detail I find somewhat distracting.

Perhaps it is just a difference of opinion on what should be the leading part of an effort ;)

Cheers,

-Markus

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 18 Feb 2015 08:07:12 +1300

On 17/02/2015 19:30, Markus Stenberg wrote:
> However, given the document, it is completely unclear to me how it would work in practise (and given the latitude allowed to the individual objectives, perhaps intentionally so). The TODO list is a (partial) indicator of that. 

There will be a new version soon where the TO DO list is quite a bit shorter,
and hopefully there will be time in Dallas for a protocol walk-through, but
you are correct, we are intentionally being generic in this draft.

> I do not mind the theory/requirements parts (they are skippable if not interested in them after all), but the lack of concrete
detail I find somewhat distracting.
> Perhaps it is just a difference of opinion on what should be the leading part of an effort ;)

I know exactly what you mean. Remember that there is some prototype code, though.
The next version does (IMNSHO) tie down a lot more details, to the point where
I feel I could at least write a pseudo-code version of the whole thing. And my
co-author is on the hook to update the prototype code when time permits.

    Brian