Subject: [Anima] Call for Volunteer - ANIMA signaling design team

From: Sheng Jiang <[email-masked]>
Date: Mon, 27 Apr 2015 10:02:13 +0000

Hi, all,

We are calling for volunteers to form a design time for ANIMA signaling design team. The chairs has assigned two editors (Brian Carpenter and Bing Liu), we are expecting up to 4 main contributors. The charter, initial goal and target date for the signaling design team is introduced below. It also available in the design team wiki page.

http://trac.tools.ietf.org/wg/anima/trac/wiki/Signaling

Because of the intended design team work, we expect that the design team members would need to spend at least half a day per week on this project for maybe 4..6 month, but it should become less afterwards. We would like to limit the design team to one year (or shorter if the goals are reached faster of course).

As WG chairs we will participate and help of course in the design team primarily for logistics. In principle, the design team discussions should be open for all ANIMA participators. People who is interested, but do not have enough time to commit, could also be able to participate and make contributions or comments.

This call is last for one week. It ends May 3rd, Sunday. Please reply before it if you are interested in the commitment.

Charter for the signaling design team

The Anima WG charter states a requirement for discovery and negotiation mechanisms to enable closed-loop interaction between autonomic nodes. It also states the goal of developing one or more protocol specifications (or extensions to existing protocols) to achieve these goals. There is an existing draft requirements analysis, whose main points include

   - support for any type of network objective parameter;
   - discovery must support any topology and bootstrap scenario;
   - synchronize parameters with other nodes individually or by flooding;
   - negotiate parameters with other nodes;
   - always secure.

A simple TLV format is proposed for the protocol design. Binary or name-based discovery are proposed as alternative discovery approaches.

The purpose of the design team is to analyze these issues and recommend a combined approach to the working group, preferably in the form of one draft or a small set of coordinated drafts. The proposed approach should be suitable for use by the Autonomic Control Plane, and for other use cases including those listed in the Anima WG charter.

In preparing the recommendation, the design team will verify and update the existing requirements and understand the relevant use cases. However, documenting and solving use cases is out of scope for the design team. The design team is encouraged to develop protocol walkthroughs and an abstract API as aids to understanding. The design team is not itself expected to produce code, but ease of implementation is an important consideration.

The draft(s) should be delivered by the July 2015 IETF (2015-07-06 cutoff date).

Initial Goals

   - Validate and update the existing list of requirements (​http://tools.ietf.org/html/draft-carpenter-anima-gdn-protocol#section-2) against bootstrap and ACP drafts (and optionally against other use case validation drafts). Target date: end May.
   - Recommend how the other milestone components of ANIMA (bootstrap, ACP, validation drafts) should use the signaling protocol(s). As a side-effect, critique the proposal on the table (​https://tools.ietf.org/html/draft-carpenter-anima-gdn-protocol#section-3).

Target date: mid June.

Best regards,

Toerless + Sheng

---

From: Jéferson Campos Nobre <[email-masked]>
Date: Mon, 27 Apr 2015 15:15:47 -0300

Dear Chairs.
I volunteer for the signaling design team.
As a side note, I was not able to join the anima-signaling mailing
list via the URL provided in the wiki.
Cheers.

Jéferson Campos Nobre
PhD Student
Computer Networks Group -  Institute of Informatics
Federal University of Rio Grande do Sul
http://www.inf.ufrgs.br/~jcnobre

On Mon, Apr 27, 2015 at 7:02 AM, Sheng Jiang <[email-masked]> wrote:
>    - Validate and update the existing list of requirements (http://tools.ietf.org/html/draft-carpenter-anima-gdn-protocol#section-2) against bootstrap and ACP drafts (and optionally against other use case validation drafts). Target date: end May.
>    - Recommend how the other milestone components of ANIMA (bootstrap, ACP, validation drafts) should use the signaling protocol(s). As a side-effect, critique the proposal on the table (https://tools.ietf.org/html/draft-carpenter-anima-gdn-protocol#section-3).
>
> Target date: mid June.
>
> Best regards,
>
> Toerless + Sheng
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 28 Apr 2015 07:55:28 +1200

> list via the URL provided in the wiki.

Yes, it looks like the list hasn't been created yet, one of the WG chairs
is taking care of that.

   Brian

---

From: Alper Yegin <[email-masked]>
Date: Tue, 28 Apr 2015 00:22:38 +0300

Hello Sheng,

IETF 92 proceedings had stated:

Would like to start building design teams for a) bootstrap 
      and b) signaling, which are milestone building blocks.

So, what you've announced is one of the two design teams to be created, right?

Alper

---

From: Sheng Jiang <[email-masked]>
Date: Tue, 28 Apr 2015 01:02:28 +0000

Hi, all,

This is a progress clarification for WG while it is also reply to Alper.

Yes, we are planning to form two design teams for bootstrapping and signaling. So far, we only announced the Call for Volunteer for signaling design team. The bootstrapping call for volunteer would probably be next week. We did this partially because we could like to make the processes clear separated to avoid confusion, also because the bootstrapping editors and charter have not ready yet.

The response for call-for-volunteer should go to WG chairs and editors directly. It is not needed to be in mail list.

The assigned editors and WG chairs would pick up the design team members after the call ends. So, the signaling design team would be announced later next week.

Creating the mail lists for the design team needs approval from our responsible AD. As long as the mail lists are available, we will also make announcement in the mail list. As we said, the design team discussions should be open for all ANIMA participators. People who is interested, but not in the design team, could also be able to participate and make contributions or comments.

Best regards,

Sheng

From: Alper Yegin [mailto:[email-masked]]
Sent: Tuesday, April 28, 2015 5:23 AM
To: Sheng Jiang
Cc: Anima WG; Toerless Eckert; Liubing (Leo); [email-masked]
Subject: Re: [Anima] Call for Volunteer - ANIMA signaling design team

Hello Sheng,

Alper

Hi, all,

Initial Goals

Target date: mid June.

Best regards,

Toerless + Sheng
_______________________________________________
Anima mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/anima

---

From: Laurent Ciavaglia <[email-masked]>
Date: Thu, 30 Apr 2015 16:49:56 +0200

Dear Sheng, all,

I would like to volunteer for the ANIMA signaling design team.
However, the mission statement (as described below) is not fully clear 
to me, thus I would suggest we (ANIMA WG) spend some cycles to clarify 
the mission, the objectives and relationship with other components / 
work items of ANIMA.

Thanks, best regards, Laurent.

-- 

Bien cordialement, Best regards,

*Laurent Ciavaglia*

Secure Cloud Networking

Bell Labs | Alcatel Lucent

phone: +33 160 402 636

email: [email-masked] 
<mailto:[email-masked]>

linkedin: laurentciavaglia <http://fr.linkedin.com/in/laurentciavaglia/>

address: Route de Villejust | 91620 Nozay | France

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 01 May 2015 07:38:15 +1200

Laurent,

Can you be specific about what is unclear? Can you reduce it to individual issues, which we can track at
http://trac.tools.ietf.org/wg/anima/trac/wiki/Open%20Issues even before the team has officially started?

Also - how things fit together is the topic of https://tools.ietf.org/html/draft-behringer-anima-reference-model-01 so maybe
that is where we should add explanations.

(To be vey specific about my thoughts, the only way to tell whether the proposed signaling protocol is adequate is to do what is
described in the design team charter: confront it with some of the use cases, as described in the two initial goals.)

Regards
   Brian

On 01/05/2015 02:49, Laurent Ciavaglia wrote:
> However, the mission statement (as described below) is not fully clear to me, thus I would suggest we (ANIMA WG) spend some
> cycles to clarify the mission, the objectives and relationship with other components / work items of ANIMA.
> 
>> We are calling for volunteers to form a design time for ANIMA signaling design team. The chairs has assigned two editors
>> (Brian Carpenter and Bing Liu), we are expecting up to 4 main contributors. The charter, initial goal and target date for the
>> signaling design team is introduced below. It also available in the design team wiki page.
>>
>> Because of the intended design team work, we expect that the design team members would need to spend at least half a day per
>> week on this project for maybe 4..6 month, but it should become less afterwards. We would like to limit the design team to one
>> year (or shorter if the goals are reached faster of course).
>>
>> As WG chairs we will participate and help of course in the design team primarily for logistics. In principle, the design team
>> discussions should be open for all ANIMA participators. People who is interested, but do not have enough time to commit, could
>> also be able to participate and make contributions or comments.
>>
>> The Anima WG charter states a requirement for discovery and negotiation mechanisms to enable closed-loop interaction between
>> autonomic nodes. It also states the goal of developing one or more protocol specifications (or extensions to existing
>> protocols) to achieve these goals. There is an existing draft requirements analysis, whose main points include
>>
>> The purpose of the design team is to analyze these issues and recommend a combined approach to the working group, preferably
>> in the form of one draft or a small set of coordinated drafts. The proposed approach should be suitable for use by the
>> Autonomic Control Plane, and for other use cases including those listed in the Anima WG charter.
>>
>> In preparing the recommendation, the design team will verify and update the existing requirements and understand the relevant
>> use cases. However, documenting and solving use cases is out of scope for the design team. The design team is encouraged to
>> develop protocol walkthroughs and an abstract API as aids to understanding. The design team is not itself expected to produce
>> code, but ease of implementation is an important consideration.
>>
>>     - Validate and update the existing list of requirements (​
>> http://tools.ietf.org/html/draft-carpenter-anima-gdn-protocol#section-2) against bootstrap and ACP drafts (and optionally
>> against other use case validation drafts). Target date: end May.
>>     - Recommend how the other milestone components of ANIMA (bootstrap, ACP, validation drafts) should use the signaling
>> protocol(s). As a side-effect, critique the proposal on the table (​
>> https://tools.ietf.org/html/draft-carpenter-anima-gdn-protocol#section-3).
>>
>> Target date: mid June.
>>
>> Best regards,
>>
>> Toerless + Sheng