Subject: [Anima] Addressing-interface addressing

From: "Liubing (Leo)" <[email-masked]>
Date: Fri, 24 Apr 2015 08:34:08 +0000

Hi Dear all,

This is another topic regarding to autonomic addressing.

For autonomic network infrastructure, is it sufficient to self-assign the devices' interfaces link-local addresses? Do we need to assign the interfaces ULA/GUA addresses in some scenarios?

I think RFC7404 already has some good discussion, that pinging/traceroute/mpls/rsvp-te might have some problem if there are only link-local addresses on the interfaces. Do we need to consider these factors in autonomic networking infrastructure?

Best regards,
Bing

---

From: Michael Richardson <[email-masked]>
Date: Fri, 24 Apr 2015 12:38:33 -0400

> For autonomic network infrastructure, is it sufficient to self-assign
    > the devices' interfaces link-local addresses? Do we need to assign the
    > interfaces ULA/GUA addresses in some scenarios?

I think that the answer depends upon which interface you are talking about.

The only way that I can see that we can use and also route link-local
addresses would be if we are in fact creating some kind of NBMA interface
for an ACP "LAN".

I don't think that's a good idea.  I think it is better to use a ULA (and I
have said I favour a ULA-C approach) on a loopback interface.  I am happy to
use SLAAC or Stable-Private (7217) for that address.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 25 Apr 2015 07:49:19 +1200

On 25/04/2015 04:38, Michael Richardson wrote:
> I don't think that's a good idea.  I think it is better to use a ULA 

I agree. Otherwise, how do nodes on different links communication
independently of the user-visible addressing scheme?

> (and I
> have said I favour a ULA-C approach) on a loopback interface.  

IMHO we don't need -C. That would imply yet another external dependency
(on a non-existent registry that has no funding model anyway). Vanilla
ULA works fine.

Regards
   Brian

> I am happy to
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima
>