Subject: [Anima] Reference doc - who helps where

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Thu, 11 Jun 2015 14:24:47 +0000

With the new outline in place (see draft-behringer-anima-reference-model-02, just posted), we can now look who owns which section. 

Now I try to best map the volunteers I've seen to the sections, according to their suggestions: 
- Michael Richardson: section 3.3 (constrained nodes)
- Liubing: 4.1 and 4.2 (Naming, addressing)
- Brian Carpenter: 4.4 (signaling). Could you also cover 4.5 (intent distribution) and 4.3 (discovery)? - very related!! 
- Jason Coleman: Section 5.1, 5.2, 5.4, 5.5 (PKI, cert, sub and cross-domain)
- Jeferson Nobre: 7.1, 7.2, 7.3 (Management, intent, aggregated reporting) 
- John Strassner: 7.4, 7.5, 7.6 (feedback loops, APIS and models.)
- Laurent Ciavaglia: Sections 8 and 9 (do they need an update?)
- Toerless and I will share the remaining sections for now. 

Did I miss any volunteer? Any wrong / missing section? 

Now, some thoughts on how we progress, to see whether we have consensus.
- The owner of a section keeps maintaining that section. This is NOT a one-off, but requires continued work on your sections. 
- Anyone in the author team is expected to read the entire doc, and comment on it, help improve it. 
- This document is NOT the standard, it just links up all the (future) standards. At the end, each section will point to the relevant standards track document. Details are for those documents. 
- This document has the serious danger of getting very big, unless we all pay attention. Many sub-sections can probably be done in a few paragraphs. I suggest that each sub-section should not exceed half a page. (Obviously, this is not a precise science, but "more or less".)  Therefore: 
- Writing style should be as concise as possible. Every sentence, every word should be there for a reason. 

Do we agree? Did I miss something? 
Michael

---

From: Jéferson Campos Nobre <[email-masked]>
Date: Thu, 11 Jun 2015 19:07:19 +0000

Hi Michael.
Agreed.
Do you plan to have a github rep like in anima signaling? I think it is a
good idea because of the number of contributors.
Best.
Jéferson

Em qui, 11 de jun de 2015 às 11:24, Michael Behringer (mbehring) <
[email-masked]> escreveu:

> With the new outline in place (see
> draft-behringer-anima-reference-model-02, just posted), we can now look who
> owns which section.
>
> - Brian Carpenter: 4.4 (signaling). Could you also cover 4.5 (intent
> distribution) and 4.3 (discovery)? - very related!!
> - The owner of a section keeps maintaining that section. This is NOT a
> one-off, but requires continued work on your sections.
> - This document is NOT the standard, it just links up all the (future)
> standards. At the end, each section will point to the relevant standards
> track document. Details are for those documents.
> - This document has the serious danger of getting very big, unless we all
> pay attention. Many sub-sections can probably be done in a few paragraphs.
> I suggest that each sub-section should not exceed half a page. (Obviously,
> this is not a precise science, but "more or less".)  Therefore:
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima
>

---

From: "Liubing (Leo)" <[email-masked]>
Date: Fri, 12 Jun 2015 05:32:34 +0000

Hi Dear all in Anima,

As we are discussing the reference model draft recently, also as Michael B. commented:

> - This document is NOT the standard, it just links up all the (future) standards.
> At the end, each section will point to the relevant standards track document.
> Details are for those documents.

We actually have been exploring the intent related issues for some time. So we thought it might be good to reveal our current work for discussion.
We've uploaded a draft to discuss the Intent Distribution issue:

> Name:		draft-liu-anima-intent-distribution
> Revision:	00
> Title:		Intent Distribution for Autonomic Networking
> Document date:	2015-06-12
> Group:		Individual Submission
> Pages:		10
> URL:          https://www.ietf.org/internet-drafts/draft-liu-anima-intent-distribution-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-liu-anima-intent-distribution/
> Htmlized:       https://tools.ietf.org/html/draft-liu-anima-intent-distribution-00

The document is still at the initial stage, so we're quite open to discuss any of the content. We also expect more of you to contribute on this work.
Many thanks!

Best regards,
Bing

---

From: John Strassner <[email-masked]>
Date: Fri, 12 Jun 2015 14:49:57 -0700

Hi Michael,

thanks for organizing this. I'm confirming both my assigned sections as
well as reading and commenting on the entire draft.

Regarding 7.2 (intent), we should be careful to sync (or explain why we
disagree) with intent as being defined in the 100 or so other places that
people are working on it. We don't need to sync in this document of course
- but we should be prepared to deal with this (imho inevitable) question
when it comes up. I'm happy to help Jefferson here (I'm active in ONF,
ONOS, Congress, TMF, and remember - SUPA has also defined intent).

How would you like to proceed on updates? For example, if I update 7.3,
should I send a draft-behringer-anima-reference-model-02-7.3-from-jcs.txt
to the author list, ANIMA, or a to-be-defined GitHub site?

best regards,
John

-- 
regards,
John

---

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Wed, 17 Jun 2015 15:51:00 +0000

From: John Strassner [mailto:[email-masked]]
Sent: 12 June 2015 23:50
To: Michael Behringer (mbehring)
Cc: Anima WG
Subject: Re: [Anima] Reference doc - who helps where

Hi Michael,

thanks for organizing this. I'm confirming both my assigned sections as well as reading and commenting on the entire draft.

Regarding 7.2 (intent), we should be careful to sync (or explain why we disagree) with intent as being defined in the 100 or so other places that people are working on it. We don't need to sync in this document of course - but we should be prepared to deal with this (imho inevitable) question when it comes up. I'm happy to help Jefferson here (I'm active in ONF, ONOS, Congress, TMF, and remember - SUPA has also defined intent).

MB: Indeed. We’ll have interesting discussions on that. A lot depends on the way Intent is defined, IMO. If we have a clear definition we’re a step further.

How would you like to proceed on updates? For example, if I update 7.3, should I send a draft-behringer-anima-reference-model-02-7.3-from-jcs.txt to the author list, ANIMA, or a to-be-defined GitHub site?

MB: You will have seen my github mail today. Whichever way you prefer, really. I suggest to copy the anima list on the texts, so that people can read/comment right away.

Michael

best regards,
John

On Thu, Jun 11, 2015 at 7:24 AM, Michael Behringer (mbehring) <[email-masked]<mailto:[email-masked]>> wrote:
With the new outline in place (see draft-behringer-anima-reference-model-02, just posted), we can now look who owns which section.

_______________________________________________
Anima mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/anima

--
regards,
John