Subject: Re: [Anima] I-D Action: draft-liu-anima-intent-distribution-00.txt

From: Brian E Carpenter <[email-masked]>
Date: Tue, 16 Jun 2015 12:02:12 +1200

Hi,

I think this is useful to start the discussion on
the nature and requirements for intent distribution.
A few first comments:

1. I agree that potentially intent could be injected
anywhere (with some sort of authorization). In many
networks it will actually come from a central NOC, but
the flexibility is good.

2. As far as the signaling protocol goes, I take this
as a fairly strong indication that we need an unsolicited
mechanism to flood intent (as well a solicited model
where an ASA discovers a source of intent and requests
the intent data). Since we already need a safe mechanism
to flood discovery, I don't think this will be too hard.

3. For the moment I think details of the protocol element
don't matter too much - if we do change GDNP to a JSON/CBOR
model, it would look different but would have the same
semantics.

    Brian

---

From: "Liubing (Leo)" <[email-masked]>
Date: Tue, 16 Jun 2015 07:59:58 +0000

Hi Brian,

Thanks for your quick comments. Please see replies inline.

> -----Original Message-----
> From: Anima [mailto:[email-masked]] On Behalf Of Brian E
> Carpenter
> Sent: Tuesday, June 16, 2015 8:02 AM
> To: Anima WG
> Subject: Re: [Anima] I-D Action: draft-liu-anima-intent-distribution-00.txt
> 
> Hi,
> 
> I think this is useful to start the discussion on the nature and requirements
> for intent distribution.
[Bing] Yes, let's identify the requirements first.

> A few first comments:
> 
> 1. I agree that potentially intent could be injected anywhere (with some sort
> of authorization). In many networks it will actually come from a central NOC,
> but the flexibility is good.
[Bing] NOC is for sure a typical use case. For the "arbitrary injection point" case, my guess is that the ANI relevant intent might require or at least benefit from it.

> 2. As far as the signaling protocol goes, I take this as a fairly strong
> indication that we need an unsolicited mechanism to flood intent (as well a
> solicited model where an ASA discovers a source of intent and requests the
> intent data). Since we already need a safe mechanism to flood discovery, I
> don't think this will be too hard.
[Bing] Indeed. We used to have a brief discussion about unsolicited synchronization in previous version of the GDNP draft. Maybe it's good restore it back and extent the semantic.

For flooding mechanism, this draft provides a specific solution as described in https://tools.ietf.org/html/draft-liu-anima-intent-distribution-00#section-3.2.3 . I think this applies to discovery too.
But for sure, this is NOT to settle down the solution by myself, it is food for discussion.

> 3. For the moment I think details of the protocol element don't matter too
> much - if we do change GDNP to a JSON/CBOR model, it would look
> different but would have the same semantics.
[Bing] Yes, the specific designs are food for discussion at current stage. 

There is one design principle I'd like to ask all of you: do we need a dedicated Intent Distribution message, or we just consider Intent Distribution as a specific content of the Unsolicited Messages?
The draft follows the latter approach, since we thought of Intent Distribution as an affair that the ASA needs to handle rather than the protocol model handling it.

Best regards,
Bing

>     Brian
> 
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima