Subject: Re: [Anima] I-D Action: draft-du-anima-an-intent-00.txt

From: Brian E Carpenter <[email-masked]>
Date: Tue, 16 Jun 2015 12:15:39 +1200

Hi,

Just to see if I am understanding the ideas in this draft,
here's a sketch of how to represent the intent for the
draft-jiang-anima-prefix-management use case in JSON terms.
(If we end up with JSON for the signaling protocol, I will
argue for JSON for intent too.)

Obviously this is hand-waving; the main question is
whether it can express the sort of things we might want
to support in intent.

{"example_intent":
[{"intent_type": "IPv6_prefix"},
{"autonomic_domain": "Customer_X_intranet"},
{"version": 73},
{"date": "20150616"},
{"content": [{"max_prefix_length": 60},
          {"min_prefix_length": 48},
          {"max_prefixes_per_customer": 2},
          {"SLA_check_needed": true},
          {"enable_log": false}]}]}

Regards
   Brian

---

From: Duzongpeng <[email-masked]>
Date: Tue, 16 Jun 2015 08:22:16 +0000

Hi Brian:

Thanks for your valuable suggestions. I agree that JSON is an option.
IMO, what we need for intent is a common format, no matter it is XML-based or JSON-based.
XML and JSON are both machine and human readable, and easily processed.

Another major concern about autonomic intent is whether we need a common policy language here. 
XML and JSON are good for data exchange, however, it is hard for them to carry some complicated semantics or logic.
So, perhaps we need a common policy language to simplify the expression jobs and make intent more flexible to extend.

For example, an operator may need to configure the autonomic network as "Efficiency First" at 7:00-23:00, and "Energy-saving First" at 23:00-7:00.
These configurations have some conditions and actions, which falls into the scope of "policy". 

About the prefix management use case, we may have the policies like if role A, the prefix length is XXX.

Best Regards
Zongpeng Du

-----Original Message-----
From: Anima [mailto:[email-masked]] On Behalf Of Brian E Carpenter
Sent: Tuesday, June 16, 2015 8:16 AM
To: Anima WG
Subject: Re: [Anima] I-D Action: draft-du-anima-an-intent-00.txt

Hi,

Just to see if I am understanding the ideas in this draft, here's a sketch of how to represent the intent for the draft-jiang-anima-prefix-management use case in JSON terms.
(If we end up with JSON for the signaling protocol, I will argue for JSON for intent too.)

Obviously this is hand-waving; the main question is whether it can express the sort of things we might want to support in intent.

{"example_intent":

Regards
   Brian

_______________________________________________
Anima mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/anima