Subject: [Anima] A question about draft-ietf-anima-autonomic-control-plane-12

From: zhangyongkang 00210452 <[email-masked]>
Date: Mon, 20 Nov 2017 07:09:16 +0000

Hi Behringer,
When I read the section 6.10.5 ACP Vlong Addressing Sub-Scheme，I was confused about the following content:
             50                              78
   +---------------------++-----------------------------+----------+
   |    (base scheme)      ||           Node-ID                             |
   |                          || Registrar-ID |   Node-Number|          V |
   +---------------------++--------------+--------------+----------+
                                      46             33/17          8/16

                 Figure 6: ACP Vlong Addressing Sub-Scheme
…
o  Registrar-ID: To maximize Node-Number and V, the Registrar-ID is
      reduced to 46 bits.  This still allows to use the MAC address of a
      registrar by removing the V and U bits from the 48 bits of a MAC
      address (those two bits are never unique, so they cannot be used
      to distinguish MAC addresses).
o  If the first bit of the "Node-Number" is "1", then the Node-Number
      is 17 bit long and the V field is 16 bit long.  Otherwise the
      Node-Number is 33 bit long and the V field is 8 bit long.  "0" bit
      Node-Numbers are intended to be used for "general purpose" ACP
      nodes that would potentially have a limited number (< 256) of
      clients (ASA/Autonomic Functions or legacy services) nof the ACP
      that require separate V(irtual) addresses.  "1" bit Node-Numbers
      are intended for ACP nodes that are ACP edge nodes (see

      Section 8.1.1) or that have a large number of clients requiring
      separate V(irtual) addresses.  For example large SDN controllers
      with container modular software architecture (see Section 8.1.2).

According the above content, Node-ID(78bits) is composed of Registrar-ID, Node-Number and V fields. But:
(1) When the first bit of Node-Number is 1, 17(Node-Number) + 16(V) + 46(Registrar-ID) = 33 + 46 = 79
(2) When the first bit of Node-Number is 0, 33(Node-Number) + 8(V) + 46(Registrar-ID) = 41 + 46 = 97

So the result confused me!
Please check the above section again when you pleasure.

---

From: zhangyongkang 00210452 <[email-masked]>
Date: Mon, 20 Nov 2017 07:11:43 +0000

Sorry, there is a mistake:
(2) When the first bit of Node-Number is 0, 33(Node-Number) + 8(V) + 46(Registrar-ID) = 41 + 46 = 87

发件人: Anima [mailto:[email-masked]] 代表 zhangyongkang 00210452
发送时间: 2017年11月20日 15:09
收件人: [email-masked]; [email-masked]
抄送: Zengweizhi; Yangang
主题: [Anima] A question about draft-ietf-anima-autonomic-control-plane-12

Hi Behringer,