Subject: Re: [Anima] Adoption call for draft-liu-anima-grasp-api-06, ends Dec. 12, 2017

From: "Liubing (Leo)" <[email-masked]>
Date: Mon, 4 Dec 2017 10:17:18 +0000

Hi all,

I support it as a co-author.

Since GRASP is eventually used by applications (ASAs), the API is essential for ASA developers. Just like the socket interface, the GRASP API can provide some services to app layer. The services are discovery/Sync/Negotiation which would allow developers to focus on network management functions and eliminate reinventing basic network protocol “wheels”.

Best regards,
Bing

From: Anima [mailto:[email-masked]] On Behalf Of Sheng Jiang
Sent: Wednesday, November 29, 2017 7:36 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Anima] Adoption call for draft-liu-anima-grasp-api-06, ends Dec. 12, 2017

During the IETF100, there was a consensus that draft-liu-anima-grasp-api is fully consistent with the current ANIMA charter, under the condition it intends to be an Informational document. After the meeting, the authors have updated the document. The current intended status is Informational. There was an adoption call on this document as a ANIMA working group document in the ANIMA session, IETF100. There were supports and no objection as far as chairs heard. As an official procedure, we now confirm the adoption in the ANIMA mailing list. This message starts a two-week adoption call on draft-liu-anima-grasp-api.

  Title:      Generic Autonomic Signaling Protocol Application Program Interface (GRASP API)

  Authors :   Liu, et al.

  Filename:   draft-liu-anima-grasp-api

  https://tools.ietf.org/html/draft-liu-anima-grasp-api-06

Please express your support or rejection. If you think this document should _not_ be adopted, please also explicitly indicate the reasons.

This adoption call will end on December 12, 2017.

Regards,

Sheng + Toerless

---

From: Xun Xiao <[email-masked]>
Date: Fri, 8 Dec 2017 08:46:41 +0000

Dear Anima and chairs,

I support to adopt this document, which will standardize the interface to the anima system. Thanks.

BR.

-Xun Xiao

From: Anima [mailto:[email-masked]] On Behalf Of Sheng Jiang
Sent: Wednesday, November 29, 2017 12:36 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Anima] Adoption call for draft-liu-anima-grasp-api-06, ends Dec. 12, 2017

  Authors :   Liu, et al.

Regards,

Sheng + Toerless

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 9 Dec 2017 17:57:48 +0100

On Nov 29, 2017, at 12:35, Sheng Jiang <[email-masked]> wrote:
> 
> During the IETF100, there was a consensus that draft-liu-anima-grasp-api is fully consistent with the current ANIMA charter, under the condition it intends to be an Informational document. After the meeting, the authors have updated the document. The current intended status is Informational. There was an adoption call on this document as a ANIMA working group document in the ANIMA session, IETF100. There were supports and no objection as far as chairs heard. As an official procedure, we now confirm the adoption in the ANIMA mailing list. 

I wasn’t in the room when this was discussed.

I believe it is a good thing that the IETF is not in the habit of automatically creating an API for each protocol that it defines (“IETF doesn’t do APIs”).  However, there are specific situations when creating APIs is useful:

— adoption of a new technology may benefit from a common API being available.  E.g., RFC 2292/3542 has helped IPv6 adoption a lot by making applications possible that would have had to use IPv4 otherwise.  Similar, RFC 6458 for SCTP.
— the API may clarify the “northbound interface” of the protocol implementation.  Sometimes it is not clear from a protocol what the actual meaning of running the protocol is supposed to be.  While we probably don’t want to automatically define a “service interface” like in the OSI model for each protocol, a more innovative protocol may be hard to understand without the image of such an API in the mind of the reader.

I believe both of these effects can be had here, so it is good that the authors have written up the API.

I also agree that there should be an intent of finishing this quickly to aid adoption, and of revisiting the API again after a few years of getting experience — after all, this is not intended as a “Standard".  This probably does not justify going for “Experimental”: First, this isn’t really a protocol, and second, there is no formal experiment being run here that will be done at some point: This API is supposed to last unless we learn that it can be improved.

So I completely agree with (what I understand was) the in-room consensus at IETF 100 and the sentiments that were expressed here.

Grüße, Carsten

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 12 Dec 2017 09:36:48 +0100

+1 supporting adoption of this document.
Also interested to contribute to the effort.

+1 on Mcr/Carstens suggestion to be fast & furios (don't drag this out for long).

Wrt. to APIs and IETF: I expect that we may need to refine terminology
to pass IESG review, such as maybe requiring us to more often emphasize how 
this is an "abstract API", or definition of "northbound service features"
or the like (even in the title).

[ Any time we use the term "API" without further
atribute, there are folks wanting to misinterpret it as a "concrete API"
(for  specific programming language). Which is what the IETF does not like
(and has no real expertise in), and which the draft also not attempts to specify. ]

Cheers
    Toerless

On Sat, Dec 09, 2017 at 05:57:48PM +0100, Carsten Bormann wrote:
> I wasn???t in the room when this was discussed.
> 
> I believe it is a good thing that the IETF is not in the habit of automatically creating an API for each protocol that it defines (???IETF doesn???t do APIs???).  However, there are specific situations when creating APIs is useful:
> 
> ??? adoption of a new technology may benefit from a common API being available.  E.g., RFC 2292/3542 has helped IPv6 adoption a lot by making applications possible that would have had to use IPv4 otherwise.  Similar, RFC 6458 for SCTP.
> ??? the API may clarify the ???northbound interface??? of the protocol implementation.  Sometimes it is not clear from a protocol what the actual meaning of running the protocol is supposed to be.  While we probably don???t want to automatically define a ???service interface??? like in the OSI model for each protocol, a more innovative protocol may be hard to understand without the image of such an API in the mind of the reader.
> 
> I also agree that there should be an intent of finishing this quickly to aid adoption, and of revisiting the API again after a few years of getting experience ??? after all, this is not intended as a ???Standard".  This probably does not justify going for ???Experimental???: First, this isn???t really a protocol, and second, there is no formal experiment being run here that will be done at some point: This API is supposed to last unless we learn that it can be improved.
>

---

From: "Diego R. Lopez" <[email-masked]>
Date: Tue, 12 Dec 2017 09:35:55 +0000

Hi,

I support the adoption. As said at the meeting, I think it is about time the IETF starts considering APIs, or at least general interfaces (as it is doing in other WGs, like TAPS), especially when we think of the increasing momentum software-enabled solutions are gaining. And the case of GRASP is especially relevant for this, so there is a clear interface for extension modules. And yes, let's make it F&F

Regarding Toerless' comments, I'd have no problem in looking for a wording that becomes more palatable to the non-API purists. We could even make this a general approach to the problem...

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]
Tel:         +34 913 129 041
Mobile:  +34 682 051 091
----------------------------------
On 12/12/2017, 09:37, "Anima on behalf of Toerless Eckert" <[email-masked] on behalf of [email-masked]> wrote:

    Cheers
        Toerless

    > So I completely agree with (what I understand was) the in-room consensus at IETF 100 and the sentiments that were expressed here.

    _______________________________________________
    Anima mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/anima

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Tue, 12 Dec 2017 16:03:13 +0000

Hello,

I think this work is of interest and should continue, either as an individual or working group document.

Laurent.

-----Original Message-----
From: Anima [mailto:[email-masked]] On Behalf Of Diego R. Lopez
Sent: Tuesday, December 12, 2017 10:36 AM
To: Toerless Eckert <[email-masked]>; Sheng Jiang <[email-masked]>; [email-masked]
Cc: [email-masked]; Carsten Bormann <[email-masked]>
Subject: Re: [Anima] Adoption call for draft-liu-anima-grasp-api-06, ends Dec. 12, 2017

Hi,

Be goode,

Dr Diego R. Lopez
Telefonica I+D

    Cheers
        Toerless

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição _______________________________________________
Anima mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/anima