Subject: Re: [Anima] ATTN/MUST REPLY: IPR disclosure against draft-ietf-anima-bootstrapping-keyinfra

From: Toerless Eckert <[email-masked]>
Date: Thu, 5 Jul 2018 21:06:38 +0200

Thanks Kent

Let me forward to the mailing list so it is aware of this information.

IPR disclosure for that Juniper patent is here, from 2015:

https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-ietf-netconf-zerotouch
https://datatracker.ietf.org/ipr/2581/

And for reference the ones disclosed explicitly against the bootstrap draft
in 2014/2016:
https://datatracker.ietf.org/ipr/search/?submit=draft&id=draft-pritikin-anima-bootstrapping-keyinfra
https://datatracker.ietf.org/ipr/2463/
https://datatracker.ietf.org/ipr/2816/

Cheers
    Toerless

On Thu, Jul 05, 2018 at 03:21:53PM +0000, Kent Watsen wrote:
> 
> The following was filed for the NETCONF WG's zerotouch draft:
> 
>    US Patent Application No. 14/626,382
> 
>    link: https://patents.justia.com/patent/20160246617
> 
> 
> I didn't think to file it for the voucher draft itself, because the voucher
> draft just sets up the environment.  The patent is primarily concerned with
> "offline bootstrapping" (e.g., booting off a USB flash drive), but it may
> have some applicability to this draft.   Please review and let me know.
> 
> Kent
> 
> 
> ===== original message =====
> 
> Dear authors of ANIMA draft-ietf-anima-bootstrapping-keyinfra
> 
> As the document shepherd, i am hereby asking each of you to confirm
> that any and all appropriate IPR disclosures required for full conformance
> with the provisions of BCP 78 and BCP 79 have already been filed?
> 
> Currently, there are two disclosures mentioned:
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_ipr_search_-3Fsubmit-3Ddraft-26id-3Ddraft-2Dietf-2Danima-2Dbootstrapping-2Dkeyinfra&d=DwIBAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=aUmDyJOX9lAznU-gnIOBXiJ8GWg7vbgP6bIAjQ6jBFE&s=9OhEIj9bViZjDM-VnPjRuJvXrRQEFhT1KoBG7DfTu6E&e=
> 
> Hint:
> 
> "I am not aware of any IPR against draft-ietf-anima-bootstrapping-keyinfra
>  that have not already been disclosed"
> 
> Is a perfect answer to the question raised by this email (if it is true).
> But remember that you are expected to be aware of all IPR with your name on it.
> 
> Cheers
>     Toerless

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 6 Jul 2018 11:47:07 +1200

> https://datatracker.ietf.org/ipr/2581/

If somebody believes that is relevant to BRSKI, that somebody needs to
file a separate disclosure.
 
> https://datatracker.ietf.org/ipr/2463/

This one isn't of great concern, since it's a reciprocal non-assert declaration.

> https://datatracker.ietf.org/ipr/2816/

This one meets minimal requirements since it is reciprocal RAND, but note
that it does *not* declare what the RAND conditions are, and the claims
in the patent are fairly wide. Personally I don't think it is a reason
to change track, exactly because the claims *are* wide - no minor
changes to BRSKI would avoid them, if they are valid at all. But vendors
will need to look closely at it.

    Brian

> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima
>

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 6 Jul 2018 22:45:36 +0200

Brian,

Thanks for the insight. I checked with IETF
legal council, and the guidance was that RFC8179/5.1.3 would
only come in second here. Given how the draft author is the
IPR author, we need for Kent to come back authoritatively
with an answer according to RFC8179/5.1.1. Or at least i need to
wait for that answer for the shepherd-writeup.

Wrt to your other comments (swapping hat to contributor):

I love to comment on patent writeups publically, but i am too fearfull
one could unexpectedly end up later as witness (if not worse) in some 
lawsuit with computers seized and inspected as evidence. So, i'll
restrict myself to commenting in environments with more privacy.

Cheers
    Toerless

-- 
---
[email-masked]