Subject: [Anima] proposed anima charter (was; Re: New work item proposal / agenda request)

From: Toerless Eckert <[email-masked]>
Date: Tue, 19 Feb 2019 12:31:32 +0100

Thanks, SHeng

As a reminder: the currently proposed charter is edited on our wiki
because the version on datatracker can seemingly only been edited by the
AD, so we can not directly contribute prposed changes.

Please revisit the proposed charter and propose any missing pieces or
other suggestion:

https://trac.ietf.org/trac/anima/wiki/Recharter2019

There are two lines for BRSKI which i hope are inclusive of the
different aspects of BRSKI that had interest on the list.

Cheers
    Toerless

On Mon, Feb 11, 2019 at 08:37:07AM +0000, Sheng Jiang wrote:
> Hi, Eliot,
> 
> Thanks for the information. Noted. We will see how the proposed charter goes with the approving procedure by the time. It is now in the hand of our responsible AD.
> 
> Sheng
> 
> From: Eliot Lear [mailto:[email-masked]]
> Sent: Monday, February 11, 2019 2:59 PM
> To: Sheng Jiang <[email-masked]>
> Cc: Fries, Steffen <[email-masked]>; Toerless Eckert <[email-masked]..de>; [email-masked]; [email-masked]; Brockhaus, Hendrik <[email-masked]>
> Subject: Re: [Anima] New work item proposal / agenda request
> 
> Hi Sheng,
> 
> IMHO this would be a good topic to be part of the recharter discussion, and so I would suggest that it come before that.  And I think perhaps we indicate the other future work going on with BRSKI.
> 
> Eliot
> 
> 
> On 11 Feb 2019, at 02:42, Sheng Jiang <[email-masked]<mailto:[email-masked]>> wrote:
> 
> Hi, Steffen,
> 
> How much time do you need? I will try my best to match your request. However, giving we are in the recharter procedure, we are not sure how much time would be needed for the charter discussion (if our new charter got approved before the meeting, then the time would be relevant short). Therefore, I cannot guarantee you the time length yet.
> 
> Regards,
> 
> Sheng
> 
> 
> -----Original Message-----
> From: Fries, Steffen [mailto:[email-masked]]
> Sent: Saturday, February 09, 2019 12:44 AM
> To: Toerless Eckert <[email-masked]<mailto:[email-masked]>>
> Cc: [email-masked]<mailto:[email-masked]>; Sheng Jiang <[email-masked]<mailto:[email-masked]>>;
> [email-masked]<mailto:[email-masked]>; Brockhaus, Hendrik <[email-masked]<mailto:[email-masked]>>
> Subject: RE: New work item proposal / agenda request
> 
> Hi Toerless,
> 
> Sounds great. Looking forward to the meeting.
> 
> Best regards
> Steffen
> 
> 
> -----Original Message-----
> From: Toerless Eckert <[email-masked]<mailto:[email-masked]>>
> Sent: Freitag, 8. Februar 2019 13:26
> To: Fries, Steffen (CT RDA ITS) <[email-masked]<mailto:[email-masked]>>
> Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>;
> Brockhaus, Hendrik (CT RDA ITS SEA-DE) <[email-masked]<mailto:[email-masked]>>
> Subject: Re: New work item proposal / agenda request
> 
> Steffen,
> 
> This should be fine on the agenda. Sheng usually runs the agenda, he
> is out this week (chinese new year). Consider yourself top in queue of
> new work items ;-)
> 
> Cheers
>    Toerless
> 
> On Thu, Feb 07, 2019 at 07:12:10PM +0000, Fries, Steffen wrote:
> 
> Hello Toerless, hello Sheng,
> 
> Based on the discussion we had in December about support of
> asynchronous operation/enrollment support in BRSKI on the mailing
> list, I'm preparing a contribution for the next IETF meeting. The work
> is based on requirements from industrial and IoT scenarios and targets
> the proposal a supporting self-contained objects as an extension to the
> currently defined BRSKI to support asynchronous operation during enrolment.
> 
> 
> I'm currently preparing the draft contribution together with Hendrik
> ( a colleague) and would like to ask for a slot in the agenda. I
> saw the agenda request for an ANIMA WG meeting and was not sure how
> far advanced the planning of the meeting agenda already is. Just wanted to
> ensure we're not too late. I will submit the draft in time before the next meeting.
> 
> 
> Best regards
> Steffen
> 
> _______________________________________________
> Anima mailing list
> [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/anima
> 

> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima

-- 
---
[email-masked]

---

From: Michael Richardson <[email-masked]>
Date: Tue, 19 Feb 2019 11:19:58 -0500

It is my understanding that charter documents are now documents like any
other, and when uploaded through the Datatracker, can then be subject to
diff.  Finding it hard to figure out the differences,, I took the 2.04 and
2.03 points from Toerless which have a different amount of white space, and
stuff them through diff, and I got:

obiwan-[/corp/ietf/anima](2.4.1) mcr 10009 %diff -u charter-3.txt charter-4.txt
--- charter-3.txt       2019-02-19 11:16:20.737525056 -0500
+++ charter-4.txt       2019-02-19 11:16:07.821564832 -0500
@@ -25,10 +25,11 @@
 ANI OAMP interfaces (Operations, Administration, Management, Provisioning), e.g. YANG models
 ANI deployment structure (virtualization, compounding)
 Variations of Voucher formats
-BRSKI/Bootstrap protocol aspects (different proxies, extensions for wireless)
+BRSKI/Bootstrap protocol aspects (different proxies, extensions for wireless, adaptions for different markets)
 GRASP extensions for common use cases (e.g. bulk transfer, DNS-SD interworking)
 Autonomic discovery of NOC services
-Autonomic Slice Management and Autonomic SLA management.
+Autonomic Multi-tenant Management and Autonomic SLA management.
 Design and Implementer guidelines for ASAs,
 ASA Lifecycle management,
 ASA coordination/dependency resolution.

and I'm perfectly happy with the changes, and with the charter as written.
I find it slightly confusing that we say that Intent is part of the framework, but
that we don't work on it without a recharter, but I guess the goal is not to
forget it, but not to go down a rathole.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 20 Feb 2019 14:57:42 +0100

> forget it, but not to go down a rathole.

Wanted to reassert what i hope is the WG agreement about Intent, and we
had discussed this since at least IETF102:

Intent was given to us (ANIMA) from NMRG as part of the initial chater
scope. We did include it into the reference model, but we failed to find
enough actionable agreement on what Intent is and what to do about it.

We therefore for now would like to punt the next steps of work on Intent
back to NMRG and hope we can make enough progress there to later bring
it back into ANIMA.

I had given a more detailed presentation to this effect at the friday
NMRG workshop at IETF101 in Montreal, but somehow i can not find any
slides from that friday meeting. Maybe Laurent can comment were that
NMRG workshop notes are. There where more really good presentations.

I have appended the one i gave to this email.

Cheers
    Toerless

---

From: Michael Richardson <[email-masked]>
Date: Wed, 20 Feb 2019 14:30:43 -0500

> enough actionable agreement on what Intent is and what to do about it.

I thought that we make it out of scope so that SUPA would do the work, but
SUPA failed. (I'm reminded by the "POLICY" WG of 20 years ago...)

    > back to NMRG and hope we can make enough progress there to later bring

Fair enough.  I don't know if the charter should refer readers to NMRG.
I also wonder if there are any proprietary efforts to define Intent that
could be referenced?

    > NMRG workshop notes are. There where more really good presentations.

Maybe in the proceedings?  I guess there is a youtube video too.
--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 21 Feb 2019 08:37:43 +1300

To put it bluntly, we know how to distribute Intent in an ANIMA network
(GRASP flooding if it's small, GRASP bulk transfer if it's big). We can
even guess that it's likely to look exactly like JSON, which is trivial to
represent in GRASP/CBOR. But we have no idea what it actually *is*.

That indeed seems to be a research problem.

Regards
   Brian

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 22 Feb 2019 11:56:53 +0100

> SUPA failed. (I'm reminded by the "POLICY" WG of 20 years ago...)

Hah. I skipped the SUPA episode because i don't remember if we really
ever made specific decisions in that case as opposed to just observing
it.

> Fair enough.  I don't know if the charter should refer readers to NMRG.

Seems the guidance we got in IETF103 was to start short and let
qualified charter reviewers ask for what they feeel missing. Where
qualified charter reviewers would i think be IESG.

> I also wonder if there are any proprietary efforts to define Intent that

Sure, but for now that collection of information should be done in NMRG.

> Maybe in the proceedings?  I guess there is a youtube video too.

No, the friday NMRG workshop was hosted at the university, so no
standard IETF video gear was there. Let me ping Laurent directly.

Cheers
    Toerless

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 22 Feb 2019 11:59:57 +0100

> represent in GRASP/CBOR. But we have no idea what it actually *is*.

Yes, thats the easy part and we have a draft waiting to be revived when
we can conclude that that part of work is needed. But right now we have
the larger issue of not knowing WHAT would be Intent, or how much of
Intent could really usefully be flooded as opposed to requiring
different distribution mechanism.

> That indeed seems to be a research problem.

I think terminology is more a political issue, but yes, NMRG is the more
appropriate place to solve this.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 22 Feb 2019 12:09:57 +0100

> standard IETF video gear was there. Let me ping Laurent directly.

https://datatracker.ietf.org/meeting/interim-2018-nmrg-03/session/nmrg

Cheers
    Toerless

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Fri, 22 Feb 2019 11:10:28 +0000

Hello,

Materials of the NMRG interim meeting at ETS Montreal, July 2018 are here: https://datatracker.ietf.org/meeting/interim-2018-nmrg-03/session/nmrg

If you think NMRG should work on a survey on IBN or other proposals, please feel free to send e-mail messages / make your case to the NMRG mailing list ([email-masked]) and/or the NMRG chair (me😉).
FYI: NMRG will hold a virtual meeting very soon (week 4-8 March) where IBN/other topics of interest could be discussed before IETF 104.

Thanks, Laurent.

> From: Anima <[email-masked]> On Behalf Of Toerless Eckert
> Sent: Friday, February 22, 2019 11:57
> To: Michael Richardson <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [Anima] Intent: -> NMRG -> ANIMA -> NMRG -> (ANIMA?)!) Re:
> proposed anima charter (was; Re: New work item proposal / agenda request)
>

---

From: "Ciavaglia, Laurent (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Fri, 22 Feb 2019 11:20:19 +0000

> Sent: Friday, February 22, 2019 12:00
> To: Brian E Carpenter <[email-masked]>
> Cc: Michael Richardson <[email-masked]>; [email-masked]

Indeed one of the challenges is to define "what" intent is, but we should not limit our view/understanding to the "intent" itself.
IP networking is not only the IP address, same for Intent-based networking, it is not only the intent format that is of importance. Other mechanisms, and a comprehensive view/understanding is required to know how to design the right thing(s).

I think where ANIMA could help NMRG is in "scoping" the problem (what intent means in an ANIMA context/network) and/or with use cases/examples of intent-driven operations/behaviors.

Best regards, laurent.