Subject: [Anima] A reminder of why we need ANIMA

From: Brian E Carpenter <[email-masked]>
Date: Mon, 26 Oct 2020 07:39:51 +1300

Hi ANIMA,

I think the document below is a timely reminder of why we *need* truly autonomic networks that are not subject to human misconfiguration errors. Start reading at "Root Cause and Event Summary".

   Brian

-------- Forwarded Message --------
Subject: how to misconfigurer ospf and take out your cellullar net
Date: Sun, 25 Oct 2020 09:31:46 +0000
From: [email-masked]

https://docs.fcc.gov/public/attachments/DOC-367699A1.docx

jon

---

From: Artur Hecker <[email-masked]>
Date: Tue, 27 Oct 2020 13:49:08 +0000

Brian, all

Great reference, thanks for sharing!

Quote: "engineers almost immediately recognized that they had misdiagnosed the problem.  However, they were unable to resolve the issue by restoring the link, because the network management tools required to do so remotely relied on the same paths they had just disabled”.

This is why we need an adaptive, virtually in-band control plane. Programmable, software-driven networks will strongly amplify this effect. To me, out-of-band control plane is a misconception of virtualization 😉 (have 2 networks, use 1), and it must still be adaptive & omnipresent.

Also nice: recommendations of the Bureau to the operators. 

Artur

> -----Original Message-----
> From: Anima <[email-masked]> On Behalf Of Brian E Carpenter
> Sent: Sunday, October 25, 2020 7:40 PM
> To: Anima WG <[email-masked]>
> Subject: [Anima] A reminder of why we need ANIMA
> 
> Hi ANIMA,
> 
> I think the document below is a timely reminder of why we *need* truly
> autonomic networks that are not subject to human misconfiguration errors.
> Start reading at "Root Cause and Event Summary".
> 
>    Brian
> 
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 28 Oct 2020 01:20:22 +0100

Gee, christmas already in October ?

http://tools.ietf.org/tools/rfcdiff/rfcdiff.pyht?url1=https://raw.githubusercontent.com/anima-wg/autonomic-control-plane/905f21becaa50760419c3ba28d8df4bb82e7a911/draft-ietf-anima-autonomic-control-plane/draft-ietf-anima-autonomic-control-plane.txt&url2=https://raw.githubusercontent.com/anima-wg/autonomic-control-plane/64d5f691f350984383eb573de01afdddaefe33ed/draft-ietf-anima-autonomic-control-plane/draft-ietf-anima-autonomic-control-plane.txt

Thanks Brian, Artur. That was the missing piece of marketing collateral for the RFC.

Cheers
    Toerless

On Tue, Oct 27, 2020 at 01:49:08PM +0000, Artur Hecker wrote:
> Quote: "engineers almost immediately recognized that they had misdiagnosed the problem.  However, they were unable to resolve the issue by restoring the link, because the network management tools required to do so remotely relied on the same paths they had just disabled???.
> 
> This is why we need an adaptive, virtually in-band control plane. Programmable, software-driven networks will strongly amplify this effect. To me, out-of-band control plane is a misconception of virtualization ???? (have 2 networks, use 1), and it must still be adaptive & omnipresent.
> 

-- 
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 28 Oct 2020 16:02:12 +0100

Some followup ponderings:

I was not even aware that the FCC publishes these fine reports. Very nice
as a tax payer (and user of 911 services) to see this level of transparency
for live & death impacting service oversight. I wonder if/how this is
handled in other countries.

These things happen regularily and hefty fines have to be paid. From quickly
googling, the last one i can find from 2015 was 17.5 million USD. This
is because the 911 service is affected. If it was not for FCC, these things
would not be publically known, because no operator likes to see things like
this published.

Having these events be reported on IP networks is i would think also a rather
new occurrance. I have not tracked and analyzed history, but 20 years ago,
i would not have expected the 911 service to run over an IP network. And back
then the TDMA/ATM networks always had some out-of-band network access,
even if it was modems over leased lines because there was not even in-band
management capabilities on a lot of (non-IP) equipment.

So, while pointing to a single incident may be anecdotal, i think it might
actually help sell the ACP, because these recurring fines add up to real
money, so improvement of network operations to provide even more than
five 9 of reliability should certainly be in everybody's interest for live
& death services, including the operators who could avoid fines then.

Cheers
    Toerless

-- 
---
[email-masked]