Subject: [Anima] I-D Action: draft-ietf-anima-grasp-api-07.txt

From: [email-masked]
Date: Tue, 13 Oct 2020 19:59:42 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Autonomic Networking Integrated Model and Approach WG of the IETF.

        Title           : Generic Autonomic Signaling Protocol Application Program Interface (GRASP API)
        Authors         : Brian Carpenter
                          Bing Liu
                          Wendong Wang
                          Xiangyang Gong
	Filename        : draft-ietf-anima-grasp-api-07.txt
	Pages           : 32
	Date            : 2020-10-13

Abstract:
   This document is a conceptual outline of an application programming
   interface (API) for the Generic Autonomic Signaling Protocol (GRASP).
   Such an API is needed for Autonomic Service Agents (ASA) calling the
   GRASP protocol module to exchange autonomic network messages with
   other ASAs.  Since GRASP is designed to support asynchronous
   operations, the API will need to be adapted to the support for
   asynchronicity in various programming languages and operating
   systems.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-anima-grasp-api/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-anima-grasp-api-07.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-anima-grasp-api-07

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 14 Oct 2020 16:05:25 +1300

Hi,

This version has been updated following the excellent AD review.

* Improved diagram and its description
* Added pointer to example logic flows
* Added note on variable length parameters
* Clarified that API decrements loop count automatically
* Other corrections and clarifications from AD review

Regards
   Brian + co-authors

On 14-Oct-20 15:59, [email-masked] wrote:
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima
>

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Wed, 14 Oct 2020 13:24:00 +0000

Thanks for the work on this document and being responsive to my comments.  Apologies again for the delay in my AD review.

I've kicked off the IETF LC.

Regards,
Rob

> -----Original Message-----
> From: Anima <[email-masked]> On Behalf Of Brian E Carpenter
> Sent: 14 October 2020 04:05
> To: [email-masked]
> Subject: Re: [Anima] I-D Action: draft-ietf-anima-grasp-api-07.txt
> 
> Hi,
> 
> >         Title           : Generic Autonomic Signaling Protocol
> Application Program Interface (GRASP API)