Subject: [Anima] Call for adoption: draft-dang-anima-network-service-auto-deployment

From: Toerless Eckert <[email-masked]>
Date: Tue, 16 Nov 2021 03:17:27 +0100

The authors of draft-dang-anima-network-service-auto-deployment have asked ANIMA WG for
adoption of the work.

Given how we are probably all still exhausted from IETF112, let me give this one a bit more time:

This emails starts a three week call for adoption for draft-dang-anima-network-service-auto-deployment
The adoption call does end when December 6 has passed for everyone on planet earth.

draft-dang-anima-network-service-auto-deployment-01

Abstract

   This document specifies an autonomic mechanism for resource-based
   network services deployment through the Autonomic Control Plane (ACP)
   in an Autonomic Network.  This mechanism uses the GRASP in [RFC8990]
   to exchange the information among the autonomic nodes so that the
   resource among the service path can be coordinated.

So, please check out the document and chime in!

Toerless, for the ANIMA chairs.

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 16 Nov 2021 03:23:26 +0100

And chiming n with my own opinion, repeating what i said on the microphone at IETF112:

I would really like to see a reference example, for example in a
new section:
   - as simple as possible, but still exploiting all aspects of the draft
     and showing the value of the draft.

   - i always love a good topology ASCII picture to go along with an example.

   - specific enough so that it could be implemented and verified.

   - seems like this could be some kind of "detnet-like"?! improved
     QoS service for some traffic class (how is the traffic class specified)..
     etc.pp: aka: answering all the question to round up such an
     example is the easiest way to determine if there are just minor
     or any mayor gaps in the proposed approach.

Thanks!
    Toerless

On Tue, Nov 16, 2021 at 03:17:27AM +0100, Toerless Eckert wrote:
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima

---

From: <[email-masked]>
Date: Tue, 16 Nov 2021 07:56:59 +0000

Hi all, 

I do see a value in documents that exercise how GRASP can be used in specific contexts. The authors can follow the structure in RFC8992 to better describe the target case, the theory of operation, etc. 

FWIW, some quick comments to the authors can be seen at:

* pdf: https://raw.githubusercontent.com/boucadair/IETF-Drafts-Reviews/master/draft-dang-anima-network-service-auto-deployment-01-rev%20Med.pdf
* doc: https://github.com/boucadair/IETF-Drafts-Reviews/raw/master/draft-dang-anima-network-service-auto-deployment-01-rev%20Med.doc

Cheers,
Med

> -----Message d'origine-----
> De : Anima <[email-masked]> De la part de Toerless Eckert
> Envoyé : mardi 16 novembre 2021 03:17
> À : [email-masked]
> Objet : [Anima] Call for adoption: draft-dang-anima-network-service-auto-
> deployment
> 
> The authors of draft-dang-anima-network-service-auto-deployment have asked
> ANIMA WG for adoption of the work.
> 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "zhouyujing (A)" <[email-masked]>
Date: Tue, 16 Nov 2021 12:10:05 +0000

Hi, Toerless

Thanks for your opinion, We are planning to add the clarification text to the next version.

1) We will update more cases to make the draft more clearly. And topology ASCII pictures are a good idea to express the case.

2) The draft will consider more specific cases. We will add more detail about the discovery, negotiation, and synchronization.

3) About "detnet-like": We think that the draft will help to improve QoS service for some cases, but it is one result of ASA ensuring the resource in the network. The draft has a wider range of use cases. It defines how to negotiate and distribute resource in the network. 

Best regards
Yujing

-----Original Message-----
From: Toerless Eckert <[email-masked]> 
Sent: 2021年11月16日 10:23
To: [email-masked]
Subject: Re: [Anima] Call for adoption: draft-dang-anima-network-service-auto-deployment

I would really like to see a reference example, for example in a new section:
   - as simple as possible, but still exploiting all aspects of the draft
     and showing the value of the draft.

Thanks!
    Toerless

On Tue, Nov 16, 2021 at 03:17:27AM +0100, Toerless Eckert wrote:
> The authors of draft-dang-anima-network-service-auto-deployment have 
> asked ANIMA WG for adoption of the work.
> 
> This emails starts a three week call for adoption for 
> draft-dang-anima-network-service-auto-deployment

---

From: "zhouyujing (A)" <[email-masked]>
Date: Tue, 16 Nov 2021 12:38:55 +0000

Hi, Med

Thanks for your opinions, we think these will help us a lot. Here are some comments that I briefly explain. And I will prepare another email with more in-depth explanation. We may discuss those later then.

[BMI1]：As for resource requirements, we think that we should use "queue and priority" replace "latency, and jitter". Like you say it is not resource requirement. But in here we want to express that the draft can negotiate and distribute many kinds of resource.
[BMI4]: I agree with you that the service head-ends may not be in the network. It is an end-to-end case and we discuss this in the ANIMA meeting, IETF 112. I will expand this in the next version and I think we can talk more detail about this question.
[BMI19]: We think that the negotiation step is the interaction of two nodes, so the a ResourceManager ASA choose one node. But why the first one is needed for discussion, choosing the first node is just our suggestion.
[BMI20]: Yes, it is the same meaning.
[BMI21]: We think different types of resource can be requested together. The ResourceManager GRASP Objective support this. 

As you say there are something the draft defined not clearly and need to be expanded. We hope we can have a deep discussion about this points. We are glad that you can help us expand them together.

We will improve some writing and highlight display problems in the next version, and thank you again for your careful reading.

Best regards
Yujing

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: 2021年11月16日 15:57
To: Toerless Eckert <[email-masked]>; [email-masked]
Subject: Re: [Anima] Call for adoption: draft-dang-anima-network-service-auto-deployment

Hi all, 

Cheers,
Med

> Envoyé : mardi 16 novembre 2021 03:17 À : [email-masked] Objet : 
> [Anima] Call for adoption: draft-dang-anima-network-service-auto-
> deployment
> 
> draft-dang-anima- network-service-auto-deployment The adoption call 
> does end when December 6 has passed for everyone on planet earth.
> 

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 17 Nov 2021 09:54:38 +1300

I agree with Med that the description of the use case is too abstract. I always try to look at use cases as a programmer: what would I put in my program to implement this?

So I think the next version should tackle this, possibly as an appendix. Give several specific examples of [restype, resval] (there are some hints 
in section 5) and a procedural
description of the resource management process for those examples.

Note that the procedural description in https://www.ietf.org/archive/id/draft-ietf-anima-asa-guidelines-03.html#name-example-logic-flows was constructed from a prototype implementation of RFC8992. If some WG participant 
wants to do an open source prototype of anima-network-service-auto-deployment, that might be a good way to proceed. See step 3 at https://xkcd.com/2530/ .

That said, I think this work is ready for WG adoption.

Regards
    Brian Carpenter

On 16-Nov-21 20:56, [email-masked] wrote:
> This message and its attachments may contain confidential or privileged 
information that may be protected by law;
> .

---

From: Michael Richardson <[email-masked]>
Date: Wed, 17 Nov 2021 08:02:08 -0500

I'd like to know a bit more about the plans for
draft-dang-anima-network-service-auto-deployment

The document says:

   The original purpose of this document was to validate the design of
   the Autonomic Networking Infrastructure (ANI) for a realistic use
   case.
...
   The goal of this document is to complete the resource-based self-
   adaptation among service and network nodes via GRASP.  And this
   document is not a complete functional specification of an autonomic
   system of Resource-based Network Services Auto-deployment, and it
   does not describe all detailed aspects of the GRASP objective
   parameters and Autonomic Service Agent (ASA) procedures necessary to
   build a complete system.  Instead, it describes the architectural
   framework utilizing the components of the ANI, outlines the different
   deployment options and aspects, and defines GRASP objectives for use
   in building the system.  It also provides some basic parameter
   examples.

What I'm reading is that this is a paper exercise and that no code or
deployment will occur.  I'm not sure why we'd publish this as an RFC.

It's the part after "instead" that really concerns me.
I'd like to see this implemented.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: "zhouyujing (A)" <[email-masked]>
Date: Thu, 18 Nov 2021 01:47:35 +0000

Hi, Brian

Thanks for your guidance materials. This is of great benefit to improve the draft. 

I agree with you that the description of the use case is too abstract. As I said in the last mail, our next version of the improvement plan is to add a more detailed description. And in my thought, the detailed description of the draft will help the WG participant to do an open source prototype.

Best regards
Yujing

-----Original Message-----
From: Brian E Carpenter <[email-masked]> 
Sent: 2021年11月17日 4:55
To: [email-masked]; Toerless Eckert <[email-masked]>; [email-masked]
Subject: Re: [Anima] Call for adoption: draft-dang-anima-network-service-auto-deployment

So I think the next version should tackle this, possibly as an appendix. Give several specific examples of [restype, resval] (there are some hints in section 5) and a procedural description of the resource management process for those examples.

Note that the procedural description in https://www.ietf.org/archive/id/draft-ietf-anima-asa-guidelines-03.html#name-example-logic-flows was constructed from a prototype implementation of RFC8992. If some WG participant wants to do an open source prototype of anima-network-service-auto-deployment, that might be a good way to proceed. See step 3 at https://xkcd.com/2530/ .

Regards
    Brian Carpenter

On 16-Nov-21 20:56, [email-masked] wrote:
> * pdf: 
> https://raw.githubusercontent.com/boucadair/IETF-Drafts-Reviews/master
> /draft-dang-anima-network-service-auto-deployment-01-rev%20Med.pdf
> * doc: 
> https://github.com/boucadair/IETF-Drafts-Reviews/raw/master/draft-dang
> -anima-network-service-auto-deployment-01-rev%20Med.doc
> 
> Cheers,
> Med
> 
> ______________________________________________________________________
> ___________________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations 
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, 
> exploites ou copies sans autorisation. Si vous avez recu ce message 
> par erreur, veuillez le signaler a l'expediteur et le detruire ainsi 
> que les pieces jointes. Les messages electroniques etant susceptibles 
> d'alteration, Orange decline toute responsabilite si ce message a ete 
> altere, deforme
ou falsifie. Merci.

---

From: "zhouyujing (A)" <[email-masked]>
Date: Thu, 18 Nov 2021 09:47:25 +0000

Hi, Micheal

We admire the text you quoted is misleading. Of course, the purpose of this standard-track document is intend to give guidance for implementation so that the resource negotiation and distribution process can be done among distributed autonomic nodes. Actually, we believe the texts in the main body of this document serve the purpose well. We define the objective and the negotiation procedures.

What the misleading texts wanted to express is the document starts from architectural framework, the complete functions of this framework also include the internal decided logic/algorithm within a autonomic nodes, but the logic/algorithm are not part of standard definition.

We will certainly fix the misleading introduction text and add more detailed procedure description that give clearer instructions for implementors.

Many thanks and best regards
Yujing

-----Original Message-----
From: Michael Richardson <[email-masked]>
Sent: Wed, 17 Nov 2021 13:02:19
To: [email-masked]; Toerless Eckert <[email-masked]>; [email-masked]
Subject: Re: [Anima] Call for adoption: draft-dang-anima-network-service-auto-deployment

The document says: