Subject: Re: [Anima] Call for adoption: draft-richardson-anima-rfc8366bis, ends December 19th, 2021

From: Qin Wu <[email-masked]>
Date: Sat, 11 Dec 2021 13:47:33 +0000

Hi, Chairs:
I have read the latest version of this draft and support adoption of this work. Here are a few comments:

1.       Since we still reuse rc:yang-data to model vouch-artifact, I believe the model structure in section 5.1 of RFC8366 should keep as is.

2.       Secondly, vouch-artifact doesn’t need to be coupled with RESTCONF protocol message, suggest to use YANG extension statement “structure” defined in RFC8791 to replace yang-data.

3.       Do we expect iana-voucher-assertion-type to be changed in the future, e.g., add a new enum value? Does it make sense to change voucher-assertion typedef into identity data type.

-Qin
发件人: Anima [mailto:[email-masked]] 代表 Sheng Jiang
发送时间: 2021年12月6日 14:57
收件人: [email-masked]
抄送: [email-masked]; Toerless Eckert <[email-masked]>
主题: [Anima] Call for adoption: draft-richardson-anima-rfc8366bis, ends December 19th, 2021

Hi, all ANIMAer,

This message starts a two-week adoption call for draft-richardson-anima-rfc8366bis, which we have traced a few discussion and think the WG is interested in. The adoption call ends December 19th, 2021.

Title:   A Voucher Artifact for Bootstrapping Protocols

Name:     draft-richardson-anima-rfc8366bis-04

Authors:  K. Watsen, M. Richardson, M. Pritikin and T. Eckert

URL:      https://datatracker.ietf.org/doc/draft-richardson-anima-rfc8366bis/

IPR:      No IPR disclosures have been submitted directly on draft-richardson-anima-voucher-delegation

This document is intended to become a standards track ANIMA WG document.

Please express your support or rejection. If you think this document should _not_ be adopted, please also explicitly indicate the reasons.

Regards,

Sheng

---

From: Michael Richardson <[email-masked]>
Date: Sun, 12 Dec 2021 15:35:44 -0500

Qin Wu <bill.wu=[email-masked]> wrote:
    > 1.       Since we still reuse rc:yang-data to model vouch-artifact, I
    > believe the model structure in section 5.1 of RFC8366 should keep as
    > is.

    > 2.       Secondly, vouch-artifact doesn’t need to be coupled with
    > RESTCONF protocol message, suggest to use YANG extension statement
    > “structure” defined in RFC8791 to replace yang-data.

Sorry, I'm confused here.  I think that #1 says that yang-data is okay.
I think that #2 says that yang-data is not okay, and we need sx:structure
instead?

Are you saying that we should update to RFC8791?
Do you think that this is a bug-fix?
I'm asking, because we have discussed that RFC8366bis might go forward as a
(step-two) Internet Standard, rather than cycling at Proposed Standard.

    > 3.       Do we expect iana-voucher-assertion-type to be changed in the
    > future, e.g., add a new enum value? Does it make sense to change
    > voucher-assertion typedef into identity data type.

Yes, we expect that new documents will Extend it.
I don't know what an identity data type is here.... I thought we did the
right thing, so I do not quite understand what you are proposing.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: <[email-masked]>
Date: Mon, 13 Dec 2021 07:38:58 +0000

Hi Qin, all,

(3) is not an issue for an IANA-maintained module.

I do think it is better to maintain the enum rather than identities given that the document talks about future cbor mapping, for which compact encoding may be needed. If this was transformed into identities, the assertion attribute must be prefixed with “iana-voucher-assertion-type”.

Cheers,
Med

De : Anima <[email-masked]> De la part de Qin Wu
Envoyé : samedi 11 décembre 2021 14:48
À : Sheng Jiang <jiangsheng=[email-masked]>; [email-masked]
Cc : [email-masked]; Toerless Eckert <[email-masked]>
Objet : Re: [Anima] Call for adoption: draft-richardson-anima-rfc8366bis, ends December 19th, 2021

Hi, Chairs:

-Qin
发件人: Anima [mailto:[email-masked]] 代表 Sheng Jiang
发送时间: 2021年12月6日 14:57
收件人: [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>; Toerless Eckert <[email-masked]<mailto:[email-masked]>>
主题: [Anima] Call for adoption: draft-richardson-anima-rfc8366bis, ends December 19th, 2021

Hi, all ANIMAer,

Regards,

Sheng

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.