Subject: [Apn] USE CASE IN MY NETWORK USING APN6 TO SOLVE LOAD BALANCING ISSUE

From: "Luc-Fabrice Ndifor Ngwa [ MTN Cameroon ]" <[email-masked]>
Date: Mon, 8 Feb 2021 17:17:39 +0000

Hi Members,
Thought it will be important to share with you a use case in my network that could be solved by APN6 and will like to get your views on it.
To understand the below, kindly note the following.

  *   When you see the link capacity put in the format X (Y),

  *   X is the useable capacity on the link
  *   Y is the real installed capacity of the link which could be impacted by fading (remember it is microwave)

Topology

Problem Statement.
Our intercity transmission network is very unstable (45 fiber cuts in a month). This impacts greatly critical services between our 2 datacenters (SITE A & SITE B).
On fiber we have about 16G of traffic between the 2 datacenters and our critical services amount to 4.3G at peak hours. However, our backup MW has a capacity of only 3.0G.
Current Protocol limitation
With MPLS TE (using RSVP for signaling), I have the possibility to choose only 2 paths and the 3rd path is the BE path.

  *   Path 1 is the direct fiber link between SITE B and SITE A  (Primary Link)
  *   Path 2 is the fiber link going through SITE C (SITE B --> SITE C --> SITE A) (Secondary Link)
  *   Path 3 is on Microwave which is BE based on the cost. Here, SITE B --> SITE A Microwave has the lower cost for all Microwave paths.
We always have double and even triple route cuts that isolate SITE B on fiber meaning the direct Microwave link SITE B --> SITE A is used due to its lower cost compared to other Microwave paths.
This link has as capacity only 2.5G but after QoS implementation, the prioritized traffic (voice, signaling, critical applications) congest as they need at least a 4.3G pipe.
In the mean-time the Microwave path SITE B --> SITE C -->  SITE A could be used as a load balanced path but underused due to protocol limitation to do load balancing (very complex)
Way Forward : APN6
Based on SLAs defined for different types of traffic or applications, we can flexibly on the PE devices choose SITE B -->  SITEA Microwave (1 hop, low latency) for low latency applications among the critical services, and SITE B --> SITE C --> SITE A Microwave (2 hops, higher latency) for  applications which are critical but could handle such latency. This will give us the flexibility to have more capacity available with load balancing to carry the 4.3G critical services and respond to business needs instead of just the single Microwave path (2.5G)  which could not handle all the critical services due to capacity limitation and protocol limitation. APN IDs are generated at the PE based on the VLAN tags used to differentiate the traffic and this traffic is steered along the paths to ensure load balancing and guarantee the transport of all the critical services during this congestion period.

​Warm regards,
Luc-Fabrice
 
Ndifor
Specialist - IP Access and Data center
[email-masked]
T +237 677 55 02 13
Head Office: 360, Rue Drouot
​P.O. Box 15 574 Douala, Cameroon
T +237 679 00 90 90
 | mtn.cm
This email is confidential. If you have received it in error, you are on notice of its status. Please notify ​the ​​sender immediately by 
​reply email and then delete this message from your system. Please do not copy it ​or use it for any purpose or disclose its content 
​to any other person as to do so could be a breach of ​confidentiality.
​
 Please be informed that no employee or agent is authorized to conclude any legally binding agreement ​on behalf of MTN Cameroon
​via email. This can be only done if the email is confirmed explicitly in writing ​by an MTN Cameroon authorized officer. In no event 
​will this email or its content be construed as a written ​approval.

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Wed, 10 Feb 2021 07:29:02 +0000

Hi Fabrice,

Thank you very much!

This is indeed a very concrete usage scenario for APN in practice.

As you stated in your email, “APN IDs are generated at the PE based on the VLAN tags used to differentiate the traffic and this traffic is steered along the paths to ensure load balancing and guarantee the transport of all the critical services during this congestion period. “

Do you plan to encapsulate the APN ID in the tunnel encapsulation? Is the tunnel based on SRv6?

Thank you!

Best regards,
Shuping

From: Apn [mailto:[email-masked]] On Behalf Of Luc-Fabrice Ndifor Ngwa [ MTN Cameroon ]
Sent: Tuesday, February 9, 2021 1:18 AM
To: [email-masked]
Subject: [Apn] USE CASE IN MY NETWORK USING APN6 TO SOLVE LOAD BALANCING ISSUE

Hi Members,
Thought it will be important to share with you a use case in my network that could be solved by APN6 and will like to get your views on it.
To understand the below, kindly note the following.
ð  When you see the link capacity put in the format X (Y),
·        X is the useable capacity on the link
·        Y is the real installed capacity of the link which could be impacted by fading (remember it is microwave)

Topology

Problem Statement.

​Warm regards,​

Luc‑Fabrice

Ndifor

Specialist ‑ IP Access and Data center

[email-masked]<mailto:[email-masked]>

T +237 677 55 02 13<tel:+237%20677%2055%2002%2013>

T +237 679 00 90 90

 |

mtn.cm<http://www.mtn.cm/>

<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmtn.cm%2Ffr%2Fpersonal%2Fpromotion%2F20sur20%2F&data=04%7C01%7CJean-Richard.Ngoko%40mtn.com%7Ce3211c0e4a92462b948b08d8c1206ebf%7Cc9b9cb5036444db4a267fa84df2f4ceb%7C0%7C0%7C637471692385859251%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=iiZfptZj%2BQy7lrw9iNIBOkapY5CSzW2Lty%2FJoxiGeVo%3D&reserved=0>

---

From: "Luc-Fabrice Ndifor Ngwa [ MTN Cameroon ]" <[email-masked]>
Date: Wed, 10 Feb 2021 11:35:14 +0000

Thanks very much for the feedback, Peng.
The APN ID will be encapsulated in the tunnel which is SRv6 based.

​Warm regards,
Luc-Fabrice
 
Ndifor
Specialist - IP Access and Data center
[email-masked]
T +237 677 55 02 13
Head Office: 360, Rue Drouot
​P.O. Box 15 574 Douala, Cameroon
T +237 679 00 90 90
 | mtn.cm
This email is confidential. If you have received it in error, you are on notice of its status. Please notify ​the ​​sender immediately by 
​reply email and then delete this message from your system. Please do not copy it ​or use it for any purpose or disclose its content 
​to any other person as to do so could be a breach of ​confidentiality.
​
 Please be informed that no employee or agent is authorized to conclude any legally binding agreement ​on behalf of MTN Cameroon
​via email. This can be only done if the email is confirmed explicitly in writing ​by an MTN Cameroon authorized officer. In no event 
​will this email or its content be construed as a written ​approval.
From: Pengshuping (Peng Shuping) <[email-masked]>
Sent: Wednesday, February 10, 2021 8:29 AM
To: Luc-Fabrice Ndifor Ngwa [ MTN Cameroon ] <[email-masked]>
Cc: [email-masked]
Subject: RE: USE CASE IN MY NETWORK USING APN6 TO SOLVE LOAD BALANCING ISSUE

Hi Fabrice,

Thank you very much!

Thank you!

Best regards,
Shuping

From: Apn [mailto:[email-masked]] On Behalf Of Luc-Fabrice Ndifor Ngwa [ MTN Cameroon ]
Sent: Tuesday, February 9, 2021 1:18 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Apn] USE CASE IN MY NETWORK USING APN6 TO SOLVE LOAD BALANCING ISSUE

Hi Members,

Topology

Problem Statement.

​Warm regards,​
Luc‑Fabrice

Ndifor