Subject: [Apn] APN6 App-Aware-ID and Service-Para are expanded for the Sticky Service of the draft-dunbar-6man-5g-edge-compute-sticky-service-02.txt

From: Linda Dunbar <[email-masked]>
Date: Mon, 22 Feb 2021 20:52:21 +0000

https://datatracker.ietf.org/doc/draft-dunbar-idr-sdwan-edge-discovery/  describes an IPv6 solution that can force an application flow originated from a UE (User Equipment) to stick to the same ANYCAST server location when the UE moves from one 5G cell site to another.

The proposed solution expands the Application-aware ID and Service-Para options specified by [6man-app-aware-ipv6-network] by including the ANYCAST Sticky Destination  information in the IPv6 Hop-by-Hop or Destination Optional Header.

Your comments and feedback are greatly appreciated. 

Thank you. 

Linda Dunbar

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Monday, February 22, 2021 1:22 PM
To: Kaippallimalil John <[email-masked]>; Linda Dunbar <[email-masked]>
Subject: New Version Notification for draft-dunbar-6man-5g-edge-compute-sticky-service-02.txt

A new version of I-D, draft-dunbar-6man-5g-edge-compute-sticky-service-02.txt
has been successfully submitted by Linda Dunbar and posted to the IETF repository.

Name:		draft-dunbar-6man-5g-edge-compute-sticky-service
Revision:	02
Title:		IPv6 Solution for 5G Edge Computing Sticky Service
Document date:	2021-02-22
Group:		Individual Submission
Pages:		18
URL:            https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-dunbar-6man-5g-edge-compute-sticky-service-02.txt&amp;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C7e12b1cb5c7b4b381ceb08d8d767207e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637496185226616916%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=mmlBhO4EA2w6cgI%2FT0EZ64UeY%2BMipTBsN%2B6BqvefsUQ%3D&amp;reserved=0
Status:         https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-dunbar-6man-5g-edge-compute-sticky-service%2F&amp;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C7e12b1cb5c7b4b381ceb08d8d767207e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637496185226616916%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=9sM8V6s5zywaaMCcFSBtppLYBbcaOlN9BW4JxWOhwUM%3D&amp;reserved=0
Htmlized:       https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-dunbar-6man-5g-edge-compute-sticky-service&amp;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C7e12b1cb5c7b4b381ceb08d8d767207e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637496185226616916%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=RO6T5CKiB35Ej6Rzg6g0x0A9hWrEdczPjD63crEQFEw%3D&amp;reserved=0
Htmlized:       https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-dunbar-6man-5g-edge-compute-sticky-service-02&amp;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C7e12b1cb5c7b4b381ceb08d8d767207e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637496185226616916%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=MLNR0t%2BfUBtqRZSbqSCK%2BJLPw5xjsXtxp%2B2SDVlQpbI%3D&amp;reserved=0
Diff:           https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-dunbar-6man-5g-edge-compute-sticky-service-02&amp;data=04%7C01%7Clinda.dunbar%40futurewei.com%7C7e12b1cb5c7b4b381ceb08d8d767207e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637496185226616916%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=tqU7EH0HnTMFeQjvX4RFC2HCmvJLro1U0dyOOqjswYM%3D&amp;reserved=0

Abstract:
   This draft describes an IPv6 solution that enables packets from an
   application on a UE (User Equipment) sticking to the same ANYCAST
   server location when the UE moves from one 5G cell site to another.

   The proposed solution expands the Application-aware ID and Service-
   Para options specified by [APN6] by including the ANYCAST Sticky
   Service location information in the IPv6 Hop-by-Hop or Destination
   Optional Header.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Linda Dunbar <[email-masked]>
Date: Tue, 23 Feb 2021 19:46:06 +0000

Sorry wrong link for the draft. Here is the correct link: https://datatracker.ietf.org/doc/draft-dunbar-6man-5g-edge-compute-sticky-service/

Linda

-----Original Message-----
From: Linda Dunbar 
Sent: Monday, February 22, 2021 2:52 PM
To: [email-masked]; 6man WG <[email-masked]>
Subject: APN6 App-Aware-ID and Service-Para are expanded for the Sticky Service of the draft-dunbar-6man-5g-edge-compute-sticky-service-02.txt

Thank you. 

Linda Dunbar

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Monday, February 22, 2021 1:22 PM
To: Kaippallimalil John <[email-masked]>; Linda Dunbar <[email-masked]>
Subject: New Version Notification for draft-dunbar-6man-5g-edge-compute-sticky-service-02.txt

Abstract:

The IETF Secretariat