Subject: [apps-discuss] I-D Action: draft-ietf-appsawg-rfc3462bis-01.txt

From: [email-masked]
Date: Wed, 21 Sep 2011 22:33:51 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Applications Area Working Group Working Group of the IETF.

	Title           : The Multipart/Report Media Type for the Reporting of Mail System Administrative Messages
	Author(s)       : Murray S. Kucherawy
	Filename        : draft-ietf-appsawg-rfc3462bis-01.txt
	Pages           : 15
	Date            : 2011-09-21

   The multipart/report Multipurpose Internet Mail Extensions (MIME)
   media type is a general &quot;family&quot; or &quot;container&quot; type for electronic
   mail reports of any kind.  Although this memo defines only the use of
   the multipart/report media type with respect to delivery status
   reports, mail processing programs will benefit if a single media type
   is used for all kinds of reports.

   This memo obsoletes RFC3462.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-appsawg-rfc3462bis-01.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-appsawg-rfc3462bis-01.txt

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 26 Sep 2011 11:22:58 +0100

>   This memo obsoletes RFC3462.
The new version addresses my earlier concerns.
One small new issue:

The newly added:
5. Registering New Report Types   
               
    Registration of new media types for the purpose of creating a new   
    report format SHOULD note in the Intended Usage section of the media   
    type registration that the type being registered is suitable for use   
    as a report-type in the context of this specification.

What does "suitable for use as a report-type" means exactly? Do you mean 
the name of the new media type can be used as the value of this attribute?

---

From: Ned Freed <[email-masked]>
Date: Mon, 26 Sep 2011 09:18:12 -0700 (PDT)

> What does "suitable for use as a report-type" means exactly?

It means you're supposed to say something like:

    This media type is suitable for use in report-type parts per RFC3462bis.

in the Intended Usage section of the type registration.

In other words, this is a recommended action, not some sort of registration
criteria the type must meet.

> Do you mean

No, that's a given for such types.

				Ned

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 26 Sep 2011 21:03:42 +0100

Ned Freed wrote:

>> >A New Internet-Draft is available from the on-line Internet-Drafts 
>> directories. This draft is a work item of the Applications Area 
>> Working Group Working Group of the IETF.
>> >
>> >    Title           : The Multipart/Report Media Type for the 
>> Reporting of Mail System Administrative Messages
>> >   media type is a general &quot;family&quot; or 
>> &quot;container&quot; type for electronic

Ok, maybe this is just me, but I don't think this is clear. Maybe say 
"suitable for use as the second body part of a multipart/report" instead?

---

From: "t.petch" <[email-masked]>
Date: Tue, 27 Sep 2011 12:34:57 +0200

---- Original Message ----- 
From: "Alexey Melnikov" <[email-masked]>
To: "Ned Freed" <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, September 26, 2011 10:03 PM
> "suitable for use as the second body part of a multipart/report" instead?

Surely it should say

"Registration of new media types for the purpose of creating a new
report format SHOULD note in the Intended Usage section of the media
type registration 
**whether or not
the type being registered is suitable for use
as a report-type in the context of this specification."

As the text stands, it merely says that all new media types are suitable,
which seems rather pointless:-)

Tom Petch

> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 27 Sep 2011 12:44:57 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of t.petch
> Sent: Tuesday, September 27, 2011 3:35 AM
> To: Alexey Melnikov; Ned Freed
> Cc: [email-masked]
> Subject: Re: [apps-discuss] I-D Action: draft-ietf-appsawg-rfc3462bis-01.txt
> 
> type registration **whether or not

I don't agree.  I think the first line of the new Section 5 makes it clear that some are (the ones being registered specifically for that purpose), and some aren't (the rest).

---

From: Ned Freed <[email-masked]>
Date: Tue, 27 Sep 2011 15:34:01 -0700 (PDT)

> > "suitable for use as the second body part of a multipart/report" instead?

Seems like a reasonable change to me.

> as a report-type in the context of this specification."

No, because a new report format is by definition suitable for use in
this area. If it weren't it would not qualify as this sort of type.

> which seems rather pointless:-)

That might apply if this document was discusingg media types in general, but
it isn't. This is quite specifically about report formats, and this text
is about the need to note that such formats identify themselves as such
in their registration.

				Ned

---

From: "t.petch" <[email-masked]>
Date: Wed, 28 Sep 2011 14:30:54 +0200

----- Original Message -----
From: "Ned Freed" <[email-masked]>
To: "t.petch" <[email-masked]>
Cc: "Alexey Melnikov" <[email-masked]>; "Ned Freed"
<[email-masked]>; <[email-masked]>
Sent: Wednesday, September 28, 2011 12:34 AM
> is about the need to note that such formats identify themselves as such

Ok, I see now, but did misunderstand, as I think Alexey did.

It does seem a bit circular, that you are saying that anything that is a new
report format SHOULD be suitable for use in the context of this
memo and SHOULD say so.

The bit I was missing was the first part, that a new report format is
automatically suitable for use; I was thinking of 'report format' as
having a looser, more generic meaning of which some would be
suitable and some would not.

Tom Petch