Subject: Re: [APPS-REVIEW] Review of draft-merrick-jms-uri-05

From: Eric Johnson <[email-masked]>
Date: Mon, 04 May 2009 11:51:52 -0700

Hi Harald, (and other apps-review members),

We do have one follow-up question, below:

Eric Johnson wrote:

[snip]
> Further responses, inline below.
> 
> Harald Alvestrand wrote:
>> Eric Johnson wrote:

[snip]

>>> Harald Alvestrand wrote:

[snip]

>>>> - in section 4.2.1, it seems somewhat bizarre that the JNDI-specific
>>>> parameters all start with "jndi", while section 4.2.1.4 states that
>>>> additional JNDI-specific parameters should start wiht "jndi-" (note the
>>>> additional dash). Why not be uniform?
>>>>     
>>> We're still discussing this in the working group.  We've not settled on
>>> an answer because I think there multiple tensions here, such as between
>>> brevity and completeness, familiarity vs. convention, and so forth.
>>> We'll hopefully have a more complete answer soon.
>>>   
>> Good.
> 
> Here's the break-down.  There are actually three classes of properties
> being specified in the parameters:
>  1. Standard properties for identifying JNDI
>     * jndiInitialContextFactory
>     * jndiURL
>  2. Custom properties for connecting to JNDI - need to spell out the
> runtime name for these parameters.
>     * Parameters we currently suggest start with "jndi-"
>  3. JDNI Resources to retrieve once connected\
>     * jndiConnectionFactoryName
> 
> We use the hyphen in case #2 to flag that what follows the hyphen is an
> actual string value for the name of a property to set when constructing
> the Map for the initial context.  We discussed always using the actual
> Java constants even for case #1, but that would mean that instead of
> specifying "jndiURL", we'd have to specify:
> 
>  * jndi-java.naming.provider.url (jndiURL)
>  * jndi-java.naming.factory.initial (jndiInitialContextFactory)
> 
> In this case, we think convention, brevity, and clarity trumps
> consistency, in that most JMS developers think of the "jndiURL" instead
> of the "java.naming.provider.url"
> 
> That does, however, leave the question open - what should we do about
> the "jndi-" case, where the URI needs to contain the actual name of the
> property to use?  We had chosen the "jndi-" prefix over an alternate
> prefix of "jndiContextParameter-", because we thought that we didn't
> lose much in the brevity.
> 
> Now that we observe that we apparently did lose something in the
> brevity.  In our first encounter outside our working group we got the
> equivalent of a "huh?" from you. To remedy, we propose switching back to
> the more verbose prefix of "jndiContextParameter-".
> 
> Do you think switching prefixes allays your concerns?

We've not heard back from anyone on this previous question.  If the
above proposed change is a helpful clarification, please let us know.
Otherwise, we're going to leave the JMS scheme proposal as it is.

-Eric.

---

From: Mark Baker <[email-masked]>
Date: Mon, 4 May 2009 13:35:29 -0700

Eric,

>From my POV, it doesn't make any difference.

Mark.