Subject: Re: [APPS-REVIEW] Applications Area Review (new) Team update

From: Xiaodong Lee <[email-masked]>
Date: Mon, 24 May 2010 09:59:26 +0800

I try to reply two times, but it's a pity that I cannot send email to 
you email address with "+", so I send email to this list, is that a APP 
issues to be focused.

Regards,
Xiaodong Lee

On 2010-5-20 1:29, SM wrote:
> Hello,
>
> Eric Burger is an IAOC member.  He will not asked to perform any 
> review until further notice due to workload.  I have not updated the 
> Apps-area webpage yet as I don't have access to it.
>
> I have not received any reply from the following members:
>
>  Harald Alvestrand
>  Cyrus Daboo
>  Reinhold Kainhofer
>  Yves Lafon
>  Xiaodong Lee
>  Barry Leiba
>  Chris Newman
>  Thomas Roessler
>
> The Applications Area Review (new) Team needs all the experience and 
> expertise it can get.  Please contact me to confirm your participation.
>
> Alexey mentioned that he is interested in comments about:
>
>  ABNF
>  Date/time
>  Error handling
>  Extensibility
>  Internationalization
>  Use  of XML/XML schema
>  Use of URIs, etc.
>
> This is not the complete list of issues to look out for.  Alexey and 
> Peter will provide a list of typical Apps Area issues so that we have 
> a better idea of what to look for.
>
> The main objective of the team is to assist the Apps Area Directors.  
> Reviews will be per-Apps AD request.  The team will also accept 
> requests from authors to review their drafts.  That will generally be 
> documents in IETF Last Call.
>
> Some of you offered to help beyond what was asked for.  I really 
> appreciate that and I will take up your offer.
>
> Best regards,
> -sm
>
> _______________________________________________
> APPS-REVIEW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-review
>

---

From: SM <[email-masked]>
Date: Mon, 24 May 2010 04:51:47 -0700

Hi Xiaodong,

Thank you for participating.

At 18:59 23-05-10, Xiaodong Lee wrote:
>I try to reply two times, but it's a pity that I cannot send email 
>to you email address with "+", so I send email to this list, is that 
>a APP issues to be focused.

I apologize for the email issue.  I'll send you an alternate email 
address off-list.

It's the first time I come across a report of such an issue; 
excluding email address fields in web forms.  As there are two 
specific working groups (EAI and YAM) in the Apps Area, I would not 
label this as a general APPS issue.

If there are any issues sending me an email, please post a message to 
this mailing list.

Regards,
S. Moonesamy

---

From: Claudio Allocchio <[email-masked]>
Date: Mon, 24 May 2010 14:18:57 +0200 (CEST)

>> I try to reply two times, but it's a pity that I cannot send email to you 
>> email address with "+", so I send email to this list, is that a APP issues 
>> to be focused.
>
> I apologize for the email issue.  I'll send you an alternate email address 
> off-list.
>
> It's the first time I come across a report of such an issue; excluding email 
> address fields in web forms.  As there are two specific working groups (EAI 
> and YAM) in the Apps Area, I would not label this as a general APPS issue.

"messaging" hat on: it is really quite strange to come across such an 
issue, and just "now":

local-part      =       dot-atom / quoted-string / obs-local-part
dot-atom        =       [CFWS] dot-atom-text [CFWS]
dot-atom-text   =       1*atext *("." 1*atext)

and

atext           =       ALPHA / DIGIT / ; Any character except controls,
                         "!" / "#" /     ;  SP, and specials.
                         "$" / "%" /     ;  Used for atoms
                         "&" / "'" /
                         "*" / "+" /
                         "-" / "/" /
                         "=" / "?" /
                         "^" / "_" /
                         "`" / "{" /
                         "|" / "}" /
                         "~"

which client (not conforming to rfc2822) are you using?

------------------------------------------------------------------------------
Claudio Allocchio             G   A   R   R          [email-masked]
                         Senior Technical Officer
tel: +39 040 3758523      Italian Academic and       G=Claudio; S=Allocchio;
fax: +39 040 3758565        Research Network         P=garr; A=garr; C=it;

            PGP Key: http://www.cert.garr.it/PGP/keys.php3#ca

---

From: Eric Burger <[email-masked]>
Date: Mon, 24 May 2010 08:43:38 -0400

According to the message headers, Dr. Lee is using Thunderbird 3.0.4. Possibly a MTA or firewall issue?

On May 24, 2010, at 8:18 AM, Claudio Allocchio wrote:

>>> I try to reply two times, but it's a pity that I cannot send email to you email address with "+", so I send email to this list, is that a APP issues to be focused.
>> 
>> I apologize for the email issue.  I'll send you an alternate email address off-list.
>> 
>> It's the first time I come across a report of such an issue; excluding email address fields in web forms.  As there are two specific working groups (EAI and YAM) in the Apps Area, I would not label this as a general APPS issue.
> 
> "messaging" hat on: it is really quite strange to come across such an issue, and just "now":
>

---

From: Claudio Allocchio <[email-masked]>
Date: Mon, 24 May 2010 15:25:11 +0200 (CEST)

> Possibly a MTA or firewall issue?

Hi Eric,

I've seen similar issues in the past related to "local-part" 
rewriting/handling in conjunction with database entries "searches".
To be more exact, an MTA was consulting an Oracle DB for each local-part, 
and the presence of pefectly legal atext character was generating a DB 
search error, which turned into an "unknown" MTA error. The offending 
character in that case was "%" in an old style poor-man-routing case.

We need more info on the enviroment from Dr. Lee, I'm afraid.

---

From: John C Klensin <[email-masked]>
Date: Mon, 24 May 2010 11:46:18 -0400

--On Monday, May 24, 2010 2:18 PM +0200 Claudio Allocchio
<[email-masked]> wrote:

>...

I see this all the time when any sort of web interface, or
interface to a database supporting we interfaces, are concerned.
Basically, "+" is taken as an escape for " ", and either:

	* The local part string [email-masked] turns into
	"john [email-masked]", but the quotes are absent, so it it
	treated as either :john <[email-masked]>" or as a syntax
	error.
	
	* The string "john+ietf" is matched against "john ietf",
	which got into the database via a web interface, and
	that match of course fails.
	
	* The string "john ietf" is matched against "john+ietf"
	in the database and that match of course fails.
	
	* some idiot writes an application that "knows" that no
	special character can appear in an email local-path
	address except possibly "." or "-" or applies the LDH
	domain rules to the entire address, yielding the same
	result.

john

---

From: SM <[email-masked]>
Date: Mon, 24 May 2010 10:44:19 -0700

>which client (not conforming to rfc2822) are you using?

That should be RFC 5321.  I asked about the MUA off-list.

>3.0.4. Possibly a MTA or firewall issue?

The MTA is Postfix and it supports sub-addressing.

At 06:25 24-05-10, Claudio Allocchio wrote:
>To be more exact, an MTA was consulting an Oracle DB for each 
>local-part, and the presence of pefectly legal atext character was 
>generating a DB search error, which turned into an "unknown" MTA 
>error. The offending character in that case was "%" in an old style 
>poor-man-routing case.

The "%" is also a SQL wildcard.

>         domain rules to the entire address, yielding the same

There is a view that matching 99.99% of email addresses in use is good enough.

Regards,
-sm