Subject: [aqm] BoF planning

From: Wesley Eddy <[email-masked]>
Date: Mon, 13 May 2013 10:47:17 -0400

For planning an AQM BoF in Berlin, my thought is that
a rather short BoF to beat up the charter and scope of
work is what we'd want.

The problem is pretty well understood, and I don't think
more than a very brief overview is needed for people that
might be interested from other areas.

I don't think we want to deep-dive into algorithms at this
BoF, other than to show that they are becoming an active
area of work again, that drafts are being brought to the
IETF, and that there is interest in getting them done as
IETF-stream RFCs.

In other words, one of the shorter timeslots should
suffice, I think.

-- 
Wes Eddy
MTI Systems

---

From: Michael Welzl <[email-masked]>
Date: Mon, 13 May 2013 17:22:05 +0200

> In other words, one of the shorter timeslots should

… and we have asked for a long one for ICCRG, so folks who do want to discuss details of current algorithms have a place to go  :-)

Cheers,
Michael

---

From: Spencer Dawkins <[email-masked]>
Date: Wed, 29 May 2013 02:30:39 -0500

> a rather short BoF to beat up the charter and scope of

Wes, thank you for your work as AQM moves BOFward.

> might be interested from other areas.

I don't know if this would be helpful for anyone except me, but ... if 
there are lessons learned about the obstacles proposed AQN mechanisms 
faced in getting deployed, that might be helpful to remind people about, 
whether at a BOF, or as a proposed working group starts to work.

> IETF, and that there is interest in getting them done as

Makes sense to me.

> In other words, one of the shorter timeslots should

Makes sense to me. Were you thinking 60-minutes or 90 minutes?

Spencer

---

From: Wesley Eddy <[email-masked]>
Date: Wed, 29 May 2013 12:22:30 -0400

> whether at a BOF, or as a proposed working group starts to work.

To some extent, Fred's draft is touching on this, and if we have
an agenda slot to talk about his work there, then maybe Fred can
cover this?

> Makes sense to me. Were you thinking 60-minutes or 90 minutes?

I was thinking 60 minutes, but it could easily expand to 90.

For agenda items, I suggest:

5 min  - brief summary of AQM discussion in TSVAREA at last IETF
5 min  - summary of AQM mailing list discussion to-date
10 min - overview of draft charter, and the need/plan to get significant
         participation from OPS and other areas
10 min - look for consensus on whether packet scheduling also should be
         in-scope or whether the focus is on "pure" AQM
10 min - talk about the state of Fred's document
10 min - brief summary/summaries of ongoing AQM algorithm work(?)
10 min - call for consensus on chartering a WG in the TSV area

We might want to expand the time for Fred's document, to be able to
actually talk about the content to greater extent.

We might also want to add time if there are operator types of folks
that we could find in order to talk about their hopes, dreams, and
concerns about this work.

Of course, this is just my 2 cents, and others might have better ideas.

-- 
Wes Eddy
MTI Systems

---

From: Scott Brim <[email-masked]>
Date: Wed, 29 May 2013 12:39:03 -0400

> I was thinking 60 minutes, but it could easily expand to 90.

If it were 90 minutes you could expand on "brief summary/summaries of
ongoing AQM algorithm work".  10 minutes is close to nothing, you can't
get into the substantive issues.

---

From: Wesley Eddy <[email-masked]>
Date: Wed, 29 May 2013 12:44:45 -0400

> get into the substantive issues.

Yeah, if people want to do that, we should.  My thought was only that
for a BoF, we should be showing whether or not there are people who
will do the work, and that the details of the algorithms and how they
perform on test data sets might be too much.

By the way, so far I think we've only heard about CoDel and PIE being
written as I-Ds ... if there are other "next generation" AQMs that
people are working on, or existing algorithms that people think should
be progressed in this WG, we should definitely get those onto the
radar as well.

-- 
Wes Eddy
MTI Systems

---

From: Emmanuel Lochin <[email-masked]>
Date: Thu, 30 May 2013 09:51:50 +0200

Hi all,

We are working on a novel stateless AQM named FavorQueue that might be 
of interest.
I will attend Berlin meeting and could make a short talk on it.
See our preliminary study here : http://arxiv.org/pdf/1103.2303v2.pdf

Emmanuel

>
> -------- Message original --------
> Sujet: 	Re: [aqm] BoF planning
> Date : 	Wed, 29 May 2013 12:44:45 -0400
> De : 	Wesley Eddy <[email-masked]>
> Organisation : 	MTI Systems
> Pour : 	Scott Brim <[email-masked]>
> Copie à : 	[email-masked]
>
>
>
> _______________________________________________
> aqm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/aqm
>

-- 
Emmanuel Lochin
Professeur ISAE - OSSI
Institut Supérieur de l'Aéronautique et de l'Espace (ISAE)
Issu du rapprochement SUPAERO et ENSICA
10 avenue Edouard Belin - BP 54032 - 31055 Toulouse cedex 4
Tel : 05 61 33 91 85 - Fax : 05 61 33 91 88
Web : http://personnel.isae.fr/emmanuel-lochin/
---
"This email and any attachments are confidential. They may contain legally privileged information or copyright material. You should not read, copy, use or disclose them without authorisation. If you are not an intended recipient, please contact us at once by return email and then delete both messages. We do not accept liability in connection with computer virus, data corruption, delay, interruption, unauthorised access or unauthorised amendment. This notice should not be removed"

---

From: David Ros <[email-masked]>
Date: Thu, 30 May 2013 09:52:34 +0200

On 30 mai 2013, at 09:51, Emmanuel Lochin wrote:

> Hi all,
> 
> We are working on a novel stateless AQM named FavorQueue that might be of interest.

Hi,

As Michael said, we at ICCRG have a long slot, so folks may give a not-so-short talk if they prefer :-)

David

> Web : 
> http://personnel.isae.fr/emmanuel-lochin/
> 
> ---

=================================================================
David ROS
http://www.rennes.enst-bretagne.fr/~dros/

"It would seem that you have no useful skill or talent whatsoever," he said. "Have you thought of going into teaching?" -- Terry Pratchett

---

From: Emmanuel Lochin <[email-masked]>
Date: Thu, 30 May 2013 10:00:26 +0200

> As Michael said, we at ICCRG have a long slot, so folks may give a not-so-short talk if they prefer :-)

Cool :)