Subject: [aqm] FQ_PIE with qlen-aware dropping probability.

From: "Hironori Okano -X (hokano - AAP3 INC at Cisco)" <[email-masked]>
Date: Fri, 17 Jul 2015 20:10:27 +0000

Hello Group,

I talked with Rong about FQ_PIE and we changed the algorithm.

Before drop_early function, we search the maximum queue length in FQ.
And based on it, we recalculate dropping probability for queue i.
prob(i) =  original_prob * queue_length(i) / max_queue_length

In other words, each queue has their own dropping probability.

We have tested it with one tcp  and one udp stream. The link speed is 10Mbps. FQ_PIE target time is 20ms.
In the graph, red line is throughput of TCP session and purple line is RTT.

I have tested with 3 tcp sessions with 20sec gap also. It looks fine.

I attached the patch and you can see diff here.
https://github.com/hironoriokano/fq-pie/commit/642457f2d0bc805176d4eeb85c7d565525b83c55

For those who want to try the fq_pie which each queue has aqm state, I have implemented it and uploaded to my github as a new branch “aqm_per_queue”. It looks fine.
https://github.com/hironoriokano/fq-pie/tree/aqm_per_queue

Best regards,

Hironori Okano

---

From: "Francini, Andrea (Andrea)" <[email-masked]>
Date: Fri, 17 Jul 2015 21:08:43 +0000

Hi Hironori Okano,

Thank you for the code and the plots.

In the scenario with 1 TCP + 1 UDP flows, what is the base RTT (RTT when queuing delay is 0) of the TCP flow?

It would be interesting to see results with base RTT  larger than 20ms (e.g., 50ms).

Best regards,

Andrea

From: aqm [mailto:[email-masked]] On Behalf Of Hironori Okano -X (hokano - AAP3 INC at Cisco)
Sent: Friday, July 17, 2015 4:10 PM
To: AQM IETF list; Fred Baker (fred); Rong Pan (ropan)
Cc: [email-masked]; Bill Ver Steeg (versteb); Preethi Natarajan (prenatar)
Subject: [aqm] FQ_PIE with qlen-aware dropping probability.

Hello Group,

For those who want to try the fq_pie which each queue has aqm state, I have implemented it and uploaded to my github as a new branch "aqm_per_queue". It looks fine.
https://github.com/hironoriokano/fq-pie/tree/aqm_per_queue

Best regards,

Hironori Okano

---

From: "Hironori Okano -X (hokano - AAP3 INC at Cisco)" <[email-masked]>
Date: Fri, 17 Jul 2015 21:38:18 +0000

Andrea,

If I ping from client to server, the RTT is about 1ms. Is this what you're asking?

Actually, I deployed test network on KVM like this.

[client]—[router]—[netem]—[server]

VMs have virtio NIC and I use HTB to control throughput 10Mbps.

Hironori Okano

From: "Francini, Andrea (Andrea)" <[email-masked]<mailto:[email-masked]>>
Date: Friday, July 17, 2015 at 2:08 PM
To: hokano <[email-masked]<mailto:[email-masked]>>, AQM IETF list <[email-masked]<mailto:[email-masked]>>, "Fred Baker (fred)" <[email-masked]<mailto:[email-masked]>>, "Rong Pan (ropan)" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Bill Ver Steeg (versteb)" <[email-masked]<mailto:[email-masked]>>, "Preethi Natarajan (prenatar)" <[email-masked]<mailto:[email-masked]>>
Subject: RE: FQ_PIE with qlen-aware dropping probability.

Hi Hironori Okano,

Best regards,

Andrea

Cc: [email-masked]<mailto:[email-masked]>; Bill Ver Steeg (versteb); Preethi Natarajan (prenatar)

Hello Group,

Best regards,

Hironori Okano

---

From: "Francini, Andrea (Andrea)" <[email-masked]>
Date: Fri, 17 Jul 2015 21:46:25 +0000

Yes, a larger client-server ping time (such as 50ms) may induce more challenging operating conditions for the AQM.

Also in the same scenario, what is the source rate of the UDP flow?

Thanks,

Andrea

From: Hironori Okano -X (hokano - AAP3 INC at Cisco) [mailto:[email-masked]]
Sent: Friday, July 17, 2015 5:38 PM
To: Francini, Andrea (Andrea); AQM IETF list; Fred Baker (fred); Rong Pan (ropan)
Cc: [email-masked]; Bill Ver Steeg (versteb); Preethi Natarajan (prenatar)
Subject: Re: FQ_PIE with qlen-aware dropping probability.

Andrea,

[client]-[router]-[netem]-[server]

Hironori Okano

Hi Hironori Okano,

Best regards,

Andrea

Hello Group,

Best regards,

Hironori Okano

---

From: "Hironori Okano -X (hokano - AAP3 INC at Cisco)" <[email-masked]>
Date: Fri, 17 Jul 2015 23:15:28 +0000

Andrea

The source rate of UDP flow is 10Mbps.

I’m testing with longer base RTT time.
It seems that a larger base RTT time is challenging for fq-pie as you said.

Hiro

Date: Friday, July 17, 2015 at 2:46 PM

Thanks,

Andrea

Andrea,

Hironori Okano

Hi Hironori Okano,

Best regards,

Andrea

Hello Group,

Best regards,

Hironori Okano