Subject: [aqm] Document Action: 'The Benefits of using Explicit Congestion Notification (ECN)' to Informational RFC (draft-ietf-aqm-ecn-benefits-08.txt)

From: The IESG <[email-masked]>
Date: Tue, 01 Dec 2015 14:10:36 -0800

The IESG has approved the following document:
- 'The Benefits of using Explicit Congestion Notification (ECN)'
  (draft-ietf-aqm-ecn-benefits-08.txt) as Informational RFC

This document is the product of the Active Queue Management and Packet
Scheduling Working Group.

The IESG contact persons are Spencer Dawkins and Martin Stiemerling.

A URL of this Internet Draft is:
https://datatracker.ietf.org/doc/draft-ietf-aqm-ecn-benefits/

Technical Summary

This document is mostly a list of demonstrated and expected benefits to 
transport protocols by using ECN. It highlights points that are most 
visible to the application layer within the end-points. It then goes on 
discussing specific deployment scenarios of ECN in a network, and the 
internet at scale. 

The key benefits of running ECN are summarized as
o) Improved throughput                                 
o) Reduced Head-of-Line blocking                       
o) Reduced probability of RTO Expiry                   
o) Applications that do not retransmit lost packets    
o) Making incipient congestion visible                 
o) Opportunities for new transport mechanisms  

Working Group Summary

The document was brought to the working group to highlight and underline the
many benefits ECN can have, if deployed at scale. During the WG discussions, the
character of the draft changed slightly, from looking only at the positive 
implications to also describe potential drawbacks and pitfalls.

The intention of this document though is less technical in nature, and instead is 
intended as a reference as to why deploying ECN at this time would be sensible. 
It aims to be a manifest that can be shown to decision-makers who quickly need
to understand the key benefits of ECN, with a high level of technical guidance.

Document Quality

Are there existing implementations of the protocol? 

The document is agnostic of any specific implementation, and rather argues
about the architectural model (well, as supported by the IP protocol) to use
ECN. Implementations of ECN in TCP (RFC3168) are in wide-spread use, but with
the ECN capabilities disabled, or only passively enabled. Arguably, the document
helped to persuade decision-maker at a large vendor to actively start deploying 
ECN.

Have a significant number of vendors indicated their plan to implement the 
specification? 

The document aims to achieve just that - to drive the adoption rate of a well
known and available protocol by vendors up.

Are there any reviewers that merit special mention as having done a thorough 
review, e.g., one that resulted in important changes or a conclusion that the 
document had no substantive issues? 

There were lively discussions in the AQM working group around this document.
First, to not only speak exclusively about the positive aspects, but also 
mention potential issues. Second, that document had widespread support in the WG
as it preaches to the choir - but word has to be spread about ECN to a larger
audience.
Personnel

Who is the Document Shepherd? 
Richard Scheffenegger, AQM WG co-chair

Who is the Responsible Area Director?
Martin Stiemerling, Transport AD

---

From: Steve Baillargeon <[email-masked]>
Date: Tue, 1 Dec 2015 22:22:34 +0000

Hi
Sorry to come so late with a comment.
Is it too late to add one more benefit to the draft?

I suspect ECN brings potential and significant savings in CPU cycles and memory usage , especially on the "server side" terminating a large number of TCP connections.
Has anyone done any analysis to confirm or contradict this assumption?

Regards
Steve Baillargeon
Ericsson

-----Original Message-----
From: aqm [mailto:[email-masked]] On Behalf Of The IESG
Sent: Tuesday, December 01, 2015 5:11 PM
To: IETF-Announce
Cc: [email-masked]; [email-masked]; [email-masked]; The IESG; [email-masked]; [email-masked]; [email-masked]
Subject: [aqm] Document Action: 'The Benefits of using Explicit Congestion Notification (ECN)' to Informational RFC (draft-ietf-aqm-ecn-benefits-08.txt)

This document is the product of the Active Queue Management and Packet Scheduling Working Group.

Technical Summary

This document is mostly a list of demonstrated and expected benefits to transport protocols by using ECN. It highlights points that are most visible to the application layer within the end-points. It then goes on discussing specific deployment scenarios of ECN in a network, and the internet at scale. 

Working Group Summary

The document was brought to the working group to highlight and underline the many benefits ECN can have, if deployed at scale. During the WG discussions, the character of the draft changed slightly, from looking only at the positive implications to also describe potential drawbacks and pitfalls.

The intention of this document though is less technical in nature, and instead is intended as a reference as to why deploying ECN at this time would be sensible. 
It aims to be a manifest that can be shown to decision-makers who quickly need to understand the key benefits of ECN, with a high level of technical guidance.

Document Quality

The document is agnostic of any specific implementation, and rather argues about the architectural model (well, as supported by the IP protocol) to use ECN. Implementations of ECN in TCP (RFC3168) are in wide-spread use, but with the ECN capabilities disabled, or only passively enabled. Arguably, the document helped to persuade decision-maker at a large vendor to actively start deploying ECN.

_______________________________________________
aqm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/aqm

---

From: Wesley Eddy <[email-masked]>
Date: Tue, 1 Dec 2015 22:03:19 -0500

> Has anyone done any analysis to confirm or contradict this assumption?

Hi Steve, thanks for the comment.

I don't think I've seen anyone analyze that before, and would guess at 
the moment that it's too tenuous to try to work into this particular 
document at its advanced stage.

I would recommend continuing discussion or research on this in AQM, 
TSVWG, ICCRG or other appropriate groups at the moment, but not altering 
the draft.  At the ADs, and editors discretion, and if there seems to be 
working group consensus, it might be noted as a potential benefit for 
future exploration, but that's about the only impact I think might be 
appropriate to this particular document at its advanced stage.

---

From: Steve Baillargeon <[email-masked]>
Date: Wed, 2 Dec 2015 13:00:57 +0000

Hi Wes
I am happy with a note as a potential benefit for future exploration.

-Steve

-----Original Message-----
From: Wesley Eddy [mailto:[email-masked]] 
Sent: Tuesday, December 01, 2015 10:03 PM
To: Steve Baillargeon
Cc: [email-masked]; [email-masked]; The IESG; [email-masked]; [email-masked]
Subject: Re: [aqm] Document Action: 'The Benefits of using Explicit Congestion Notification (ECN)' to Informational RFC (draft-ietf-aqm-ecn-benefits-08.txt)

I don't think I've seen anyone analyze that before, and would guess at the moment that it's too tenuous to try to work into this particular document at its advanced stage.

I would recommend continuing discussion or research on this in AQM, TSVWG, ICCRG or other appropriate groups at the moment, but not altering the draft.  At the ADs, and editors discretion, and if there seems to be working group consensus, it might be noted as a potential benefit for future exploration, but that's about the only impact I think might be appropriate to this particular document at its advanced stage.

---

From: [email-masked]
Date: Wed, 2 Dec 2015 22:15:19 -0000

Does anyone have data?

I'm not sure that it helps people to say there is research in evaluating
the potential for ECN to save CPU cycles. I'm intrigued, and I'd like to
see the research. But is this something we should add.

Gorry

> Cc: [email-masked]; [email-masked]; The IESG;
> [email-masked]; [email-masked]
> Subject: Re: [aqm] Document Action: 'The Benefits of using Explicit
> Congestion Notification (ECN)' to Informational RFC
> (draft-ietf-aqm-ecn-benefits-08.txt)
>
>> I suspect ECN brings potential and significant savings in CPU cycles and
>> memory usage , especially on the "server side" terminating a large
>> number of TCP connections.
> I don't think I've seen anyone analyze that before, and would guess at the
> moment that it's too tenuous to try to work into this particular document
> at its advanced stage.
>
> I would recommend continuing discussion or research on this in AQM, TSVWG,
> ICCRG or other appropriate groups at the moment, but not altering the
> draft.  At the ADs, and editors discretion, and if there seems to be

---

From: Steve Baillargeon <[email-masked]>
Date: Thu, 10 Dec 2015 12:17:17 +0000

Stuart, Sarma
This draft describes the potential benefits when applications use a transport that enables Explicit Congestion Notification (ECN).
Do you know if ECN provide savings in CPU cycles and memory usage , especially on the "server side" terminating a  large number of TCP connections?

Regards
Steve B 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, December 02, 2015 5:15 PM
To: Steve Baillargeon
Cc: Wesley Eddy; [email-masked]; [email-masked]; The IESG; [email-masked]; [email-masked]
Subject: RE: [aqm] Document Action: 'The Benefits of using Explicit Congestion Notification (ECN)' to Informational RFC (draft-ietf-aqm-ecn-benefits-08.txt)

Does anyone have data?

I'm not sure that it helps people to say there is research in evaluating the potential for ECN to save CPU cycles. I'm intrigued, and I'd like to see the research. But is this something we should add.

Gorry

>> I suspect ECN brings potential and significant savings in CPU cycles 
>> and memory usage , especially on the "server side" terminating a 
>> large number of TCP connections.
> TSVWG, ICCRG or other appropriate groups at the moment, but not 
> altering the draft.  At the ADs, and editors discretion, and if there 
> seems to be working group consensus, it might be noted as a potential 
> benefit for future exploration, but that's about the only impact I 
> think might be appropriate to this particular document at its advanced stage.
>