Subject: [aqm] An independent implementation of CoDel in FreeBSD/ipfw/dummynet

From: Rasool Al-Saadi <[email-masked]>
Date: Wed, 16 Dec 2015 11:35:30 +0000

Hello all,

I am Rasool Al-Saadi, a PhD student at Centre for Advanced Internet Architectures - Swinburne University of Technology. I and my supervisor Grenville Armitage are implementing CoDel (and eventually PIE, FQ_CoDel and FQ_PIE) in FreeBSD targeting ipfw/dummynet framework as a small project funded by Comcast Corporation, USA.

We used CoDel I-D (https://datatracker.ietf.org/doc/draft-ietf-aqm-codel/) as the main source to implement CoDel and we believe that the information in the latest draft (draft-ietf-aqm-codel-02) sufficient and the pseudo-code is straightforward to create functional CoDel code. However, we have some questions/confusion regarding CoDel I-D:

1- There is little confusion in the text. In section 3.3, the text says "... the initial drop spacing SHOULD be set to the estimator's interval plus twice the target (i.e., initial drop spacing = 1.1 * interval) ...", while in section 4.1, the text says "As discussed in section 3.3, the initial next drop spacing is intended to be long enough to give the endpoints time to react to the single drop so SHOULD be set to a value of 1.0 to 1.1 times the interval."

2- In section 3.2 and 4.4, the text says the ideal setpoint is 5-10% of the interval (connection RTT). So, should we allow the user to specify the target value as a percentage of the interval or an absolute value?

Regards,
Rasool

---

From: grenville armitage <[email-masked]>
Date: Thu, 17 Dec 2015 09:01:06 +1100

On 12/16/2015 22:35, Rasool Al-Saadi wrote:
	[..]
> We used CoDel I-D
> (https://datatracker.ietf.org/doc/draft-ietf-aqm-codel/) as the main
> source to implement CoDel and we believe that the information in the
> latest draft (draft-ietf-aqm-codel-02) sufficient and the pseudo-code
> is straightforward to create functional CoDel code. However, we have
> some questions/confusion regarding CoDel I-D:

To clarify, we intended this to be +ve feedback in the context of the current Last Call for the CoDel I-D.

cheers,
gja