Subject: Re: [arch-d] On scaling of flat identifier spaces (was Re: On identifiers: wh...

From: [email-masked]
Date: Mon, 27 Nov 2006 04:34:32 EST

So, what I am missing?  Why do identifier systems necessarily  need to  
be structured?

--Pekka Nikander

Answer: because of the many advantages: It is not only the capability to  
pick the right one in a very short time. Diverse properties can be looked up!  
Filtering. Statistics.
In Germany the social security number is much bigger than in the US. It  
contains somehow the date-of-birth, the first letter of the name, some  
administrative organisationals,...
 
IMO the address should contain some part related to the individual  user, 
plus eventually also some address family characteristics (  private, org, edu, 
gov,...  ) and definitely some locating part (ASN,  geographic coordinates). Of 
course, only part of such an address can be  checksummed.
 
Heiner Hummel
 
_______________________________________________
Architecture-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/architecture-discuss

---

From: David Conrad <[email-masked]>
Date: Tue, 28 Nov 2006 00:38:22 -0800

Heiner,

On Nov 27, 2006, at 1:34 AM, [email-masked] wrote:
> IMO the address should contain some part related to the individual  
> user, plus eventually also some address family characteristics  
> ( private, org, edu, gov,...  ) and definitely some locating part  
> (ASN, geographic coordinates). Of course, only part of such an  
> address can be checksummed.

People interested in privacy might have a few issues with this.

Rgds,
-drc

---

From: John Day <[email-masked]>
Date: Tue, 28 Nov 2006 11:13:42 -0500

At 0:38 -0800 2006/11/28, David Conrad wrote:
>>user, plus eventually also some address family characteristics ( 
>>private, org, edu, gov,...  ) and definitely some locating part 

I agree with David.  And would go further, no way.  This information 
has nothing to do with an address.

John

---

From: "Bound, Jim" <[email-masked]>
Date: Wed, 29 Nov 2006 11:00:59 -0500

I don't agree an identifier to assist with routing path should be the
same as end-to-end identifiers at all.  The privacy and security
ramifications are to wide and dangerous.

I want to be able at some point in time world wide to be able to encrypt
the packet from my mobile node so the only thing exposed in the clear is
the IP header and any options and everything else is simply not
available to routers, network node managers, mid-com boxes, etc as a
tool to move my packet across the Internet.  Putting my identity in the
src and dst address of my IP header is not acceptable.

Best,
/jim

> -----Original Message-----
> From: John Day [mailto:[email-masked]] 
> Sent: Tuesday, November 28, 2006 11:14 AM
> To: David Conrad; [email-masked]
> Cc: [email-masked]; 
> [email-masked]; [email-masked]
> Subject: Re: [arch-d] On scaling of flat identifier spaces 
> (was Re: Onidentifiers: wh...
> 
> >>private, org, edu, gov,...  ) and definitely some locating 
> part (ASN, 
> >>geographic coordinates). Of course, only part of such an 
> address can 
> >>be checksummed.
> >
> I agree with David.  And would go further, no way.  This 
> information has nothing to do with an address.
> 
> John
>