Subject: Re: [arch-d] On scaling of flat identifier spaces (was Re: On identifiers: wh...

From: [email-masked]
Date: Tue, 28 Nov 2006 13:46:29 EST

John,
I completely respect your NO. And indeed, it is not a requirement in  order 
to be able to accomplish something (e.g. like routing). However, it is a  
political offer and does allow differentiating (filtering). And here we get to  
some other topics like political priorities. And I think we should understand  
such other priorities/issues/wishes.  

I also pointed out that -in my view a mistake - we merge technical  operation 
into the address (unicast, anycast, multicast) which is neither  necessary 
nor favorable and which can be handled better. 
However we should think about what else might be merged into an address  
because it is appropriate to do so. There are also other groups (ITU-T e.g.)  
which have developed some ideas on addresses. And also: New ideas and new  
arguments should be welcome. I am not a politician. But (who knows)  maybe an address 
is also something to be protected/defended/scoped ?
 
I can assure you: I do not know the right or the whole answer. But I  think 
we should invite politicians to come up with their wishes, too.
 
Heiner

In einer eMail vom 28.11.2006 17:14:51 Westeuropäische Normalzeit schreibt  
[email-masked]:

At 0:38  -0800 2006/11/28, David Conrad wrote:
>Heiner,
>
>On Nov 27,  2006, at 1:34 AM, [email-masked] wrote:
>>IMO the address  should contain some part related to the individual 
>>user, plus  eventually also some address family characteristics ( 
>>private,  org, edu, gov,...  ) and definitely some locating part 
>>(ASN,  geographic coordinates). Of course, only part of such an 
>>address  can be checksummed.
>
>People interested in privacy might have a  few issues with this.

I agree with David.  And would go further,  no way.  This information 
has nothing to do with an  address.

John

_______________________________________________
Architecture-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/architecture-discuss

---

From: "Tony Li" <[email-masked]>
Date: Tue, 28 Nov 2006 11:02:23 -0800

I can assure you: I do not know the right or the whole answer. But I
think we should invite politicians to come up with their wishes, too.

I'm hopeful that this will remain a technical discussion.
 
Tony

---

From: John Day <[email-masked]>
Date: Tue, 28 Nov 2006 14:11:01 -0500

Having played the electro-political engineering 
game for more than a few decades, I can assure 
you that if given the chance politicians will 
screw up anything they touch.  We are lucky in 
this case however, since there is absolutely no 
part of *addressing* that is political.  Any 
attempt otherwise is simply misguided.  (The same 
can not be said of application names, however.)

Addresses are topologically-dependent names whose 
use is internal to a layer.  There is never any 
need (in a well-formed architecture) for 
addresses to be visible to any but the internal 
machinery of the layer.  There is no rationale 
for them to have any other visibility to 
applications or anything else outside the layer, 
certainly none political.

Take care,
John

At 13:46 -0500 2006/11/28, [email-masked] wrote:
>John,
>I completely respect your NO. And indeed, it is 
>not a requirement in order to be able to 
>accomplish something (e.g. like routing). 
>However, it is a political offer and does allow 
>differentiating (filtering). And here we get to 
>some other topics like political priorities. And 
>I think we should understand such other 
>priorities/issues/wishes.
>
>I also pointed out that -in my view a mistake - 
>we merge technical operation into the address 
>(unicast, anycast, multicast) which is neither 
>necessary nor favorable and which can be handled 
>better.
>However we should think about what else might be 
>merged into an address because it is appropriate 
>to do so. There are also other groups (ITU-T 
>e.g.) which have developed some ideas on 
>addresses. And also: New ideas and new arguments 
>should be welcome. I am not a politician. But 
>(who knows) maybe an address is also something 
>to be protected/defended/scoped ?
>
>I can assure you: I do not know the right or the 
>whole answer. But I think we should invite 
>politicians to come up with their wishes, too.
>
>Heiner
>
>