Subject: Re: [arch-d] Major practical decision

From: [email-masked]
Date: Sat, 9 Dec 2006 16:17:57 EST

Jim, my point is, that flat routing produces a huge amount of message  
dissemination (upon changes) as to inform routers which shouldn't  need  that 
information because it shouldn't affect their routing decisions.  Hierarchy would 
confine that.
Heiner

In einer eMail vom 09.12.2006 12:37:38 Westeuropäische Normalzeit schreibt  
[email-masked]:

Interesting is anyone  proposing an alternative to hierarchical routing if so 
I would like to hear  that logic?
/jim

____________________________________
 From: [email-masked]  [mailto:[email-masked]] 
Sent: Saturday, December 09, 2006  3:39 AM
To: [email-masked]; [email-masked]
Cc:  [email-masked]
Subject: Re: [arch-d] Major  practical decision

There is no alternative to hierarchical routing and also: there is no  need 
for flat routing.
Heiner
Why should a router in Europe be informed if some router (not bike)  tips 
over in China?!

In einer eMail vom 09.12.2006 05:47:09 Westeuropäische Normalzeit  schreibt 
[email-masked]:

> So, what's it to be:  jack-up (i.e. insertion of a new  
> internetworking  layer),
> or new end-end names (i.e. insertion of a new end-end  naming layer)?

My $.02:

We're supposed to be  architecting a fix for the Internet that should  
last for the  foreseeable future.  Not just the next 10 or 20 years,  
but  the next 100 or so.  The jack-up model is somewhat less clean  and  
inevitably introduces suboptimalities at the interface  between the  
layers.  Thus, I'm in favor of replacing the  namespace.

Regards,
Tony

_______________________________________________
Architecture-discuss  mailing  list
[email-masked]
https://www1.ietf.org/mailman/listinfo/architecture-discuss

_______________________________________________
Architecture-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/architecture-discuss

---

From: "Bound, Jim" <[email-masked]>
Date: Sat, 9 Dec 2006 17:01:56 -0500

Heiner, I actually agreed with you but was checking if any were proposing an alternative and said it generically to not limit any response to flat routing.
 
thanks
/jim

________________________________

	From: [email-masked] [mailto:[email-masked]] 
	Sent: Saturday, December 09, 2006 4:18 PM
	To: Bound, Jim; [email-masked]; [email-masked]
	Cc: [email-masked]
	Subject: Re: [arch-d] Major practical decision

	Jim, my point is, that flat routing produces a huge amount of message dissemination (upon changes) as to inform routers which shouldn't need  that information because it shouldn't affect their routing decisions. Hierarchy would confine that.
	Heiner
	 
	In einer eMail vom 09.12.2006 12:37:38 Westeuropäische Normalzeit schreibt [email-masked]:

		Interesting is anyone proposing an alternative to hierarchical routing if so I would like to hear that logic?
		/jim

________________________________

			
			There is no alternative to hierarchical routing and also: there is no need for flat routing.
			Heiner
			Why should a router in Europe be informed if some router (not bike) tips over in China?!

				My $.02:

				Regards,
				Tony

---

From: Tony Li <[email-masked]>
Date: Sat, 9 Dec 2006 16:27:00 -0800

Heiner,

If it was unclear, I was in no way advocating abandoning hierarchical  
abstraction.

In fact, I think I'm one of the larger cheerleaders for abstraction  
of routing names, and for applying it in multiple layers.  Long ago,  
back when we were discussing CIDR, I proposed that we create another  
level of abstraction by allocating prefixes at the continental level  
(say a /4) and then allowing registries to delegate out of that.  The  
thought being that we would get another useful abstraction boundary  
at continental interconnects.  This got shot down, sadly.

Tony

On Dec 9, 2006, at 1:17 PM, [email-masked] wrote:

> Jim, my point is, that flat routing produces a huge amount of  
> message dissemination (upon changes) as to inform routers which  
> shouldn't need  that information because it shouldn't affect their  
> routing decisions. Hierarchy would confine that.
> Heiner
>
> Interesting is anyone proposing an alternative to hierarchical  
> routing if so I would like to hear that logic?
> /jim
>