Subject: [arch-d] Fwd: I-D Action: draft-carpenter-limited-domains-00.txt

From: Brian E Carpenter <[email-masked]>
Date: Fri, 22 Jun 2018 16:50:07 +1200

Hi, 

This draft is a bit hard to classify, but certainly has an
architectural aspect. We'd be very interested to hear comments
on this list or in the corridors at IETF 102. Hopefully there
will be a few slides at the Hot RFC session on Sunday, and
possibly later in the week too.

Regards

    Brian & Sheng

-------- Forwarded Message --------
Subject: I-D Action: draft-carpenter-limited-domains-00.txt
Date: Sun, 10 Jun 2018 21:55:59 -0700
From: [email-masked]
Reply-To: [email-masked]
To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : Limited Domains and Internet Protocols
        Authors         : Brian Carpenter
                          Sheng Jiang
	Filename        : draft-carpenter-limited-domains-00.txt
	Pages           : 12
	Date            : 2018-06-10

Abstract:
   There is a noticeable trend towards network requirements, behaviours
   and semantics that are specific to a limited region of the Internet
   and a particular set of requirements.  Policies, default parameters,
   the options supported, the style of network management and security
   requirements may vary.  This document reviews examples of such
   limited domains and emerging solutions.  It shows the needs for a
   precise definition of a limited domain boundary and for a
   corresponding protocol to allow nodes to discover where such a
   boundary exists.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-carpenter-limited-domains/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-carpenter-limited-domains-00
https://datatracker.ietf.org/doc/html/draft-carpenter-limited-domains-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Niels ten Oever <[email-masked]>
Date: Fri, 22 Jun 2018 10:07:18 +0200

Hi Brian,

Thanks for this. More in-depth comments later, in the mean time I
suggest you s/balkanization/fragmentation. Since the negative
connotation that is connected to Balkanization is often perceived as
insulting and stigmatizing by people from that region.

Best,

Niels

On 06/22/2018 06:50 AM, Brian E Carpenter wrote:
> Architecture-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/architecture-discuss
> 

-- 
Niels ten Oever
Researcher and PhD Candidate
Datactive Research Group
University of Amsterdam

PGP fingerprint	   2458 0B70 5C4A FD8A 9488
                   643A 0ED8 3F3A 468A C8B3

---

From: Joe Touch <[email-masked]>
Date: Fri, 22 Jun 2018 11:34:02 -0700

Suggest using ‘partitioning’ or some other term than fragmentation. 

> On Jun 22, 2018, at 1:07 AM, Niels ten Oever <[email-masked]> wrote:
> 
> Hi Brian,
>

---

From: Niels ten Oever <[email-masked]>
Date: Fri, 22 Jun 2018 22:29:25 +0200

Fragmentation seems to be the term that is used in the literature though:

https://www.wiley.com/en-us/Will+the+Internet+Fragment%3F%3A+Sovereignty%2C+Globalization+and+Cyberspace-p-9781509501229

https://www.weforum.org/reports/internet-fragmentation-an-overview

Best,

Niels

---

From: John C Klensin <[email-masked]>
Date: Fri, 22 Jun 2018 19:04:42 -0400

There is a different sort of whatever-one-wants-to-call it going
on here.  In the Internet Governance and political literature,
"fragmentation" has been popular.  In significantly more
technical contexts, that term has a very different meaning
(presumably the source of Joe's objection) and hence other terms
may be preferred.  Of course, because the term has at least two
very different meanings where the Internet is concerned, it
would be possible to take exception to the use of "domain" as
well.

IMO, Brian and Sheng should use the terminology that, in their
judgment, is most likely to make the document accessible to
their audience, preferably without offending anyone.

Speaking personally, this appears to be an interesting document
and I would much rather see discussions of its substance than
quibbling about terminology in a draft this early in its
lifecycle.  YMMD.

     john

--On Friday, June 22, 2018 22:29 +0200 Niels ten Oever
<[email-masked]> wrote:

> https://www.wiley.com/en-us/Will+the+Internet+Fragment%3F%3A+S
> overeignty%2C+Globalization+and+Cyberspace-p-9781509501229
> 
>> Suggest using 'partitioning' or some other term than
>> fragmentation. 
>> 
>>> Thanks for this. More in-depth comments later, in the mean
>>> time I suggest you s/balkanization/fragmentation. Since the
>>> negative connotation that is connected to Balkanization is
>>> often perceived as insulting and stigmatizing by people from
>>> that region.
>>> 
>>> Best,
>>> 
>>> Niels
>>> 
>>>> architectural aspect. We'd be very interested to hear
>>>> comments on this list or in the corridors at IETF 102.
>>>> Hopefully there will be a few slides at the Hot RFC session
>>>> on Sunday, and possibly later in the week too.
>>>> 
>>>> Regards
>>>> 
>>>>    Brian & Sheng
>>>> 
>>>>        Title           : Limited Domains and Internet
>>>>        Protocols Authors         : Brian Carpenter Sheng
>>>>                          Jiang
>>>>   There is a noticeable trend towards network requirements,
>>>>   behaviours and semantics that are specific to a limited
>>>>   region of the Internet and a particular set of
>>>>   requirements.  Policies, default parameters, the options
>>>>   supported, the style of network management and security
>>>>   requirements may vary.  This document reviews examples of
>>>>   such limited domains and emerging solutions.  It shows
>>>>   the needs for a precise definition of a limited domain
>>>>   boundary and for a corresponding protocol to allow nodes
>>>>   to discover where such a boundary exists.
>>>> 
>>>> 
>>>> Please note that it may take a couple of minutes from the
>>>> time of submission until the htmlized version and diff are
>>>> available at tools.ietf.org.
>>>>

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 23 Jun 2018 11:38:59 +1200

Niels,

I take the point, but the Balkanization term has been used
historically in our community, and it has an explicit emotional
overtone that no politically correct term will provide. And it's
only mentioned *in quotes* to indicate that it's out of scope for
the draft.

Joe is correct, 'fragmentation' is a term of art in IP so really
doesn't work. I quite like https://en.wikipedia.org/wiki/Splinternet.
But, again, that isn't what the draft is about.

Regards
   Brian

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 25 Jun 2018 14:14:20 +0100

Brian

There are many non-PC expressions that used to succinctly express 
concepts in their time. However we are now more enlightened, and out of 
respect for others we have ceased to use them.

Perhaps the word "partitioned" would work in your document?

- Stewart

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 26 Jun 2018 08:30:16 +1200

> Perhaps the word "partitioned" would work in your document?

Not without an explanation. "Splintering" is the best I've found, but
it still doesn't convey the issue without extra verbiage.

Regardless, we're not going to update the draft for this alone. What do
you think about the actual content?

    Brian