Subject: Re: [arch-d] ipv4 and ipv6 Coexistence.

From: [email-masked]
Date: Wed, 26 Feb 2020 09:00:01 +0000 (UTC)

Imho, ipv6 is just like ipv4. It does not dispatch the old errors:
Unicast, multicast,anycast are different services and needs to be addressed by differentiating service bits in the header – and not by different address ranges! Also: Traffic congestion is a problem inmidst the network and needs to be solved by partial detouring. More than a decade ago, I elaborated algorithm+protocol how to utilize ALL adjacent links for forwarding:  to ALL those neighbor-s(!) closer  to the destination,  to equally-distant neighbors,  to 1-hop-more-remote neighbors and for the worst case by means of 2 encapsulations to a far more distant(also relatively to the destination) intermediate node, followed to  some remote but closer-to-the-destination intermediate node. Included IP header info hereby would haved avoided any endless looping.  That was for OSPF networks. With respect to interdomain, I elaborated TARA whose concept is well-known because applied by Google-map-routing: All nodes participate to enable the view of several zooming levels with accordingly skimmed topologies. The next-hop was looked-up from 1, respective 3 offset-tables rather than by binary search from a 850 000 entries-sized BGP table.

Invain. So I still think IPv6 will never fly.

Heiner

-----Ursprüngliche Mitteilung-----
Von: Fred Baker <[email-masked]>
An: Toerless Eckert <[email-masked]>
Cc: architecture-discuss <[email-masked]>; Mark Andrews <[email-masked]>
Verschickt: Di, 25. Feb. 2020 19:16
Betreff: Re: [arch-d] ipv4 and ipv6 Coexistence.

On Feb 24, 2020, at 2:27 PM, Toerless Eckert <[email-masked]> wrote:
> 
> In private / controlled networks, the choices are not only IPv4 vs.
> IPv6 or their interop, but also (SR-)MPLS and even more so L2 ethernet
> switching.

You make some important points, but...

We have had several countries discuss pulling off the Internet or doing something pretty disruptive, such as unilaterally changing from DNS to something else or imposing government-controlled firewalls. My point to them - and I have spoken with more than one - is that disrupting Internet communications affects the flow of international commerce, and therefore money, into their countries.

The same point applies in this case. If a company wants to internally only use <something> as a link layer protocol, that's their choice, but if they step very far away from IPv4 and IPv6, it means that they can't do business with their vendors and their customers - they have to in some way translate or overlay at that boundary. What has been beneficial with Internet technologies since they were invented was that one no longer had to think about global deployments of BBN 1822, X.25, Ethernet, or any of a long list of other things; they became carriers for a common architecture enabling global communications._______________________________________________
Architecture-discuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/architecture-discuss

---

From: [email-masked]
Date: Wed, 26 Feb 2020 09:02:05 +0000 (UTC)

Heiner 
 
-----Ursprüngliche Mitteilung-----
Von: Brian E Carpenter <[email-masked]>
An: Toerless Eckert <[email-masked]>; Mark Andrews <[email-masked]>
Cc: architecture-discuss <[email-masked]>
Verschickt: Di, 25. Feb. 2020 20:17
Betreff: Re: [arch-d] ipv4 and ipv6 Coexistence.

Hi Toerless,

> I am primarily concerned that we did manage to recognize we needed
> disruptive innovartion in the 90th, when we came up with IPv6, 

I'm not at all sure we intended to be disruptive. In fact, the word
"coexistence" was there from before the start (I put it there, in
RFC1671) and to a considerable extent the IPv6 design tried to adopt
current best practice and was in fact a very conservative design; some
said it was too conservative.

As you can easily see, my foresight in that RFC was far from perfect
but the emphasis on coexistence and interworking was something that
every operator required from the start. If not, we wouldn't have got very
far.

Regards
  Brian

On 25-Feb-20 11:27, Toerless Eckert wrote:
> [Bcc [email-masked], Cc: [email-masked]]
> 
> Mark: 
> 
> Funny to see how yours is the first actual answer to at least how i read
> Khaleds question. I would summarize what you said with:
> 
> https://en.wikipedia.org/wiki/IPv6_transition_mechanism
> 
> (14 standardized plus a lot more. Aka: thank you, but we have enough)
> 
> Most everybody else jumps to the growth of the IPv6 Internet, which
> to me is just the visible tip of the iceberg of overall IPv4 and IPv6
> deployments. I think the picture changes quite a bit if we look at the
> whole iceberg. 
> 
> For all intent and purpose, Internet IPv6 vs. Internet IPv4 could soon
> be software-only overlay virtual networks whereas the actual
> terrabit accelerated hardware forwarding plane of future networks
> maybe something else. 4G/5G "core" "network" already are such
> overlay networks. 
> 
> [Rant]
> I am not sure if the question, as constrained as  Khaled is asking
> it will really help us to improve what we should do in the future. But
> neither is the defensive reaction of IPv6 evangelists pointing at the
> growth curve of the IPv6 Internet as the only relevant metric to the
> success and benefits of IPv6.
> 
> I am primarily concerned that we did manage to recognize we needed
> disruptive innovartion in the 90th, when we came up with IPv6, but
> now the predominant religion seems to be being stuck in small
> incremental enhancements of that 25 year old architecture, especially
> because its bible (RFC8200) did only think of the IPv6 Internet use-case
> requirements, but not those of private/controlled networks.
> [/Rant]
> 
> Cheer
>    Toerless
> 
> On Thu, Feb 20, 2020 at 12:26:28PM +1100, Mark Andrews wrote:
>> Really we do not need to be inventing anything new in this space.
>> We already have too many mechanisms.  ISPs just need to DEPLOY the
>> existing mechanism.
>>
>> We have plain dual stack.
>>
>> We have public IPv4 + 6rd for ISPs where the access network doesn???t
>> support IPv6.
>>
>> We have CGN + 6RD + 100.64/10 for ISPs where the access network doesn???t
>> support IPv6 and they have run out of IPv4 space.
>>
>> We have DS-Lite, MAP-E, MAP-T, NAT64 ??? providing IPV4AAS for when the ISP
>> has run out of IPv4 and the access network supports IPv6.
>>
>> We have CGN + IPv6.
>>
>> Do we really need something more at the protocol level?
>>
>> We do need Governments to ban the selling of new IPv4-only domestic
>> devices (CPE routers, TV???s, game boxes, etc.).
>>
>> Mark
>>
>>> On 20 Feb 2020, at 11:32, Khaled Omar <[email-masked]> wrote:
>>>
>>> Regardless the different %s, lets take the average one, it can not make us optimistic and stop thinking about a better solution, we should learn from the long time passed without full migration occured, if we will wait till that happens, the division will occur which is not good for the internet, lets welcome new ideas and give it the space, time, and opportunity fairly, if it will be good then welcome, if not, trash is made for this. 
>>>
>>> Get Outlook for Android
>>>
>>> From: ietf <[email-masked]> on behalf of JORDI PALET MARTINEZ <jordi.palet=[email-masked]>
>>> Sent: Thursday, February 20, 2020 2:00:58 AM
>>> To: IETF Rinse Repeat <[email-masked]>
>>> Subject: Re: ipv4 and ipv6 Coexistence.
>>>  
>>> And you're missing several points about how those stats are looked at.
>>>
>>> The % in the stats shown by google/others is only what they can measure, but they can't measure *all*. There are countries (big ones) that don't allow measurements, or at least the same level of details, and however, are doing massive IPv6 deployments.
>>>
>>> All the CDNs and caches have IPv6. The customers that have those caches and enable IPv6 for their subscribers, are getting ranges over 65%, sometimes even up to 85-90% of IPv6 traffic when mainly the subscribers are householders instead of big enterprises.
>>>
>>> Also, the google (and others) measurements, show average worldwide, but if you look to many countries they have even surpassed the 50% or so.
>>>
>>> Regards,
>>> Jordi
>>> @jordipalet
>>>  
>>>  
>>>
>>> ???El 20/2/20 5:38, "ietf en nombre de Khaled Omar" <[email-masked] en nombre de [email-masked]> escribió:
>>>
>>>    Since long time I was observing this, still almost the same, no clear progress occurred.
>>>    
>>>    Thanks,
>>>    
>>>    Khaled Omar
>>>    
>>>    -----Original Message-----
>>>    From: Scott O. Bradner <[email-masked]> 
>>>    Sent: Wednesday, February 19, 2020 8:11 PM
>>>    To: Khaled Omar <[email-masked]>
>>>    Cc: IETF Rinse Repeat <[email-masked]>
>>>    Subject: Re: ipv4 and ipv6 Coexistence.
>>>    
>>>    Quite a few folk are already there - see https://www.google.com/intl/en/ipv6/statistics.html
>>>    
>>>    Scott
>>>    
>>>    
>>>
>>>
>>>
>>> **********************************************
>>> IPv4 is over
>>> Are you ready for the new Internet ?
>>> http://www.theipv6company.com
>>> The IPv6 Company
>>>
>>> This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.
>>>
>>>
>>>
>>
>> -- 
>> Mark Andrews, ISC
>> 1 Seymour St., Dundas Valley, NSW 2117, Australia
>> PHONE: +61 2 9871 4742              INTERNET: [email-masked]
> 
> 

_______________________________________________
Architecture-discuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/architecture-discuss