Subject: [arch-d] Invite to webex side meeting 03/25, 8:00 AM on "New IP Architecture and Protocols".

From: Toerless Eckert <[email-masked]>
Date: Fri, 20 Mar 2020 23:38:01 +0100

Dear colleagues

At IETF106, we had an inofficial IETF106 side meeting on New-IP Research,
see https://trac.ietf.org/trac/ietf/meeting/wiki/106sidemeetings

If you are interested to continue or join the discussion,
we would like to invite you to a followup, this time via webex:

Meeting invite/info below.

Please contact us for comments and questions:
  [email-masked], [email-masked]

Thank you
    Toerless

------ https://etherpad.wikimedia.org/p/v107-side-meeting
       (backup at: https://bit.ly/2WvxZFn )

Meeting
  Title: New IP Architecture and Protocols Meeting
  Time:  03/25/2020, 08:00 - 09:00 AM PST [1500 - 1600 UTC] (extend to 9:30 if needed)
                     07:30 - 08:00 AM PST [1430 - 1500 UTC] Webex testing if you need it.
  Where: Webex (see below)
     
Agenda 

The Internet Protocol (IP) has been used successfully in our times. But can it still support and implement emerging applications, industry verticals, and network infrastructural changes in the future? Some typical emerging applications include, but not limited to, industrial machine-to-machine communications, industrial control and manufacturing, driverless vehicles, and holographic type communications. The infrastructural changes include, for example, convergence and integration of satellite networks with terrestrial networks, ManyNets, and Industrial IoT. 

This is the 2nd in its series of New IP Research Side Meetings with the following as the objectives:
-        To share findings and observations about the Internet and its protocols regarding its fundamental weakness, incapability and vulnerability by its design. 
-        To explore the impacts of future applications to the IP architecture and protocols
-        To investigate the implications of infrastructural changes for the IP architecture and protocols 

1. Welcome  (Richard Li) - 5 minutes 
2. Forwarding Layer Problem Statement – (Stewart Bryant) – 30 minutes
            available at https://tools.ietf.org/html/draft-bryant-arch-fwd-layer-ps-00
3. An Evolution of Network Control: from Earth to Space (Dan King) – 30 minutes  
4. Next steps/wrap up (Richard Li) – 5 minutes

Tooling Logistics
Logistics:
   Webex: https://futurewei.my.webex.com/futurewei.my/j.php?MTID=mfa1d34bd6f206e768351e5b010cb1649
          Meeting number (access code): 627 299 859
          Meeting password: 8CjPUGgaR99
          ICS calender entry: https://futurewei.my.webex.com/futurewei.my/j.php?MTID=m035fce7bd56f4f654fa24a2fc2f8edaa
          More webex info: https://raw.githubusercontent.com/network2030/meetings/master/v107-side-meeting/webex_meeting.txt
     Meeting will not be recorded
     Please use chat channel to ask questions in text or queue yourself to ask questions in audio.
     Please mute yourself when not speaking.
     Email entered in Webex is not relevant (enter anything you want).
     Please read here for great IETF info how to use start/use webex:
        https://www.ietf.org/how/meetings/107/session-participant-guide/ 
   Etherpad URL:  https://etherpad.wikimedia.org/p/v107-side-meeting
      Please enter your Name, Affiliation into the Etherpad if you want to
      Etherpad will also be used to take minutes below, participants welcome to help
   GitHub URL: https://github.com/network2030/meetings/tree/master/v107-side-meeting
      Meeting minutes / participant list will be published to github after meeting together with slides here

Q&A/Discussion
   We think the meeting can be an informal side meeting without too much structure. 
   If you have a question to the attendees, please use the webex chat.
   If you have questions to the presenter, please wait for times when presenter asks for questions/comments
   As needed, we will use the IETF "+q" on the webex channel to form a question/comment queue
   We suggest to direct followup discussions to [email-masked] if you think it is of interest to the IETF.

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 20 Mar 2020 23:03:42 +0000

Hmm,

On 20/03/2020 22:38, Toerless Eckert wrote:
> We suggest to direct followup discussions to
> [email-masked] if you think it is of interest to the
> IETF.
AFAIK this is basically an initiative driven by one or
a small set of vendors. It is not an IAB activity and
this list is. ISTM somewhat cheeky to cast this as if
it were sort-of "official" by sending ICS invites to
this list and suggesting this list be used for follow
ups. I'm saying that as an individual and have not
asked other IAB folks what they think, but again
speaking personally, I'd be much happier if people
and organisations had a bit more style.

S.

---

From: Melinda Shore <[email-masked]>
Date: Fri, 20 Mar 2020 15:09:09 -0800

> and organisations had a bit more style.

That was close to my reaction, as well.

Melinda

-- 
Melinda Shore
[email-masked]

Software longa, hardware brevis

---

From: Tony Li <[email-masked]>
Date: Fri, 20 Mar 2020 16:15:40 -0700

And I hate to see the IAB stomp on discussions.

T

> On Mar 20, 2020, at 4:09 PM, Melinda Shore <[email-masked]> wrote:
> 
> _______________________________________________
> Architecture-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/architecture-discuss

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 20 Mar 2020 23:20:08 +0000

> And I hate to see the IAB stomp on discussions.

What discussion? What stomp?

I gave the list my (not the IAB's) reaction to those
semi-official looking emails.

Starting a real discussion first would be better from
my POV than what appears to be a corporate push. (I
don't blame you or any company for that, but I really
do lament the lack of style as I already said.)

S.

---

From: Christian Esteve Rothenberg <[email-masked]>
Date: Fri, 20 Mar 2020 20:31:57 -0300

My apologies for any ICS invites sent from my G calendar after "smartly"
adding all of you as guests while adding the calendar entry. My bad of
course not having paid attention to this "detail". Worse, it is the second
time I do this on a large mailing list.

Warm regards, keep calm and healthy
-ch

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 21 Mar 2020 13:53:57 +1300

Huh? It looks as if my calendar auto-generated an invite too. Very bizarre, and apologies. I will not use the 'import' feature again.

Regards
   Brian Carpenter

On 21-Mar-20 11:38, Toerless Eckert wrote:
> 2. Forwarding Layer Problem Statement â€“ (Stewart Bryant) â€“ 30 minutes
> 3. An Evolution of Network Control: from Earth to Space (Dan King) â€“ 30 minutes  
> 4. Next steps/wrap up (Richard Li) â€“ 5 minutes
> 
> Tooling Logistics
> Logistics:
>           ICS calender entry: https://futurewei.my.webex.com/futurewei.my/j..php?MTID=m035fce7bd56f4f654fa24a2fc2f8edaa

---

From: Scott Brim <[email-masked]>
Date: Fri, 20 Mar 2020 21:39:13 -0400

So ... is the only problem the invitations?

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 21 Mar 2020 02:24:03 +0000

Hi Scott,

> So ... is the only problem the invitations?

Well, I'm not expressing any opinion here/as of now on
the content of the proposals, I was really reacting
to the manner in which this was being aired, as if it
were somehow "official."

It'd (IMO) be much better to just send a mail saying
"here's <ref> the technical detail, whatcha think?" rather
than teeing up some pesudo-official presentations and
agenda'd meetings etc. In general, taking such a pseudo-
official approach tends to bias me towards thinking the
proponents themselves consider their arguments weak,
but that's just my own bias maybe, and I'm often wrong.

Cheers,
S.

---

From: Stewart Bryant <[email-masked]>
Date: Sat, 21 Mar 2020 11:10:07 +0000

..and also when the IAB fails to drive the changes needed in the Internet to support the evolving applications requirements or to properly track the changes in the Internet itself.

I did kind of think that the IAB would have had a 10 to 20 year evolution plan front and centre of its thinking, but I have never seen any evidence that it regards that to be one of its core responsibilities.

I also thought that the IAB ought to be an enabler of this thought process by encouraging input form others, but rather than that it seems to be a tightly closed community.

.. just saying.

- Stewart

> On 20 Mar 2020, at 23:15, Tony Li <[email-masked]> wrote:
> 
>

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 21 Mar 2020 17:56:48 +0100

On 2020-03-20, at 23:38, Toerless Eckert <[email-masked]> wrote:
> 
> Time:  03/25/2020, 08:00 - 09:00 AM PST [1500 - 1600 UTC] 

This information is broken (US is not on PST any more).

In any case, I have copied a pointer into 

https://trac.ietf.org/trac/ietf/meeting/wiki/ietf107replacements

which you can edit once you have figured out when you want to run that meeting.

Grüße, Carsten

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 24 Mar 2020 02:51:11 +0100

Stephen,

1) Wrt to side-meeting announcement:
In a similar way as you had planned for a side-meeting for Chirp,
we had planned an inofficial side meeting to offer discussing this
drafts topic until corona hit. So we just tried to set up a a virtual
inofficial side meeting as good as possible without any IETF
online collaboration tool support for such inofficial side meetings.

2) Wrt to discussion on a list vs. side meeting:
A lot of new -00 work to the IETF is first brought in front of a fitting
in-person IETF audience before being dicussed at length on lists, especially
when its not incremental work. In our case, this work was predated by
the IETF106 inofficial side meeting, after which we started to write
down the -00 draft and tried to find the best community to discuss this
with. Everybody told us to use [email-masked].

3) Wrt to [email-masked] being an IAB activity:
https://www.iab.org/mailman/listinfo/architecture-discuss
""The architecture-discuss list serves as a technical discussion forum for
all members of the IETF community that are interested in larger
architectural issues. ... ""
I do not see IAB being mentioned in the text at all. Maybe you want
to refine that text if the list is assumed to be subject to specific
IAB regulations not described yet. I would hope it is not, because
the current scope definition is IMHO very good.

4) Wrt. ICS invite "cheeky to cast .. sort-of official"
I think its clear now, that this ICS was a tragic accident by a third
party. I specifically DID NOT include an ICS because it clearly would be
too invasive on a list like architecture-discuss!! I can also not remember
(maybe i am wrong) that this list is used for official IAB
announcements / meeting invites either.

5) Wrt. "a bit more style"
Always happy to improve my collaboration style.
Let me know what is missing given above explanations.

Cheers
    Toerless

> and organisations had a bit more style.

pub   RSA 4096/7B172BEA 2017-12-22 Stephen Farrell (2017) <[email-masked]>
> sub   RSA 4096/36CB8BB6 2017-12-22
>

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 24 Mar 2020 03:22:42 +0100

Thanks, Carsten. 

Replaced PST with PDT in etherpad. Should i use PT, or just give up and
only use UTC exclusively ? *sigh* ;-)

There does not seem to be a good way for other folks to find the
page ietf107replacements page you created, or is it linked anywhere  ?

Would be great if other side-meetings where also encouraged to
schedule virtually, doesn't have to be during the actual IETF week itself.

Cheers
    Toerless