Subject: [arch-d] on the nature of architecture discussion (was: Re: [Chirp] Fwd: IETF 107 Vancouver In-Person Meeting Cancelled)

From: Toerless Eckert <[email-masked]>
Date: Thu, 2 Apr 2020 17:27:17 +0200

[Cc'ing to architecture-discuss, because this reply goes
beyond the scope of chirp.]

Stephen, *:

I don't think that a mailing list alone is a sufficient way to
encourage interested parties to invest significant amount of
cycles to contribute original work towards a subject even if
as a one off: document and/or presentation. If you want
people to invest cycles towards something you're interested in,
you need to give contributors a well defined opportunity to
engage in-person through a meeting (or virtual meeting
in the time of corona) and allowing the work invested to be
referenceable by future work of others (such as meeting
proceedings for presentations).

We have this mode of operations in hundreds of conferences
including IRTF, we have it in IETF WGs for standards, we do
not have this for architectural discussions for the Internet. 

Why not ?

Stephen, I know we may have a fundamental difference in opinion about
this if i correctly interpret your harsh criticism about my teams
organized inofficial side-meeting in march, but i for once don't
think that a discussion about internet architecture will magically
improve through the absence of such meetings.

Why is there no internet architecture discuss meeting slot in
every IETF meeting (virtual in times of corona) ? I can not
even start to comprehend why i am seemingly the only one asking
this question.

To me, providing such fairly open scoped meeting looks like
the most fundamental meeting the IAB should organize to engage
the community in an open fashion. Consider it the "dispatch"
equivalent of other areas.

Topics of special interest to IAB (such as chirp) could be
indicated as prioritized topics to encourage contribution to 
them, and if they show critical mass the could be dispatched
into separate forums.

I can see no outcome worse than what we seemingly have now on
this architecture-discuss mailing list: agony and inactivity
interrupted by often snide lecturing meta discussions about those who
attempt to contribute something, however well or badly that is done.

Cheers
    Toerless

On Thu, Apr 02, 2020 at 12:32:27PM +0100, Stephen Farrell wrote:
> 
> Hiya,
> 
> I only got one request to hold such a meeting so I guess
> we don't want one.
> 
> That, and the lack of activity on this list is a bit of
> a pity I think so ideas welcome as to how to energise a
> discussion... If you have such an idea, then please just
> start a new thread on the list.
> 
> Cheers,
> S.
> 
> On 10/03/2020 20:50, Stephen Farrell wrote:
> > 
> > Hi all,
> > 
> > Many of you will have seen this but we'll not be meeting
> > f2f in Vancouver this time. Hopefully things will have
> > improved by the timeframe of IETF108 and we'll be able
> > to enjoy a meeting then.
> > 
> > In the meantime, would people like to organise a call
> > in a few weeks to replace our planned get together in
> > Vancouver? If so, please mail me, the IAB or the list:-)
> > 
> > If we do want a call, the IESG have asked for a
> > bit of time to do some scheduling that they need to do
> > before WGs (and groups like us:-) start to schedule
> > such calls. So let's first see if we want a call and
> > then we can do scheduling.
> > 
> > Cheers,
> > S.
> > 
> > 
> > -------- Forwarded Message --------
> > Subject: IETF 107 Vancouver In-Person Meeting Cancelled
> > Date: Tue, 10 Mar 2020 12:10:27 -0700
> > From: The IESG <[email-masked]>
> > Reply-To: [email-masked]
> > To: IETF Announcement List <[email-masked]>
> > CC: [email-masked], [email-masked], [email-masked]
> > 
> > The IESG and the IRTF Chair have decided to cancel the in-person IETF
> > 107 Vancouver meeting. This decision is based on input we gathered from
> > Working Group (WG) and Research Group (RG) chairs about our ability to
> > hold productive WG and RG sessions at IETF 107. Our assessment of this
> > feedback is that a majority of sessions would not be viable if we were
> > to hold the in-person IETF meeting. On this basis, we believe we cannot
> > hold an effective in-person meeting.
> > As a result of this cancellation, the in-person Hackathon, Code Sprint,
> > all other in-person events planned for the weekend of March 21-22, the
> > chairs training scheduled for March 20, and all other in-person sessions
> > during the week are cancelled.
> > 
> > The IESG is working on an alternative all-virtual agenda for the week of
> > March 21-27 with a limited schedule adapted to accommodate the time
> > zones of as many participants as possible. We are also planning to
> > support an increased volume of virtual interim meetings during the weeks
> > that follow. We will send another update to the community soon with more
> > information about these plans. The Hackathon organizers are also
> > considering plans for virtual Hackathon support.
> > 
> > We have re-opened Internet-Draft submissions, which had been closed on
> > March 9 in anticipation of the in-person meeting. Internet-Drafts may be
> > submitted at <https://datatracker.ietf.org/submit/>.
> > 
> > A separate announcement from the IETF Executive Director will follow
> > with details about registration cancellations and refunds.
> > These are unusual times given the circumstances created by the spread of
> > COVID-19.  We hope that everyone remains safe and healthy.
> > 
> > Regards,
> > The IESG and the IRTF Chair
> > 
> > _______________________________________________
> > IETF-Announce mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/ietf-announce
> > 
> > 
> > 

pub   RSA 4096/7B172BEA 2017-12-22 Stephen Farrell (2017) <[email-masked]>
> sub   RSA 4096/36CB8BB6 2017-12-22
> 

> -- 
> Chirp mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/chirp

-- 
---
[email-masked]

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 2 Apr 2020 16:32:05 +0100

Hiya,

> Why not ?

I'd be really happy to organise a meeting for chirp. [1]
If people want one, just mail me or that list.

But, I asked on the list already, as I just said, and
only 1 person was interested, so I'm very puzzled as
to what it is you are complaining about.

S.

[1] https://www.iab.org/mailman/listinfo/chirp

---

From: Jari Arkko <[email-masked]>
Date: Thu, 2 Apr 2020 18:37:02 +0300

Toerless, you ask good questions. But I’d say it is difficult to discuss a large topic in the abstract. Not saying we shouldn’t have arch-dispatch, but it isn’t immediately obvious to me that such a meeting would work well. It is however easier to discuss more specific issues, and for those there does exist many IAB-sponsored meetings (such as ones Stephen has helped set up), IRTF RG meetings looking at interesting Internet evolution topics, and meetings outside IETF meeting week (such as workshops). And ultimately there are of course many more private gatherings where some smaller set of people are starting to discuss a new topic.

Jari

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 2 Apr 2020 18:14:57 +0200

On Thu, Apr 02, 2020 at 06:37:02PM +0300, Jari Arkko wrote:
> Toerless, you ask good questions. But I???d say it is difficult to discuss a large topic in the abstract. Not saying we shouldn???t have arch-dispatch, but it isn???t immediately obvious to me that such a meeting would work well.

I am sure it will not work well initially because it would be
new for us, but i am even more persuaded we should attempt to
do it and give it time through iteration and learning of how
to improve the process. For example, like in research
conferences, we might need to invest more into upfront
vetting/review of proposals - but not to limit the topics, but
to improve the quality. 

And we can look at the continuum of useful outputs:

On one end, there is a one-off draft/presentation, but it could
still turn out to be viable long-term reference for further
followup work. And compared to all those research conferences
we would have the chance for the community to review and
help improve the document through few iterations, even if it
stops there. Such as many abandoned IETF drafts. IMHO still
a lot better outcome than that of many journal published research
conference papers.

On the other end is the criticial mass of interested parties that
drive a topic over to a community vetted/approved RFC. But we
do not even have such a process for possible architecture RFCs
and IMHO existing IETF WGs mostly start when the architecture
is defined well enough already.

> It is however easier to discuss more specific issues, and for those there does exist many IAB-sponsored meetings (such as ones Stephen has helped set up)

The main problem to limit discussions to more specific topics
is always the problem of timelyness and priorities between
what the organizers think is of interest and what possible
contributors think.  Especially when there are commercial
divergences if not conflicts. 

> IRTF RG meetings looking at interesting Internet evolution topics, and meetings outside IETF meeting week (such as workshops).

Unfortunately, i have seen very strong rejection by the IRTF chair
to consider topics he deems to be more architectural in nature than
"research" in nature. Starting even with the problem of what
composition model we want or the like to have for system level
architecture or principles of how to evolve the forwarding plane.
And i would have no argument about that distinction if we just
had an architecture track as we have a reearch track to do the work.

> And ultimately there are of course many more private gatherings where some smaller set of people are starting to discuss a new topic.

Who are not even given equal access to collaboration tools in the IETF
community (concern raised at plenary by me). because of the IMHO bogus
argument of fear of "endorsement". 

Cheers
    Toerless

> Architecture-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/architecture-discuss

-- 
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 2 Apr 2020 18:37:05 +0200

I am complaining about the absence of a recurring, IAB organized
architecture-discuss/dispatch meeting slot at IETF meetings.

If we had this, then you could indicate that 'chirp' contributions are
a preferred topic to be presented/discussed in such a track.

You do encourage contributions by giving them these incentices:
recurring meeting with longer time horizon: ability to plan putting cycles
into a contribution. Present in a larger context of an arch-discuss
track == reach out to more opportunistic participants.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 2 Apr 2020 17:44:24 +0100

(dropping the chirp list...)

> architecture-discuss/dispatch meeting slot at IETF meetings.

Ok, I think I now get  what you're after. Not sure I'm
convinced it'd be worthwhile, but if people wanted to
try that, then saying so, and I guess suggesting topics
to cover would be the things to do I guess. Then the
IAB could think about that input and whether such
sessions might be a good idea or not.

S.

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 2 Apr 2020 19:30:58 +0200

> sessions might be a good idea or not.

Thanks. As i said, a one-off will not succeed, but there should
be the will to think/work on improving this through experience.

Asking for submissions to be sent out earlier (even 1 month)
to allow for pre-meeting vetting for example is a good step. Assigning
designated reviewers might even be better. Lets experiment.
We all know how more difficult these broader topic discussions
are, but we have done very little experimentation in the
past trying to improve.

Also, wrt. IAB workshops and the like:

- The co-location of IRTF work into IETF weeks is i think very
  successful for that community. I wish the IAB would consider
  this option more. 
- With corona/virtual meetings we should IMHO simply have a joint,
  integrated IRTF/IAB/IETF activities calender over e.g.: a period of one
  "virtual" meeting month and use the same/inified tooling/publishing mechanisms.
  That gives contributors  hopefully the same attendance cross-polination opportunity
  as the physcial IETF week.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Melinda Shore <[email-masked]>
Date: Thu, 2 Apr 2020 11:14:46 -0800

> not have this for architectural discussions for the Internet. 

FWIW, many years ago we had these discussions in the technical
plenaries.  They were, as a rule, unproductive, which may be why
they have fallen by the wayside.

I'm curious to know what you think would change if there were
structured general architectural discussions.

Melinda

-- 
Melinda Shore
[email-masked]

Software longa, hardware brevis

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 2 Apr 2020 21:34:30 +0200

> they have fallen by the wayside.

I vaguely remember there was something, but i don't remember the format. 

> structured general architectural discussions.

Was it only presentations or also associated drafts ? Was the
material asked to be make available sufficiently long ago to
allow quality updates be prior review ? Was there an organized
attempt to get upfront or afterwards reviews ? Was there an associated
email discussion forum ? Was there the opportunity to follow up
across multiple such plenaries to refine the content ? Was
there somebody responsible trying to help with a dispatch style
mechanism to help get material further reviewed by other IETF/IRTF
groups that might hav emore interest ? Was there any attempt to
force authors to fold feedback into updated documents so that
final versions summarized not only author opinion but also community
feedback ?  Just off the top of my head. There certainly a lot more
aspects.

I think we know a lot of the process steps that can help to make
discussions/presentations about these difficult topics more successful,
i don't think we experiment enough with them. Especially not on
what i think is the architecture track. We only have well working
tracks for research and standardization. Not architecture. 

But architecture specifically could learn and experiment with a lot
of the mechanisms in the range from research conferences over to
IETF WGs.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 3 Apr 2020 08:50:17 +1300

>> architecture-discuss/dispatch meeting slot at IETF meetings.

I don't think you should place any reliance on "meetings" in the traditional
sense for the coming few years. Whether the sort of thing you want can
happen in on-line meetings is less clear to me, since on-line meetings
require floor-control, which is not what you want in any sort of
wide-ranging blue-sky discussion.

<snip>

> structured general architectural discussions.

I think that the most important architectural documents have generally
originated from inspired individuals, not from structured discussions.

Examples (intentionally ancient): 
https://tools.ietf.org/html/rfc871
https://tools.ietf.org/html/rfc875

    Brian

---

From: Melinda Shore <[email-masked]>
Date: Thu, 2 Apr 2020 11:58:34 -0800

On 4/2/20 11:34 AM, Toerless Eckert wrote:
> allow quality updates be prior review ? 

Neither, really.  It largely consisted of heated discussions at
the mike lines.  While there were presentations, for the most
part they were not architectural in nature (with a few notable
exceptions).

My sense, from several decades of involvement in the IETF in
various capacities, is that 1) it would take years to get
agreement on a diagram of the current internet architecture
and what you'd end up would be aspirational rather than
descriptive; 2) architectural discussions in the past have
had minimal impact on actual protocol design; and 3) complexity
always wins in the end (the history and output of the NSIS
working group might be a particularly illustrative example
of the latter).

Right now, there is nothing stopping anybody from publishing
drafts and contributing to (or, indeed, leading) architectural
discussions in IETF working groups.  I'm not sure what
inferences we should make from the fact that for the most part
that's not happening now.

I'm skeptical about the actual value of what you're proposing
but as I said, there's nothing stopping you (or anybody else)
from starting up something informally, which would give us all
a better sense of the actual interest level and what the likely
output would be.

Also, note that there have been IAB programs like stackevo to
deal with these questions.

Melinda

---

From: [email-masked]
Date: Thu, 2 Apr 2020 14:30:51 -0700

> that's not happening now.

Well, we’ve tried that before. We’ve put in a great deal of time and effort to make architectural changes. And they were met 
with total indifference.

My takeaway from this is that the only time that change is welcome or even possible is when there is a great deal of 
(perceived) pain. The pain MUST be much much greater than the pain of change. Architectural improvement is not welcome.

The last time the IAB articulated that there was such a threat of pain was the ROAD conference in the early ‘90s. That
led to the architectural (non)change of IPv6.

Thus, until there is a serious architectural threat, the only thing to do is to sit quietly and wait for time to pass.

Regards,
Tony

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 3 Apr 2020 01:14:48 +0200

On Fri, Apr 03, 2020 at 08:50:17AM +1300, Brian E Carpenter wrote:
> sense for the coming few years.

Just because i am trying to be more positive about a victory over corona
doesn't mean i would not also like to use this sad opportunity for
the community to work out better ways to leverage virtual meetings.

> Whether the sort of thing you want can

I don't think this particular topics issues are any different than
those of other tracks. The need for floor control is independent
of whether you are on-line or physcially in a room. It purely depends on the
number of passionate participants and the degree of passion about
the topic. Typically we have these actual discussions mostly in
official/inofficial side-meetings these days, typically through the
absence of powerpoint.

Not commenting on the technical aspects of the on-line meeting
aspects, thats better done on [email-masked].

> https://tools.ietf.org/html/rfc875

Yes, what would today likely be individual submission track is always
a good option to consider. Not sure how much more hurdles would be
in a way to do the same today. Certainly a lot more than what it did
to publish an acuel, true to the name "Request For Comment" back then.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 3 Apr 2020 03:05:13 +0200

> part they were not architectural in nature (with a few notable

Ok, remembering some bits now.
That was fun, but yes, not what i was thinking of.

> descriptive;

I think we can and are doing descriptive. Most of stackevo
mentioned by you below was descriptive. So are IMHO
many other documents/RFC i would consider to be architectural.

I can think of aspirational as a good and even necessar thing. 

> 2) architectural discussions in the past have
> had minimal impact on actual protocol design;

That is a very broad statement. We should first have an
unserstanding about what we mean with architecture before
i should even ask you to give me example evidence of this.

My architecture interests for example are probably a lot lower 
inside the machine room of the Internet than e.g. the
Internet BGP peering architecure. But all of it is valid
architecture topics to me.

For example, i would consider CBOR an example of an
architcure concept (presentation layer) brought into
IETF and protocols.

One example architecture area of interest for me is the problem that we
are not well enough taking the architecture of routers in to
account for our protocols, or better yet propose to evolve
architecture of both routers and protocols to be better fits in the
future.

I am betting neither of these topics are what you would
have considered to be architecture in your statement... ??

> and 3) complexity

If architecture can be associated directly with protocols
of an IETF WG, then yes, it could and should happen
in that WG, but i think there are more cases where even
this does not happen. E.g.: I have seen ADs eliminate architecture
from charters because it does not produce implementable protocols.

But the more fundamental issue is that architecture mostly
needs to predate protocol development, like research mostly
needs to predate architecture and protocols. I can not
see a logic that argues we must have an IRTF, but we cannot
have an IATF (Internet Architecture Task Force). The
whole construct of IAB for architecture is weird to me.

> a better sense of the actual interest level and what the likely

Oh, i think there is a lot of sport in trying to discourage work
that is not officially sponsored by the IETF/IAB authorities
at least from my imited experience.

We need to be darn careful with every single word we
write about a side meeting. Make sure it is called "non official"
every time you mention it, having people seemingly "borrow"
sign up sheets for examination what could be wrong with them,
ending up with concerns of using the same color (!) as "official" IETF
meeting sign up sheets. Dismissive comments about even doing
a side-meeting, Not being allowed to use IETF tooling
like webex, jabber, wiki, etherpad, and so on.  Because using
IETF tools would mean "endorsement of the activity" *sigh*.

This is sad in general, but at a time when it is legally crucial
to make sure all communications is easily recognizeable as
public and published because of the US Govt. export regulations
(see EAR 734.7) it is outright dangerous to make it so difficult
for inofficial side-meetings to use or emulate the
public/published nature of official IETF meetings.

> deal with these questions.

Last RFC published in 2016. Concluded in 2019.
Followup to architecture-discuss according to closing mail.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 3 Apr 2020 02:23:30 +0100

Hiya,

This aspect is nothing to do with having or not having
meetings, so don't take this as a negative or positive,
but this bit of your mail hits a button of mine...

On 03/04/2020 02:05, Toerless Eckert wrote:
> needs to predate protocol development

I've always thought that Internet architecture was mostly
post-hoc "discovery" and wasn't really ex-ante invention.
But, I wasn't there, and haven't delved deeply, so I don't
claim to be sure. Has anyone tried to do a study to figure
out if either of those are reasonable descriptions that
match history?

Cheers,
S.

---

From: "John Levine" <[email-masked]>
Date: 2 Apr 2020 22:55:51 -0400

In article <[email-masked]> you write:
>needs to predate architecture and protocols.

Not to be unduly snarky, but have we already forgotten about OSI?

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 3 Apr 2020 12:36:01 +0100

> On 2 Apr 2020, at 20:58, Melinda Shore <[email-masked]> wrote:
> 

Regrettably the actions of the US Government excluded an active part of the IETF community from taking part in informal technical discussions.

If a principled position of the IETF is the inclusion of all competent contributors, we cannot have informal technical discussions until the US Government changes its position.

As far as I can tell, ignoring the position taken by the US Government puts us at risk as individuals regardless of our nationality or our affiliation.

Hence the request for formality in these discussions.

- Stewart

---

From: S Moonesamy <[email-masked]>
Date: Fri, 03 Apr 2020 05:24:47 -0700

Hi Toerless,
>whole construct of IAB for architecture is weird to me.

The "architecture" in the mailing list name is a misnomer.  For 
example, the last longest discussion was about Internet governance 
instead of architecture.  The problem could be the Internet 
Engineering Task Force if that entity views itself as the supreme 
body for Internet protocols.

>at least from my imited experience.

There might be some truth in the above.

>IETF tools would mean "endorsement of the activity" *sigh*.

Stephen expressed his opinion about that.  I doubt that we would be 
encouraging people to be open if we do not allow opinions which might 
be deemed as politically-incorrect.

I don't mind if anyone wishes to hold a side meeting.  The tools 
mentioned above are available to any organization.

>public/published nature of official IETF meetings.

If I understood correctly, the rationale for using (IETF) side 
meetings is that they offer a workaround for U.S. export 
restrictions.  It may be risky to do things like that.

Regards,
S. Moonesamy

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 3 Apr 2020 15:02:21 +0200

> Not to be unduly snarky, but have we already forgotten about OSI?

I thought the plan was that the next person asking
this question has to write an RFC comparing TCP/IP with ISO that
fairly takes into account the views of proponents of both sides.

So, you're going to write that draft ?

;-)

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 3 Apr 2020 17:11:15 +0200

On Fri, Apr 03, 2020 at 05:24:47AM -0700, S Moonesamy wrote:
> encouraging people to be open if we do not allow opinions which might be
> deemed as politically-incorrect.
> 
> I don't mind if anyone wishes to hold a side meeting.  The tools mentioned
> above are available to any organization.

Right now i have to find and use non-ietf tools to avoid not being
in violation with whatever unwritten IETF policy there is. I found
these for etherpad, i can pay for webex, it becomes of course annoying
with jabber and wiki.

I am mostly annoyed by the IMHO illogical nature of the current IESG
position that making tooling available, and therefore encouraging
more informal discussions in the community is the same as endorsing
the payload of that discussion. Especially given how it only applies
to the electronic tooling, not the physcial one (rooms).

> If I understood correctly, the rationale for using (IETF) side meetings is
> that they offer a workaround for U.S. export restrictions.  It may be risky
> to do things like that.

Just to be sure my points are not conflated:

In the absence of U.S. export restrictions, i would be making
exactly the same arguments here wrt. to the problems of doing
architecture work in the IETF and the need for using inofficial
side-meetings to make technical progress on things not currently
well supported by established official IETF structures. I would
just leave out the "dangerous" part.

EAR 734.7 does not distinguish between official or inofficial
meetings, it just talks about published/public exclusions to the
scope of the EAR and hence the applicability of the entity list.
So, if you follow the words of the regulation, inofficial
side-meetings are as much or as little of a workaround as
any other IETF or other SDO meetings are.

IMHO, whatever the type of meeting is, the main risk is the
one of selective investigation and prosecution, something where of course
Futurewei has to be a lot more concerned about than any other
company.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: S Moonesamy <[email-masked]>
Date: Fri, 03 Apr 2020 16:36:43 -0700

Hi Toerless,
>to the electronic tooling, not the physcial one (rooms).

It has been a while since I looked at the meeting room "policy".  I 
am not sure whether it was formalized or whether it is from some 
discussions about such meetings.  I could argue that it should be 
formalized but then I am not sure whether that would be a good 
idea.  Anyway, that does not solve the problem which you described 
above.  IASA could allow a requester to use idle resources for 
informal discussions.  It would be good if the informality is not 
debatable.  For example, would you ask me to sign a "blue sheet" if 
we have a discussion in the hallway?

>Just to be sure my points are not conflated:

Ok.

>Futurewei has to be a lot more concerned about than any other

I would not look at it as a matter of which entity would be a lot 
more concerned about.  It is better if that does not turn into a 
concern for the other entity.

Regards,
S. Moonesamy

---

From: Bob Briscoe <[email-masked]>
Date: Mon, 6 Apr 2020 14:25:31 +0100

Toerless,

I helped with a series of 'Re-Arch' research workshops from 2008 to 
2010. The name was about "re-architecting" the Internet (whatever that 
means), but the accepted papers included articulation of insights about 
the existing architecture. I was also involved in various activities 
before that to promote research investigation into the Internet's 
architecture. So, based on that experience, here's my 2 penny's worth.

You don't want to have "arch-dispatch" sessions too often. Good 
architectural ideas don't come up that often, so if you create too much 
space to talk about them, the vacuum will get filled with waffle. Once a 
year is probably enough. But then, if you detect waffle is starting to 
fill a vacuum, it's best to back off the timer to biennial. Of course, 
if some new activity spins out of this (as it sometimes should from an 
arch-dispatch activity), that takes on a separate existence that is more 
frequent than the annual cycle of dispatch sessions.

You certainly don't want to do this from mic lines. It's too easy for 
"random-ietf-bigot" to have opinions about architecture that don't add 
anything (other than for those collecting lists of opinions). 
Contributors need to have had to do some work, like writing an accepted 
paper, to even get into the room.

It needs to be framed in a context of actionable outcomes. I mean, 
something like arch-dispatch would be a suitable context, 'cos it gives 
out the "actionable-only" message. That doesn't preclude "vague 
thoughts", but only as long as they have the potential to lead to some 
change that will impact on real life once they firm-up.

So, IAB might be a more appropriate context than IRTF, but you want an 
environment that will attract researchers and thinkers. So the 
"political officers" need to be in the background managing the process 
rather than holding the floor.

The architecture of such a valuable artefact as the Internet can become 
highly political. Huge businesses have been built on the Internet's 
current architecture, with a vested interest for it not to change. One 
person's architectural improvement is destruction of someone else's 
business (selling hacks to work round architectural problems is big 
business). And one progression of changes destroys someone else's idea 
of how they thought changes would progress. So altho the discussion will 
often seem academic, the structure in which ideas are taken forward has 
to be resilient against the wars it might start. That part is much 
easier said than done.

Cheers

Bob

-- 
________________________________________________________________
Bob Briscoe                               http://bobbriscoe.net/

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 6 Apr 2020 14:54:52 +0100

> 
> You certainly don't want to do this from mic lines. It's too easy for "random-ietf-bigot" to have opinions about architecture that don't add anything (other than for those collecting lists of opinions). Contributors need to have had to do some work, like writing an accepted paper, to even get into the room.
> 

Interesting idea, let’s apply that to the IETF sessions as well: no one can get into the room unless that have published an RFC? 

On the other hand, perhaps not :)

- Stewart

---

From: Joseph Touch <[email-masked]>
Date: Mon, 6 Apr 2020 07:53:52 -0700

> On Apr 6, 2020, at 6:25 AM, Bob Briscoe <[email-masked]> wrote:
> 

In various areas, that’s called an echo chamber (or worse).

There are conferences with that reputation too; let’s not aspire to that.

Joe

---

From: Toerless Eckert <[email-masked]>
Date: Mon, 6 Apr 2020 17:51:34 +0200

Thanks for your insight, Bob

I don't think we do disagree too much except for the benefit of regular
frequency of having these "open" or "dispatch" style meeting. But
as i think i pointed out in other emails, i can think of a lot more
architectural aspects to be in scope than the whole "overall Internet
architecture".

The main issue really is that i think you need to keep an effort like
this running at maybe low flame for a while before possible contributors
will find opportunities to do something. Even if it is more documenting
uncontentuous BCPs or informational text around architecture topics.

Of course, you can not only have soapbox discussions, but it would
really be a lot of fun to have some amount of soapbox microphone lines
and then punish that by asking for it to be written down, and actually
tracking whether it was and rejecting further soapboxing until it
does get written down. Or any other strategies to actually foster
useful output. Catch the people where they are (bitching) and
redirect to something productive ;-)

Cheers
    Toerless

On Mon, Apr 06, 2020 at 02:25:31PM +0100, Bob Briscoe wrote:
> Toerless,
> 
> I helped with a series of 'Re-Arch' research workshops from 2008 to 2010.
> The name was about "re-architecting" the Internet (whatever that means), but
> the accepted papers included articulation of insights about the existing
> architecture. I was also involved in various activities before that to
> promote research investigation into the Internet's architecture. So, based
> on that experience, here's my 2 penny's worth.
> 
> year is probably enough. But then, if you detect waffle is starting to fill
> a vacuum, it's best to back off the timer to biennial. Of course, if some
> new activity spins out of this (as it sometimes should from an arch-dispatch
> activity), that takes on a separate existence that is more frequent than the
> annual cycle of dispatch sessions.
> 
> anything (other than for those collecting lists of opinions). Contributors
> need to have had to do some work, like writing an accepted paper, to even
> get into the room.
> 
> It needs to be framed in a context of actionable outcomes. I mean, something
> like arch-dispatch would be a suitable context, 'cos it gives out the
> "actionable-only" message. That doesn't preclude "vague thoughts", but only
> as long as they have the potential to lead to some change that will impact
> on real life once they firm-up.
> 
> environment that will attract researchers and thinkers. So the "political
> officers" need to be in the background managing the process rather than
> holding the floor.
> 
> highly political. Huge businesses have been built on the Internet's current
> architecture, with a vested interest for it not to change. One person's
> architectural improvement is destruction of someone else's business (selling
> hacks to work round architectural problems is big business). And one
> progression of changes destroys someone else's idea of how they thought
> changes would progress. So altho the discussion will often seem academic,
> the structure in which ideas are taken forward has to be resilient against
> the wars it might start. That part is much easier said than done.
> 
> Cheers
> 
> 
> Bob
> 

-- 
---
[email-masked]