Subject: [arch-d] Updates on IAB mailing lists

From: Tommy Pauly <[email-masked]>
Date: Mon, 20 Apr 2020 09:08:48 -0700

Hello architecture-discuss,

We’d like to share a few updates about IAB mailing lists, and solicit the community’s feedback on some new text.

First, Tommy Pauly will be joining Stephen Farrell on the (existing, but rarely employed) sergeants-at-arms team to help moderate the list.

Second, we’d like to clarify the sergeants-at-arms roles for the lists. The current description on https://www.iab.org/iab-mailing-lists/ <https://www.iab.org/iab-mailing-lists/> does mention that the lists use a sergeant-at-arms model for moderation, but does not describe what this role entails. It also does not specify if this role applies to all of the lists on the page, such as program lists.

We’re proposing adding the following text to https://www.iab.org/iab-mailing-lists/ <https://www.iab.org/iab-mailing-lists/>, largely based on the IETF list SAA. We’d love to hear feedback on this approach!

====

IAB mailing lists have sergeants-at-arms, whose role is ensure there are no inappropriate postings. Inappropriate postings consist of: spam and bulk e-mail; announcements of conferences or activities that are not sponsored or endorsed by the Internet Society, the IETF, or the IAB; unprofessional commentary, regardless of subject; and discussion of subjects unrelated to IAB policy, programs, activities, or technical concerns.

The sergeants-at-arms are empowered to restrict posting by a person or of a thread when the content is inappropriate and represents a pattern of abuse. Complaints regarding a decision should be referred to the IAB chair.

The current sergeants-at-arms for “[email-masked] <mailto:[email-masked]>” are Stephen Farrell and Tommy Pauly. For program-specific lists, the program chairs act as moderators. The "[email-masked] <mailto:[email-masked]>” list is moderated by the Temporary RFC Series Project Manager.

====

Third, we have many lists that are enumerated on the website that are for closed programs or past workshops. We checked the activity on these lists, and we believe that we can close the following lists. Any further discussion on these topics is welcome on architecture-discuss.

- [email-masked] <mailto:[email-masked]>
- [email-masked] <mailto:[email-masked]>
- [email-masked] <mailto:[email-masked]>
- [email-masked] <mailto:[email-masked]>
- [email-masked] <mailto:[email-masked]>
- [email-masked] <mailto:[email-masked]>
- [email-masked] <mailto:[email-masked]>
- [email-masked] <mailto:[email-masked]>
- [email-masked] <mailto:[email-masked]>
- [email-masked] <mailto:[email-masked]>

The remaining lists will be:

- [email-masked] <mailto:[email-masked]>
- [email-masked] <mailto:[email-masked]>
- [email-masked] <mailto:[email-masked]>
- [email-masked] <mailto:[email-masked]>

Best,
Tommy Pauly, on behalf of the IAB

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 20 Apr 2020 18:11:19 +0200

On 2020-04-20, at 18:08, Tommy Pauly <tpauly=[email-masked]> wrote:
> - [email-masked]

Really?  That is a somewhat specialized audience I don’t expect to find on architecture-discuss.

Grüße, Carsten

---

From: Mary Barnes <[email-masked]>
Date: Mon, 20 Apr 2020 14:29:56 -0500

The third point about closing all those other lists should really go to the
main IETF discussion list - it's really orthogonal to those other lists,
which are intentionally very narrow in scope and were often limited to
program members. Those other lists were never considered to be under the
purview of the architecture-discuss mailing list (at least not when I took
over as IAB executive director nor while I was an IAB member).

The architecture-discuss list had been around for a long time but hadn't
been used much at all until recently.  I think is a good thing that it is
now being used.

Regards,
Mary.

On Mon, Apr 20, 2020 at 11:12 AM Carsten Bormann <[email-masked]> wrote:

> _______________________________________________
> Architecture-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/architecture-discuss
>

---

From: Mary Barnes <[email-masked]>
Date: Mon, 20 Apr 2020 14:34:11 -0500

Just to be clear, my point is that architecture-discuss was not intended to
be an IAB discussion list any more than IETF discussion list is scoped to
IESG discussion.

On Mon, Apr 20, 2020 at 2:29 PM Mary Barnes <[email-masked]>
wrote:

> The third point about closing all those other lists should really go to
> the main IETF discussion list - it's really orthogonal to those other
> lists, which are intentionally very narrow in scope and were often limited
> to program members. Those other lists were never considered to be under the

---

From: Mirja Kuehlewind <[email-masked]>
Date: Mon, 20 Apr 2020 21:37:38 +0200

Hi Mary, hi Carsten,

Please find some more information about these lists here:

https://www.iab.org/iab-mailing-lists/

The lists we propose to close didn’t have any traffic for a long time and most of them have been used for discussion related to an IAB workshop or IAB program that doesn’t exist anymore.

We plan to confirm on each of the list that they can be closed.

Mirja

> On 20. Apr 2020, at 21:29, Mary Barnes <[email-masked]> wrote:
> 
> The third point about closing all those other lists should really go to the main IETF discussion list - it's really orthogonal to those other lists, which are intentionally very narrow in scope and were often limited to program members. Those other lists were never considered to be under the purview of the architecture-discuss mailing list (at least not when I took over as IAB executive director nor while I was an IAB member).  
> 
> The architecture-discuss list had been around for a long time but hadn't been used much at all until recently.  I think is a good thing that it is now being used. 
> 
> Regards,
> Mary.
>

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 20 Apr 2020 22:30:51 +0200

> The lists we propose to close didn’t have any traffic for a long time and most of them have been used for discussion related to an IAB workshop or IAB program that doesn’t exist anymore.

For i18n-discuss, there are occasional flares of activity, the last significant one 2018-12.
This is not “for a long time”.
These flares reached exactly the right set of people.
Is there a reasonable alternative that doesn’t waste the time of hundreds of others?

> We plan to confirm on each of the list that they can be closed.

OK, so I can shut up here now.

Grüße, Carsten

---

From: S Moonesamy <[email-masked]>
Date: Mon, 20 Apr 2020 13:54:29 -0700

Dear Mr Pauly,
At 09:08 AM 20-04-2020, Tommy Pauly wrote:
>We'd like to share a few updates about IAB mailing lists, and 
>solicit the community's feedback on some new text.
>
>First, Tommy Pauly will be joining Stephen Farrell on the (existing, 
>but rarely employed) sergeants-at-arms team to help moderate the list.
>
>Second, we'd like to clarify the sergeants-at-arms roles for the 
>lists. The current description on 
>https://www.iab.org/iab-mailing-lists/ does mention that the lists 
>use a sergeant-at-arms model for moderation, but does not describe 
>what this role entails. It also does not specify if this role 
>applies to all of the lists on the page, such as program lists.
>
>We're proposing adding the following text to 
>https://www.iab.org/iab-mailing-lists/, largely based on the IETF 
>list SAA. We'd love to hear feedback on this approach!

I would like to thank the Internet Architecture Board for requesting 
feedback about the [email-masked] mailing list.  Given 
the domain name in that email address, isn't it a mailing list which 
falls under the Internet Engineering Task Force?

There was an announcement about the moderators some time ago.  I 
don't recall seeing them  described as "sergeant-at-arms".  I looked 
up the term and I found this: "in feudal England a sergeant at arms 
was an armed officer of a lord and was often one of a special body 
required to be in immediate attendance on the king's person, to 
arrest traitors and other offenders".  Given some recent 
interventions on the ietf@ mailing list, I would not suggest the 
sergeant at arms as a model to follow.

Regards,
S. Moonesamy

---

From: Tommy Pauly <[email-masked]>
Date: Mon, 20 Apr 2020 14:04:41 -0700

Hi S. Moonesamy,

Thanks for your response!

> On Apr 20, 2020, at 1:54 PM, S Moonesamy <[email-masked]> wrote:
> 
> Dear Mr Pauly,
>> We'd like to share a few updates about IAB mailing lists, and solicit the community's feedback on some new text.
>> 
>> Second, we'd like to clarify the sergeants-at-arms roles for the lists. The current description on https://www.iab.org/iab-mailing-lists/ does mention that the lists use a sergeant-at-arms model for moderation, but does not describe what this role entails. It also does not specify if this role applies to all of the lists on the page, such as program lists.
>> 
>> We're proposing adding the following text to https://www.iab.org/iab-mailing-lists/, largely based on the IETF list SAA. We'd love to hear feedback on this approach!
> 
> I would like to thank the Internet Architecture Board for requesting feedback about the [email-masked] mailing list.  Given the domain name in that email address, isn't it a mailing list which falls under the Internet Engineering Task Force?

This mailing list is, in fact, an IAB-sponsored activity. The email address is confusing for historical reasons. [email-masked] <mailto:[email-masked]> is an alias for the same list.

> 
> There was an announcement about the moderators some time ago.  I don't recall seeing them  described as "sergeant-at-arms".  I looked up the term and I found this: "in feudal England a sergeant at arms was an armed officer of a lord and was often one of a special body required to be in immediate attendance on the king's person, to arrest traitors and other offenders".  Given some recent interventions on the ietf@ mailing list, I would not suggest the sergeant at arms as a model to follow.

The SAA role for the mailing list already existed, and the goal of this text is to clarify what the role is on the public website. It is primarily a way to moderate spam and ensure that a mailing list is a respectful and productive space. If there are particular suggestions for the content and scope of the role in terms of the textual description, I’d be happy to hear them.

Thanks,
Tommy

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 21 Apr 2020 09:10:34 +1200

On 21-Apr-20 07:34, Mary Barnes wrote:
> Just to be clear, my point is that architecture-discuss was not intended to be an IAB discussion list any more than IETF discussion list is scoped to IESG discussion. 

Not quite accurate - see below. Especially "This is an IAB-sponsored activity...".

   Brian

-------- Forwarded Message --------
Subject: New architecture-discuss mailing list forum
Date: Mon, 17 Oct 2005 16:00:54 -0400
From: Leslie Daigle <[email-masked]>
To: IETF Announcement list <[email-masked]>
CC: [email-masked], [email-masked], [email-masked]

A new mailing list has been created to provide a forum for general
discussion of Internet architectural issues:

   [email-masked]
   https://www1.ietf.org/mailman/listinfo/architecture-discuss

The architecture-discuss list serves as a technical discussion forum for
all members of the IETF community that are interested in larger
architectural issues. It is meant to be an open discussion forum for
all long and/or wide range architectural concerns related to the
Internet Architecture. In particular, it may be used to discuss and
bring forth different points of view on controversial architectural
questions. Discussions that drill down and dwell on specifics of
individual protocols or technologies are to be discouraged, redirected
to appropriate other fora, or re-cast to discussions of broader
implications for Internet architecture.

This is an IAB-sponsored activity, but IAB members will be
participating as individuals and not representatives of the IAB. As
such, postings to list must not be considered as IAB opinion, and must
not be quoted as such. Indeed, it is expected that IAB members will
disagree with each other, at least occasionally, just like the any
part of this community.  :-)  Note that questions asking for an official
IAB opinion, issues requiring immediate action (by anyone), issues
related to the way the IETF operates, do not belong on this list.
Issues pertaining to IAB business should still be directed to
[email-masked] .

Leslie Daigle,
for the IAB.

------------------------

[Some examples of potential topics for discussion, provided by Pekka Nikkander]

1. Mobility and multi-homing

The IETF currently hosts a bunch of working groups focusing on  various aspects
of mobility and multi homing.  At the Internet Area,  there are five WGs and a
couple of almost-WGs charted for standards  track work: MIP4, MIP6, NEMO, SHIM6,
MONAMI6, and NETLMM.  In  addition to those, there are experimental approaches,
such as HIP,  and optimisations, such as MIPSHOP and MOBOPTS.  Outside of the 
Internet area, MOBIKE is focusing on mobility and multi-homing for  IPsec and
SCTP and DCCP folks have had their mobility and multi- homing discussions.  The
wider research community is full of various  proposals, including overlay
approaches (such as i3) and underlay  approaches (such as using MPLS tunnels to
implement host routes).

Given this multitude of work and even partially overlapping standards  track
solutions, what would be the right way or right ways forward?   Could we design
a way towards converging solutions?  How do we ensure  robustness of solutions
if we attempt to deploy multiple solutions at  the same time; for example, SHIM6
+ Mobile IPv6 + SHIM6?  How do more  unified solutions, like using CGA-based
mobility with SHIM6 contrast  to this?  What about using HIP with routable IP
addresses instead of  Host Identity Tags (HITs) as Upper Layer Identifiers? 
Going a little  bit furthermore, what are the architectural impacts of doing
mobility  and multi-homing at the IP layer vs. other layers?

2. IP virtualisation

In the recent discussion w.r.t. tunnelling at the Internet Area list,  a clear
need for virtualisation came up.  While tunnelling with clear 
implementation-level virtualisation boundaries is clearly one viable  way to
implement virtual IP networks on the top of the "real" IP  infrastructure, this
issue seems to warrant some deeper digging.   Tunnelling has well known
drawbacks, and we may want to ask what  would be the alternatives.  In order to
understand alternatives, if  any, we need to understand better the requirements
behind IP  virtualisation, or what people *really* want to achieve with it.  Is
it merely ease of configuration, or reduced operational costs?  If  so, could
there be other architectural ways of achieving the same  ease or perhaps even
larger capital and operational savings?  Some  people have been promoting adding
"realms" as a first class service  to the base IP.  Would that provide an
alternative solution?

While the mobility and multi-homing discussion seems to more circle  around
evaluating existing proposals and trying to navigate towards  more unified
solutions, here we seem to lack genuine alternatives and  deep understanding of
the real problem domain.

3. Overall open architectural issues

Some IAB members have been collecting open architectural issues for a  while,
with the intention of bringing up an up to date collection of  information at a
later date, probably in a form of a WikiPedia-like  web site.  This work is
going on, and we'd like to get as much  information as possible from the wider
community.  Hence, suggestions  on what are the more pressing longer-term open
issues are very  welcome.  To given an idea of the current issues so far
identified,  here is a partial list.  The list doesn't say much without 
explanation, but it may give an idea of the type of issues we are  looking at.

End-to-end connectivity
=======================

The original value of the Internet, the ability to connect to any  host with
any protocol, has eroded away during the last decade. While  it is impossible to
get back to the original mode of operation,  largely due to security reasons,
some form of better-than-today end- to-end connectivity would be very valuable.

o Living with NATs, filters, and firewalls
o Introducing identity realms or domains
o Evolving the application interface (API)

End-user experience
===================
o Transparent security
o Zero Configuration and Service Discovery

Balancing Accessibility, Security, and Privacy
==============================================
o System for plausible sender identity for received packets
o Secure self-configuration
o Integrating security across the stack
o Dealing with bad traffic

_______________________________________________
IETF-Announce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf-announce

---

From: S Moonesamy <[email-masked]>
Date: Mon, 20 Apr 2020 14:26:49 -0700

Dear Mr Pauly,
At 02:04 PM 20-04-2020, Tommy Pauly wrote:
>This mailing list is, in fact, an IAB-sponsored activity. The email 
>address is confusing for historical reasons. 
>[email-masked] is an alias for the same list.

Ok.

>The SAA role for the mailing list already existed, and the goal of 
>this text is to clarify what the role is on the public website. It 
>is primarily a way to moderate spam and ensure that a mailing list 
>is a respectful and productive space. If there are particular 
>suggestions for the content and scope of the role in terms of the 
>textual description, I'd be happy to hear them.

Most of the mailing list I am subscribed to have a moderator.  The 
practice is for the person to curtail spam and see that mailing list 
discussions do not go out of hand.  If I had a suggestion to make, it 
would be to figure out a description which the IAB members consider 
as appropriate for this mailing list.

It may happen that you take a decision which I disagree with.  It 
does not mean that you are wrong or that you are doing a bad 
job.  That is the nature of things.

Regards,
S. Moonesamy

---

From: Mary Barnes <[email-masked]>
Date: Mon, 20 Apr 2020 17:18:51 -0500

So, that predates my tenure on the IAB by about 6 years, so we probably had
rolled over a lot of the IAB at that time by then (it looks like Dave
Thaler would have been the only one left from that era).   It would have
been more clear had the last paragraph been included as part of the list
description:

And, maybe it should be added now.  Right now this is the list description,
which says nothing specific to the IAB:
The architecture-discuss list serves as a technical discussion forum for
all members of the IETF community that are interested in larger
architectural issues. It is meant to be an open discussion forum for all
long and/or wide range architectural concerns related to the Internet
Architecture. In particular, it may be used to discuss and bring forth
different points of view on controversial architectural questions.
Discussions that drill down and dwell on specifics of individual protocols
or technologies are to be discouraged, redirected to appropriate other
fora, or re-cast to discussions of broader implications for Internet
architecture.

Regards,
Mary.

On Mon, Apr 20, 2020 at 4:11 PM Brian E Carpenter <
[email-masked]> wrote:

> > Just to be clear, my point is that architecture-discuss was not intended
> to be an IAB discussion list any more than IETF discussion list is scoped
> to IESG discussion.
>

---

From: John C Klensin <[email-masked]>
Date: Mon, 20 Apr 2020 18:47:18 -0400

Carsten,

I was just about to ask the same question and make the same
point.  As far as I know, there are no other lists in the IETF
community available for discussions of, or raising questions
about, general i18n questions.  The closest approximation I know
of is the ART Area i18n Directorate list and I don't believe
that is an open list.  If the IAB wants to be rid of this one
--perhaps consistent with shutting the Program down-- then may I
suggest they work with the IESG as needed to get a non-WG list,
ideally of the same name, set up?

thanks,
   john

--On Monday, April 20, 2020 22:30 +0200 Carsten Bormann
<[email-masked]> wrote:

>> The lists we propose to close didn't have any traffic for a
>> long time and most of them have been used for discussion
>> related to an IAB workshop or IAB program that doesn't
>> exist anymore.
> 
> For i18n-discuss, there are occasional flares of activity, the
> last significant one 2018-12. This is not "for a long
> time".
> Is there a reasonable alternative that doesn't waste the
> time of hundreds of others?
>

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 21 Apr 2020 00:13:26 +0100

Hi SM, all,

On 20/04/2020 22:26, S Moonesamy wrote:
> Most of the mailing list I am subscribed to have a moderator.

Yeah, that term is more familiar to me too, whereas the SAA
term seems to me like an oddity, both for ietf@ietf and in
this case. I'd be happy to see suggested better terms but
can also live with the oddity.

To be honest, when I agreed to help look after the arch-d
list, I didn't actually know the SAA term was how that was
described - I only copped onto that a few weeks ago when I
actually looked back at the text on the web page;-) And I
haven't actually had to do anything acting in an SAA-role
at all in the year since, which is good. (I did send less
than a handful of mails for list management reasons but
zero of a "do this or else" nature.) I'm nonetheless quite
happy that Tommy is willing to help out in my inactivity!

Other than that, I won't try answer all the mails, but
there is no intent to change what's an ok topic for
discussion, nor the scope of any list - this is all just
bookkeeping, so at least from my POV, not a biggie. But
if, as a result, we improve how the various lists are
described, and people's understanding of that, that seems
like an improvement.

Lastly, wrt the other lists we might close, it was me who
went over those and I only checked for recent traffic, so
Tommy's mail doesn't mean "we want to shut down discussion"
but rather "do we still need this?" If the i18n list is
still periodically useful, then that's great and it'll
not end up closed. (And to be open about it, one of the
reasons we wanted to sort all this out was because as
soon as we touched anything, we risked creating ambiguity
as to whether the IAB might own this role for rfc-interest
and rfced-future - and IIRC no IAB member wanted us to
own that role for those lists, so we figured these tweaks
would settle that.)

Hope that helps,
S.

---

From: S Moonesamy <[email-masked]>
Date: Mon, 20 Apr 2020 17:27:56 -0700

Hi Stephen,

Thanks for the explanation.

I did a quick verification and saw that the i18n program was closed 
in 2017.  That matches my recollection.  I am aware that some of the 
other IAB programs were closed.  I don't have an opinion about 
whether to keep those mailing lists running.

I did not consider the rfced-future list when I wrote the email.  The 
rfc-interest list has been running without much intervention.  I may 
have an opinion about those lists.

I'll be quiet (for now) about the SAA model. :-)

Regards,
S. Moonesamy

---

From: "Christopher Wood" <[email-masked]>
Date: Tue, 21 Apr 2020 14:23:32 -0700

On Mon, Apr 20, 2020, at 9:08 AM, Tommy Pauly wrote:
> We’d like to share a few updates about IAB mailing lists, and solicit 
> the community’s feedback on some new text.
> 

Thank you both for your service!

> Second, we’d like to clarify the sergeants-at-arms roles for the lists. 
> The current description on https://www.iab.org/iab-mailing-lists/ does 
> mention that the lists use a sergeant-at-arms model for moderation, but 
> does not describe what this role entails. It also does not specify if 
> this role applies to all of the lists on the page, such as program 
> lists.
> 
> We’re proposing adding the following text to 
> https://www.iab.org/iab-mailing-lists/, largely based on the IETF list 
> SAA. We’d love to hear feedback on this approach!
> 
> ====
> 
> IAB mailing lists have sergeants-at-arms, whose role is ensure there 

nit: "whose role is ensure"

> are no inappropriate postings. Inappropriate postings consist of: spam 
> and bulk e-mail; announcements of conferences or activities that are 
> not sponsored or endorsed by the Internet Society, the IETF, or the 
> IAB; unprofessional commentary, regardless of subject; and discussion 
> of subjects unrelated to IAB policy, programs, activities, or technical 
> concerns.
> 
> The sergeants-at-arms are empowered to restrict posting by a person or 
> of a thread when the content is inappropriate and represents a pattern 
> of abuse. Complaints regarding a decision should be referred to the IAB 
> chair.
> 
> The current sergeants-at-arms for “[email-masked] 
> <mailto:[email-masked]>” are Stephen Farrell and Tommy 
> Pauly. For program-specific lists, the program chairs act as 
> moderators. The "[email-masked]” list is moderated by the 
> Temporary RFC Series Project Manager.
> 
> ====

This seems like a fine addition to me.

> Third, we have many lists that are enumerated on the website that are 
> for closed programs or past workshops. We checked the activity on these 
> lists, and we believe that we can close the following lists. Any 
> further discussion on these topics is welcome on architecture-discuss.
> 
> - [email-masked]
> - [email-masked]
> - [email-masked]
> - [email-masked]
> - [email-masked]
> - [email-masked]
> - [email-masked]
> - [email-masked]
> - [email-masked]
> - [email-masked]
> 
> - [email-masked]
> - [email-masked]
> - [email-masked]
> - [email-masked]

And this seems like a sensible way to consolidate ongoing discussions. 

Thanks for clearing and cleaning things up!

Best,
Chris

---

From: Bob Hinden <[email-masked]>
Date: Wed, 29 Apr 2020 08:10:46 -0700

Brian,

> On Apr 20, 2020, at 2:10 PM, Brian E Carpenter <[email-masked]> wrote:
> 
> Not quite accurate - see below. Especially "This is an IAB-sponsored activity…".

I agree.

I think it is fine and correct for the Internet Architecture Board (IAB) to have a public mailing list to allow discussion of the Internet Architecture.   That is, I would think, why we have the IAB.

Bob