Subject: [arch-d] ETSI Liaison Work

From: Rob Sayre <[email-masked]>
Date: Sat, 27 Jun 2020 23:00:42 -0700

Hi,

I had some questions about why the IETF might establish a formal liaison
relationship with ETSI, and why that might appear in IAB minutes, rather
than in the IETF/IESG. The document in question is here:

https://www.iab.org/documents/minutes/minutes-2020/iab-minutes-2020-05-27/

"3. ETSI Liaison Work
Zhenbin Li suggested that the IETF might want to consider trying to
establish a formal liaison with ETSI, noting a concern that there might be
overlap between work in the IETF TEAS WG and the ETSI Industry
Specification Group on Zero touch network and Service Management (ZSM).

...

Zhenbin Li agreed to follow up with Deborah Brungard and the Routing Area
Directors about whether there is need for a formal liaison relationship
with ETSI, and report back to the IAB."

ETSI had been unfamiliar to me, but I recently reviewed an ETSI application
for a TLS code point assignment:
https://mailarchive.ietf.org/arch/msg/tls/bkx_bXcPSt_TwE7iJRM9acOQkDA/

I was surprised that the IETF would entertain a 99-page PDF that no
individual signed their name to, but I do agree that code point assignment
is not meant to be a gatekeeping mechanism.

I did more research into ETSI after that, and this article turned up:

https://www.eff.org/deeplinks/2019/02/ets-isnt-tls-and-you-shouldnt-use-it

I would like to hear more from Zhenbin Li, Deborah Brungard, and the
Routing Area Directors about this proposal.

thanks,
Rob

---

From: Fred Baker <[email-masked]>
Date: Sun, 28 Jun 2020 00:43:26 -0700

Besides the fact that liaisons have been IAB territory for ages?

Sent from my iPad

> On Jun 27, 2020, at 11:01 PM, Rob Sayre <[email-masked]> wrote:
> 
> 
> Hi,
> 
> I had some questions about why the IETF might establish a formal liaison relationship with ETSI, and why that might appear in IAB minutes, rather than in the IETF/IESG. The document in question is here:
> 
> Zhenbin Li suggested that the IETF might want to consider trying to establish a formal liaison with ETSI, noting a concern that there might be overlap between work in the IETF TEAS WG and the ETSI Industry Specification Group on Zero touch network and Service Management (ZSM).
> 
> ...
> 
> Zhenbin Li agreed to follow up with Deborah Brungard and the Routing Area Directors about whether there is need for a formal liaison relationship with ETSI, and report back to the IAB."
> 
> ETSI had been unfamiliar to me, but I recently reviewed an ETSI application for a TLS code point assignment:
> I was surprised that the IETF would entertain a 99-page PDF that no individual signed their name to, but I do agree that code point assignment is not meant to be a gatekeeping mechanism.
> 
> I would like to hear more from Zhenbin Li, Deborah Brungard, and the Routing Area Directors about this proposal.
> 
> thanks,
> Rob

---

From: Rob Sayre <[email-masked]>
Date: Sun, 28 Jun 2020 00:46:23 -0700

> Besides the fact that liaisons have been IAB territory for ages?

This is a great response.

thanks,
Rob

---

From: "Paul Hoffman" <[email-masked]>
Date: Sun, 28 Jun 2020 08:14:07 -0700

On 27 Jun 2020, at 23:00, Rob Sayre wrote:

> than in the IETF/IESG.

A longer, hopefully more helpful, response to this part of the question 
can be found at:
    https://www.iab.org/liaisons/

> Specification Group on Zero touch network and Service Management 

Personally, I'm surprised that the IETF (through the IAB) does not have 
a liaison agreement with ETSI. The external liaison list is at:
    https://www.iab.org/liaisons/

Although there are always layer 8 and 9 reasons for having, or not 
having, liaison agreements, ETSI's work often plays into IETF's work in 
many different areas (I remember them from those always-entertaining 
PKIX days).

--Paul Hoffman

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 29 Jun 2020 09:00:13 +1200

>     https://www.iab.org/liaisons/

In fact, discussion between the IAB (on behalf of the IETF) and ETSI goes back at least to 1998 and there was a lot of collaboration over the years, either direct or through 3GPP.

Around 1998/1999, the IAB was reluctant to establish formal liaisons except with global-scope SDOs, and ETSI was still perceived then as regional (E = Europe), so we didn't. But that argument possibly doesn't apply today, and it seems reasonable for the IAB to discuss the question.

Liaison does not of course mean agreeing with what the other SDO does, but it does make review and comment of each others' work more prominent.

Regards
     Brian

> _______________________________________________
> Architecture-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/architecture-discuss
>

---

From: Rob Sayre <[email-masked]>
Date: Sun, 28 Jun 2020 14:03:30 -0700

On Sun, Jun 28, 2020 at 8:14 AM Paul Hoffman <[email-masked]> wrote:

> having, liaison agreements, ...
>

Yes. This is the substance of my question.

thanks,
Rob

PS - I used the word "reviewed", but I should have written "read and
commented", since no one asked me to do anything. :)

---

From: Guntur Wiseno Putra <[email-masked]>
Date: Mon, 29 Jun 2020 10:43:15 +0700

Dear Rob &
architecture-discuss,

Adding a collection of references on "ETSI" having not been mentioned so
far in this thread:

(By the help of the search engine available at "liaison statements" for
"ETSI":)
Total Statements: 94

https://datatracker.ietf.org/liaison/posted/?text=ETSI&source=&destination=&start_date=&end_date=

Regard,
Guntur Wiseno Putra

---

From: Rob Sayre <[email-masked]>
Date: Sun, 28 Jun 2020 21:15:23 -0700

Amazing work, thank you!

thanks,
Rob

---

From: Lizhenbin <[email-masked]>
Date: Mon, 29 Jun 2020 06:53:43 +0000

Hi Rob,

Thank very much for paying attention to the work. Please refer to my reply inline identified by '[Robin]'.

Best Regards,

Zhenbin (Robin)

________________________________
发件人: ietf [[email-masked]] 代表 Rob Sayre [[email-masked]]
发送时间: 2020年6月28日 14:00
收件人: IETF discussion list; [email-masked]
主题: ETSI Liaison Work

Hi,

"3. ETSI Liaison Work

...

Zhenbin Li agreed to follow up with Deborah Brungard and the Routing Area Directors about whether there is need for a formal liaison relationship with ETSI, and report back to the IAB."
[Robin] Thanks Paul to propose the following link which explains why IAB discussed the work.
https://www.iab.org/liaisons/

In addition, since there is no formal liaison between IETF and IAB and I work for the Liaison Oversight Program, I took the work to investigate the requirements for the liaison with IETF.
https://www.iab.org/activities/programs/iab-liaison-coordination-program/

https://www.eff.org/deeplinks/2019/02/ets-isnt-tls-and-you-shouldnt-use-it
[Robin] In fact the discussion for the liaison work is triggered by Daniele Ceccarelli (CCAMP WG Chair) this time. He asked if IETF needs to set up the liaison because of he had seen requests coming from NFV, ZSM and the new working group on security (don't remember the name) in ETSI which has a very high overlap with what we're doing in TEAS, CCAMP, OPSAWG. After discussion in the IAB meeting, it is suggested to discuss with Deborah and the routing ADs about the need. That is the reason why the RTG area is mentioned specially.
In the IAB meeting held on June 17, the need was discussed according to the feedback from Daniele Ceccarelli, Gonzalo Camarillo and Deborah Brungard and my collected information on the organization of ETSI. It seems that there is no need from Routing for a formal liaison relationship with ETSI at the working level. And the IAB discussed that there seems not much need to set up the higher level liaison with ETSI temporarily.
I think your proposed reference is very helpful to understand more about the possible liaison work between ETSI and IETF. I will go on to collect these feedback and propose them for IAB to evaluate. More suggestions on the work are welcome.

thanks,
Rob

---

From: Lizhenbin <[email-masked]>
Date: Mon, 29 Jun 2020 08:30:21 +0000

Hi Guntur,

It is very helpful. Thanks very much.

I will go through these liaison and go on to summarize the need for the ETSI Liaison work.

Best Regards,

Zhenbin (Robin)

________________________________
发件人: Architecture-discuss [[email-masked]] 代表 Guntur Wiseno Putra [[email-masked]]
发送时间: 2020年6月29日 11:43
收件人: Rob Sayre
抄送: [email-masked]; Paul Hoffman; IETF discussion list
主题: Re: [arch-d] ETSI Liaison Work

Dear Rob &
architecture-discuss,

Adding a collection of references on "ETSI" having not been mentioned so far in this thread:

(By the help of the search engine available at "liaison statements" for "ETSI":)
Total Statements: 94

Regard,
Guntur Wiseno Putra

Pada Senin, 29 Juni 2020, Rob Sayre <[email-masked]<mailto:[email-masked]>> menulis:
On Sun, Jun 28, 2020 at 8:14 AM Paul Hoffman <[email-masked]<mailto:[email-masked]>> wrote:

thanks,
Rob

PS - I used the word "reviewed", but I should have written "read and commented", since no one asked me to do anything. :)

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Tue, 30 Jun 2020 16:22:46 +0000

Hi Rob-
My perspective below-
Thanks-
Deborah

From: Architecture-discuss <[email-masked]> On Behalf Of Lizhenbin
Sent: Monday, June 29, 2020 2:54 AM
To: Rob Sayre <[email-masked]>
Cc: [email-masked]; IETF discussion list <[email-masked]>
Subject: [arch-d] 答复: ETSI Liaison Work

Hi Rob,

Best Regards,

Zhenbin (Robin)

________________________________
发件人: ietf [[email-masked]] 代表 Rob Sayre [[email-masked]]
发送时间: 2020年6月28日 14:00
收件人: IETF discussion list; [email-masked]<mailto:[email-masked]>
主题: ETSI Liaison Work
Hi,

https://www.iab.org/documents/minutes/minutes-2020/iab-minutes-2020-05-27/<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.iab.org_documents_minutes_minutes-2D2020_iab-2Dminutes-2D2020-2D05-2D27_&d=DwMFoQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=tA-v3h7bKzWgzXFTCNBDz8YMjuHgppZMjWYM5Y4vUDc&s=ecdYjyGvaSDaw99AoU1cW2yxRBfpI7cWbq5WQW1sJis&e=>

"3. ETSI Liaison Work

....

Zhenbin Li agreed to follow up with Deborah Brungard and the Routing Area Directors about whether there is need for a formal liaison relationship with ETSI, and report back to the IAB."
[Robin] Thanks Paul to propose the following link which explains why IAB discussed the work.
https://www.iab.org/liaisons/<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.iab.org_liaisons_&d=DwMFoQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=tA-v3h7bKzWgzXFTCNBDz8YMjuHgppZMjWYM5Y4vUDc&s=SkN1_6R6NOPOTqFdnMydJtltqxPued3Y55sxg6fQEXo&e=>

In addition, since there is no formal liaison between IETF and IAB and I work for the Liaison Oversight Program, I took the work to investigate the requirements for the liaison with IETF.
https://www.iab.org/activities/programs/iab-liaison-coordination-program/<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.iab.org_activities_programs_iab-2Dliaison-2Dcoordination-2Dprogram_&d=DwMFoQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=tA-v3h7bKzWgzXFTCNBDz8YMjuHgppZMjWYM5Y4vUDc&s=Q6RdG-kRfZN9m7ip34o8tSgeGSH1OJ4O1053J92w19M&e=>

ETSI had been unfamiliar to me, but I recently reviewed an ETSI application for a TLS code point assignment:
https://mailarchive.ietf.org/arch/msg/tls/bkx_bXcPSt_TwE7iJRM9acOQkDA/<https://urldefense.proofpoint.com/v2/url?u=https-3A__mailarchive.ietf.org_arch_msg_tls_bkx-5FbXcPSt-5FTwE7iJRM9acOQkDA_&d=DwMFoQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=tA-v3h7bKzWgzXFTCNBDz8YMjuHgppZMjWYM5Y4vUDc&s=CeSdmxeQhuI-vaJ11iyNi9P0G8s6BIo1B8wlA6dvtw8&e=>

https://www.eff.org/deeplinks/2019/02/ets-isnt-tls-and-you-shouldnt-use-it<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.eff.org_deeplinks_2019_02_ets-2Disnt-2Dtls-2Dand-2Dyou-2Dshouldnt-2Duse-2Dit&d=DwMFoQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=6UhGpW9lwi9dM7jYlxXD8w&m=tA-v3h7bKzWgzXFTCNBDz8YMjuHgppZMjWYM5Y4vUDc&s=_lIfgGzkaa7sr1x_LURTIbjDMEUcuQ5dLQAMUU-6CKM&e=>
[Robin] In fact the discussion for the liaison work is triggered by Daniele Ceccarelli (CCAMP WG Chair) this time. He asked if IETF needs to set up the liaison because of he had seen requests coming from NFV, ZSM and the new working group on security (don't remember the name) in ETSI which has a very high overlap with what we're doing in TEAS, CCAMP, OPSAWG. After discussion in the IAB meeting, it is suggested to discuss with Deborah and the routing ADs about the need. That is the reason why the RTG area is mentioned specially.
In the IAB meeting held on June 17, the need was discussed according to the feedback from Daniele Ceccarelli, Gonzalo Camarillo and Deborah Brungard and my collected information on the organization of ETSI. It seems that there is no need from Routing for a formal liaison relationship with ETSI at the working level. And the IAB discussed that there seems not much need to set up the higher level liaison with ETSI temporarily.
I think your proposed reference is very helpful to understand more about the possible liaison work between ETSI and IETF. I will go on to collect these feedback and propose them for IAB to evaluate. More suggestions on the work are welcome.

[Deborah]
For the routing area, TEAS had a request from ZSM on the status of some of TEAS documents. There have been no others. ETSI NFV, ETSI ZSM, TEAS are looking at similar applications – buzzwords of the industry – SDN, NFV, network slicing, zero touch. As usual, different SDOs choose different paths on solution work e.g. ETSI NFV is concentrated on TOSCA. There are many SDOs overlapping in this space e.g. ONF is another one. What is different from previous needed liaison activity when we did need a liaison manager at the working group level, for example, ITU-T SG15’s work on GMPLS and TMPLS, these groups are not modifying IETF routing area protocols. They may be choosing different ways to model e.g. ETSI NFV MANO model for APIs. Similar to IETF’s approach to other SDOs, it really is not for IETF to say “choose our model/acronyms/solution” when not involving our protocols. Companies may not want the different paths on solution work, but as RFC4929 notes, it is the expectation for the companies participating in these SDOs to contribute to that SDO, not the IETF liaison process to mandate (RFC4052).

There are two aspects to the liaison process – the exchange of information on work, which can be done without a designated formal liaison manager, and the designation of a formal liaison manager:
https://www.iab.org/liaisons/
https://www.ietf.org/about/liaisons/

Considering the routing area work at this time, I didn’t see that conditions warranted to recommend to the IAB that we needed to have formal liaison managers appointed to oversee ETSI ZSM and ETSI NFV work. A formal liaison manager at the level of overall ETSI work, e.g. our 3GPP formal manager, Gonzalo, may be of interest but that would be for the IAB working with ETSI to determine if mutual interest as usually the partnering organization also chooses a contact from their side.
---
I would like to hear more from Zhenbin Li, Deborah Brungard, and the Routing Area Directors about this proposal.

thanks,
Rob