Subject: [arch-d] 2 questions (groups) to IAB

From: Toerless Eckert <[email-masked]>
Date: Tue, 28 Jul 2020 14:23:24 +0200

Dear IAB,

Q1: Community discussion with IAB about their workshop/programs

Could the IAB please present a short statement about how the IAB decides
what workshops to run and when to start a new program? Would the IAB be                                
open to receiving suggestions from the community, and how would those
suggestions be handled?

Q2: IAB and evolving IP

IETF chair has declared in liaison 1677, that "IETF maintains copyright
and change control for the IP specifications" and "extensions or modifications
to IETF technologies must be discussed with the IETF before any are worked
on in other SDOs". In addition, IAB is chartered with external liaison and
architectural oversight. With this role, i would respectfully like to ask
IAB about he following issue:

There is interest from contributors working inside IETF as well as
outside researchers and SDO such as ITU-T to investigate options for
future IP/network layer packet/protocol evolution withing but also beyond
those options that could naturally evolve from the considerations of RFC4775.

This could be seen as similar to what was done 30 years ago in IP-NG through
e.g.g: TUBA, TP/IX, CATNIP, IPAE, SIP, PIP and so on. Except that the
requirements for such investigations are different from those in 1990th
(IPv4 address space exhaustion). For example the networks to which the
desired benefits might most apply would not necessarily have to be primarily
the Internet.

What is in the opinion of IAB the right place to do this work in the community,
e.g., IAB workshop/program, IETF experimental WG, some other new org form ?
How does IAB think it should be involved in such an effort ?

Note: IRTF chair has already stated that he considers architecture investigation
into generic network header encoding options as a pure engineering and therefore
non-research topic and thinks it is unsuitable for an IRTF RG.
I disagree, but that was his statement he made to me.

Lastly: Where can i find the definition as to what packet protocol
formats would or would not fall into the IETF chairs "IETF ... copyright
and change control for the IP specifications" ?  E.g.: would any newly
designed protocol be subject to IETF copyright claims if it can be
made interoperable in some fashion with IPv4 or IPv6 ? Or is it just
the naming aspect of "InternetworkProtocol" ? I do not understand
the assessment criteria. 

This question is quite important because without such definition,
it is impossible to determine which proposed protocols Alissas liaison 1677
ask against other SDO applies to.

Thank you very much
    Toerless Eckert

---

From: Colin Perkins <[email-masked]>
Date: Tue, 28 Jul 2020 15:13:08 +0100

> On 28 Jul 2020, at 13:23, Toerless Eckert <[email-masked]> wrote:
> 
> Dear IAB,
> 

We had a single hallway conversation about this topic at the Singapore IETF 106 meeting. What I recall saying was that I thought the specific topic you raised was better suited to a longer-term engineering effort in IETF than to an IRTF research group, not that the broader topic was forever out of scope for IRTF. 

Colin

> _______________________________________________
> Architecture-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/architecture-discuss

-- 
Colin Perkins
https://csperkins.org/

---

From: Mirja Kuehlewind <[email-masked]>
Date: Wed, 29 Jul 2020 17:04:03 +0200

Hi Toerless,

Thanks for your requests. Please see replies inline.

> On 28. Jul 2020, at 14:23, Toerless Eckert <[email-masked]> wrote:
> 
> Dear IAB,
> 

More information on IAB programs can be found on the IAB webpage: https://www.iab.org/activities/programs/

As noted there, programs serve to support the IAB in their chartered responsibilities. As such, programs as well as workshops are usually created/hold based on discussion within the IAB. In past discussions we have evaluated each program based on its merits, scope, energy levels within the IAB and the community, and its likelihood of success. As I also briefly mentioned in the IAB open meeting today, we in the IAB are currently also discussing our own practices and procedures to establish and work with and in those programs, and how best such programs can engage with the IETF community. As such an update to the noted IAB page is likely to come up at some future point.

The IAB is always interested in community input on technical work the IAB is currently doing as well as technical discussion on larger architectural issues. Especially for the later the [email-masked] list is the right place, not only for community discussion but also to reach the IAB as IAB members are participating on that list. Of course you can also always reach the IAB directly, as you just did using [email-masked]

When we receive input from the community that requires further discussion, we may do that in our business calls. Our calls (except the executive sessions of course) are open for observers and the agenda is published in advance on the IAB wiki.

> How does IAB think it should be involved in such an effort ?

The IAB used to have a program on IP Stack Evolution which was just closed last year. Before that there was a program on IP Evolution. For both concluded programs you can find further information about the scope as well as published documents or other actives the program members were involved with on the IAB webpage:
https://www.iab.org/activities/programs/concluded-programs/ip-stack-evolution-program/
https://www.iab.org/activities/programs/concluded-programs/ip-evolution/

These programs were concluded as the intermediate goals of these programs were reached. As also announced in the IAB open meeting yesterday, the IAB is considering a to some extend follow-up new program on Evolvability, Deployability, and Maintainability (EDM). For further discussion on these aspects an new mailing list has been created: [email-masked]

From your description above the scope of the work you are interested in seems rather broad. More generally speaking, the IAB aims to stimulate discussion around architectural issues in the Internet that are not always broadly recognised by the wider community, or that either require more coordinations between areas or are not covered by active work in the IETF. However, for questions related to a certain protocol or groups of protocols where one or more IETF working groups already exists, I recommend you that discussion should take place there to reach out to the relevant part if the IETF community directly.

> ask against other SDO applies to.

I believe this is a question for the IETF Chair to ask. 

Best,
Mirja