Subject: [arch-d] Musings on Internet evolution

From: Jari Arkko <[email-masked]>
Date: Wed, 8 Jul 2020 16:26:47 +0300

Colin, Tommy, Alissa and me wrote some thoughts on COVID-19 impacts, Internet evolution, and future challenges. See here:

http://www.circleid.com/posts/20200707-evolving-the-internet-through-covid-19-and-beyond/

But what do you think? What do you think has fuelled evolution, what do you see in store in these processes in the future, and what bigger challenges do you think we face in the Internet? Do you see other changes that functional aspects, e.g., about the way evolution happens? (We’ve seen some movement from standards to open source-based interoperability, for instance.)

Jari

---

From: Bill Woodcock <[email-masked]>
Date: Wed, 8 Jul 2020 17:25:50 +0200

> On Jul 8, 2020, at 3:26 PM, Jari Arkko <[email-masked]> wrote:
> 

I assume you saw this:   http://www.oecd.org/coronavirus/policy-responses/keeping-the-internet-up-and-running-in-times-of-crisis-4017c4c9/

We had quite a lot of expert input which didn’t make it into the report, as well, which I can summarize, if people are interested.

From my point of view, I think the most interesting finding is that this is the end of network-to-network (i.e. routed subnet) VPNs for home-office situations.  While that was supportable for a few executives, it doesn’t work if most of your workforce is WFH.

One of the big positives in the “new normal” has been the democratization of Internet governance meetings…  My colleagues Sara Alamin and Gaël Hernandez have a brief article coming out shortly on that topic.  When meetings happen online, they’re less dominated by people from countries which issue each other travel visas and which have inexpensive and frequent air travel between each other.  That’s good news, in a more-eyes-on-the-problem sense, and in a design-that-works-better-for-everybody-works-better-for-everybody sense.

The main conclusion I’ve been seeing people draw from the Zoom situation is that we’ve passed some sort of tipping-point of ridiculousness in the everything-as-a-service, in-the-cloud shitshow, and that governments, particularly, need to get back to a point where they’re capable of standing on their own feet and operating the services they need, using code they’re familiar with.  So, good news for open-source and open-standards, if people pay attention to that.

                                -Bill

---

From: Vittorio Bertola <[email-masked]>
Date: Wed, 8 Jul 2020 18:41:40 +0200 (CEST)

> Il 08/07/2020 15:26 Jari Arkko <[email-masked]> ha scritto:
> 
>  

Understandably, your article is focused on the ability of the Internet to cope with evolution at the technical level, which is excellent. But you seem to miss the evolution at the societal level, where two big and interconnected topics have emerged (at least in Europe) in the last 2-3 years:

1) centralization: in practice, much of the Internet is now decentralized technically but centralized economically and in terms of control into the hands of a few immense and unaccountable businesses; 

2) digital sovereignty: how can national governments restore some degree of non-negotiable control over the consequences that the Internet has on their societies, and fulfill their strategic need for the Internet to continue working even in the face of strained international relations.

The last 2-3 decades were an age of globalization, but as the pendulum swings and many social groups are increasingly unhappy, the next ones could again be an age of nationalism. If so, the borderless technical nature of the Internet could get increasingly strained by the attempts to counter #1 and accomplish #2, if it failed to adapt to the new political climate.

-- 
Vittorio Bertola | Head of Policy & Innovation, Open-Xchange
[email-masked] 
Office @ Via Treviso 12, 10144 Torino, Italy

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 8 Jul 2020 22:24:11 +0100 (BST)

Hi

Would my research on localizable sentences be of any interest in 
relation to this?

It is open source.

Originally intended for human to human communication through the 
language barrier in some circumstances, it could also be used for human 
to thing, thing to human, and thing to thing communication.

http://www.users.globalnet.co.uk/~ngo/localizable_sentences_research.htm

http://www.users.globalnet.co.uk/~ngo/

William Overington

Wednesday 8 July 2020

------ Original Message ------
From: "Jari Arkko" <[email-masked]>
To: [email-masked]
Sent: Wednesday, 2020 Jul 8 At 14:26
Subject: [arch-d] Musings on Internet evolution
Colin, Tommy, Alissa and me wrote some thoughts on COVID-19 impacts, 
Internet evolution, and future challenges. See here:

http://www.circleid.com/posts/20200707-evolving-the-internet-through-covid-19-and-beyond/ 
<http://www.circleid.com/posts/20200707-evolving-the-internet-through-covid-19-and-beyond/>

But what do you think? What do you think has fuelled evolution, what do 
you see in store in these processes in the future, and what bigger 
challenges do you think we face in the Internet? Do you see other 
changes that functional aspects, e.g., about the way evolution happens? 
(We’ve seen some movement from standards to open source-based 
interoperability, for instance.)

Jari

_______________________________________________
Architecture-discuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/architecture-discuss 
<https://www.ietf.org/mailman/listinfo/architecture-discuss>

---

From: Guntur Wiseno Putra <[email-masked]>
Date: Thu, 9 Jul 2020 10:49:27 +0700

Dear Jarri, Bill &
architecture-discuss,

(Beside "emergency telecommunication" of which the Internet is to be part
of in relation with "emergency response" to the pandemic Covid-19/Corona
virus I mentioned in this architecture-discuss times ago

https://mailarchive.ietf.org/arch/msg/architecture-discuss/thlgeoDJElb71D1jjq4X9hKgyFU/

,) it seems to be a way of evolvability/evolution --a typically
collaborative one and at least a potential one as I imagine with no a
careful reading-- the Internet take: how the Internet of Things inspires
the Web of Things among which there is a concern with agriculture where
there are initiatives on E-Agriculture considering "big data for disaster
resilience" and "working and studying from home" while Research Data
Alliance regarding with agriculture and the current global pandemic
Covid-19/Corona virus.

A thread at the Public-AgriW3C Community Group mailing list "WoT
Collaboration" reflects that mind above:

https://www.w3.org/mid/507fd4a3-896c-0310-b0ba-655513fcc24e@
affrc.go.jp;list=public-agri

To summarize, it is about initiatives:

- The Web of Things for The Internet of Things (section Introduction of the
document "WoT Architecture"); & the section 4.1.8. Agriculture
https://www.w3.org/TR/2020/REC-wot-architecture-20200409/#agriculture

- publications on E-Agriculture published by the International
Telecommunication Union (ITU): https://www.itu.int/en/ITU-D/I
CT-Applications/Pages/e-agriculture.aspx

- (In relation with the current pandemic Covid 19, this may have such a
relevance:)
Case Study 1. "Big Data Ecosystem for Disaster Resilience" in
"E-Agriculture in Action: Big Data for Agriculture" (ed. G. Sylvester, pp.
37-44) https://www.itu.int/en/ITU-D/ICT-Applications/Documents/Publ
ications/Big%20Data%20for%20Agriculture.pdf

- Research Data Alliance activities on fata engineering: "RDA Covid-19" and
"agrisemantics" readings referring to the RDA also.

https://www.rd-alliance.org/group/rda-covid19-rda-covid19-omics-rda-covid19-
epidemiology-rda-covid19-clinical-rda-covid19-0

https://www.rd-alliance.org/groups/agrisemantics-wg.html

- (While there is the "Big Data for Disaster Resilience" mentioned above,)
I finded this initiative on agriculture in times of home-based activities
of which there was a relevance of the current pandemic Covid-19: "Working
and Studying from Home? FAO Has A Lot to Share"
http://www.fao.org/publications/highlights-detail/en/c/1269559/

Regard,
Guntur Wiseno Putra

Pada Rabu, 08 Juli 2020, Bill Woodcock <[email-masked]> menulis:

> challenges do you think we face in the Internet? Do you see other changes
> that functional aspects, e.g., about the way evolution happens? (We’ve seen
> some movement from standards to open source-based interoperability, for
> instance.)
>
> I assume you saw this:   http://www.oecd.org/coronavir
> us/policy-responses/keeping-the-internet-up-and-running-in-t
> imes-of-crisis-4017c4c9/
>
> We had quite a lot of expert input which didn’t make it into the report,
> as well, which I can summarize, if people are interested.
>
> From my point of view, I think the most interesting finding is that this
> is the end of network-to-network (i.e. routed subnet) VPNs for home-office
> situations.  While that was supportable for a few executives, it doesn’t
> work if most of your workforce is WFH.
>
> One of the big positives in the “new normal” has been the democratization
> of Internet governance meetings…  My colleagues Sara Alamin and Gaël
> Hernandez have a brief article coming out shortly on that topic.  When
> meetings happen online, they’re less dominated by people from countries
> which issue each other travel visas and which have inexpensive and frequent
> air travel between each other.  That’s good news, in a
> more-eyes-on-the-problem sense, and in a design-that-works-better-for-e
> verybody-works-better-for-everybody sense.
>
> The main conclusion I’ve been seeing people draw from the Zoom situation
> is that we’ve passed some sort of tipping-point of ridiculousness in the
> everything-as-a-service, in-the-cloud shitshow, and that governments,
> particularly, need to get back to a point where they’re capable of standing
> on their own feet and operating the services they need, using code they’re
> familiar with.  So, good news for open-source and open-standards, if people
> pay attention to that.
>
>                                 -Bill
>
>

---

From: Jari Arkko <[email-masked]>
Date: Thu, 9 Jul 2020 11:02:14 +0300

Vittorio,

> 1) centralization: in practice, much of the Internet is now decentralized technically but centralized economically and in terms of control into the hands of a few immense and unaccountable business…

I certainly agree. As you say, this was not the focus of this article, but we do in fact mention consolidation in the challenges section. We and many others have written separately about the details of consolidation and centralisation. See for instance [1].

> 2) digital sovereignty: how can national governments restore some degree of non-negotiable control over the consequences that the Internet has on their societies, and fulfill their strategic need f…

That’s a very interesting topic, probably also worth more thought and writing.

Sovereignty is of course also complex, to start with because you on one hand want global reach and access to information, but you do want some local control. And when I say control, I don’t mean in the sense of controlling what the newspapers are allowed to write. Or that the one in charge should be the government. Rather, I mean for instance the ability to design your network as resilient, e.g., the ability to function when breakages occur elsewhere. Or the freedom to use local Internet infrastructure.

Jari

[1] Plugging in the recent ISOC-sponsored special issue of Journal of Cyber Policy here: https://www.tandfonline.com/toc/rcyb20/current <https://www.tandfonline.com/toc/rcyb20/current>

---

From: Jari Arkko <[email-masked]>
Date: Thu, 9 Jul 2020 11:12:05 +0300

Bill,

> We had quite a lot of expert input which didn’t make it into the report, as well, which I can summarize, if people are interested.

Thanks for this - I had actually not seen that before. Very useful.

One observation that I have heard from many who have been involved in practical day-to-day Internet businesses is that while the user experience may be relatively smooth, that doesn’t mean that nothing needed to be done. A *lot* of work has happened behind the scenes, capacity added, issues addressed, things moved, calls made, etc. etc.

> From my point of view, I think the most interesting finding is that this is the end of network-to-network (i.e. routed subnet) VPNs for home-office situations.  While that was supportable for a few executives, it doesn’t work if most of your workforce is WFH

Ok.

> One of the big positives in the “new normal” has been the democratization of Internet governance meetings…  My colleagues Sara Alamin and Gaël Hernandez have a brief article coming out shortly on t…

Yes, that has been very good!

> The main conclusion I’ve been seeing people draw from the Zoom situation is that we’ve passed some sort of tipping-point of ridiculousness in the everything-as-a-service, in-the-cloud shitshow, and…

I certainly hope so. (Cautiously optimistic but lets see in few years.)

Anyway, I think this has been a part of a more general realisation in the society, e.g., critical supplies and services availability. And it applies to companies as well, not just governments. Business continuity.

Jari

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 10 Jul 2020 16:32:22 +1200

An interesting counter-factual question is: how would it have worked out with a connection-oriented virtual-circuit technology?

The OECD comment about lack of in-country peering rather suggests what the answer would have been.

Regards
   Brian

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 17 Jul 2020 15:36:53 +0200

> http://www.circleid.com/posts/20200707-evolving-the-internet-through-covid-19-and-beyond/
But what do you think?

Hi,

Thank you for putting the document together, and for asking.

I think I share the view that operating the Internet did not see
significant disruption during the frontal COVID crisis.  For example,
the announced overload of netflix did not materialize.  But certainly
there might have been other operations that were affected.

An additional reason why it is difficult to say now how COVID affect(ed)
the Internet is because COVID is not over.  It is a wave, now maybe at a
second ripple, which can not be understood in just a few months time.
We are below the water level, we are not surfing on it.  It might last
years, like the other pandemics.  Let us check the status of that impact
periodically.

I would like to add another musing, which I do not intend to
be provocative at all, but I feel it deserves being part of a complete
picture.  The musing is the following: it is universally agreed that the
Internet helped a lot steering through the crisis, and I fully share the
view, having myself experienced the benefits.  However, I will dare to
ask: did the Internet contribute to the creation of this event?  Can
we in all confidence answer by the negative?  As a tool created by
humans, to what extent the existence and use of the Internet contributed
to the factors that are now mentioned as potential sources of this
crisis? (de-forestation, unbalanced population to areas, and less
Nature in general).  Musing on this question does not lead me to be
certain that Internet did only good in this event.

Alex

  > What do you think has fuelled evolution, what do you see in store in
> these processes in the future, and what bigger challenges do you 
> think we face in the Internet? Do you see other changes that 
> functional aspects, e.g., about the way evolution happens? (We’ve 
> seen some movement from standards to open source-based 
> interoperability, for instance.)>

> Jari
> 
> _______________________________________________ Architecture-discuss 
> mailing list [email-masked]