Subject: [arch-d] Call for Feedback on the new proposed structure for Technical Programs and Administrative Support Groups

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 12 Nov 2020 18:47:21 +0100

Hi all,

The IAB has been working on refactoring its programs. You can find the proposed description of the new structure and procedures on Github [1]. The aim of this effort is to increase transparency, visibility, and openness of the architectural work done by the IAB. 

In analysing the current IAB programs, the IAB identified two kinds of programs which are quite different in their needs and goals. Therefore, the new structure proposes to separate today’s IAB programs into Technical Programs and Administrative Support Groups. 

Technical Programs are more short-lived activities (even though this might be longer than one IAB cycle) and focus on specific technical or architectural issues that require both input from experts as well as community discussion. Current Technical Programs are model-t and EDM. 

Administrative Support Groups are long-term activities that help the IAB to fulfil their oversight or administrative responsibilities. Based on the nature of their task these groups usually consist of a small, dedicated set of experts that may have a need to handle matters confidentially. Administrative Support Groups are the current technical plenary program, the IANA program, and the liaison program. Please note that the IAB is also in the progress of reviewing these activities. 

RSOC could also be considered as an Administrative Support Group; however, given the on-going process in the future RFC editor model program, the IAB will not implement any changes or actions on RSOC until this process has concluded.

Further, the future RFC editor model program is not considered in this new structure. The IAB is not intending to implement any changes or intervene in any way with the work of the program.

We believe that this new structure will better support the IAB’s needs and hopefully clarify procedures and expectation. Further, we hope that this will also help to increase the exchange with the community!

Please provide feedback on this mailing list, on GitHub by raising an issue, or directly to the IAB <[email-masked]>.

Mirja Kühlewind
IAB chair

[1] https://github.com/intarchboard/IAB-programs/blob/master/IAB-programs.md

---

From: Melinda Shore <[email-masked]>
Date: Thu, 12 Nov 2020 10:57:52 -0900

On 11/12/20 8:47 AM, Mirja Kuehlewind wrote:> The IAB has been working
on refactoring its programs. You can find
> the proposed description of the new structure and procedures on
> Github [1]. The aim of this effort is to increase transparency,
> visibility, and openness of the architectural work done by the IAB.

Out of curiosity, is this in response to a problem?

Melinda

-- 
Software longa, hardware brevis

PGP key fingerprint  4F68 2D93 2A17 96F8 20F2
                     34C0 DFB8 9172 9A76 DB8F

---

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 12 Nov 2020 21:29:07 +0100

Hi Melinda,

I should probably have said that there is a description on the IAB webpage about programs (https://www.iab.org/activities/programs/) which however is rather out-dated compared to what we do in programs these days. So the goal is more transparency and openness in the program itself but also in the way we maintain them. There has been no concrete event that this is a response to, if that was the question, but I think you know that the IAB has been discussing this for a while already.

Mirja

> On 12. Nov 2020, at 20:57, Melinda Shore <[email-masked]> wrote:
> 
> _______________________________________________
> Architecture-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/architecture-discuss

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 12 Nov 2020 14:32:42 -0600

Hi, Mirja, and the IAB,

On Thu, Nov 12, 2020 at 11:47 AM Mirja Kuehlewind <[email-masked]>
wrote:

> Hi all,
>
> The IAB has been working on refactoring its programs. You can find the
> proposed description of the new structure and procedures on Github [1]. The
> aim of this effort is to increase transparency, visibility, and openness of
> the architectural work done by the IAB.
>
> In analysing the current IAB programs, the IAB identified two kinds of
> programs which are quite different in their needs and goals. Therefore, the
> new structure proposes to separate today’s IAB programs into Technical
> Programs and Administrative Support Groups.
>
> Technical Programs are more short-lived activities (even though this might
> be longer than one IAB cycle) and focus on specific technical or
> architectural issues that require both input from experts as well as
> community discussion. Current Technical Programs are model-t and EDM.
>
> Administrative Support Groups are long-term activities that help the IAB
> to fulfil their oversight or administrative responsibilities. Based on the
> nature of their task these groups usually consist of a small, dedicated set
> of experts that may have a need to handle matters confidentially.
> Administrative Support Groups are the current technical plenary program,
> the IANA program, and the liaison program. Please note that the IAB is also
> in the progress of reviewing these activities.
>

This roughly makes sense to me, but I would suggest finding another term
beyond "Administrative Support", which seems to collide fabulously with the
use of the word "Administrative" all over the IETF.

I think it's accurate to say that these are "Oversight Groups", each tied
closely to an IAB responsibility in
https://tools.ietf.org/html/rfc2850#section-2.

I'm not wedded to "Oversight", but please don't use "Administrative",
because we'll spend the next decade or two explaining the difference
between these programs and stuff in the IETF.

I'm not sure why the IAB is talking about "Groups" for these instead of
"Programs", which is (I think) an understood-as-IAB term, but I'm assuming
there's a reason, such as the management procedures are different. If
that's not true, "Oversight Programs" would be an improvement.

I know you'll Do The Right Thing, of course.

Best,

Spencer

> RSOC could also be considered as an Administrative Support Group; however,
> given the on-going process in the future RFC editor model program, the IAB
> will not implement any changes or actions on RSOC until this process has
> concluded.
>
> Further, the future RFC editor model program is not considered in this new
> structure. The IAB is not intending to implement any changes or intervene
> in any way with the work of the program.
>
> We believe that this new structure will better support the IAB’s needs and
> hopefully clarify procedures and expectation. Further, we hope that this
> will also help to increase the exchange with the community!
>
> Please provide feedback on this mailing list, on GitHub by raising an
> issue, or directly to the IAB <[email-masked]>.
>
> Mirja Kühlewind
> IAB chair
>
> [1]
> https://github.com/intarchboard/IAB-programs/blob/master/IAB-programs.md
>
>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 12 Nov 2020 14:43:16 -0600

FWIW,

On Thu, Nov 12, 2020 at 2:29 PM Mirja Kuehlewind <[email-masked]>
wrote:

> Hi Melinda,
>
> I should probably have said that there is a description on the IAB webpage
> about programs (https://www.iab.org/activities/programs/) which however
> is rather out-dated compared to what we do in programs these days. So the
> goal is more transparency and openness in the program itself but also in
> the way we maintain them. There has been no concrete event that this is a
> response to, if that was the question, but I think you know that the IAB
> has been discussing this for a while already.
>

I started my first reply in this thread by saying "This roughly makes sense
to me ...", but since Mirja replied, I should probably have said why.

I think these groups really are different - to mention one type of
difference, the programs were originally set up to involve more people than
just the current IAB (which was the way the IAB discharged its chartered
responsibilities in 2010, when I joined), and one of the things I THINK I'm
seeing is that the technical programs seem to be continuing that movement,
to the point of open membership without approval by IAB vote, while at
least some of the Administrative/Oversight Groups/Programs appropriately
have closed membership (I'm thinking of the Liaison Oversight program and
its predecessor programs during the TMPLS/MPLS-TP wars, or the IANA program
during the spinoff of IANA from US DoC contracting).

I don't think that's the only difference, but I don't know what current IAB
thinking is about other differences.

So, I was guessing that the IAB was thinking of distinctions like that,
which I think are appropriate, between two kinds of programs, so that each
kind of program better understands its expectations.

I hope that's helpful (but Do The Right Thing, of course!).

Best,

Spencer

---

From: Melinda Shore <[email-masked]>
Date: Thu, 12 Nov 2020 12:02:29 -0900

On 11/12/20 11:43 AM, Spencer Dawkins at IETF wrote:
> which I think are appropriate, between two kinds of programs, so that
> each kind of program better understands its expectations.

I think the only place I saw any confusion about that during my
tenure was around RFC Editor oversight/what-have-you, including
but not limited to the RSOC.  I'm not really seeing a problem
here that needs solving.  I do think that this discussion will
inevitably lead to a discussion of the function and value of
the IAB, which I do think might be worth having if it were possible
to have that discussion in a civil manner.  So, I think the Law of
Unintended Consequences is going to dominate here and given the
lack of an actual problem (I could be convinced otherwise but
so far there's no problem in evidence) I'm not clear on the value
of this exercise.

Melinda

-- 
Melinda Shore
[email-masked]