Subject: [arch-d] centralization

From: Yaakov Stein <[email-masked]>
Date: Thu, 11 Mar 2021 17:57:26 +0000

> Market consolidation and centralization can be good ...
> But there are also some serious drawbacks.

Yes. There are often trade-offs and these trade-offs can be analyzed.

In response to one remark I pushed into the chat window a remark about the CAP theorem.
This theorem is commonly used when analyzing distributed systems,
and is directly applicable to networks which are distributed systems for delivery of packets.

Basically the CAP theorem says you can't have all three of Consistency, Availability, and Partition (fault) Tolerance.
IETF people are used to distributed routing protocols that emphasize A and P at the expense of C
(which is why we need a TTL field in the packet header),
while computation academics who expect consistency gave us centralized SDN.
For databases the two extremes are called ACID and BASE.

To enable more nuanced trade-offs networks use both control (distributed) and management (centralized) planes,
for example centralized management for policy and distributed control for rerouting.
(So, what SDN does is not to introduce a control plane, but rather to replace the control plane by a management plane.)

However, when referring to multi-user networked applications (not the communications service)
there is strong pressure towards centralization.
Why do we have basically one Facebook, one Amazon, etc?
Because the value of a network application is super linear (Metcalfe's law puts is a N^2, Reid's law puts it at 2^N)
which means that one large network is worth much more than 2 half-sized networks.
Over time this pressure can't be resisted.

Y(J)S

---

From: Lars-Johan Liman <[email-masked]>
Date: Fri, 12 Mar 2021 08:22:28 +0100

Yaakov,

Interesting! Thanks!

I follow much of your argumentation, but I kind of came to a soft halt

> which means that one large network is worth much more than 2

I think this statement should be qualified a bit, because I think one
parameter is how "worth" is measured. I would argue (and I admit this is
from gut feeling more than from facts or knowledge, so I will not take
offence from being contradicted) that a non-functional large network is
worth less than 2 funcional half-sized networks, at least for some
purposes.

My gut feeling tells me that the cost of keeping a centralised system
consistent rises with its size, and it's probably not linear. Isn't
there a point where the cost of keeping it consistent and reliable
exceeds the extra value added by increasing its size by delta-x?

Or, where the risks of systemic failure overtakes the added value.

Granted: obviously these points are moving targets, being pushed by
development, but still?

The "worth" can be measured not only in short time capital gain, but
also in risks, no?

> Over time this pressure can't be resisted.

Agreed, if measured only in short time capital gain, but maybe it can be
(at least for longer time) if political backpressure (with less focus on
capital gain) is applied?

				Best regards,
				  /Liman

#----------------------------------------------------------------------
# Lars-Johan Liman, M.Sc.               !  E-mail: [email-masked]
# Senior Systems Specialist             !  Tel: +46 8 - 562 860 12
# Netnod Internet Exchange, Stockholm   !  http://www.netnod.se/
#----------------------------------------------------------------------

> Basically the CAP theorem says you can't have all three of
> Consistency, Availability, and Partition (fault) Tolerance.

> To enable more nuanced trade-offs networks use both control
> (distributed) and management (centralized) planes,
> (So, what SDN does is not to introduce a control plane, but rather to
> replace the control plane by a management plane.)

> Because the value of a network application is super linear (Metcalfe's
> law puts is a N^2, Reid's law puts it at 2^N)

---

From: Eliot Lear <[email-masked]>
Date: Fri, 12 Mar 2021 09:49:16 +0100

Hi,

In this context, there are two questions to be asked:
What does it mean for the Internet to go down?
What can be done to keep it from going down?
While we often describe the Internet as a network of networks, from society’s perspective, we need a better definition.  A straw man might be this:

The Internet is the sum of the services that are used by the aggregate of users.

In order to keep this message short, I will simply assert that while cloud services can on the whole improve resiliency, when core services go down, the impact is so vast that we simply don’t want to see it happen.  And so I don’t want to spend much time on Q1.  If anyone really wants to debate the point in detail, fine, but otherwise...

That brings us to the 2nd question.  What can be done to improve resiliency?  That is where I think recommendations need to be focused.

Eliot

> On 12 Mar 2021, at 08:22, Lars-Johan Liman <[email-masked]> wrote:
> 
> Yaakov,
> 
> Interesting! Thanks!
> 
> _______________________________________________
> Architecture-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/architecture-discuss

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 12 Mar 2021 11:40:54 +0100

Eliot, *:

agree and continuing down the rabbit hole:

Stephen had started a thread and even i think a mailing list about
resilience, but the response was hmm. is "lukewarm" more PC than "lame" ? ;-)

So, 2 high level points:

I raised the question a short while ago, but with Stephen gone from IAB,
i would first like to raise the question how we could make any form
of organized work about resilience more resilient against arbitary
leadership changes (a problem i primarily attribute to the way IAB
activities are often structured).

I also think that as much fun as resilience at the technical level we
do and would like to work and document on is, i fear that there is a lot
more aspects to resilience at the policy level that are very important,
and unlike privacy and language we don't seem to have attracted a
community interested to work on the policy level AND know how to do it.
Maybe there is some outreach to be done to ISOC and/or even HRPC might
be a good place to look for advise to foster work on that layer.

Cheers
    Toerless

On Fri, Mar 12, 2021 at 09:49:16AM +0100, Eliot Lear wrote:
> While we often describe the Internet as a network of networks, from society???s perspective, we need a better definition.  A straw man might be this:
> 
> In order to keep this message short, I will simply assert that while cloud services can on the whole improve resiliency, when core services go down, the impact is so vast that we simply don???t want to see it happen.  And so I don???t want to spend much time on Q1.  If anyone really wants to debate the point in detail, fine, but otherwise...
> 

-- 
---
[email-masked]

---

From: Andrew Campling <[email-masked]>
Date: Fri, 12 Mar 2021 14:16:40 +0000

On Fri, Mar 12, 2021 at 10:41, Toerless Eckert <[email-masked]<mailto:[email-masked]>> wrote:

> I also think that as much fun as resilience at the technical level we do and would like to work and document on is, i fear that there is a lot more aspects to resilience at the policy level that are very important, and unlike privacy and language we don't seem to have attracted a community interested to work on the policy level AND know how to do it.

> Maybe there is some outreach to be done to ISOC and/or even HRPC might be a good place to look for advise to foster work on that layer.

I agree that there are both technical and policy considerations here, relating to resilience, privacy and other aspects of centralisation.  Given it can be argued there are clear pros and cons to centralisation, even if IMHO the long term impact is almost certainly entirely detrimental to the interest of the end user, I think that this is an excellent opportunity to put into practice the suggested multi-stakeholder engagement as recommended in RFC 8890.  ISoc has already undertaken some work and published a report on this topic and I suspect that there will be a range of other interested parties that may put forward differing perspectives.

Andrew