Subject: [arch-d] 2 suggestions from the IAB open meeting

From: Lixia Zhang <[email-masked]>
Date: Thu, 11 Mar 2021 08:04:12 -0800

I would like to support the following 2 suggestions I heard from today’s open meeting

1/ setting up a separate mailing list for discussions on adm/liaison  related issues.  
This would leave arch-discuss just for technical arch issues as its name called.

2/ looking into a workshop on internet centralization/decentralization.

I agree with the comments that extended discussions are needed on the topic, and see the workshop preparation could serve as a drive for focused discussions.

If a workshop is to be planned, IAB might start with an open agenda and solicit inputs from the broader community, e.g. what topics (and sub-topics) to be consider for the agenda

Lixia

PS: I would also like to take opportunity to clarify one of my text comment at the IAB open meeting: 
My comment is something like “protocol designs are what we do. The real question is what kinds of protocols we design”

I saw a couple responses like “but IAB can be a lot more than that (protocol designs)” — of course.  My comment was only on the protocol design part.

---

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 16 Mar 2021 12:04:36 +0100

Hi Lixia,

Thanks for bringing this to the list. Please see inline.

> On 11. Mar 2021, at 17:04, Lixia Zhang <[email-masked]> wrote:
> 

For any input regarding liaison management, please send an email directly to [email-masked] at this point. As I said in the IAB open meeting, the IAB is currently in the process of discussing various aspects and we will reach out to the community again when we made some progress. Any input or feedback is of course very welcome at any time!

For question directly on a specific liaison or handling of liaison statements, you can also use [email-masked] now.

The IAB has been using the architecture-discuss list for announcements about e.g. workshops, documents, or program for a quiet while and that was in scope for the list already when the list was started. As you can see the load is not extremely high. We discussed the use of that list for these kind of announcements last year as well and concluded that this list is a good opportunity to reach the community. Also I would say most of the announcements, e.g. on workshop or document feedback calls have some technical aspects as well. I personally don’t really see the benefit of moving the few admin-only related announcement to a separate list (with the risk of not reaching the community) but I will discuss this with the rest of the IAB again!

> 2/ looking into a workshop on internet centralization/decentralization.

As I said in the IAB open meeting, the IAB discussed a possible workshop in this space multiple times. However, the general topic is very broad and a workshop to be successful and to eventually come to some conclusions/next steps usually needs to be more focused. As such, the IAB, e.g., held the DEDR workshop in 2019 where centralisation was one main focus, see

https://www.rfc-editor.org/rfc/rfc8980.html#name-centralized-deployment-mode

The IAB is still discussing aspects of centralisation and, as also mentioned in the plenary and the IAB open meeting, Jari is holding the pen on an update of his draft. For now I very much appreciate to continue the discussion on the architecture-discuss list. But I'm also sure this will be a topic again at the next IAB retreat and potentially the next IAB open meeting.

Mirja

> _______________________________________________
> Architecture-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/architecture-discuss

---

From: Mary Barnes <[email-masked]>
Date: Tue, 16 Mar 2021 11:25:10 -0500

One comment below [MB].

On Tue, Mar 16, 2021 at 6:05 AM Mirja Kuehlewind <[email-masked]>
wrote:

> For any input regarding liaison management, please send an email directly
> to [email-masked] at this point. As I said in the IAB open meeting, the IAB
> is currently in the process of discussing various aspects and we will reach
> out to the community again when we made some progress. Any input or
> feedback is of course very welcome at any time!
>
> For question directly on a specific liaison or handling of liaison
> statements, you can also use [email-masked] now.
>
> The IAB has been using the architecture-discuss list for announcements
> about e.g. workshops, documents, or program for a quiet while and that was
> in scope for the list already when the list was started. As you can see the
> load is not extremely high. We discussed the use of that list for these
> kind of announcements last year as well and concluded that this list is a
> good opportunity to reach the community. Also I would say most of the
> announcements, e.g. on workshop or document feedback calls have some
> technical aspects as well. I personally don’t really see the benefit of
> moving the few admin-only related announcement to a separate list (with the
> risk of not reaching the community) but I will discuss this with the rest
> of the IAB again!
>
[MB] As I said in that other thread while back, when I was IAB executive
director, I had the understanding that the list was for the community to
discuss technical architectural issues as Lixia stated.   Looking at the
archives, I'm not seeing that it was historically used for workshop
announcements.  And, I'm recalling that the architecture-discuss list was a
subset of the broader community.   I didn't know it existed until I was on
IAB.   Why can't you just post the announcements that you want to ensure
the community sees on the main IETF announcement list?  They've always been
posted there, anyways as I recall.   [/MB]

> As I said in the IAB open meeting, the IAB discussed a possible workshop
> in this space multiple times. However, the general topic is very broad and
> a workshop to be successful and to eventually come to some conclusions/next
> steps usually needs to be more focused. As such, the IAB, e.g., held the
> DEDR workshop in 2019 where centralisation was one main focus, see
>
>
> The IAB is still discussing aspects of centralisation and, as also
> mentioned in the plenary and the IAB open meeting, Jari is holding the pen
> on an update of his draft. For now I very much appreciate to continue the
> discussion on the architecture-discuss list. But I'm also sure this will be
> a topic again at the next IAB retreat and potentially the next IAB open
> meeting.
>
> Mirja
>
>
>
> >
> > I agree with the comments that extended discussions are needed on the
> topic, and see the workshop preparation could serve as a drive for focused
> discussions.
> >
> > If a workshop is to be planned, IAB might start with an open agenda and
> solicit inputs from the broader community, e.g. what topics (and
> sub-topics) to be consider for the agenda
> >
> > Lixia
> >
> > My comment is something like “protocol designs are what we do. The real
> question is what kinds of protocols we design”
> >
> > I saw a couple responses like “but IAB can be a lot more than that
> (protocol designs)” — of course.  My comment was only on the protocol
> design part.
> >

---

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 16 Mar 2021 17:55:11 +0100

Hi Mary,

See below.

> On 16. Mar 2021, at 17:25, Mary Barnes <[email-masked]> wrote:
> 
> [MB] As I said in that other thread while back, when I was IAB executive director, I had the understanding that the list was for the community to discuss technical architectural issues as Lixia stated.   Looking at the archives, I'm not seeing that it was historically used for workshop announcements.  And, I'm recalling that the architecture-discuss list was a subset of the broader community.   I didn't know it existed until I was on IAB.   Why can't you just post the announcements that you want to ensure the community sees on the main IETF announcement list?  They've always been posted there, anyways as I recall.   [/MB]

Yes, we do also send announcements that are important for the whole community to the IETF announcement list. They usually include workshop calls (which we also try to distribute to other lists as well) but also e.g. the IAB report or any feedback calls for candidates or announcement about appointments.

However, there are also announcements which are about “other" things things the IAB is doing, e.g. since we send out adoption and feedback calls for IAB stream document we sent them to architecture-discuss list.

Again, maybe this split is not always clear and I will discuss again this with the rest of the IAB. 

Mirja

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 17 Mar 2021 09:50:50 +1300

Mirja,

On 17-Mar-21 00:04, Mirja Kuehlewind wrote:
...
> For question directly on a specific liaison or handling of liaison statements, you can also use [email-masked] now.

Please advertise that at https://www.iab.org/liaisons/ (it is already mentioned at https://www.ietf.org/about/liaisons/).

Thanks
   Brian

---

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 16 Mar 2021 23:02:12 +0100

Hi Brian,

It's already there on the iab page as well; check for a blue email address in the text…

I know, the iab page is not really “easily accessible” but I guess that’s another problem we need to address at some point.

Mirja

> On 16. Mar 2021, at 21:50, Brian E Carpenter <[email-masked]> wrote:
> 
> Mirja,
>

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 17 Mar 2021 09:55:10 +1100

On Tue, Mar 16, 2021, at 22:04, Mirja Kuehlewind wrote:
> about e.g. workshops, documents, or program for a quiet while and that 
> was in scope for the list already when the list was started. As you can 
> see the load is not extremely high. We discussed the use of that list 
> for these kind of announcements last year as well and concluded that 
> this list is a good opportunity to reach the community. 

Respectfully, I disagree.  It's not about load, but separation of interest groups.

If the topic is relevant for this list, as some of those topics you list might be, then CC for this list is appropriate.  When it comes to the IAB discharging their administrative responsibilities, a dedicated list would be preferable.

People subscribe to this list to discuss topics related to Internet architecture and while it might be convenient to use that to reach those people for other purposes, that's called spamming.

---

From: Wes Hardaker <[email-masked]>
Date: Tue, 16 Mar 2021 20:40:15 -0700

"Martin Thomson" <[email-masked]> writes:

> It's not about load, but separation of interest groups.

+1.  The IETF has always had many many mailing lists, for better or for
worse.  But the separation does allow a clean subscription model for the
topics you're interested in.  And many are only interested in technical
topics and can care less about administrative -- and vice versa.
-- 
Wes Hardaker
USC/ISI