Subject: [art] [Technical Errata Reported] RFC7807 (6178)

From: RFC Errata System <[email-masked]>
Date: Sun, 17 May 2020 22:45:22 -0700 (PDT)

The following errata report has been submitted for RFC7807,
"Problem Details for HTTP APIs".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6178

--------------------------------------
Type: Technical
Reported by: Gary Peck <[email-masked]>

Section: 3

Original Text
-------------
   The ability to convey problem-specific extensions allows more than
   one problem to be conveyed.  For example:

   HTTP/1.1 400 Bad Request
   Content-Type: application/problem+json
   Content-Language: en

   {
   "type": "https://example.net/validation-error",
   "title": "Your request parameters didn't validate.",
   "invalid-params": [ {
                         "name": "age",
                         "reason": "must be a positive integer"
                       },
                       {
                         "name": "color",
                         "reason": "must be 'green', 'red' or 'blue'"}
                     ]
   }

Corrected Text
--------------
   The ability to convey problem-specific extensions allows more than
   one problem to be conveyed.  For example:

   HTTP/1.1 400 Bad Request
   Content-Type: application/problem+json
   Content-Language: en

   {
   "type": "https://example.net/validation-error",
   "title": "Your request parameters didn't validate.",
   "invalid_params": [ {
                         "name": "age",
                         "reason": "must be a positive integer"
                       },
                       {
                         "name": "color",
                         "reason": "must be 'green', 'red' or 'blue'"}
                     ]
   }

Notes
-----
The "invalid-params" member in the example is named incorrectly. According to Section 4, it should contain an "_" rather than a "-" in its name:

>   If such additional members are defined, their names SHOULD start with
>   a letter (ALPHA, as per [RFC5234], Appendix B.1) and SHOULD consist
>   of characters from ALPHA, DIGIT ([RFC5234], Appendix B.1), and "_"
>   (so that it can be serialized in formats other than JSON), and they
>   SHOULD be three characters or longer.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7807 (draft-ietf-appsawg-http-problem-03)
--------------------------------------
Title               : Problem Details for HTTP APIs
Publication Date    : March 2016
Author(s)           : M. Nottingham, E. Wilde
Category            : PROPOSED STANDARD
Source              : ART Area General Application Working Group
Area                : Applications and Real-Time
Stream              : IETF
Verifying Party     : IESG

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 19 May 2020 09:44:07 +1000

This looks correct to me - thanks for the report.

Cheers,

> On 18 May 2020, at 3:45 pm, RFC Errata System <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/