Subject: [art] draft-melnikov-iana-reg-forwarded-00

From: "Martin Thomson" <[email-masked]>
Date: Fri, 06 Nov 2020 16:55:03 +1100

This draft is on the DISPATCH agenda, but I have a technical comment, maybe a question.

The draft proposes a new parameter for the content type of a message to distinguish between something that is forwarded as opposed to being part of the message.

How does this relate to Content-Disposition (RFC 2183)?  On the web, we use this to distinguish between stuff that should be downloaded and stuff that should be rendered in place.  It seems like this is a clear example of the same problem.  The attachment/inline split seems to be at least a loose fit for the use cases described.  If this isn't a good fit, then you can define extensions or dispositions that suit more accurately.

If you use Content-Disposition you also don't bind these semantics to the media type, but make them available for any content type.

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 6 Nov 2020 10:27:12 +0000

Hi Martin,

> On 6 Nov 2020, at 05:55, Martin Thomson <[email-masked]> wrote:
> 

I admit I just never thought of this, although I am using Content-Disposition in my email client all the time. So, are you suggesting to use “Content-Disposition: inline” to signal “non forwarded” case of message/rfc822?

> If you use Content-Disposition you also don't bind these semantics to the media type, but make them available for any content type.

True, although at the moment I can’t think of any use cases which is not message/rfc822 or message/global.

Best Regards,
Alexey

---

From: "Martin Thomson" <[email-masked]>
Date: Mon, 09 Nov 2020 10:29:25 +1100

On Fri, Nov 6, 2020, at 21:27, Alexey Melnikov wrote:
> I admit I just never thought of this, although I am using 
> Content-Disposition in my email client all the time. So, are you 
> suggesting to use “Content-Disposition: inline” to signal “non 
> forwarded” case of message/rfc822?

Pretty much.  If that doesn't work, then a new type or maybe an attribute.